14:58:24 <h01ger> #startmeeting
14:58:24 <MeetBot> Meeting started Thu Sep 24 14:58:24 2020 UTC. The chair is h01ger. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:24 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:58:40 <h01ger> #topic 1. Say hi / review & amend agenda as needed - https://pad.riseup.net/p/lts-meeting-agenda
14:58:43 <bwh> hi
14:58:45 <Beuc> o/
14:58:46 <h01ger> hallihallo
14:58:53 <bhe[m]> hello
14:58:57 <lamby> <- Chris Lamb
14:59:00 <el_cubano> hola
14:59:09 <apo> hi
14:59:43 * h01ger hopes everybody has looked at the agenda :)
14:59:59 <buxy> hi
15:00:18 * h01ger gives us another 2 minutes before starting for real as for the 2nd topic we need utkarsh2102
15:01:02 <pochu> o/
15:02:26 <h01ger> #topic 2.1 survey - status publishing
15:02:49 <h01ger> hi OlaLundqvist - agenda is at https://pad.riseup.net/p/lts-meeting-agenda - you didnt miss anythying except topic 1 so far
15:03:11 <h01ger> and for the survey topic status of publishing the results we need utkarsh2102
15:03:21 <bhe[m]> seems utkarsh2102 is not around ( I am also from matrix side and I don't see his status here)
15:03:42 <buxy> let's do 3 first if utkarsh2102 isn't around right now
15:03:44 <h01ger> so i'd say we move on and if he joins we can go back to this topic else postpone it to next month / mail
15:04:05 <h01ger> #agreed we need utkarsh2102 to know the status, topic thus postponed
15:04:18 <h01ger> #topic 3. Define "claim" more clearly (Beuc)
15:04:35 <h01ger> Beuc wrote: intuitively I understand as "I'm fixing this package's vulnerabilities asap", but packages are regularly unclaimed with no activity, and I saw a commit claim 3 packages at once, so maybe I'm wrong
15:04:52 <h01ger> i think you are right and people sometimes claim packages too long
15:05:12 <h01ger> i also think the semiautomatic unclaiming largely works
15:05:17 <OlaLundqvist> Agree
15:05:18 <bwh> I have linux and linux-4.19 claimed indefinitely, which also has different meaning
15:05:19 <h01ger> i'm curious what you all think
15:05:46 <h01ger> bwh: sure, we also have some of these exceptions
15:06:00 <OlaLundqvist> I think we are a little too worried about double work.
15:06:25 <OlaLundqvist> What I think a claim should mean is that someone have started to prepare an update.
15:06:39 <OlaLundqvist> Or think he/she will do that very soon.
15:07:18 <OlaLundqvist> If we are just checking whether we can figure out what the vulnerability is and figuring out a possible solution does not necessarily mean a claim.
15:07:25 <OlaLundqvist> But this do risk double work of course.
15:07:51 <el_cubano> That is better than necessary work being overlooked.
15:08:16 <h01ger> do claims prevent people from finding any work? or just from finding easy work?
15:08:48 <OlaLundqvist> It prevents me from finding work sometimes.
15:09:08 <OlaLundqvist> In other cases thare are just work left on unimportant things.
15:09:32 <Beuc> I usually find enough work.
15:09:42 <OlaLundqvist> But the situation is much better than it was half a year ago.
15:09:43 <h01ger> i could unclain more aggressivly, like after a week or 10 days of no activity
15:09:44 <Beuc> I'm cautious about claiming and it pains me to see updates delayed.
15:10:11 <lamby> Beuc: What is the problem you are seeing? Just having a vague definition of "claim" is not, in itself, a problem, if you see what I mean.
15:10:13 <h01ger> (but that would have the price of more busy work keeping claims up2date. which could be desired if its not just busy work ;)
15:10:23 <lamby> (noting OlaLundqvist's issues, mind you)
15:10:26 <OlaLundqvist> A possible way is to let people claim with a timer.
15:10:50 <OlaLundqvist> For example I could tell that I claim this package for today checking things. But tomorrow if I do not make any progress someone else should take over.
15:10:57 <OlaLundqvist> But that requires automation...
15:11:19 <h01ger> Beuc: for that it would probably be good to have data about how delayed||timely our updates are.
15:11:30 <buxy> OlaLundqvist: which means you should look into the extra-tasks, I'm astonished for example that we still don't have a list of packages that have an history of security updates and that are lacking autopkgtest as requested in packages that have had security updates and that lack autopkgtest as requested in https://salsa.debian.org/lts-team/lts-extra-tasks/-/issues/1
15:11:33 <h01ger> which would probably be good to have anyway
15:11:52 <OlaLundqvist> buxy: Point taken
15:12:20 <h01ger> #info reminder: if there are no packages to work on people should look at the extra-tasks
15:12:51 <OlaLundqvist> I just realize that my idea of claim with timer can be easily fixed by writing that in a note. :-)
15:13:28 <OlaLundqvist> But the find-work tool do not realize that of course.
15:14:02 <buxy> extra-tasks are meant to help find LTS-related work but you can have ideas of useful LTS work on your own...
15:14:15 <Beuc> lamby, basically I want to compare my understanding of claiming, to see if I'm being too cautious
15:14:59 * h01ger wonders how to do proceed with this topic, whats left to discuss and to do
15:15:29 <lamby> Beuc: What does "being too cautious" mean, specifically? I'm still not quite sure of what the issue might be, which would be the first step before we discuss solutions (dates/timers/scripts)
15:15:55 <Beuc> Mainly unnecessarily delaying updates
15:16:01 <utkarsh2102> Beuc: I also don't particularly understand the real motive behind adding more intensive notes. If you're still working, isn't WIP enough?
15:16:20 <Beuc> due to repeated unclaim/reclaim, or multi-claims at once
15:16:27 <utkarsh2102> as in, I mean, what help does it do in writing more intensive notes?
15:16:45 <buxy> Our README say "When working on an package claim it by adding your name next to it in dla-needed.txt." so putting your name there means that you're working on it _now_. You might not finish it at once, you might have to wait for external feedback, but you should have started the process.
15:17:06 <buxy> And if it takes long, you have to document why.
15:17:11 * h01ger doesnt see anything wrong with multi claims per se
15:17:48 * utkarsh2102 nods
15:18:15 <Beuc> h01ger, the more you parallelize, the greater the delay (since 1 people can only work sequentially)
15:18:17 <Beuc> anyway
15:18:54 <OlaLundqvist> I do not have a problem with multiple claims, but when someone claims multiple packages at the same time this sort of contradicts the _now_ part of the README.
15:18:54 <buxy> h01ger: let's say I can handle 1 package per day and I have free time in the next 10 day, I claim 10 packages, but if we have 10 persons with free time we could have provided all the updates in the first day.
15:18:57 <h01ger> well sure, but i can also do 3 sequiental claims instead of one multi claim. if i upload them all withing 48h all is good. so
15:19:03 <Beuc> h01ger, if that's not enough of an issue then probably I'm being too cautious. And we need to move forward on the task to monitor our reactivity as discussed by buxy. Maybe a topic for next time.
15:19:04 <OlaLundqvist> But the description is good enough I think.
15:19:23 <h01ger> buxy: sure. but thats not a problem of multi claim but too much claiming
15:19:43 <OlaLundqvist> h0lger: Yes you are right.
15:20:17 <bhe[m]> I don't think WIP is enough. May be non LTS people are also looking through dla-needed and may be they see something and can help. I don't know.
15:20:27 * h01ger concludes we have discussed this topic now and i dont see anything actionable, so i would say: next topic. or i could reduce the semi automatic unclaim timer to 10 days
15:21:02 <OlaLundqvist> Both alternatives are fine with me
15:21:08 <h01ger> we dont have that many topics today so there is little hurry :)
15:21:13 * utkarsh2102 will add more intesive notes from now on :)
15:21:14 <buxy> someone should look into the topic of how to monitor the time in the various states
15:21:29 <Beuc> buxy, you mentioned working with sec.team about the monitoring
15:21:39 <buxy> and make a proposal to be discussed next time
15:21:39 <h01ger> buxy: shall we make this an https://salsa.debian.org/lts-team/lts-extra-tasks/-/issues/?
15:21:58 <buxy> Beuc: did I really?
15:22:23 <Beuc> In the conversation about monitoring our reactivity to serious issues,
15:22:30 <buxy> h01ger: yeah, if only people picked up issues there :)
15:22:35 <h01ger> :)
15:22:49 <Beuc> you concluded that to get appropriate data, we needed to coordinate with sec.team
15:22:56 <h01ger> Beuc: can i pass on the task to create this issue?
15:23:08 <buxy> Beuc: IIRC I was asking myself if the security team would not dislike us doing something like this, but maybe I'm wrong
15:23:32 <Beuc> buxy, OK I'll reply to that thread to clarify and then create a task
15:24:10 <h01ger> #action Beuc will create an lts-extra-task to create stats about how delayed/timely our lts updates are. (time from cve know until fixed)
15:24:16 <Beuc> thx
15:24:21 <buxy> Beuc: ah, possibly, but I did not say that I would do it...
15:24:29 <h01ger> #topic 2.1 survey = status publishing
15:24:39 <h01ger> utkarsh2102: hello, the stage is yours! :)
15:24:52 <utkarsh2102> hi!
15:25:25 <h01ger> (i guess you are aware about the paragraph in the last monthly freexian lts report where the survey was mentioned)
15:25:48 <utkarsh2102> so as for the survey part: we're more or less, ready. since the PDF was written in LaTeX, the HTML code can also be easily generated.
15:26:04 <h01ger> \o/
15:26:15 <h01ger> where to you plan to publish it?
15:26:15 <utkarsh2102> Well, I have generated the HTML already, 16 days ago, to be precise.
15:26:56 <utkarsh2102> I'm not sharing the link publicly atm. But if you think I should share the link to HTML now, let me know.
15:27:15 <utkarsh2102> Basically, it's on GitHub, so you can already see, since the link is on the mail :)
15:27:23 <OlaLundqvist> Will we publish individual comments or just the aggregated data?
15:27:30 <utkarsh2102> As to where to publish it, I am not sure. Do you have opinions?
15:27:46 <utkarsh2102> OlaLundqvist: we will not publish the comments, I think.
15:28:08 <OlaLundqvist> Sounds like a good plan.
15:28:10 <utkarsh2102> at least, we certainly don't want to publish *all*. so there's that.
15:28:18 <h01ger> utkarsh2102: somewhere on salsa i suppose. or paradise.d.o maybe?
15:28:19 <buxy> maybe in lts-team.pages.debian.net ?
15:28:40 <utkarsh2102> TIL^^ :)
15:29:07 <utkarsh2102> oh wait, it doesn't exist yet :)
15:29:25 <utkarsh2102> sure, either is fine, I don't have a preference over the other.
15:29:58 <h01ger> #info utkarsh2102 is working on it and close to publishing. he send a mail with a preview link 16 days ago
15:30:06 <h01ger> not sure whats holding you back
15:30:24 <utkarsh2102> h01ger: you already have the mail from my end, no?
15:30:35 <utkarsh2102> based on our discussion where you wanted to see the HTML
15:30:40 <utkarsh2102> s/see/have
15:31:20 <utkarsh2102> I'll resend to the list this weekend.
15:31:22 <buxy> utkarsh2102: yeah, we'd have to create it, but some webspace for the team seems a good idea in general, right now we're all on the wiki, unless we can handle this as an attachement in the wiki?
15:32:33 <OlaLundqvist> I do not have any particular preference on where to publish it.
15:32:42 <utkarsh2102> I can try wiki, sure. There are, more or less, attachments of the data/stats.
15:32:57 * h01ger thinks we can move on and utkarsh2102 will be able resolve the details of publishing
15:33:06 <h01ger> agreed?
15:33:17 <Beuc> wiki sounds good
15:33:26 * utkarsh2102 has too much pressure now :P
15:33:30 <utkarsh2102> yep, alright
15:33:51 <h01ger> #info we'll release in the wiki if possible, else probably create lts-team.pages.debian.net
15:34:08 <h01ger> #topic 2.2 survey - specific comments from other Debian teams including Sec. team
15:34:21 * h01ger has no idea who wrote this and whats the meaning
15:34:32 <Beuc> I wrote this
15:34:35 <utkarsh2102> me neither
15:34:38 <utkarsh2102> ah!
15:34:52 <Beuc> AFAICR buxy requested that we compiled specific comments from fellow Debian teams
15:35:21 <utkarsh2102> yes.
15:35:22 <Beuc> current we have all comments but don't know if that comes from an end-user or a Debian person
15:35:30 <utkarsh2102> but that's for our internal review.
15:36:03 <Beuc> I believe the end goal is to come with guidelines on improving our work with other Debian team, including sec.team
15:36:17 <utkarsh2102> I have the CSV, just needs a bit scripting to fetch all the comments from the person who has ticked the boxes we want reviews from.
15:36:31 <OlaLundqvist> We should probably go through the comments to see what is valuable.
15:36:42 <OlaLundqvist> Not only from the other Debian teams.
15:36:55 <utkarsh2102> I agree, going over the comments from everyone is really a good ide.a
15:36:58 <h01ger> so in summary, we want an internal results from the survey too?
15:37:02 <OlaLundqvist> I went through quite a few some time back, but then I forgot what was valuable if anything.
15:37:15 <buxy> OlaLundqvist: can you handle this?
15:37:34 <OlaLundqvist> Well yes I can do that. The question is what I should look for.
15:37:51 <utkarsh2102> anything that's specific and helps us in some way or the other.
15:37:54 <OlaLundqvist> Compile a list of different kind of comments, or should I try to figure out what is useful?
15:38:12 <OlaLundqvist> I'll see what I can do. I guess we should make this as a new task?
15:38:16 <utkarsh2102> I can assist Ola since I've already gone through all of them once and have noted some general stuff.
15:38:18 <el_cubano> Some initial analysis would be the most useful.
15:38:19 <h01ger> #action OlaLundqvist will work on preparing that internal survey result by going through the comments
15:38:35 <bwh> Try to group them, and extract any particular useful suggestions?
15:38:43 <utkarsh2102> right.
15:38:45 <buxy> utkarsh2102: please send Ola the raw CSV so that he can also do the filtering
15:38:53 <utkarsh2102> on it.
15:38:55 <OlaLundqvist> Sounds good. I'll work on it.
15:38:57 <h01ger> #action further details are left as an excercise for the task (irc log has good ideas)
15:39:18 <h01ger> next topic?
15:39:26 <utkarsh2102> Ola should have a mail from my end now ;)
15:39:27 <buxy> OlaLundqvist: any actionable comment should likely result in some new issue filed against lts-extra-tasks
15:39:52 <OlaLundqvist> Great.
15:40:17 <h01ger> #topic 4. different pad to prepare the agenda?
15:41:10 <h01ger> i'm fine with the riseup pad (and i believe Beuc just saw a temporary hickup), afaik there's no .debian.org pad and i'm not really keen on using gobby here. imo a pad is nicer.
15:41:12 <el_cubano> Does the current pad we are using have some deficiency?
15:41:47 <utkarsh2102> The Ruby team uses wiki for agenda preparation. That's also useful.
15:41:57 <utkarsh2102> for eg: https://wiki.debian.org/Teams/Ruby/IRCMeetings
15:42:06 <Beuc> h01ger, indeed ironically the pad was only down when I was writing the e-mail reminder about the agenda
15:42:16 <h01ger> wiki would also work for me
15:42:46 <h01ger> i'm inclined to leave the status quo for now then
15:42:51 <bhe[m]> pads are much better than wiki.
15:43:02 * OlaLundqvist have no opinion about this
15:43:17 <Beuc> fine by me
15:43:21 <h01ger> #action no action, agenda stays where it is
15:43:23 <buxy> a pad is fine, and I have no preference between riseup or framapad
15:43:39 <h01ger> #topic 5. next meeting next month with video, just where?
15:44:01 <utkarsh2102> I'd like to give zoom a try this time, maybe? :)
15:44:20 <utkarsh2102> we have many instances of Jitsi not working for us, let's try Zoom once?
15:44:29 <utkarsh2102> (as buxy has proposed earlier)
15:44:45 <h01ger> works for me, i never used zoom and (often, not always) i like to do things at least once
15:44:51 <bwh> No, absolutely not
15:45:08 <utkarsh2102> I could also suggest Google meet but that'd upset a lot of people so I'd rather not say that :)
15:45:16 <bwh> Zoom's web client is barely usable
15:45:51 <h01ger> in any case i'd like someone to drive this and manage invitations etc
15:46:03 <buxy> bwh: would you prefer google meet?
15:46:08 <utkarsh2102> bwh: hangouts, google meet works good I think
15:46:17 <utkarsh2102> I can send out invitations if so^
15:46:32 <bwh> Hangouts/Meet works for me
15:46:45 <lamby> wfm too
15:46:45 <bhe[m]> I am staying with my comment on last meeting regarding zoom vs jitsi
15:47:27 <bwh> (Jitsi would still be my 1st choice)
15:47:40 <h01ger> bhe[m]: unless you dont repeat them briefly they might also stay with you ;)
15:48:19 <bhe[m]> which was 'no zoom'
15:48:26 <h01ger> thx :)
15:48:36 <buxy> I have read that latest firefox has features reducing the CPU usage of jitsi (which was my main problem I believe) but let's try google meet this time around
15:48:58 <utkarsh2102> yep, happy to.
15:49:11 <bwh> buxy: That will be welcome
15:49:35 <h01ger> #action utkarsh2102 will send out invitations to a google meet thing.
15:49:46 <utkarsh2102> \o/
15:49:56 <h01ger> #info we tried jitsi before and it failed us. we can still try again but lets try something else in between
15:50:06 <Beuc> I don't guarantee that I'll stream my face through those services, but I'll attend.
15:50:22 <h01ger> and i suggest we all be on irc too
15:50:33 <OlaLundqvist> Sounds like a good suggestion
15:50:58 <h01ger> no one is required to attend the lts meetings, not even on irc. and noone is required to stream ones face or dog.
15:51:08 <lamby> I suggest we have IRC open as a backup, but not to have two conversation modes at once. :)
15:51:24 <h01ger> yes
15:51:38 <h01ger> #info we have IRC open as a backup, but not to have two conversation modes at once
15:51:45 * el_cubano agrees that IRC backup is a good idea
15:51:54 <h01ger> and if zoom fails, we use the backup
15:52:01 <h01ger> #info and if zoom fails, we use the backup
15:52:06 <Beuc> zoom? :)
15:52:17 <h01ger> #info s#zoom#google#
15:52:21 <h01ger> thx
15:52:25 <h01ger> #topic 6. any other business
15:52:41 <h01ger> we could finish 5min early today ;)
15:53:12 <buxy> Hey, let's use those 5 minutes.
15:53:18 <h01ger> sure
15:53:25 <OlaLundqvist> I have a quick question if noone else have anything
15:53:36 <utkarsh2102> please go on :)
15:53:37 <h01ger> i was joking, not wanting to discourage anyone. please bring up stuff
15:53:54 <OlaLundqvist> I have prepared ceph but I have little possiblity to test it.
15:54:17 <buxy> I want to let you know that I'm super busy lately and that I have slacked... the discussion about using the infrastructure funding is still pending, I must still start it on -project.
15:54:20 <OlaLundqvist> Should I leave it to someone else, upload it or spend quite some time on figuring it out
15:55:37 <buxy> I'd like to let you know also that Freexian is working on a new service offer related to LTS support of PHP versions. There can be no interactions between the two services but we can also start to think in changing the global approach that we have with customers.
15:55:59 <h01ger> OlaLundqvist: you could ask bernd zeimetz whether he could do some tests
15:56:07 <OlaLundqvist> Thank you
15:56:25 <buxy> There's quite some overlap between the LTS/ELTS/PHP customers.
15:56:53 <h01ger> buxy: i'm not sure what you mean with changing the global approach we have with customers..
15:56:57 <OlaLundqvist> I think PHP is one big reason why many want to stay on an earlier release.
15:56:58 <el_cubano> I don't understand "There can be no interactions ..."
15:57:39 <buxy> In general, I have the feeling that Freexian is getting to big for me to handle alone so I should really look into ways to bring someone else on-board to help me drive the company. This is just FYI.
15:57:58 <h01ger> OlaLundqvist: other than that, have you included the ceph maintainers in your question? i'm not sure if removing ceph is an option (havent checked)
15:58:13 <OlaLundqvist> I included ceph maintainers, but no answer.
15:58:42 <buxy> h01ger: I mean that we can sell LTS/ELTS/PHP as separate services, or we can think into providing a subscription service where they pay a fixed fee and then they can adjust how they use their budget between the various services that we provide
15:58:45 <h01ger> buxy: thanks for the infos. please keep us posted!
15:58:47 <OlaLundqvist> Some of LTS contributor is using ceph because it is in the package to support list
15:58:58 <h01ger> buxy: ah
15:59:44 <buxy> those are the things in the back of my mind right now
16:00:39 <h01ger> any other advice for OlaLundqvist and ceph?
16:01:19 <h01ger> though i conclude we can close this meeting and people can still comment on ceph when the meeting is closed :)
16:01:23 <OlaLundqvist> I'll see if I can figure out how to at least regression test it.
16:01:28 <h01ger> thank you all! o/
16:01:35 <utkarsh2102> \o/
16:01:46 <OlaLundqvist> Thank you all. See you soon on email. :)
16:01:46 <lamby> Thanks to all, and thanks to h01ger for running the meeting.
16:01:58 <h01ger> #endmeeting