14:01:31 <santiago> #startmeeting
14:01:31 <MeetBot> Meeting started Thu Jul 18 14:01:31 2024 UTC.  The chair is santiago. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:31 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:06 <santiago> #rollcall
14:02:24 <ta> hi everybody
14:02:27 <santiago> hello everybody, please say hi if you are there
14:02:31 <lamby> hello
14:02:34 <bhe[m]> Hi.
14:02:36 <Beuc> hi
14:02:37 <guilhem> hi there
14:03:58 <santiago> we can wait a couple of more minutes for those coming a little bit late
14:04:30 <santiago> in the meantime, don't hesitate to add any item to the agenda, in case you have something to discuss :-)
14:05:14 <rouca> hello
14:05:19 <rouca> hi
14:05:21 <santiago> hi!
14:05:56 <santiago> for the moment, we have two items, so we can expect a short meeting
14:06:01 <kanashiro> o/
14:06:35 <santiago> FTR, I am chairing this meeting, since Roberto is AFK
14:06:52 <santiago> kanashiro, oi!
14:07:10 <santiago> I propose to start with the first item:
14:07:23 <santiago> #topic Transitions: bullseye -> LTS / buster -> ELTS
14:09:26 <santiago> as you may now, buster ended its LTS period last June. bullseye will become LTS on August 15th
14:10:00 <santiago> I've got some questions regarding the things to be done currently, and I sent an email with some ideas. Do you have any question about that?
14:11:02 <ta> no, everything is clear
14:11:18 <santiago> OK, don't hesitate to speak up if you have any
14:11:41 <santiago> as discussed during the last meeting, but I would like to remind it here
14:11:45 <Beuc> I recently mentioned we need to setup the bullseye CI / update https://lts-team.pages.debian.net/git-workflow-lts.html :)
14:12:29 <santiago> there was a change in the life cycle of debian releases. The security team and the release team agreed on supporting every releases for three years
14:12:48 <santiago> previously, oldstable was supported one year after stable was releases
14:13:26 <santiago> hopefully, this change would make the lifecycle more clear for everyone (users and developers)
14:13:47 <santiago> and that is the reason why bullseye will become LTS on August 15th
14:13:56 <santiago> Beuc, yep, noted
14:14:32 <santiago> with my salsa CI hat on, I would prefer if we reduce the changes in the LTS Team pipeline
14:15:57 <santiago> but, yeah, I (or somebody else, help is welcome) need to create the recipe for bullseye
14:16:40 <santiago> any other question or comment?
14:17:07 <lamby> None here. :)
14:17:41 <santiago> :-)
14:18:47 <rouca> none
14:18:48 <Beuc> I'm not sure what kind of differences we accumulated, though I just got bitten by one in https://salsa.debian.org/salsa-ci-team/pipeline/-/issues/362#note_507441  so yeah
14:19:24 <Beuc> But we can discuss this further separately
14:19:32 <santiago> yes!
14:19:54 <santiago> #action santiago to create the bullseye pipeline recipe (and update the documentation)
14:20:15 * santiago wonders if the meetbot syntax is correct
14:20:45 <santiago> anyway, if the transition time is clear, and there is no more questions, we can move forward!
14:21:15 <santiago> #topic old-standing packages in the queue
14:21:25 <santiago> this is again me
14:22:09 <santiago> as discussed last meeting, I proposed to create gitlab issues to handle packages that have been in the queue for long time
14:22:44 <santiago> because of the transition, elts is only in the scope currently
14:23:04 <santiago> there were already a couple of issues for samba and imagemagick
14:23:23 <santiago> and before the meeting, I created those for mariadb-10.1/stretch and rails
14:24:18 <santiago> the idea behind is to look for ways to fix the issues in those packages
14:24:32 <santiago> and we'll see if that helps
14:24:41 <rouca> for imagemagick we are going to see the end of tunnel
14:24:52 <santiago> rouca, yeap
14:24:56 <santiago> \O/
14:25:06 <santiago> thanks a lot for your work on it, btw
14:26:11 <santiago> I wonder if this gitlab issues could help to share the load of those difficult packages. But again, I see this as an experiment
14:26:20 <santiago> and feedback is warmly welcome
14:26:41 <rouca> for me issue was helpful. I suppose it ease also tracking of problem
14:27:45 <santiago> (I need to update ela-needed.txt to point to the last two issues)
14:27:52 <santiago> any questions or comments?
14:28:58 <ta> the old variant of handling long-time-packages did not really work, so experiments can only improve the situation
14:29:48 <santiago> I don't remember that variant, probably I was not doing LTS work at that time
14:30:28 <ta> no, I mean the variant of just putting package in ela-needed.txt and waiting that someone will claim it
14:30:40 <santiago> ah, ok!
14:30:47 <rouca> I think also ticketing could improve the release early release often
14:31:09 <santiago> we'll see :-)
14:31:56 <santiago> so please, don't hesitate to look at those issues/packages
14:32:43 <santiago> fixing all the open mariadb-10.1 is a huge task for a single person, and we probably won't be able to fix those that come from mysql
14:33:23 <santiago> but if we distribute the load among several people, it could make the task easier
14:33:54 <santiago> any other comment before we change topic?
14:34:10 <rouca> for mariadb
14:34:23 <rouca> it is a really hard to find CVE commit on mysql...
14:34:40 <rouca> mariadb upstream use guess and could be contacted for identifying commit
14:34:42 <santiago> yes, we will end up <ignoring> them, I guess
14:35:04 <rouca> and they are often no POC for testing
14:35:29 <santiago> mariadb identify some CVEs in their jira
14:36:15 <Beuc> that or backport the newer version
14:36:48 <santiago> Beuc, yes, there is an issue regarding backporting 10.11
14:37:22 <santiago> pochu has been working on it, and probably he could appreciate some help :-)
14:37:50 <Beuc> noted
14:38:14 <santiago> we can discuss this on the mariadb-10.1 issue for better tracking
14:38:20 <santiago> anything else?
14:38:42 <Beuc> A note on the transition,
14:39:14 <Beuc> I noticed the last bullseye PU is announced for August 31th, so 2 weeks after we take over.
14:39:39 <Beuc> So we'll have to be careful not to conflict with it.
14:40:05 <santiago> yes, AFAIU, the last PU is done after the last DSA is issued
14:40:10 <santiago> Beuc, good point!
14:40:52 <santiago> that means to don't make uploads when the release team is preparing the PU, right? is there anything else on that?
14:41:24 <Beuc> Mainly check https://bugs.debian.org/cgi-bin/pkgreport.cgi?users=release.debian.org@packages.debian.org;tag=pu if there's anything related to the package you picked, yes :)
14:42:47 <santiago> understood
14:43:35 <santiago> if no objections, let's move forward to the next topic
14:44:06 <santiago> #topic AOB
14:44:15 <lamby> None here.
14:44:21 <santiago> any other topic?
14:45:17 <rouca> yes
14:45:18 <santiago> #info Note: the last bullseye PU is announced for August 31th, so 2 weeks after we take over. So we'll have to be careful not to conflict with it. That means mainly check https://bugs.debian.org/cgi-bin/pkgreport.cgi?users=release.debian.org@packages.debian.org;tag=pu if there's anything related to the package you picked
14:45:34 <santiago> rouca, yes?
14:45:36 <rouca> I have a regression on LTS
14:45:39 <rouca> testing
14:45:41 <rouca> buster sorry
14:45:53 <rouca> tmp.mount service fail due to be masked
14:46:04 <rouca> so expect failure for restarting some services
14:46:05 <santiago> ah, the Salsa CI regression?
14:46:11 <rouca> santiago: yes
14:47:21 <santiago> for the context: https://salsa.debian.org/salsa-ci-team/pipeline/-/issues/361
14:47:55 <rouca> so every systemd unit that depend on local filesystem will now fail
14:48:08 <santiago> my intuition tells me it is because of a switch in the autopkgtest image, that base previously based on unstable, and now it is based on stable
14:48:41 <santiago> I propose you to address that after the meeting. I could create an old-fashion autopkgtest image that you could test
14:48:52 <santiago> does that work for you?
14:49:10 <rouca> that work but other teams member could expect failure until solved
14:49:31 <santiago> probably, but I need to confirm that is the issue
14:49:40 <Beuc> rouca, (incidentally I just hit an apache2 regression on a server of mine, maybe that'll concern your apache2 upload, I'll do a report and post you the BTS link.)
14:50:02 <rouca> Beuc: upstream released a CVE fix today for adressing a regression
14:50:29 <santiago> #action santiago to look at the salsa ci regression reported by rouca: https://salsa.debian.org/salsa-ci-team/pipeline/-/issues/361
14:50:43 <rouca> Beuc: but bts report welcome
14:50:49 <santiago> CI is fun! (help is welcome)
14:51:38 <santiago> any other topic?
14:51:43 <rouca> no thanks
14:52:05 <ta> nope
14:52:08 <santiago> 5
14:52:09 <santiago> 4
14:52:11 <santiago> 3
14:52:13 <santiago> 2
14:52:14 <santiago> 1
14:52:15 <guilhem> nope
14:52:32 <santiago> # topic Next meeting
14:52:41 <santiago> Next meeting is scheduled on 2024-08-22 14:00 UTC
14:52:56 <santiago> thank you everyone for attending :-)
14:53:13 <lamby> thank you :)
14:53:13 <ta> thank you for being the chair
14:53:22 <santiago> #topic Next meeting
14:53:48 <santiago> see you next month, or in Busan for those attending DC24 \O/
14:54:39 <ta> byebye
14:54:51 <santiago> bye bye!
14:54:52 <santiago> #endmeeting