14:00:08 <el_cubano> #startmeeting
14:00:08 <MeetBot> Meeting started Thu Sep 26 14:00:08 2024 UTC.  The chair is el_cubano. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:08 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:19 <el_cubano> #topic Welcome
14:00:30 <tobi> hi
14:00:37 <el_cubano> Hello everyone! Thanks for being here for the monthly LTS meeting
14:00:45 <el_cubano> #topic Rollcall
14:00:55 <el_cubano> Please announce yourself so that we have a record of your attendance
14:00:56 <santiago> o/
14:01:00 <ta> hi
14:01:01 <guilhem> hello
14:01:17 <jochensp> Hi
14:01:26 <lamby> Hello.
14:01:53 <tobi> Hi
14:03:15 <helmut> hi
14:03:34 <el_cubano> rouca: ping
14:03:38 <el_cubano> federico3: ping
14:03:47 <rouca> ehllo
14:03:53 <rouca> hello
14:03:58 <federico3> hi there
14:04:17 <el_cubano> OK. Just making sure you two were still around, in case you wanted to participate
14:04:45 <el_cubano> OK. This looks like a good crowd, so let's go ahead and get started.
14:05:12 <el_cubano> #topic FD dispatch for first half of 2025
14:06:03 <el_cubano> Next week I will be dispatching FD slots for the first half of 2025. Please ensure that you have set your 'frontdesk' status as 'active' in contributors.yml (both for LTS and for ELTS), if you are interested in receiving FD slots
14:07:04 <rouca> el_cubano: do we have a mentoring for being a FD ?
14:08:01 <el_cubano> not directly
14:08:20 <el_cubano> The FD tasks are documented and they are fairly straightforward
14:08:49 <rouca> ok will get a glimpse
14:09:16 <el_cubano> A summary is: (1) daily perform initial triage of new CVEs, (2) ensure mailing list/IRC queries are answered, (3) periodically check/follow-up on things from Xla-needed.txt
14:10:30 <el_cubano> If you are intersted/available, go ahead and set yourself active and between now and your first official shift you could see if someone will let you shadow them for a few days to get an idea of how (1) works
14:11:09 <rouca> ok
14:11:32 <el_cubano> Any other questions or comments about FD dispatch?
14:11:45 <santiago> not here
14:14:03 <rouca> not here
14:14:41 <el_cubano> OK. Let's move on
14:14:54 <el_cubano> #topic Extra hours transactions
14:15:24 <el_cubano> At the moment we have a decent buffer of hours in the Available:Extra accounts (there are two accounts, one each in the LTS and ELTS ledgers)
14:16:14 <el_cubano> If you take additional hours, please make sure that you date the transaction on the last day of the month. The 'freexian grant-extra-hours' command will handle this automatically
14:16:28 <el_cubano> Please see the email I sent out to the team earlier this month for more details
14:18:28 <rouca> ok
14:19:51 <el_cubano> Any questions about this?
14:20:10 <lamby> None here.
14:20:12 <guilhem> nope
14:20:45 <el_cubano> OK. So, let's move on
14:20:59 <el_cubano> #topic Being good neighbors w/ secteam
14:21:08 <santiago> that is for me
14:21:08 <el_cubano> santiago: you have the floor
14:21:34 <santiago> my comments on this topic are somehow too early
14:21:49 <santiago> We (el_cubano and I) are preparing a short documentation mainly about how to interact with the security track
14:22:03 <santiago> the idea is to avoid/minimize conflicts with the security team work and avoid putting extra load on their side
14:22:26 <santiago> to summarise: we should avoid making changes in the security tracker data relating to stable or more recent releases. such changes should be done in coordination with the security team first
14:23:30 <santiago> while we are encouraged to help on solving security fixes in more recent debian releases than LTS, stable remains the responsibility of the security team and release teams, so we should coordinate with them any possible change that modifies the triage, proposing updates, etc.
14:24:05 <santiago> just let's avoid modifying the concerned security tracker data without previously asking
14:24:21 <santiago> We will share with you some guidelines when they are finished :-)
14:24:36 <santiago> any questions/comments on this topic so far?
14:24:40 <helmut> but adding notes to unfixed CVEs concerning >= stable (e.g. links to patches) is still ok? (that used to be ok)
14:24:57 <santiago> yes, that is our understanding
14:25:12 <tobi> do you have an example what went wrong lately?
14:25:30 <santiago> NOTEs pointing to commits that introduce or fix a vulnerability are welcome
14:25:47 <santiago> The secteams follows a syntax for those NOTEs, and it is nice to follow it
14:26:09 * tobi is quite always quite unsure if a change to the secteam tracker is ok or not...
14:26:10 <santiago> NOTE: Fixed by: commit <HEAD>, if I understand it correctly
14:26:16 <el_cubano> tobi: Some ELTS-related notes were added to the main non-ELTS CVE list
14:26:21 <helmut> tagging stuff nodsa is a secteam-only thing afaiui
14:26:31 <el_cubano> Also, someone claimed a package in dsa-needed.txt
14:26:43 <tobi> ok
14:27:21 <rouca> thanks for clarifying
14:28:56 <santiago> yeah, there have been some conflicts, and the idea is just to avoid giving any extra load to the other teams
14:29:35 <santiago> any other question/comment?
14:30:29 <rouca> no thanks
14:30:44 <helmut> side note: elts tracker is now merged on a different machine than before. ideally that does not pose any observable difference.
14:34:04 <el_cubano> OK. Any other questions or comments about this?
14:36:11 <ta> no
14:36:41 <Santiago[m]> I think we can move on, then
14:37:47 <el_cubano> OK.
14:37:53 <el_cubano> #topic AOB
14:38:08 <el_cubano> Does anyone have anything that they would like to bring up?
14:38:51 <rouca> no
14:38:55 <helmut> right. we decided to move autopkgtesting into salsa-ci last time
14:39:24 <helmut> I took the question about a worker to freexian managers and the answer was that we should focus on getting it into debusine instead
14:39:42 <helmut> the autopkgtest-rdep workflow is not fully operational yet, but close
14:40:11 <helmut> once it works, I'll share notes how to upload a package to debusine.debian.net and perform a rdep test.
14:40:50 <lamby> Ooh, interesting.
14:40:58 <rouca> :)
14:41:08 <helmut> the elts side will also more and more move onto debusine. not sure which ones goes first
14:41:37 <h01ger> it seems that lts uploads (of bullseye) are published without their .buildinfo files. eg the .buildinfo file for the recent expat update (dla 3893-1) cannot be found anywhere.
14:42:58 <helmut> fsvo close ;) https://salsa.debian.org/freexian-team/debusine/-/issues/397
14:47:22 <el_cubano> Does anyone know about the .buildinfo files?
14:47:57 <santiago> h01ger, thanks for the heads-up. I guess that is on the wanna-build team side, right?
14:50:41 * tobi has to leave now, will read up later
14:50:47 <el_cubano> tobi: bye
14:51:15 <el_cubano> So, it looks like we need to check w/ the wanna-build team
14:51:19 <el_cubano> santiago: Can you do that?
14:51:29 <santiago> el_cubano, yeap
14:51:54 <el_cubano> #action santiago to check w/ wanna-build team about .buildinfo files
14:52:06 <el_cubano> OK. Does anybody else have anything under AOB?
14:52:12 <lamby> Nothing here.
14:52:20 <ta> no
14:52:35 <guilhem> no
14:52:59 <rouca> yes I really really like the bug tracking by ticket for instance mariadb10.1
14:53:04 <h01ger> santiago: probably, yes
14:53:24 * h01ger has not much insight how those areas of debian work
14:53:27 <el_cubano> rouca: ack
14:54:02 <rouca> and I think the partial release every X days is a good stuff to do for closing hard package
14:54:14 <santiago> rouca, thanks a lot for your work on mariadb-10.1, btw!
14:54:18 <el_cubano> santiago and pochu have been discussing possible changes to Xla-needed.txt and the aspect of Salsa issues has been part of the discussion
14:54:49 <santiago> and I am late on sharing my plans about that
14:55:26 <santiago> but I will propose to switch to a yaml based format + using salsa/gitlab issues when appropriate
14:55:45 <santiago> I will send an email, it will be easier to discuss there
14:56:20 <el_cubano> sounds good
14:56:23 <santiago> (by email), giving the remaining time. Unless someone wants to say something about it
14:56:29 <rouca> thanks: santiago
14:57:03 <el_cubano> Anyone else?
14:58:39 <rouca> no
14:59:24 <el_cubano> OK. Thanks to everyone for participating!
14:59:32 <el_cubano> Oh, I almost forgot...
14:59:38 <el_cubano> #topic Next meeting
14:59:44 <el_cubano> Next meeting: 2024-10-24 14:00 UTC [Location: Jitsi: https://jitsi.debian.social/LTS-monthly-meeting]
15:00:11 <jochensp> el_cubano: thanks for sharing and see you all :)
15:00:16 <ta> thanks to you for moderating
15:00:25 <ta> bye bye
15:00:27 <santiago> thank you everybody!
15:00:37 <lamby> o/
15:01:00 <el_cubano> #endmeeting