14:00:28 <santiago> #startmeeting
14:00:28 <MeetBot> Meeting started Thu Jan 22 14:00:28 2026 UTC.  The chair is santiago. Information about MeetBot at https://wiki.debian.org/MeetBot.
14:00:28 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:30 <jochensp> hi
14:00:35 <paride> o/ hi
14:00:37 <charles> o/
14:00:37 <ta> hi
14:00:37 <santiago> #rollcall
14:00:47 <LucasKanashiro[m]> o/
14:00:49 <el_cubano> hello o/
14:00:50 <charles> o/
14:00:54 <santiago> please, say hi if you're here :-)
14:01:04 <pochu> hi
14:01:21 <santiago> while we wait for everybody, as a reminder, the meeting agenda is at https://pad.riseup.net/p/lts-meeting-agenda
14:01:49 <Beuc> hi
14:01:50 <guilhem> hello
14:01:54 <ah[m]> hi
14:02:34 <santiago> let's go with our first item:
14:02:46 <santiago> #topic New team members
14:03:08 <santiago> Arnaud Rebillout has recently joined the team (still in-training)
14:03:30 <helmut> \o
14:03:35 <jochensp> welcome Arnaud :)
14:03:49 <santiago> I was not expecting Arnaud to be here online
14:04:59 <charles> welcome!
14:05:00 <santiago> and I think we can move forward
14:05:15 <santiago> (we'll see if Arnaud can make any next meeting)
14:05:27 <santiago> #topic Action item review
14:05:40 <santiago> el_cubano, your name is on the agenda
14:05:46 <santiago> do you want to handle this?
14:06:33 <el_cubano> That's probably an oversight on my part. I'm pretty sure I meant to dump this one someone else :-)
14:06:44 <santiago> :-)
14:06:53 <el_cubano> But, yes, I can take this.
14:07:11 <santiago> (... or on my part)
14:07:15 <el_cubano> We carried over 2 action items from last month. AFAIK neither one has seen any progress.
14:07:33 <el_cubano> I take that back.
14:07:42 <el_cubano> There was discussion about the nvidia-graphics-driver
14:07:49 <el_cubano> But I didn't follow the thread.
14:08:09 <el_cubano> santiago: Since tobi isn't here, did you have anything you wanted to mention about it?
14:08:16 <santiago> regarding nvidia-graphics-driver, we are waiting for Andreas to confirm if everything is done on trixie and bookworm first
14:08:30 <el_cubano> ack.
14:08:42 <el_cubano> So, this one should carry over.
14:08:46 <santiago> Andreas mentioned that after trixie and bookworm, he would prepare the bullseye update, and we are waiting for him
14:08:50 <santiago> yeap
14:08:53 <el_cubano> #action carry-over: Follow-up to ML and Andreas concerning upload of nvidia-graphics-drivers
14:09:16 * el_cubano wonders if MeetBot records actions without providing any feedback
14:09:37 <utkarsh2102> also hi! sorry a bit late o/
14:09:49 <el_cubano> utkarsh2102: Did you happen to have any update on the other action?
14:09:50 <santiago> el_cubano, I *believe* it does
14:09:56 <el_cubano> santiago: ack
14:10:06 <el_cubano> IIRC, you had offered to help facilitate w/ jbicha
14:10:34 <utkarsh2102> yes, spoke with Holger, i'll file a bug, CC'ing -devel to get broader discussion
14:11:00 <utkarsh2102> but on a quick look, it doesn't hurt to seed d-s-s
14:11:16 <utkarsh2102> el_cubano: i guess that's what you were asking about?
14:11:16 * charles thinks meetbot does record actions without feedback el_cubano
14:12:01 <el_cubano> utkarsh2102: ack
14:12:03 <santiago> so this item should be carried over again, right?
14:12:14 <el_cubano> #action carry-over: Start a discussion about debian-security-support being installed by default
14:12:33 <el_cubano> update on ^^: utkarsh2102 to file a bug & CC -devel for the discussion
14:12:38 <utkarsh2102> yep, will do that^
14:12:59 <el_cubano> thx
14:13:10 <el_cubano> OK. I think that's everything for action item review
14:13:17 <santiago> OK, thank you, el_cubano
14:13:21 <el_cubano> y/w
14:13:24 <santiago> next item:
14:13:44 <santiago> #topic Replacing the weekly semi-automatic unclaim with manual queries about the status / progress of the concerned packages
14:13:53 <santiago> that's on me
14:14:15 <santiago> probably you have noticed, last Monday no packages were (semi-)automatically unclaimed
14:14:59 <charles> oh, interesting
14:15:01 <jochensp> I think that is a very good idea. Will you record the progress report in the security-tracker?
14:15:06 <santiago> instead of doing that, part of the (coordination) weekly task is to reach out to the different fellows about the status of "staled" packages
14:15:39 <santiago> my gut feeling is that some human interaction could help
14:16:00 <ta> that might be a big task to take care of all "unclaims"
14:16:38 <santiago> jochensp, WRT recording the progress on the security tracker, I'd say it depends
14:16:51 <jochensp> k
14:17:02 <santiago> I'm mostly interested in the reasons for the time spent on those packages
14:17:08 <santiago> if help is needed
14:18:06 <santiago> I've seen sometimes is just a small issue blocking the update
14:18:46 <pochu> I think this may work out for the best, so I'm happy we're trying it
14:19:12 <santiago> ta, not sure it would be a such big task. but in any case, it's one of the duties on the coordination side
14:20:02 <santiago> any questions or comments about this?
14:20:18 <LucasKanashiro[m]> +1
14:20:54 <pochu> I guess we can help by a) trying to finish packages in a shorter time frame and b) if it takes long, adding notes on what's blocking progress
14:21:20 <charles> +1
14:21:44 <santiago> c) requesting help when needed
14:22:43 <santiago> OK, if there are no objections, we can move to the next item in the agenda, that I guess is by helmut
14:23:02 <santiago> # Debusine status
14:23:28 <santiago> helmut, please, tell me if you didn't add that item
14:23:34 <charles> santiago: missing the "topic"?
14:23:39 <santiago> ouch!
14:23:43 <santiago> #topic Debusine status
14:24:28 <helmut> simple. regression tracking didn't move
14:24:49 <helmut> someone requested isolation-machine autopkgtests. that also is a feature requiring Debusine code changes
14:25:19 <helmut> no progress on either of these unfortunately, but it was christmas and new year. let's stay tuned on regression tracking. any questions?
14:26:03 <jochensp> as repositories are available now, would it make sense to use them for customer testing?
14:26:19 <helmut> What do you consider customer testing?
14:26:45 <buxy> regression tracking is in need of tests, Colin was planning to test the feature soon
14:26:56 <jochensp> I think for ELTS we sometimes send test versions to customers before publishing them
14:27:39 <helmut> jochensp: that is something we can probably do. We do not generally enable the creation of experiment workspaces yet (also requested by e.g. ta). You may ask for a workspace if you have such a need.
14:27:43 <buxy> regarding isolation machine, what feature is missing? It should work but it requires to maintain task configuration to know which package should run with the incus-vm backend
14:28:36 <helmut> buxy: https://salsa.debian.org/freexian-team/debusine/-/issues/653
14:28:58 <tumbleweed> FWIW, that doesn't stop you from allowing the use of incus-vm
14:29:06 <tumbleweed> It just means that it won't work on our arm workers
14:29:42 <helmut> We could create a separate workflow to run incus-vm autopkgtests indeed, but we cannot enable it as part of the upload pipeline yet.
14:32:08 <santiago> do we really need a separate workflow?
14:32:44 <helmut> Until that issue is resolved, we would. Once it is resolved, we would generally use incus-vm for amd64 autopkgtests (like ci.f.c).
14:33:10 <tumbleweed> helmut: why not just allow incus-vm to be manually specified for a run?
14:33:37 <tumbleweed> (and let it fail on ARM)
14:33:58 <helmut> That's an easy change and I have no objections. Would ELTS contributors be happy with that?
14:34:58 <Beuc> what do you mean by "manually specified"?
14:35:17 <tumbleweed> autopkgtest_backend: incus-vm
14:35:20 <helmut> Beuc: your dput invocation gains a separate option
14:35:22 <buxy> dput -O debusine_workflow.autopkgtest_backend=incus-vm ...
14:36:18 <Beuc> We can try.
14:36:39 <helmut> #action helmut to allow setting autopkgtest_backend on elts upload workflows
14:37:07 <Beuc> (incidentally what's the issue with ARM, no support for virtualization on the ELTS ARM hardware?)
14:37:27 <santiago> no nested virtualization support
14:38:18 <helmut> our workers are virtual machines. we would need physical workers for doing incus-vm on arm
14:39:08 <santiago> helmut, could you remind me please, would autopkgtest_backend=incus-vm be possible on debusine.debian.net too?
14:39:09 <Beuc> (or have the workers connect to a bare-metal incus setup? anyway let's move on :))
14:39:47 <buxy> santiago: it's already possible there
14:39:47 <helmut> santiago: we can change that there as well. tumbleweed can you handle that?
14:40:03 <tumbleweed> helmut: sure
14:40:08 <santiago> OK, thanks!
14:40:29 <buxy> https://debusine.debian.net/debian/developers/workflow-template/upload-to-bookworm/ has autopkgtest_backend in Runtime parameters (and same for all)
14:40:32 <santiago> if there are no more comments / questions, I think we can move on
14:40:44 <tumbleweed> buxy: I thought as much :)
14:41:29 <santiago> #topic AOB
14:42:01 <charles> Regarding authentication to access the elts repo, should we mail someone to get credentials? That is https://www.freexian.com/lts/extended/docs/how-to-use-extended-lts-repositories/index.html#configuring-authentication-for-apt
14:42:11 <charles> I heve a few topics there...
14:42:43 <helmut> charles: there is authenticated access for customers, but authentication will not be required in 2026.
14:42:44 <santiago> we don't have a timeframe for taking the public repo down yet
14:43:11 <charles> ah, cool, then the follow-up question is also answered
14:43:25 <charles> ack then
14:43:52 <charles> will continue to use deb.freexian.com for now as sources.list forelts
14:44:21 <santiago> yes, no changes are required, for the time being
14:44:30 <santiago> next topic?
14:44:33 <charles> The next question might be a bit more directed to santiago: Any updates on salsaci-arm64-runner-01.debian.net? It is still offline
14:44:54 <santiago> charles, there is some movement on the new hosting place
14:44:57 <charles> since I did the change turning those jobs off on salsa-ci, I'm trying to keep an eye to revert them
14:45:06 <helmut> FYI, it is now possible to pass autopkgtest_backend
14:45:28 <santiago> but the machine is not up yet... :(
14:45:29 <charles> santiago: ack, but no clear timeframe, right?
14:45:46 <santiago> charles, no, I am afraid. It doesn't depend on us
14:46:00 <charles> ack, no problem, I'll keep an eye from time to time
14:46:01 <santiago> I'll let you all know when there are changes on that
14:46:08 <charles> ok, thanks
14:46:08 <santiago> next topic?
14:46:21 <charles> I out of topics :-)
14:46:44 <santiago> thanks for raising those topics
14:46:49 <santiago> any other business?
14:47:56 <santiago> OK, so I think we can conclude the main part meeting. We have in our agenda the appendix, about the discussion on technical questions or issues
14:48:25 <santiago> #info Next meeting: 2026-02-26 14:00 UTC
14:48:51 <santiago> on Jitsi
14:49:32 <santiago> we can end up the meeting here, and if somebody has any technical issue to discuss, don't hesitate to speak up
14:49:43 <santiago> thank you everybody for attending
14:49:51 <santiago> #endmeeting