#debian-perl: Perl 5.20 transition

Meeting started by gregoa at 17:57:53 UTC (full logs).

Meeting summary

  1. useful links (gregoa, 17:58:12)
    1. https://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=perl-5.20-transition;users=debian-perl@lists.debian.org bugs tagged perl-5.20.transition (gregoa, 17:58:18)
    2. https://release.debian.org/transitions/html/perl5.20.html transition page (gregoa, 17:58:23)
    3. https://lists.debian.org/debian-perl/2014/07/msg00046.html proposed agenda (gregoa, 17:58:26)
    4. http://meetbot.debian.net/debian-perl/2014/ meetings logs (gregoa, 17:58:48)

  2. Intro and welcome (gregoa, 17:58:52)
  3. review FTBFS and other mass-testing bugs (gregoa, 18:02:12)
    1. uploading 5.20 to sid would introduce 45 new RC bugs (gregoa, 18:03:33)
    2. Of the 45 RC critical bugs, 37 have patches, and 2 are pending (hlieberman, 18:04:31)
    3. AGREED: swig bugs: we NMU with the patched generated files if there is no maintainer reaction (gregoa, 18:08:30)
    4. two unfixed bugs are "Perl 5.20: alternative dependencies" (Dom, 18:15:56)
    5. ACTION: ansgar to look into the swig bugs (trying to regenerate stuff during build) (gregoa, 18:20:57)
    6. ACTION: ntyni looks at embperl (gregoa, 18:23:04)
    7. ACTION: fsfs hopefully feels pinged as well for embperl :) (gregoa, 18:23:17)
    8. one of the debhelper patches is applied in git, not the other (gregoa, 18:24:36)
    9. #751684 in debhelper should probably be wishlist, and only has a minor effect if unfixed (Dom, 18:26:16)
    10. #751684 (gregoa, 18:26:40)
    11. ... is the one fixed in git (gregoa, 18:26:50)
    12. it would be nice to have #750021 fixed before the transition (gregoa, 18:31:03)
    13. ACTION: Dom to ping #750021 (gregoa, 18:32:34)

  4. review bugs/work needed on perl package (gregoa, 18:33:15)
    1. bug pinging covers the debian-policy bugs as well (gregoa, 18:34:14)
    2. check if something from 5.18 needs to be merged into 5.20 (gregoa, 18:36:26)
    3. s390x libc reversion and perl 5.20 transition should not be entangled (Dom, 18:46:09)
    4. ACTION: ntyni and Dom to review Depends/Recommends one last time with all their eyes (gregoa, 18:50:12)
    5. ACTION: Dom to review the build logs again (gregoa, 18:51:09)
    6. can also be improved after transition in case it becomes necessary (gregoa, 18:52:14)
    7. https://lists.debian.org/debian-perl/2014/05/msg00137.html ← rra and NEWS.Debian and CGI.pm (gregoa, 18:55:02)
    8. AGREED: someone drafts a release notes update for changes to perl for jessie (gregoa, 18:57:19)

  5. actions/next steps (gregoa, 18:58:32)
    1. ACTION: Dom will complete the rebuild of arch:any packages and send a report to debian-perl (gregoa, 19:00:18)
    2. current proposed date for upload to sid: August 12th or thereabouts (gregoa, 19:01:14)
    3. ACTION: pochu to check with aurel32 about s390x libc (gregoa, 19:04:59)
    4. entangling perl and libc would be good (gregoa, 19:05:20)
    5. RT fine with either bumping to serious in advance or keeping at important and NMUing to DELAYED/5 (gregoa, 19:08:12)
    6. ACTION: dam to bump blocking bugs to serious asap (gregoa, 19:10:00)
    7. AGREED: start NMUing remaining bugs in a couple of days (gregoa, 19:11:15)
    8. ACTION: dam and gregoa NMU blocking packagaes, others welcome to join (gregoa, 19:12:21)

  6. 5.20.1 timing (gregoa, 19:13:41)
    1. http://www.nntp.perl.org/group/perl.perl5.porters/2014/07/msg217597.html (Dom, 19:15:49)
    2. anything super-urgent can be included from 5.20.1, and anything else can wait until the dust settles (gregoa, 19:16:52)
    3. AGREED: plan A: 5.20.0 in august, just in case of delays 5.20.1 if it's there (gregoa, 19:19:00)

  7. AOB? (gregoa, 19:19:27)
    1. it should be fine to do the revert [s390x libc] right before the perl transition (gregoa, 19:20:45)


Meeting ended at 19:22:14 UTC (full logs).

Action items

  1. ansgar to look into the swig bugs (trying to regenerate stuff during build)
  2. ntyni looks at embperl
  3. fsfs hopefully feels pinged as well for embperl :)
  4. Dom to ping #750021
  5. ntyni and Dom to review Depends/Recommends one last time with all their eyes
  6. Dom to review the build logs again
  7. Dom will complete the rebuild of arch:any packages and send a report to debian-perl
  8. pochu to check with aurel32 about s390x libc
  9. dam to bump blocking bugs to serious asap
  10. dam and gregoa NMU blocking packagaes, others welcome to join


Action items, by person

  1. ansgar
    1. ansgar to look into the swig bugs (trying to regenerate stuff during build)
  2. dam
    1. dam to bump blocking bugs to serious asap
    2. dam and gregoa NMU blocking packagaes, others welcome to join
  3. Dom
    1. Dom to ping #750021
    2. ntyni and Dom to review Depends/Recommends one last time with all their eyes
    3. Dom to review the build logs again
    4. Dom will complete the rebuild of arch:any packages and send a report to debian-perl
  4. gregoa
    1. dam and gregoa NMU blocking packagaes, others welcome to join
  5. ntyni
    1. ntyni looks at embperl
    2. ntyni and Dom to review Depends/Recommends one last time with all their eyes
  6. pochu
    1. pochu to check with aurel32 about s390x libc


People present (lines said)

  1. gregoa (127)
  2. Dom (111)
  3. ntyni (74)
  4. pochu (18)
  5. mst (17)
  6. dam (14)
  7. ansgar (10)
  8. hlieberman (5)
  9. MeetBot (4)
  10. XTaran (2)
  11. daxim (1)


Generated by MeetBot 0.1.4.