14:00:51 <larjona> #startmeeting
14:00:51 <MeetBot> Meeting started Mon Sep 21 14:00:51 2015 UTC.  The chair is larjona. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:51 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:04 <larjona> Dear all, welcome to this Debian Publicity Team meeting.
14:01:19 <larjona> #info Info about this meeting in
14:01:21 <larjona> https://wiki.debian.org/Teams/Publicity/Meetings/2015-09-21
14:01:27 <boutil> hello!
14:01:32 <larjona> #topic Round of introductions
14:01:57 <larjona> I'm here fighting with meetbot. Please say hello
14:02:12 <boutil> hello! (again)
14:02:20 <tvincent> Hello !
14:02:55 <larjona> (if it's your first time in a meeting, please introduce yourselves)
14:02:59 <moray_> Hi (though I probably need to leave the keyboard soon)
14:03:08 <ana> Hi
14:03:39 <cnote> Hi e
14:05:39 <larjona> Well, let's go on, just say hello if you come late
14:05:47 <larjona> #topic Transition to Git: finished? comments, TODO...
14:06:05 <larjona> Congratulations to all the people involved in making the transition to git possible.
14:06:25 <larjona> I'm not sure if there's pending work to do, or comments...
14:06:30 <boutil> all the repositories have migrated to Git
14:06:42 <boutil> We need to review the documentation to contribute to the team
14:06:45 <cnote> Big thanks! I like using got
14:07:09 <cnote> (on a tablet)
14:07:18 <boutil> Also, we could add a "myrepos" configuration for the publicity team to help fetching/syncing all repos of the team easily
14:07:21 <jipege> Hello, last dpn has been done using git, and it works !
14:07:24 <moray_> yes, good that this finally happened :)
14:07:28 <larjona> I'd like to ask if all the accounts that had permissions in svn now they have permissions in git.
14:07:36 <ana> #info We need to review the documentation to contribute to the team
14:07:42 <larjona> Justin B Rye (l10n-english) reported some problems
14:07:56 <ana> #action We need to review the documentation to contribute to the team
14:08:13 <larjona> #action larjona will review the documentation
14:08:15 <indiebio> Hi, I'm almost at my desk...
14:08:25 <ana> larjona: yes, permissions are handled by the alioth group
14:08:49 <ana> we would need to check if all the repos are DD-writable
14:08:52 <larjona> I still didn't tried to checkout/commit... shame on me!
14:08:57 <boutil> The Git workflow is not as simple as SVN: to push changes, you need now two separate actions (commit and push)
14:08:57 <ana> I don't know how that is done
14:09:17 <boutil> Maybe that was what JB Rye got confused about
14:09:28 <larjona> no, he got error trying to push
14:09:29 <boutil> (and the fact that the anonscm address is read-only)
14:09:50 <cnote> As I recall there are several methods to do the push.
14:09:55 <boutil> we should add some instructions to the mail asking for reviews and translations
14:09:58 <cnote> Which added to the confusion.
14:10:34 <larjona> Ok, I'll try to put some work on this, when finishing my setup.
14:10:49 <ana> #info we should add some instructions (about git usage) to the mail asking for reviews and translations
14:11:07 <larjona> I'd like to ask another question: we get two mails for each commit, one of them is not useful IMO (The one without the diff)
14:11:13 <tvincent> ana: the dpn repo is DD-writable, haven't have an occasion to test the other ones yet.
14:11:39 <boutil> tvincent: they are all supposed to have the same config.
14:11:50 <boutil> so it should be fine
14:12:12 <tvincent> Cool. :)
14:12:38 <jipege> announcements also works
14:12:53 <boutil> larjona: I think that it has to do with the current hook publishing commits to emails
14:13:53 <boutil> there was a change a couple of years. Now commits are grouped (one group by push action)
14:14:18 <boutil> so you get 1 mail at the beginning of the group, + additional mail for each commit
14:14:33 <boutil> often, we push commits one by one on the team.
14:14:42 <boutil> I'll see if we can revert to the old behaviour
14:14:59 <boutil> #action boutil see if we can deactivate extra emails when committing
14:15:06 <larjona> thanks boutil
14:15:19 <larjona> Anything else about the git migration?
14:15:43 <boutil> it just works :)
14:15:54 <larjona> Thanks and congratulations, again
14:16:06 <larjona> ok, moving on
14:16:09 <larjona> #topic Summary of ideas gathered from talk/BoF at DebConf
14:16:44 <larjona> I've watched the talk and the BoF
14:16:57 <larjona> BoF was difficult for me to understand, but I gathered some nots
14:17:13 <cnote> (thanks to tvincent for the subs)
14:17:25 <tvincent> :)
14:17:40 <ana> agreed, thanks tvincent for the subs :)
14:17:40 <larjona> oh, then I have to rewatch!
14:17:52 <boutil> +1
14:18:05 <larjona> I don't know if you want to remark anything...
14:18:36 <cnote> larjona: the floor is open?
14:18:43 <boutil> one of the results of the discussions we had during DebConf (but no visible on videos) was some remarks about DPN/annoucements/blog
14:18:46 <cnote> or where you talking to tvincent?
14:19:03 * larjona didn't understand "the floor is open"
14:19:19 <boutil> maybe we could try to slim down the DPN, and just keep articles,
14:19:32 <cnote> Where you talking to tvincent when you asked for remarks? But I see boutil is talking so n/m
14:19:54 <boutil> remove security, wwnp, nnwp
14:19:57 <cnote> I would like to change the format of the DPN to something more streamlines.
14:20:07 <boutil> and make blog posts from "Nice new packages"
14:20:15 <boutil> and "team what do you do?" sections
14:20:32 <boutil> - it would make the DPN easier to release
14:20:45 <boutil> - the blog would get more material
14:20:49 <larjona> I was asking for everybody
14:21:12 <cnote> boutil is speaking my ideas :)
14:21:23 <larjona> boutil cnotewhat about sending a proposal to the mailing list?
14:21:24 <cnote> thoughts is the better word.
14:22:04 <boutil> #action boutil send a proposal for a new formula for the DPN and to move content to the blog
14:22:38 <boutil> there was also a proposal for a HTML design for the DPN mail to make it more sexy
14:23:01 <larjona> #action larjona to review the spigot setup to publish DPN "titles" or "highlights"
14:23:14 <boutil> (in addition to the text only version)
14:23:43 <cnote> speaking of the DPN changes, can we speak briefly on the TODO file? It gets a lot of links in it that are either too old by the time we get to it or are too focused on certain items.
14:23:52 <boutil> One would need to see how to integrate it with our workflow
14:24:00 <cnote> Which I think speaks toward the overall scope of what DPN is covering.
14:24:01 <larjona> I suppose they don't talk about the design how DPN is view from www.debian.org?
14:24:45 <boutil> larjona: no, it was a proposition for a HTML email for the mailing list
14:24:46 <ana> we can ask tamo + indiebio to send an email about his, it was their idea/proposal
14:25:01 <ana> his->this (nice HTML for DPN)
14:25:18 <boutil> yes!
14:25:20 <indiebio> yup
14:25:36 <indiebio> tamo's idea, mainly
14:25:45 <boutil> that would be very nice
14:26:16 <larjona> indiebio can we make #action indiebio will talk with tamo and send a proposal about DPN html design, to the list?
14:26:26 <indiebio> sure larjona
14:26:33 <larjona> #action indiebio will talk with tamo and send a proposal about DPN html design, to the list
14:26:40 <indiebio> and DPN is Debian Publicity ... Network?
14:26:47 <boutil> cnote: I think that the problem with links will disappear if we manage to release more often :)
14:26:52 <boutil> indiebio: News
14:26:56 <indiebio> thanks
14:27:01 <larjona> DPN is debian project news
14:27:02 <boutil> Debian Project News
14:27:16 <cnote> Network does have a nice ring to it!
14:27:19 <ana> we might rename TODO to IDEAS, so it's implicit that not all the links have to make it to DPN
14:27:32 <cnote> second ana's suggestion
14:27:38 <boutil> agreed
14:28:20 <boutil> by the way, at DebConf, I met the ZSH team and gathered some notes for a "team what do you do?" article
14:28:41 <larjona> #action somebody to rename TODO to IDEAS (not all the links need to go to DPN)
14:28:51 <boutil> they are in gobby.debian.org, under Teams/Publicity/twdyd/zsh
14:28:59 <larjona> thanks boutil
14:29:05 <cnote> If we move some content from the DPN to the blog, are we concerned with the DPN being too lean?
14:29:37 <larjona> cnote I think we can discuss about it when the proposal arrives the mailing list
14:30:23 * larjona is more afraid about IDEAS links becoming dents/twits, and then, no interesting stuff for DPN
14:31:04 <cnote> I think with the size of the project it would still be interesting.
14:31:18 <cnote> But the question is asked are we sure that people are going to be reading it?
14:31:35 <cnote> We are moving from consolidating in one area to spreading out a bit.
14:32:04 <boutil> some say they don't read news mailing lists. But I also had positive feedback about the DPN
14:32:23 <boutil> so I'm sure that at least some people like it!
14:32:39 <larjona> And DPN has translations, too. Bits not (yet), nor dents/twits (yet?)
14:33:11 <boutil> I think there is a project to add translations to the blog, right ana?
14:33:20 <ana> #info bits.d.o will get translations in the next 2 weeks
14:33:25 <larjona> wow!
14:33:26 <boutil> (if more material is moved to it)
14:33:32 <ana> I'm currently migrating the versin of pelican in master.d.o to the one in jessie
14:33:55 <larjona> thanks ana! That's very good news
14:33:57 <ana> #info bits.d.o might get sub-blogs, currently studying it
14:34:05 <ana> as in bits.debian.org/debaday/
14:34:15 <tvincent> ana: Cool! Will it be enough to have access to publicity repos to translate?
14:34:39 <cnote> and also regarding the DPN content...do we need to cover Debian exclusively? I think it states on the wiki that we are to cover "everything which might have a noticable impact on the Project", this does leave us with the ability to add or fill empty space if we do start to cover/write about industry items.
14:34:44 <ana> tvincent: yes, the only software you'll need extra is pelican. So you can build the blog in local and see how it looks
14:34:55 <tvincent> awesome :)
14:35:56 <indiebio> cnote, would this be where 'Debian in the field' would fit in?
14:36:36 <cnote> indiebio, no I think your suggestion/idea can stand on its on merit. :)
14:36:49 <indiebio> ok
14:36:59 * indiebio is hammering away to get something to show as example...
14:37:03 <larjona> I would propose that we wait/discuss/work in next weeks via mailing list, and if we cannot agree in the DPN/bits reorganization, we meet again in October with main topic "DPN/bits reorganization"
14:37:06 <cnote> More along the lines of perhaps a standards change
14:37:54 <ana> larjona: I talked with both boutil (in debconf) and cnote (IRC) and people more or less have the same ideas
14:38:01 <ana> we only need to agree in the small details :)
14:38:33 <larjona> fine! It's just that I don't know how to "advance" now in the discussion :)
14:38:45 <larjona> (20 minutes to finish meeting...)
14:39:14 <ana> #topic delegation
14:39:29 <larjona> #topic Delegation
14:39:33 <ana> thanks :)
14:39:51 <ana> I sent an email to DSA to merge all the grups in LDAP and have a single publicity group
14:40:07 <ana> it might take some time... turns out we had 4 different groups: dpn, publicity, press and debbits
14:40:41 <ana> with the delegation we have "inherited" press releases and I would like to summot Maulkin on how to handle this :)
14:40:44 <ana> summon*
14:41:24 <ana> I'm talking about the emails sent to debian-announce: https://lists.debian.org/debian-announce/
14:42:09 <larjona> Anybody else apart from Maulkin with experience in the announcements/press releases workflow?
14:42:10 <boutil> do you know also how we are suppose to trigger rebuilds of the News section of the website?
14:42:25 <ana> larjona: pabs MadameZou and moray_
14:42:29 <cnote> It is online
14:42:42 <cnote> I looked at it the other day when i was going to do the 7.9 announce.
14:42:47 <cnote> iirc
14:42:58 <ana> I'm a bit confused because we got some mails in debian-news that IMHO should have been in debian-announce
14:43:11 <ana> the difference between both lists is something we should agree on
14:43:20 <larjona> #info Update delegation mergin press/bits/publicity into publicity: https://lists.debian.org/msgid-search/20150917134723.GL32659@halon.org.uk
14:44:38 <cnote> https://wiki.debian.org/Teams/Publicity/Announcements <- larjona?
14:44:47 <larjona> #info announcements workflo: https://wiki.debian.org/Teams/Publicity/Announcements
14:44:58 <larjona> workflow*
14:45:08 <jipege> debian-announce is just about release
14:45:18 * Maulkin has been summoned.
14:45:32 * cnote makes 3 wishes
14:45:56 <ana> jipege: that's lately, in the past we had more things there. e.g. https://lists.debian.org/debian-announce/2012/threads.html
14:46:09 <Maulkin> So, https://wiki.debian.org/Teams/Publicity/Announcements is the magic place, but you'll probably find special issues depending on what type of release it is.
14:46:30 <Maulkin> Also, -news should be used by default. -announce is only for point releases etc.
14:46:47 <larjona> #info  -news should be used by default. -announce is only for point releases etc.
14:47:00 <Maulkin> (or basically, other /major/ announcements)
14:47:35 <ana> Maulkin: ok, I'm fine with this. Did you decide in press this change or it just happened?
14:48:11 <Maulkin> Nope, this was brought up a while ago... ~2013?
14:48:50 <Maulkin> I can try and dig up the mailing list ref if needed.
14:49:37 <larjona> If we agree to keep things like that, we should update the description of both lists: https://lists.debian.org/debian-announce/ and https://lists.debian.org/debian-news/
14:50:11 <Maulkin> Also, whoever needs the magic runes to send stuff to those lists, please mail me :)
14:50:21 <cnote> We moderate those lists correct?
14:50:48 <larjona> Both lists appear in lists.d.o as moderated
14:50:53 <Maulkin> 'Moderate' is a very strong word. There's a special header you put in the mail, and it goes through. No header == discard.
14:51:02 <Maulkin> So... yeah.
14:51:02 <cnote> ty
14:51:55 <larjona> 8 minutes to finish the meeting
14:52:10 <ana> Maulkin: could you mail us directly this "magic" runes ? :)
14:52:11 <boutil> Maulkin: can you send the runes to all the members of the Publicity delegations
14:52:14 <boutil> ?
14:53:39 <Maulkin> ana: Yeah, but I won't remember, I'm in another call at the moment, so ENOACCESS.
14:53:50 <cnote> We touched a bit on documentation, we need to document the workflow for the major releases if we are to repeat the (awesome) success of the Jessie release.
14:53:52 <Maulkin> Please send me a mail and I'll reply :)
14:53:55 <larjona> #action Maulkin will send mail to the new Publicity delegated people about details to send announcements/press releases
14:54:17 <larjona> #action larjona will remind the people about their pending actions :)
14:54:43 <larjona> ok, let's move?
14:54:50 <boutil> yep
14:54:56 <larjona> #topic Status of the team (people): plans, changes, new contributors...
14:55:11 <Maulkin> larjona: :รพ
14:55:32 <larjona> I became DD in August. I'm planning to get more involved here,but also to repeat involvement in DebConf (Debconf16)
14:55:39 <boutil> congratulations!
14:55:44 <indiebio> congrats!
14:55:55 <larjona> thanks to all of you for your mentoring and friendship
14:56:09 * ana have to go
14:56:19 <larjona> thanks ana!
14:57:08 <Maulkin> Also, larjona is the first person to have an application processed by a DPL :)
14:57:16 <larjona> yeah!
14:57:17 <boutil> :)
14:57:22 <cnote> Nice. :)
14:57:57 <boutil> On my side, nothing new to discuss on this item, that was not already told before
14:58:20 <larjona> As part of the welcome team, I'd also like to help other people to get more people in Publicity team, so feel free to send interested people to me
14:58:33 <indiebio> uhm , when do I speak of my idea? :)
14:58:39 <larjona> now
14:58:50 <larjona> #topic Other business.
14:59:05 <larjona> sorry indiebio
14:59:18 <indiebio> no probs, doesn't have to be today either...
14:59:27 <larjona> shall we continue some more minutes? No problem in my side
14:59:41 <boutil> I have to leave unfortunately
14:59:45 <cnote> I have to dash for 10 minutes.
15:00:00 <cnote> indiebio: you are speaking to the html/Debian in the News stuff?
15:00:26 <indiebio> cnote: I don't think so. I made a rough hack of what I'm thinking of here: http://indiebio.co.za/debian-in-the-field-draft
15:00:39 * boutil says bye and will read the logs later
15:00:49 <larjona> thanks boutil
15:00:59 <larjona> #info indiebio has some ideas, gathered in http://indiebio.co.za/debian-in-the-field-draft
15:01:02 <indiebio> it's not edited properly yet, and the guy - Mark - still needs to read it, but this is sortof what I'm thinking of. Short snippets, with (hopefully better quality) images
15:01:11 <cnote> I like it.
15:01:31 <indiebio> I imagine finding ideas from just speaking to people, and trawling places like debi-chem, debimed etc etc
15:02:12 <indiebio> I would like to have a relative frequency of local (aka South African) content for the next 10 months or so, to make this also work as advertising DebConf16, particularly to South Africans
15:02:27 <cnote> I'd like to push more 'Publicity' stuff in the sense of the word and this does fit with that perfectly...along with the WDYD section, etc..
15:02:40 <indiebio> as my main aim with being involved in DebConf16 is to grow awareness of Debian in (South) Africa
15:02:41 <larjona> Fine, it could be a kind of "special issues" of www.debian.org/users
15:02:50 <cnote> I really have to run for a moment, hopefully you all go a bit overand are here when I return.
15:03:11 <larjona> ok we stay until 17:10 and then I cut the logs, agree?
15:03:13 <indiebio> we can figure out in good time where the posts should live
15:04:09 <larjona> indiebio but we "need" a quick solution for taking advantage for DebConf16, isn't it?
15:04:29 <indiebio> so I guess I would like people to think about it, and highlight any concerns or ideas for improvement while it is still in beta :)
15:04:36 <indiebio> larjona, meaning?
15:04:46 <larjona> maybe those kind of posts could go to bits.debian.org, and then, an entry in www.debian.org/users with summary + link to the bits blogpost
15:04:53 <indiebio> yes
15:05:18 <indiebio> It doesn't really matter where it lives as wherever we advertise it can link to that. It just needs to be appropriate
15:05:38 <indiebio> aka hosting it on my site would be weird
15:05:49 <indiebio> but I can chat about it on my site and link to Debian
15:05:59 <larjona> indiebio I understand
15:06:09 <indiebio> which means that people here must be happy with the content and style too
15:06:56 <indiebio> I'm thinking of a rough frequency of 'a few a month', maybe two per month?
15:07:22 <indiebio> so that's all I really wanted to say :)
15:09:32 <larjona> indiebio I like the idea, and if the appearance of bits.debian.org suits you, I think the posts could live there. I'm not sure if you need something (assistance in formatting the post for bits, or agreement of the whole team...)
15:11:34 <indiebio> not sure... the appearance of bits.debian.org is fine (similar to my site at first glance :) ) I would have to see what the formatting is, I should be ok if I can look at other posts or a template.
15:11:44 <larjona> ok
15:11:57 <indiebio> I would definitely need agreement on style and content, but it's easy enough to edit things as we go along
15:12:25 <indiebio> random question, how do I get posting rights?
15:12:49 <larjona> #action larjona and indiebio will explore possibilities for regular posts in bits.debian.org about "Debian in the field" (case uses for Debian)
15:13:19 <indiebio> Going forward, I could post it on my site (rewriting the draft everytime) and get people to view it before it goes to bits, if people want that safety net.
15:13:22 <indiebio> cool.
15:14:04 <larjona> Shall we finish the meeting? (cutting the log). I will still be here to discuss details about posting rights and so
15:16:26 <larjona> ok, I think I'll finish the meeting
15:16:42 <larjona> Thanks everybody for attending
15:17:06 <larjona> #endmeeting