12:00:14 <zack> #startmeeting
12:00:14 <MeetBot> Meeting started Fri Jan  9 12:00:14 2015 UTC.  The chair is zack. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:14 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:00:20 <zack> sophiejjj: hi!
12:00:21 <matthieucan> pfiou, just in time
12:00:23 <matthieucan> hi!
12:00:31 <zack> matthieucan: that was timely, yes :)
12:00:34 <zack> #chairs matthieucan
12:00:36 <zack> #chair matthieucan
12:00:36 <MeetBot> Current chairs: matthieucan zack
12:00:43 <zack> #topic debsources opw - next meeting
12:00:50 <sophiejjj> i
12:00:51 <sophiejjj> hi
12:01:06 <zack> is next week, same time, good for next meeting?
12:01:11 <sophiejjj> yes.
12:01:25 <matthieucan> yes
12:01:28 <zack> #agreed next meeting next Fri, usual time
12:01:35 <zack> nice, that was easy!
12:01:40 <zack> #topic debsources opw - weekly review
12:01:50 <zack> let's go through this week's plans, as usual
12:02:00 <zack> 1st item was: test coverage ≥ 85% (see #762951)
12:02:04 <zack> sophiejjj: status on that?
12:02:14 <sophiejjj> let me have a look
12:02:37 <sophiejjj> 81%
12:02:51 <zack> better than last week!
12:02:55 <matthieucan> almost there :)
12:02:58 <sophiejjj> ;)
12:03:10 <zack> sophiejjj: do you want to keep that as a task for next week?
12:03:15 <sophiejjj> sure.
12:03:20 <sophiejjj> I will move that.
12:03:27 <zack> ok, thanks
12:03:36 <sophiejjj> done.
12:03:41 <zack> next item: show the destination of symbolic links. make the format more of "ls -l"
12:03:46 <zack> that is done, right?
12:03:58 <matthieucan> yes, it looks good!
12:04:05 <sophiejjj> yes.
12:04:11 <zack> amazing, please archive the item
12:04:24 <zack> next item: #761121 allow symlink within same pkg - add test for insecure links
12:04:29 <zack> done?
12:04:35 <sophiejjj> done.
12:04:40 <zack> \o/
12:04:43 <zack> please archive
12:04:50 <sophiejjj> archived.
12:04:54 <zack> next! work out basic project structure for copyright.d.n
12:04:59 <zack> status?
12:06:03 <matthieucan> in discussion, email thread about blueprints, etc
12:06:16 <sophiejjj> blueprints seems feasible.
12:06:18 <matthieucan> for me it's not entirely clear what we'll do according to apps, etc
12:06:34 <zack> sophiejjj: any work done on your part that we haven't yet seen in email?
12:06:41 <zack> (on this specific item, I mean)
12:06:50 <sophiejjj> no.
12:07:08 <zack> just because of time issues, or is there any other blocker?
12:07:19 <matthieucan> will we have a separate git repo for that?
12:07:36 <zack> matthieucan: I'll get to that in a minute
12:07:37 <sophiejjj> mainly time issues, I am writing a survey these days.
12:07:48 <zack> sophiejjj: uhm, ok
12:08:00 <zack> sophiejjj: but please, can you let us know in advance when you've other time commitment?
12:08:20 <sophiejjj> zack: yup. sorry.
12:08:39 <zack> it's OK, it's just better to know in advance, than discover afterwards :)
12:08:48 <zack> sophiejjj: how long do you still need for the survey?
12:09:52 <sophiejjj> till jan.20. But I can do debsources in the meantime.
12:10:51 <zack> ok, if you think it will take more than 1 day/week, please let us know, so that we can adapt OPW aims accordingly
12:10:58 <zack> (maybe via email, no need to discuss that during the meeting)
12:11:01 <zack> deal? :)
12:11:06 <sophiejjj> deal.
12:11:09 <zack> awesome!
12:11:23 <zack> so, I'd like to prioritize a bit the work on copyright.d.n for next week
12:11:36 <zack> can you please move the project structure item to next week?
12:11:47 <zack> then, I think we should discuss matthieucan's point about where to have the code
12:12:01 <sophiejjj> moved.
12:12:17 <zack> sophiejjj: does the blueprint stuff scares you and/or poses some problem? (if so, I can we can postpone it, while still working on the project structure)
12:12:40 <sophiejjj> it doesn't I think.
12:13:04 <sophiejjj> but it poses a different work-style.
12:13:10 <zack> so, how about start creating a dedicated page, rooted at APP/copyright, and start implementing there the main features?
12:13:27 <sophiejjj> I mean, I guess unlike the filling some stubs, it requires a totoal bottom-up of the code.
12:13:38 <sophiejjj> got it.
12:13:52 <zack> like package browsing would be /copyright/path/to/package/
12:13:59 <zack> search /copyright/search/, etc.
12:14:12 <zack> it is up to you whether you use a blueprint or not
12:14:17 <zack> it would be *better* to do so, I think
12:14:19 <matthieucan> this seems fair. Having a plugged blueprint on /copyright will definitely work
12:14:30 <zack> matthieucan: thanks, I was about to ask you :)
12:14:36 <sophiejjj> gotcha.
12:14:41 <matthieucan> not having it will work as well, but it will mix both apps
12:14:55 <zack> sophiejjj: what do you think would be a minimal feature (or features) that you could implement during next week?
12:15:18 <zack> some examples could be:
12:15:25 <matthieucan> should we discuss the db structure before?
12:15:32 <sophiejjj> listing the packages ?
12:15:39 <zack> matthieucan: I think we should use the same DB of the current app
12:15:58 <zack> matthieucan: a dedicated copyright table could be added later, in the meantime we can parse d/copyright on the flight, no?
12:15:59 <matthieucan> zack: yes, but we'll need new tables/columns
12:16:00 <sophiejjj> like the way the frontpage of debsources?
12:16:09 <matthieucan> zack: oh yes, sure
12:16:31 <zack> sophiejjj: ok, so that would be an item like "package browsing starting from /copyright/...", please add it to trello
12:16:46 <zack> sophiejjj: note, we do *not* want to see copy/paste code there, it should reuse the existing code for package browsing
12:16:55 <sophiejjj> got it.
12:17:09 <matthieucan> hence moving stuff to a separate module, see email thread about that
12:17:10 <sophiejjj> so I may refactor the code in debsources.
12:17:15 <matthieucan> didn't have time to file a bug yet
12:17:30 <zack> I've no idea whether the current browsing code can be reused as is or not
12:17:49 <matthieucan> I think so, at least what's in models.py
12:17:51 <matthieucan> IIRC
12:17:52 <zack> I think you two are in the best position to discuss that (via email would be better, I guess)
12:17:59 <matthieucan> sure
12:18:14 <zack> matthieucan: in the mid term, it would be best to move that out of models.py though, right?
12:18:19 <sophiejjj> I will look into that, and will consult matthieucan if I have problems.
12:18:21 <zack> I mean, strictly speaking navigation != ORM :)
12:18:42 <matthieucan> zack: yes, but they are implemented as methods of these objects
12:18:47 <matthieucan> which still make sense :)
12:19:03 <zack> matthieucan: they are yes, I think they shouldn't :), but that's a different discussion
12:19:26 <zack> sophiejjj: I think it should also be doable to do a very basic rendering of machine-parseable debian/copyright file, once reaching a specific package/version
12:19:35 <matthieucan> zack: yes, maybe we should have orm.py and models.py separately
12:19:48 <zack> sophiejjj: could be as stupid as "just dumping the file content", but only if the file is machine parseable
12:19:58 <sophiejjj> matthieucan: I think model is of the same semantics as orm.
12:20:00 <zack> sophiejjj: because that will give you a change of learning the debian.copyright Python API
12:20:19 <sophiejjj> zack: regarding the debian.copyright
12:20:32 <matthieucan> sophiejjj: yes, but we reached a point where we have too many methods on our classes, and the orm becomes less clear
12:20:43 <sophiejjj> I'd like to learn more about the debian stuff, like the forthmentioned d.copyright in this OPW.
12:21:04 <sophiejjj> matthieucan: I got your point. Actually there was a bug about it, IIRC.
12:21:14 <zack> sophiejjj: there is, yes
12:21:23 <sophiejjj> I tried to do that.
12:21:56 <sophiejjj> and I didn't finish it, IIRC, the code is tangled together and cutting them through is somewhat laborious.
12:22:18 <zack> it is a bit, yes
12:22:31 <zack> let's see if having to reuse it for /copyright helps in actually having to do that
12:22:40 <matthieucan> sophiejjj: you're right, we should probably use inheritance for app-specific classes, this shouldn't be too hard I think
12:23:01 <zack> sophiejjj: so, I've added 2 items that revolve around copyright.d.n, can you have a look and see if they make sense to you?
12:23:26 <zack> (then we should move to the next items of last week, I think)
12:23:41 <sophiejjj> yeah.
12:24:04 <zack> matthieucan: regarding the Git repo, I think that it makes sense to use the same one (at least for now, but also in the long term I think)
12:24:15 <zack> sophiejjj: great
12:24:49 <matthieucan> zack: yes, it will be simpler. In that case it might be difficult to separate the apps, but that's not necessarily needed
12:24:58 <zack> ok, so let's move to next item
12:25:01 <zack> next item is: #761119 - suite-based navigation
12:25:12 <zack> there is a patch for sophiejjj, but I haven't had time to review it yet, unfortunately
12:25:20 <zack> (new semester starting, I'm a bit busy these days...)
12:25:26 <matthieucan> me neither
12:25:35 <zack> matthieucan: do you think you can review sophiejjj's patch in the next few days?
12:25:46 <matthieucan> zack: sure, before end of week-end
12:25:49 <zack> sophiejjj: that patch is only for the first part of the bug report, right?
12:25:52 <sophiejjj> yes.
12:25:53 <zack> matthieucan: awesome!, thanks a lot
12:26:04 <sophiejjj> I think much about the html should be accordingly modified.
12:26:11 <zack> #action matthieucan to review sophiejjj's 1st patch for #761119
12:26:26 <matthieucan> sophiejjj: what html?
12:26:31 <zack> sophiejjj: please move the item to next week
12:26:53 <sophiejjj> like, the link to the corresponding /suite/prefix
12:26:56 <zack> matthieucan: I think she means the template, for implementing the *2nd* part of the bug
12:27:07 <sophiejjj> should it be a combo-box, or? etc.
12:27:17 <sophiejjj> zack: the first part.
12:27:23 <zack> oh, sorry then
12:27:32 <zack> O
12:27:42 <sophiejjj> first the user should be able to select the desired suite.
12:27:55 <matthieucan> oh I see
12:28:06 <sophiejjj> second, for the returned result.
12:28:21 <sophiejjj> a new url_for should be added.
12:28:24 <KGB-0> 03Mattia Rizzolo 05master c2a458f 06jenkins.debian.net 10bin/ 10(6 files) reproducible: update links after apache change. strip the leading /userContent where possible
12:28:41 <zack> I'll live that to you two, do you think we can continue/finish that discussion via email? (I'm a bit short of time ATM)
12:28:50 <zack> I'll *leave* (sorry for the typo)
12:28:55 <matthieucan> sophiejjj: feel free to modify the html where it's needed
12:28:55 <sophiejjj> now?
12:28:56 <matthieucan> zack: sure
12:29:25 <zack> so last item was: #761083 - inject binary package metadata
12:29:32 <zack> sophiejjj: any progress on that?
12:29:39 <sophiejjj> I read the updater.py
12:29:48 <zack> the plan was to just *look* around and figure out were changes where needed
12:30:01 <zack> sophiejjj: awesome, you scared about it? :-)
12:30:02 <sophiejjj> so the stage, adding the packages.
12:30:10 <sophiejjj> and the stage, mapping the suite.
12:30:21 <sophiejjj> gc maybe, or maybe not. I am not sure.
12:30:29 <matthieucan> yes gc as well
12:30:41 <zack> I guess the GC part can be left fo the DB
12:30:55 <zack> if the binary package entries reference the source package entry, they will automatically disappear
12:30:59 <matthieucan> adding the source/mapping/binary should be done in the same sqlalchemy transaction
12:31:00 <zack> when the source package entries are removed from the DB
12:31:23 <matthieucan> zack: with triggers?
12:31:34 <zack> matthieucan: no triggers, just plain referential integrity
12:31:43 <zack> (with CASCADE and the like)
12:32:01 <zack> we already use that for all plugin data, for instance
12:32:14 <matthieucan> oh ok, sure
12:32:41 <zack> sophiejjj: in fact, the main part that will need work is:
12:32:53 <zack> - retrieving Packages file
12:32:56 <zack> - parsing them
12:33:11 <sophiejjj> got it.
12:33:13 <zack> - and session.add() to the tables that already exist the corresponding ORM entries
12:33:34 <sophiejjj> is there existing binaries files for me to play with?
12:33:39 <zack> sophiejjj: *if* you think you can give that a try next week, move the item to the appropriate list, *if not*, let's move it back to backburner
12:34:04 <zack> sophiejjj: yes, I can provide you one, with examples on how to parse it (the parser is already available in python-debian)
12:34:11 <sophiejjj> I think I shall move it to the backburner.
12:34:17 <zack> sophiejjj: ok, please do
12:34:35 <sophiejjj> I will first do the per suite. Since I've started on that.
12:34:36 <zack> I'll add a TODO item for me (for the future) to give you a sample Packages file and a parsing example
12:34:47 <zack> ok, great
12:34:51 <zack> looks like we're done with the weekly review
12:34:56 <zack> #topic debsources opw - misc
12:35:10 <zack> sophiejjj, matthieucan: anything else before we adjourn the meeting?
12:35:25 <matthieucan> everything's fine with me :)
12:35:32 <sophiejjj> yes. fine with me, too.
12:35:41 <zack> wonderful, so...
12:35:43 <zack> #endmeeting