12:00:39 <matthieucan> #startmeeting
12:00:39 <MeetBot> Meeting started Fri Jan 30 12:00:39 2015 UTC.  The chair is matthieucan. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:00:39 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:00:42 <sophiejjj> lol.
12:00:53 <matthieucan> #topic debsources OPW - next meeting
12:00:59 <matthieucan> agreed for next week?
12:01:03 <sophiejjj> en.
12:01:10 <matthieucan> I think zack will be here
12:01:42 <sophiejjj> zack is FOSDEM now?
12:01:42 <matthieucan> #agreed next meeting next Friday, usual time
12:01:48 <matthieucan> yes
12:02:23 <matthieucan> anything else before the weekly review?
12:02:34 <sophiejjj> nothing. ;)
12:02:39 <matthieucan> great
12:02:50 <matthieucan> #topic debsources OPW - weekly review
12:03:02 <matthieucan> blog post
12:03:07 <matthieucan> it's done
12:03:14 <matthieucan> you can move it :)
12:03:29 <sophiejjj> done.
12:03:34 <matthieucan> cool
12:03:45 <matthieucan> suite info on /foo's
12:03:50 <matthieucan> is this merged and deployed?
12:03:57 <sophiejjj> I think yes.
12:04:11 <matthieucan> perfect :)
12:04:37 <sophiejjj> I will archive it.
12:04:48 <sophiejjj> done.
12:04:50 <matthieucan> thanks
12:04:53 <matthieucan> anything new with test coverage? what's the current status?
12:05:01 <sophiejjj> nothing new.
12:05:07 <sophiejjj> around 81% IIRC.
12:05:27 <matthieucan> ok, postponed to next week? or backburner?
12:05:41 <sophiejjj> backburner, since the restructure?
12:05:58 <sophiejjj> I've moved it.
12:06:01 <matthieucan> agreed, there is a lot to do with c.d.n !
12:06:16 <sophiejjj> shall we create a list for the next week?
12:06:25 <matthieucan> definitely
12:06:41 <matthieucan> are you doing it already or should I create it?
12:06:51 <sophiejjj> I am trying to do that,,,
12:06:56 <sophiejjj> or you do it, thanks.
12:07:44 <matthieucan> cool, seems to work fine :)
12:08:01 <sophiejjj> haha. cool. hello.
12:08:12 <matthieucan> so let's move on to c.d.n
12:08:15 <sophiejjj> yup.
12:08:18 <sophiejjj> I've some questions.
12:08:25 <matthieucan> was I clear enough in the email thread from yesterday?
12:08:27 <matthieucan> yes, sure
12:08:40 * sophiejjj still is not sure about that.
12:09:15 <sophiejjj> what do you mean by "I propose to have 2 apps"?
12:09:27 <sophiejjj> is the app the "Flask app" ?
12:09:47 <matthieucan> by "app" I mean a classic Flask app structure, with views/templates/static files/etc
12:10:00 <sophiejjj> aha.
12:10:01 <matthieucan> 2 apps = debsources + copyright
12:10:13 <matthieucan> and not a third one, because we only need something to plug the blueprints
12:10:16 <sophiejjj> I was saying, one app with two blueprints.
12:10:33 <matthieucan> app=blueprint  in my mind, actually
12:10:41 <sophiejjj> I remember you once said, one app with two blueprints, one app with one blueprint(c.d.n)
12:10:42 <matthieucan> ok, sorry for the misunderstanding
12:10:53 <matthieucan> hm
12:11:01 <matthieucan> I see
12:11:04 <sophiejjj> ok. so shall we make it clear, app = flask_app, and blueprint is just blueprint?
12:11:16 <matthieucan> it was about copyright.debian.net, and s.d.n/copyright
12:11:23 <matthieucan> yes
12:11:40 <matthieucan> it depends if we want the same on c.d.n and s.d.n/copyright
12:11:48 <matthieucan> IIRC, there was no consensus about that
12:12:08 <sophiejjj> since you are saying it, I am confused about s.d.n/copyright
12:12:25 <sophiejjj> It doesn't need the browsing functionality I think.
12:12:41 <matthieucan> it would be the copyright blueprint, integrated to the current debsources infra
12:13:02 <matthieucan> yes, but it would need the links to the browsing in the interface
12:13:15 <h01ger> buxy: before i forget: thanks from me too for merging pabs reproducible patches! also the layout looks fine now in wheezy konqueror so i think i will replace the PTS links from jenkins+piuparts to point to the new tracker soon. IOW: if i havent done so by next tuesday, feel free to remind me :-)   (and sorry to shout this in the meeting! i'm glad you have them here! /me travels thats why...)
12:13:26 <sophiejjj> en. that's a must. but I am wondering what functionality should the "copyright blueprint" support.
12:14:23 <matthieucan> we're definitely not clear about what we want with "copyright" w.r.t. what debsources does
12:14:28 <matthieucan> what we can do in the meantime
12:14:56 <sophiejjj> matthieucan: but if "copyright" doesn't need browsing, then we *don't need" the re-structure.
12:15:07 <matthieucan> is implement e.g. the debian/copyright file dump, because this won't be lost work, whatever we choose for the browsing/searching functionalities and friends
12:15:26 <matthieucan> there is still a bit of restructure
12:15:27 <sophiejjj> matthieucan: yes. but a problem is, what about the html/css stuff.
12:15:34 <matthieucan> for that for instance
12:15:45 <matthieucan> this should be moved to something like a library
12:16:07 <sophiejjj> ennn.
12:16:08 <matthieucan> "something like", because they are not classical importable "functions", but rather a collection of templates
12:17:20 <sophiejjj> matthieucan: well I think, if I remember correctly, "dumping" is already done, the "dumping" we are referring to is more about rendering.
12:17:40 <sophiejjj> which is more related with the html/css, and the web logic, instead of the library thing.
12:18:15 <matthieucan> by dumping, are we talking about the third card in the trello list of this past week?
12:18:31 <sophiejjj> yes.
12:18:49 <matthieucan> where has this been done?
12:18:51 <sophiejjj> like source file rendering, but with no highlight.js.
12:18:57 <matthieucan> oh I see
12:19:17 <sophiejjj> just showing the content, so it's more of a web stuff. not the lib.
12:19:40 <sophiejjj> zack said there is a parsable for the copyright file already.
12:20:02 <sophiejjj> matthieucan: do you think a "c.d.n" really important?
12:20:14 <sophiejjj> isn't "s.d.n/copyright" enought?
12:20:23 <sophiejjj> s/enought/enough/
12:20:30 <matthieucan> I don't know that, this is zack's idea and initiative
12:20:31 <matthieucan> but
12:20:34 <matthieucan> what we could do
12:20:56 <sophiejjj> yes. we could do.
12:21:24 <sophiejjj> and I think "restructruing" is just a labor work, since we already have the code, so just a matter of time.
12:21:29 <matthieucan> is to implement the copyright related features in a module, integrate all of this in debsources, without blueprints, and create a new flask app to have another, lighter, interface for s.d.n
12:22:16 <matthieucan> this would not be too complicated, wouldn't need too much refactoring, but is not the most beautiful solution when it comes to software patterns
12:22:28 <sophiejjj> yes.
12:22:35 <matthieucan> I think we should (re)begin a mail thread with zack about that
12:22:55 <sophiejjj> I think it all depends on what  "c.d.n" will be like.
12:23:16 <sophiejjj> if it's what zack described in the specification, I think it's worth doing.
12:23:25 <matthieucan> I imagined it as the subset of features present in debsources and related only to copyright
12:24:00 <sophiejjj> en. I am just scared about the "browsing/searching"
12:24:07 <sophiejjj> since debsources is mostly about that.
12:24:22 <sophiejjj> and with the "browsing/searching", c.d.n is like a *copy* of s.d.n
12:25:04 <matthieucan> we may delegate the browsing/searching to debsources, a bit like codesearch.debian.net delegates the "viewing" part to debsources
12:25:15 <sophiejjj> haha.
12:25:40 <sophiejjj> that's what "s.d.n" behaves, a link will be added in the packge page, delegating to "copyright"
12:25:57 <matthieucan> and the other way around: debsources delegates code pattern search to codesearch.debian.net
12:26:06 <sophiejjj> en.
12:26:26 <sophiejjj> matthieucan: so my point is, "s.d.n" and "c.d.n" has too much funcionality overlapped.
12:26:29 <matthieucan> this pattern is another solution we'd have to discuss more deeply if we go for it
12:26:37 <matthieucan> for sure
12:27:11 <sophiejjj> and about the "delegation" you just mentioned.
12:27:31 <sophiejjj> so when you arrive at "c.d.n", what will happen?
12:28:56 <sophiejjj> matthieucan: there?
12:29:39 <matthieucan> this is discussable, but one might search for a package, seeing the results on s.d.n/search?option=copyright, so debsources is aware of that and creates links to redirect the user to s.d.n in the results list
12:30:00 <matthieucan> this is not that cool, seen like that
12:30:15 <matthieucan> hm
12:30:24 <sophiejjj> en. that's one solution.
12:30:55 <matthieucan> what we should do is:
12:31:16 <matthieucan> create two lists: features of c.d.n, features of s.d.n/copyright
12:31:25 <matthieucan> see what exactly overlaps
12:31:30 <sophiejjj> en.
12:31:53 <sophiejjj> well. zack will have more words to say on that ? ;)
12:32:43 <matthieucan> ok, what about adding a card in trello for that week: make a sum-up of the options we have, of the features we want in both apps/blueprints/whatever, and discuss this with zack via email?
12:32:58 <sophiejjj> ok. I will add that.
12:33:11 <matthieucan> I definitely need a clear one-screen picture of this :)
12:33:14 <matthieucan> great!
12:33:57 <sophiejjj> done.
12:34:20 <matthieucan> cool
12:34:40 <matthieucan> so, did you actually write code related to copyright yet?
12:35:02 <sophiejjj> I wrote, but gave up quickly though.
12:35:21 <sophiejjj> and then I sent you the emails.
12:35:30 <matthieucan> ok
12:35:36 <matthieucan> do you use a distant git repo?
12:35:47 <sophiejjj> aha.
12:35:58 <sophiejjj> I will setup one on bitbucket, is that OK?
12:36:06 <matthieucan> because we'll need a branch access to test your code, since email-patches won't scale in case of a big refactoring with many patches
12:36:09 <matthieucan> bitbucket is perfect
12:36:27 <sophiejjj> hg is more perfece. ;).
12:36:44 <matthieucan> hahaha, try to convince zack :D
12:37:10 <matthieucan> anything else related to copyright?
12:37:36 <sophiejjj> I've some confustion about the details of re-structure.
12:37:55 <sophiejjj> but I think I maybe write it in email?
12:38:28 <matthieucan> yes, a sum-up of the situation will help us a lot I think (at least me :/)
12:38:49 <sophiejjj> ;)
12:38:58 <matthieucan> alright
12:39:02 <matthieucan> what about reading/learning?
12:39:08 <sophiejjj> what?
12:39:11 <matthieucan> did you play with debian-python?
12:39:15 <matthieucan> the trello card
12:39:24 <sophiejjj> haha.
12:39:25 <matthieucan> python-debian*
12:39:30 <sophiejjj> zack never asked me that list.
12:40:07 <matthieucan> it's a parallel thing if I'm not wrong, not a deliverable :)
12:40:24 <matthieucan> keep it in mind, it will be useful for c.d.n
12:40:29 <sophiejjj> yep.
12:40:39 <matthieucan> nothing complicated, just using library functions related to debian packages
12:40:54 <matthieucan> let's let that card there
12:41:07 <sophiejjj> moved.
12:41:21 <matthieucan> oh, great
12:41:24 <matthieucan> I'd like to move the copyright cards from that week
12:41:43 <sophiejjj> which one?
12:41:48 <matthieucan> maybe create a category for copyright, so we keep the cards for when we'll have solved our problems
12:42:01 <sophiejjj> good idea!
12:42:23 <sophiejjj> I just renamed.
12:42:49 <matthieucan> well done
12:42:58 <sophiejjj> I am always curious.
12:43:05 <matthieucan> about?
12:43:19 <sophiejjj> so in deployment, we use apache+wsgi+python? right?
12:43:33 <matthieucan> we replaced wsgi with fcgi
12:43:36 <matthieucan> but yes
12:44:00 <sophiejjj> fastcgi is compatible with wsgi specificaiton? ( I am not familiar with that)
12:44:37 <matthieucan> no, we have both configurations in debsources/etc
12:45:13 <matthieucan> if you want to know more about deployment, you can read the etc files, or check my docker conf for debsources: https://github.com/matthieucan/Dockerfiles/tree/master/debsources
12:45:31 <sophiejjj> aha. from my place, the speed is rather quick. Is the server powering debsources super cool or just python can handle that?
12:46:20 <matthieucan> what speed do you mean? if it's about searching for instance, the postgresql indexes do the trick
12:46:29 <matthieucan> but the server and python are super cool indeed ;)
12:46:40 <sophiejjj> aha. indexes. that makes sense.
12:46:54 <matthieucan> models.py if you're curious about that
12:47:03 <sophiejjj> cuz we don't cache the result, we visit the db upon request.
12:47:12 <sophiejjj> so I was concerned about the performance.
12:47:37 <matthieucan> we talked about using varnish once, I don't know what happened since then
12:48:01 <sophiejjj> the browsering-experience is quite good now.
12:48:13 <sophiejjj> any statistics on IP/PV ?
12:48:30 <matthieucan> pv?
12:48:57 <sophiejjj> page viewed per day.
12:49:06 <sophiejjj> and ip per day.
12:49:28 <matthieucan> we use analog for the http stats, but they are not public. Ping zack to know more about that :)
12:50:02 <sophiejjj> lol.
12:50:11 <sophiejjj> did we end the bot?
12:50:27 <matthieucan> #topic - debsources OPW - misc
12:50:32 <matthieucan> anything else?
12:50:45 <sophiejjj> nothing atm.
12:50:57 <matthieucan> alright
12:51:00 <matthieucan> #endmeeting