12:01:10 <zack> #startmeeting
12:01:10 <MeetBot> Meeting started Fri Feb  6 12:01:10 2015 UTC.  The chair is zack. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:01:10 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:01:18 <zack> #chair matthieucan
12:01:18 <MeetBot> Current chairs: matthieucan zack
12:01:29 <zack> #topic opw debsources - next meeting
12:01:32 <zack> next week, same time?
12:01:43 <sophiejjj> I am ok.
12:01:52 <matthieucan> yes
12:02:19 <zack> #agreed next meeting next Friday, usual time
12:02:24 <zack> #topic opw debsources - weekly review
12:02:38 <zack> sophiejjj: your turn :)
12:02:43 <zack> I'm a bit worried about thef act we'
12:11:15 <matthieucan> I think the refactoring is big enough already, without the mainlib/utils/db rewriting
12:11:15 <sophiejjj> yes.
12:11:15 <zack> what's your plan to address that problem?
12:11:16 <sophiejjj> hmmm
12:11:16 <sophiejjj> are you going to participate in gsoc?
12:11:17 <zack> well, maybe, but that's not an answer
12:11:18 <zack> your internship work should be done by the end of the internship. full stop
12:11:18 <zack> especially because if it is not, no one else could contribute to the code base
12:11:18 <zack> or it should take the risk of huge divergences
12:11:23 <sophiejjj> yes. that's my major concern.
12:11:30 <zack> so, here is what I think you should do
12:11:32 <sophiejjj> so I am hurrying on it these days.
12:11:50 <zack> split the refactoring work you're doing into (relative) small sub-parts
12:12:02 <zack> and push those sub-parts to us one by one, so that they're mergeable on their own
12:12:29 <sophiejjj> zack: I don't think it's feasible.
12:12:50 <zack> then you should reduce the aim of your refactoring work
12:13:41 <zack> it is IMHO very unwise to start a 1-month long refactoring work, in the last month of a 3 month internship
12:13:47 <zack> the risk is simply too high
12:13:52 <matthieucan> first step, blueprints. second step, move methods from views. whynot third step, mainlib refactoring, after discussion, but small priority today
12:14:11 <zack> matthieucan: right, that's a nice partitioning of the work
12:14:58 <sophiejjj> I am now working on the blueprint though.
12:15:11 <sophiejjj> the thing matters is, the code is hard to merge in, I think.
12:15:18 <sophiejjj> unless it's totally done.
12:15:34 <zack> it's hard to merge, I think, because you're trying to do too many things at once
12:15:49 <sophiejjj> yes. that's right.
12:15:52 <zack> why couldn't the mainlib refactoring wait until the blueprint refactoring is done?
12:16:01 <sophiejjj> no.
12:16:07 <matthieucan> sophiejjj: what do you mean? can't you add s blueprint system without touching views.py? I'm not talking of sharing methods with c.d.n yet
12:16:42 <sophiejjj> hmm.
12:16:50 <sophiejjj> but anyway the mainlib is not the major concern.
12:17:04 <zack> right, mine was just an example
12:17:05 <sophiejjj> the big workload is coverting methods to view and handle the related html.
12:17:27 <zack> to summarize: we cannot afford, at this stage, to wait several week before seeing a patch that is proposed for merge
12:17:45 <zack> we should have code that is potentially mergeable on a weekly basis, possibly more frequently with that
12:17:53 <zack> not because we're on a hurry, that's not the problem
12:18:05 <zack> but because we want to give you feedback as quickly as possible
12:18:15 <zack> to avoid that you're working on stuff that risk not being merged
12:18:20 <zack> does that make sense?
12:18:24 <sophiejjj> yes.
12:19:26 <zack> so, what do you think could be reasonably quickly mergeable into master of the current work?
12:20:05 <sophiejjj> no.
12:20:18 <sophiejjj> refactoring is a large work.
12:20:43 <zack> uhm
12:20:52 <sophiejjj> current code is based on the assumption of a single webapp
12:21:02 <sophiejjj> directly registered with the routes of debsources.
12:21:44 <zack> ok
12:21:48 <sophiejjj> finding a balance between "merging" and refactoring is kinda a dilemma.
12:22:12 <sophiejjj> by refacotring.
12:22:20 <zack> let's say that we're encouraging you to push that "balance" toward "the sooner we have something reviewable for merge, the better"
12:22:20 <sophiejjj> I am maintaing the logic of the current debsources.
12:22:27 <zack> if that means giving up on some side-goals, so be it
12:23:18 <zack> to be clear, I'm pushing in that direction because I do not want your work to go wasted, I really want to be able to integrate it into the codebase before the end of OPW
12:23:52 <zack> and sometime I've the feeling you're taking a path that is making it less likely to happen, rather than more likely to happen
12:24:09 <sophiejjj> zack: I totally understand you.
12:24:33 <zack> so, what do you want to set as a goal for next week?
12:25:07 <matthieucan> or what about a mid-week goal?
12:25:16 <sophiejjj> the goal is hard to set, if I could think of one, I would tell you.
12:25:52 <matthieucan> what about being able to plug a second blueprint? nothing about shared library, but only a flask blueprint
12:26:44 <matthieucan> with this done, it'll be simpler to refactor, because we'll directly see what needs to be shared/hacked
12:27:08 <sophiejjj> matthieucan: I've done that on my code at gh. but considering merging into the current codebase is like dancing with the shackles.
12:27:24 <matthieucan> nothing cherry-pickable?
12:27:57 <sophiejjj> hmm.
12:28:36 <zack> ok, so let me propose another way of approaching this
12:28:52 <zack> - please mail us a short summary of the goals of the current refactoring work
12:29:08 <zack> - and an estimation of how much you think of that work is already done, and how much still needs to be done
12:29:17 <sophiejjj> got it.
12:29:37 <zack> - then, during next week, maybe daily, we keep in touch (mail or IRC) to see how well the work is progressing
12:30:02 <zack> in the meantime we can at least review the work done thus far, and try to figure out if there are choices we need to change
12:30:13 <zack> matthieucan: I guess that'll be mostly up to you for the webapp part though ;)
12:30:36 <matthieucan> yeah, sure
12:30:51 <matthieucan> I can't commit on providing a daily feedback, but I'll do my best
12:31:23 <zack> great, thanks
12:31:38 <zack> sophiejjj: what do you think? would that "progress tracking" help you?
12:31:59 <sophiejjj> sure.
12:32:16 <zack> sophiejjj: anything else you'd like to add to next week objectives?
12:32:42 <zack> (or anything else you'd like to discuss before closing the meeting?)
12:33:05 <sophiejjj> currently no.
12:33:18 <zack> ok, let's adjourn then
12:33:21 <zack> #endmeeting