12:09:35 <zack> #startmeeting
12:09:35 <MeetBot> Meeting started Fri Feb 20 12:09:35 2015 UTC. The chair is zack. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:09:35 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:09:38 <zack> #chair matthieucan
12:09:38 <MeetBot> Current chairs: matthieucan zack
12:09:46 <zack> #topic opw debsources - next meeting
12:09:53 <zack> next friday, usual time?
12:09:56 <matthieucan> yes
12:10:19 <zack> sophiejjj: ?
12:10:26 <sophiejjj> hi
12:10:29 <sophiejjj> sure
12:10:43 <zack> #agreed next meeting next Friday, usual time
12:10:53 <zack> #topic opw debsources - refactoring status
12:11:04 <zack> so, you 2 are more into the current threads than me
12:11:11 <zack> but I think the most important point is agreeing on next actions
12:11:16 <sophiejjj> yes.
12:11:18 <zack> do we have an agreement there?
12:11:24 <sophiejjj> gimem a minute
12:11:42 <zack> sure
12:11:46 <matthieucan> do we have merge-ready patches at this point?
12:11:55 <sophiejjj> or, something is wrong on my git .ignore though.
12:12:06 <sophiejjj> ok. my intention is to create a source blueprint
12:12:14 <zack> ok
12:12:17 <sophiejjj> it's put in this folder: https://github.com/sophiejjj/debsources/tree/bp/debsources/app
12:12:32 <sophiejjj> it will be registed on a prefix /sources
12:12:42 <zack> would that allow to reuse the navigation code from the copyright.d.n blueprint, or is that a separate thing?
12:12:45 <sophiejjj> so the original code will not be interfered.
12:13:07 <matthieucan> why /sources and not / ?
12:13:12 <sophiejjj> zack: If we wanna make things re-usable, some code that s.d.n depends on must be modified.
12:13:25 <zack> sophiejjj: that's fine
12:13:30 <sophiejjj> because I don't want to modify the original code at this time
12:13:37 <zack> matthieucan: right, but that doesn't really matter, does it?
12:13:40 <sophiejjj> the code is, how to say, "fragile"
12:13:49 <zack> I mean, once sources.d.n is a blueprint, it could be registered where we want, no?
12:13:58 <matthieucan> zack: yes
12:14:00 <sophiejjj> so I make a s.d.n a blueprint, and registed under /soruces.
12:14:09 <sophiejjj> when it works, then put it under /
12:14:13 <sophiejjj> no, under s.d.n
12:14:19 <matthieucan> alright
12:14:28 <zack> sophiejjj: just remember that as long as it is not registered at /, it will not be mergeable
12:14:33 <zack> because it will break the current code base
12:14:37 <zack> and most of its tests, I suspect
12:14:53 <sophiejjj> zack: it will be mergeable.
12:15:00 <zack> how so?
12:15:00 <sophiejjj> because it won't break the existing code.
12:15:05 <sophiejjj> let me re-elaborate
12:15:21 <sophiejjj> (i shall have a working code, but my .gitignore maybe ignores it, sadly)
12:15:29 <zack> eh :)
12:15:39 <sophiejjj> I will work on the sources.debian.net/sources, it's a blueprint.
12:15:53 <sophiejjj> everything under /sources will be the same as you visited souces.d.n (ultimately)
12:16:07 <sophiejjj> at that period, we move the s.d.n/sources to s.d.n
12:16:25 <sophiejjj> this process won't break the existing code
12:16:31 <sophiejjj> regarding this, is it OK?
12:16:33 <zack> there is something I don't get, specifically:
12:16:52 <zack> are you saying that, in the interim, instead of *moving* stuff to the blueprint, you will *copy* current code to a blueprint?
12:17:05 <zack> (that is the only way I can see the code won't break in the interim)
12:17:24 <sophiejjj> zack: kinda.
12:17:36 <sophiejjj> but it's not *copy*, the new code will be blueprint based.
12:17:41 <matthieucan> we shouldn't have multiple copies of the same files
12:17:57 <zack> sophiejjj: yes, but we don't want to have copies of, say, the templates in the code base
12:17:58 <matthieucan> the blueprint won't change the code much
12:18:00 <zack> not even temporarily
12:18:10 <zack> because what happens if the work, for whatever reason, does not get completed?
12:18:31 <sophiejjj> the code will be under separted folders
12:18:35 <sophiejjj> the template is a headache for me.
12:18:38 <sophiejjj> let me reason it.
12:18:56 <sophiejjj> 1. all the stuff are not blueprint aware, say, url_for('blabal') the are not dot prefix.
12:19:10 <matthieucan> temporarily duplicating things is not the way to refactor
12:19:11 <sophiejjj> 2. the implication is, all the routes of s.d.n are registered on the application
12:19:48 <sophiejjj> 3. they are structurally not for blueprints. say, the base.html includes stuffs only related to s.d.n
12:20:17 <sophiejjj> matthieucan: aha. I am not just copying it. I will modify the template to make it support both s.d.n and c.d.n
12:20:27 <zack> that's fine
12:20:40 <sophiejjj> for example. https://github.com/sophiejjj/debsources/blob/bp/debsources/app/templates/base.html#L48
12:20:43 <zack> just be advised that we won't merge commits that temporarily duplicate existing code :)
12:21:11 <sophiejjj> zack: by duplicate, I'd like to learn more about it.
12:21:17 <sophiejjj> 100% identical code or?
12:21:24 <zack> copy/paste/modify <- that's duplication
12:21:30 <matthieucan> change things where they are, not copy them and change
12:21:43 <sophiejjj> yup. I got it.
12:21:58 <sophiejjj> but kinda hard for me to do.
12:22:20 <zack> well, in your repository you can have intermediary commits with duplications
12:22:27 <sophiejjj> yes.
12:22:29 <sophiejjj> my intention is,
12:22:32 <zack> but we will merge only when the duplication is gone
12:22:39 <sophiejjj> I commit those intermidiary, but have your review.
12:22:39 <zack> by squashing those commits together
12:22:48 <sophiejjj> when it's done, then merge it.
12:22:55 <zack> that works for me
12:23:01 <sophiejjj> as long as review is supported, then it will be ok for me.
12:23:13 <zack> matthieucan: ?
12:23:29 <zack> while reviewing we can focus on how the new code will look like
12:23:38 <matthieucan> yes, but for reviewing, I need to be pointed at diffs, so precise commits which show what has been changed
12:24:03 <zack> yes, please, try to make life simpler for the reviewer :)
12:24:22 <sophiejjj> I will write as much as I can regarding the changes I made.
12:24:58 <matthieucan> if you copy things, I won't see the changes, since new files will be added. Having to manually compare files is more difficult, especially if renamings have been done
12:25:27 <zack> here is a tip on how to make that easier
12:25:36 <zack> first, do a commit in which you *only* copy the files around
12:25:45 <zack> and write in the commit log that the commit in question is only a copy
12:25:52 <zack> then, in subsequent commits, you do the changes in the new place
12:26:01 <sophiejjj> I got it.
12:26:07 <matthieucan> yes that'd be perfect :)
12:26:14 <zack> \o/
12:26:29 <zack> looks like we have a plan
12:26:32 <sophiejjj> since we can squash it, make the commits the smaller the better.
12:26:39 <zack> anything else to discuss?
12:26:48 <matthieucan> yes, small commits are better
12:27:20 <sophiejjj> currently no. I will work out a more detailed structure for mattheiu to review.
12:27:34 <zack> sophiejjj: you happy about the work of this week?
12:27:53 <sophiejjj> yes. it seems get back to track. ;)
12:28:02 <matthieucan> well done :)
12:28:03 <zack> awesome
12:28:16 <zack> so, let's talk to you really soon via email then
12:28:19 <sophiejjj> and to be honest. in this direction, my previous work on this part can be re-used.
12:29:00 <zack> even better
12:29:09 <sophiejjj> btw, I was worried about the 'url_for' and 'server_name' part, which causes problems for me.
12:29:34 <sophiejjj> but since we are working under url_prefix, we can solve it later, and working on the main problem.
12:29:50 <matthieucan> ok, ping me when you need help for that
12:29:57 <sophiejjj> sure.
12:30:08 <zack> cool, let's adjourn the meeting then
12:30:10 <zack> #endmeeting