#debian-release Meeting

Meeting started by nthykier at 18:59:21 UTC (full logs).

Meeting summary

  1. Apologies/Admin (jmw, 19:00:54)
  2. Transitions (jmw, 19:03:06)
    1. No major issues with transitions at this time. (nthykier, 19:04:10)

  3. Reproducible builds: rebuild before release (jmw, 19:04:37)
    1. https://lists.alioth.debian.org/pipermail/reproducible-builds/Week-of-Mon-20151102/003828.html (jmw, 19:06:15)
    2. Multi-arch would mean rebuilding all architectures (jmw, 19:08:35)
    3. arch:all packages could not be rebuilt (jmw, 19:09:01)
    4. Build-Depends loops would need sorting out by hand (jmw, 19:12:25)
    5. AGREED: Right now, a full rebuild would not be feasible (jmw, 19:17:08)
    6. AGREED: We should await developments in dak so we know what support will be like in Stretch (jmw, 19:18:00)
    7. ACTION: nthykier to voice concerns to the reproducible team (nthykier, 19:18:41)

  4. mips64el (jmw, 19:19:21)
    1. mips64el is available in sid, and could join testing (jmw, 19:23:51)
    2. https://wiki.debian.org/ArchiveQualification/mips64el is helpful perhaps? (jmw, 19:24:24)
    3. imported packages should be rebuilt first (jmw, 19:25:43)
    4. ACTION: pochu contact the mips64el ports and ask about a) plans b) whether they want to join Stretch (jmw, 19:27:47)
    5. ACTION: pochu add mips64el to arch_qualify.html (jmw, 19:29:10)

  5. Linux version in Stretch (jmw, 19:29:52)
    1. AGREED: We want Linux 4.10 in Stretch if possible to reduce the maintenance burden in (old)stable (jmw, 19:44:00)
    2. AGREED: Stretch freeze will be delayed by two calendar months (jmw, 19:48:06)
    3. AGREED: Linux 4.10 will get an automatic freeze exception if it doesn't make the deep freeze (jmw, 19:48:35)
    4. For the avoidance of doubt, this policy applies only to linux (jmw, 19:49:10)
    5. AGREED: Linux maintainers are encouraged to upload release candidates of 4.10 in sid to shake out bugs earlier (jmw, 19:51:03)

  6. MySQL variants in Stretch (jmw, 19:52:21)
    1. Recent DSAs of MySQL and MariaDB went much better, and there are no major concerns right now (jmw, 19:58:49)
    2. Security team requirements have been published (<20160129193951.GA23052@pisco.westfalen.local>) (jmw, 20:00:19)
    3. Switching dependencies to MariaDB early reduces the risk of needing to do it in a hurry later (jmw, 20:05:02)
    4. AGREED: MySQL dependencies should be transitioned to MariaDB (jmw, 20:09:35)
    5. MySQL could still be shipped in Stretch if there are no objections from the security team, but it's unlikely that dependencies would be switched back (jmw, 20:10:18)
    6. ACTION: jmw write to pkg-mysql-maint to get a plan formed (jmw, 20:10:27)

  7. d-d-a after meetings? (jmw, 20:11:33)
    1. AGREED: d-d-a mails to be reserved for announcements (jmw, 20:16:03)

  8. Next meeting (jmw, 20:16:09)
    1. Next meeting: 23rd March 2016 (jmw, 20:17:36)

  9. AOB (jmw, 20:17:39)


Meeting ended at 20:17:47 UTC (full logs).

Action items

  1. nthykier to voice concerns to the reproducible team
  2. pochu contact the mips64el ports and ask about a) plans b) whether they want to join Stretch
  3. pochu add mips64el to arch_qualify.html
  4. jmw write to pkg-mysql-maint to get a plan formed


Action items, by person

  1. jmw
    1. jmw write to pkg-mysql-maint to get a plan formed
  2. nthykier
    1. nthykier to voice concerns to the reproducible team
  3. pochu
    1. pochu contact the mips64el ports and ask about a) plans b) whether they want to join Stretch
    2. pochu add mips64el to arch_qualify.html


People present (lines said)

  1. jmw (149)
  2. nthykier (92)
  3. pochu (43)
  4. mehdi (14)
  5. jcristau (13)
  6. MeetBot (12)
  7. adsb (11)
  8. ansgar (4)
  9. otto (1)
  10. ivodd (0)


Generated by MeetBot 0.1.4.