18:58:58 <jmw> #startmeeting
18:58:58 <MeetBot> Meeting started Wed Apr 27 18:58:58 2016 UTC.  The chair is jmw. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:58:58 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:59:01 <jmw> guten abend
18:59:19 <jmw> #chair nthykier
18:59:19 <MeetBot> Current chairs: jmw nthykier
19:00:07 <nthykier> o/
19:00:37 <adsb> my dinner's just finished cooking, so I'm around but need to grab and eat that
19:00:52 <jmw> adsb: ok, we'll highlight if there's anything for you
19:00:59 <jmw> did pochu make it back?
19:02:11 <jmw> hum, might be just us then
19:02:48 <nthykier> fun
19:04:23 <nthykier> So, I can say I hope to have Britney fixed
19:04:38 <jmw> explodey cron!
19:05:37 <jmw> nthykier: shall we crack on with some admin stuff and see if anyone else shows up?
19:05:48 <nthykier> sure
19:05:56 <jmw> #topic Admin/Previous minutes/Apologies
19:06:24 <jmw> previous minutes are http://meetbot.debian.net/debian-release/2016/debian-release.2016-03-23-18.58.html and don't appear to have been controversial
19:06:50 <jmw> #info Previous minutes: http://meetbot.debian.net/debian-release/2016/debian-release.2016-03-23-18.58.html
19:07:09 <jmw> of the usual suspects, jcristau isn't expected here tonight, pochu is MIA and adsb is eating
19:07:43 <jmw> #topic Mysql variants in Stretch
19:08:14 <jmw> so the only update here is that pkg-mysql-maint are on the case and have some details to iron out internally, but are working on a plan
19:08:27 <jmw> did anything go to -devel yet? I don't read it
19:08:42 <nthykier> Don't remember seeing it any thing either on d-d
19:08:57 <jmw> #info Latest developments: http://lists.alioth.debian.org/pipermail/pkg-mysql-maint/2016-April/008918.html
19:09:00 <jmw> ok
19:09:30 <jmw> we are just playing the waiting game for now then, and maybe in a couple of weeks I will poke the list if nothing has happened
19:09:41 <jmw> #info jmw monitor mysql developments
19:09:48 <jmw> moving on?
19:10:17 <nthykier> pochu had an action item related to this
19:10:24 <nthykier> do we know of the status of that?
19:10:27 <adsb> .
19:10:46 <jmw> yes, pochu mailed pkg-mysql-maint to get them started on planning the transition
19:11:05 <jmw> the mail I linked is the response
19:11:27 <nthykier> cool - wasn't sure if it was done with that or not
19:11:32 <jmw> yup
19:11:47 <jmw> I think deciding what to do with libmysqlclient.so.18 is the blocker from the pov
19:12:08 <nthykier> ok
19:12:15 <nthykier> (also ok to moving on)
19:12:24 <jmw> #topic Sprint at Suncamp
19:12:49 <jmw> so, some releasers will join DSA and FTP masters at suncamp in a few weeks time
19:12:56 <jmw> though I cannot for the life of me find the wiki page now
19:13:11 <nthykier> And we got a sprint sponsored by the DPL
19:13:14 <nthykier> erh, ex-DPL
19:14:00 <jmw> ah yes, on his outgoing spending spree
19:14:13 <pochu> o/
19:14:14 <nthykier> so that looks healthy and on going (the sprint that is)
19:14:16 <jmw> wonder how well wiki.d.o's search works
19:14:22 <jmw> hey pochu
19:14:40 <jmw> ah here it is
19:14:53 <jmw> #info Some members of the release team will join DSA and FTP at Suncamp
19:14:59 <jmw> #link https://wiki.debian.org/DebianEvents/Europe/2016/DSC?action=show&redirect=SunCamp
19:15:11 <jmw> #info Sprint focus: split of release tools from ftp-master.debian.org
19:15:24 <jmw> I don't think there's much else to say
19:15:32 <nthykier> nope
19:15:37 <jmw> #topic Transitions check
19:15:54 <jmw> as usual, pochu is charging away at transitions and I don't think there's anything controversial in progress
19:16:13 <nthykier> png happned?
19:16:21 <adsb> finally
19:16:23 <jmw> oh it did, yes
19:16:26 <jmw> 6 years on
19:16:39 <jmw> pochu: is everything healthy?
19:16:46 <jmw> #info libpng transition is complete
19:16:55 <adsb> and there was much rejoicing
19:17:13 <jmw> (and removal enthusiasm...)
19:18:04 <nthykier> do we have any news on the "jasper" removal?
19:18:24 <jmw> I haven't seen any
19:18:42 <jmw> but https://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=jasper-rm;users=jmm@debian.org has many bugs
19:19:02 <nthykier> including several key packages
19:19:26 <jmw> I wonder if jmm_ is around
19:20:39 <nthykier> There is also guile-1.8-rm, which survived Jessie
19:20:42 <pochu> sorry
19:20:49 <adsb> because lilypond?
19:20:52 <pochu> yes, things are good :)
19:20:52 <nthykier> (lilypond being the only rdep still)
19:21:03 <pochu> yes lilypond is blocking guile-1.8's removal
19:21:27 <nthykier> right, that is not new - though I was hoping we might finish it for Stretch
19:21:28 <pochu> upstream is slowly working on that. I suggested an upload to experimental so it could be tested but nothing happened
19:21:33 <adsb> from memory don was going to fix it, one day, honest
19:22:04 <jmw> and none of us could bring ourselves to remove it, yes
19:22:09 <pochu> yeah. I wasn't sure whether to get it out of stretch now to put some pressure, or if we would not mind releasing Stretch with it for lilypond's shake
19:22:33 <pochu> if we won't release it with it no matter what, then we should remove it from stretch *now*
19:23:27 <jmw> removing it from stretch isn't a death sentence either of course, it'll still be in unstable and could re-enter
19:23:36 <jmw> I'm tempted, I must say
19:23:43 <pochu> lilypond or guile-1.8?
19:23:56 <jmw> lilypond, once it doesn't use guile-1.8
19:24:00 <pochu> lilypond surely could... right
19:25:28 <nthykier> I am also okay with setting a deadline for the guile-1.8 removal
19:25:32 <nthykier> (from testin)
19:25:35 <nthykier> testing*
19:25:50 <jmw> lilypond is the only thing left depending on guile-1.8, right? (I don't have my keys on me to check franck)
19:26:04 <nthykier> in testing, yes
19:26:13 <nthykier> (according to ben)
19:26:14 <pochu> yes, see https://release.debian.org/transitions/html/guile-1.8-rm.html
19:26:53 <jmw> maybe an RC bug against lilypond saying that guile-1.8 will be removed is the way to go. interested people will get a reasonable amount of notice, and britney will just do it when the time comes
19:27:12 <nthykier> sgtm
19:27:21 <jmw> anyone want an action? :)
19:27:34 <pochu> I can do that
19:27:43 <jmw> #agree guile-1.8 should be removed from testing before Stretch
19:27:47 <jmw> pochu: thanks
19:28:00 <jmw> #info lilypond is the last remaining package dependent on guile-1.8
19:28:17 <nthykier> mmm
19:28:23 <jmw> #action pochu file RC bug against lilypond to start an auto-removal timer
19:28:24 <nthykier> nack
19:28:30 <jmw> oh?
19:28:33 <nthykier> lilypond has rdeps
19:28:37 <jmw> oh yay
19:28:38 <jmw> #undo
19:28:38 <MeetBot> Removing item from minutes: <MeetBot.items.Action object at 0x10e1b10>
19:28:41 <nthykier> # Broken Depends:
19:28:41 <nthykier> songwrite: songwrite
19:28:43 <jmw> #undo
19:28:43 <MeetBot> Removing item from minutes: <MeetBot.items.Info object at 0x1392fd0>
19:28:44 <nthykier> # Broken Build-Depends:
19:28:45 <nthykier> denemo: lilypond
19:28:53 <nthykier> thought I would mention it before we continued
19:29:01 <nthykier> (not sure they are blockers)
19:30:24 <jmw> songwrite has a popcon of 85
19:30:25 <nthykier> ok, got a happy dak with: dak rm -nR -s testing guile-1.8 lilypond songwrite denemo
19:30:38 <jmw> denemo has ~500
19:30:46 <jmw> lilypond ~2500
19:30:57 <nthykier> I'm still ok (just wanted to check the rdep list )
19:31:23 <nthykier> FTR, there is #746005 (re: RC bug against lilypond)
19:31:29 <nthykier> (currently not RC)
19:31:42 <pochu> yes, that was RC and got downgraded
19:31:54 <pochu> so we'd just have to bump it :)
19:32:00 <jmw> maybe we should file/upgrade anyway, and at least get some discussion going
19:32:11 <pochu> yes
19:32:14 <nthykier> ok with me
19:33:02 <jmw> #info lilypond is the last remaining package dependent on guile-1.8 but has reverse dependencies of its own (low-ish popcon)
19:33:30 <jmw> #action pochu upgrade #746005 against lilypond to get the ball rolling on removal, or at least a discussion
19:33:35 <jmw> how's that?
19:33:38 <nthykier> ack
19:33:45 <pochu> yep
19:33:54 <jmw> how about jasper?
19:34:10 <nthykier> an action to me on nagging the sec team for a status?
19:34:48 <jmw> if you like
19:34:58 <jmw> #info removal of jasper has been proposed but we could do with an update
19:35:19 <pochu> oh btw there's an uncoordinated Ada transition going on atm
19:35:21 <jmw> #action nthykier follow up jasper with security team for a status update
19:35:24 <jmw> oh happy fun
19:35:46 <pochu> I love how well coordinated those are
19:35:49 <jmw> #info An uncoordinated Ada transition has started
19:35:58 <pochu> last one took several months to complete
19:36:13 <pochu> fortunately it's rather self-contained
19:36:14 <doko> not me ...
19:36:25 <jmw> pochu: is that the libgtkada tracker?
19:36:32 <pochu> jmw: that's a part of it yes
19:36:41 <pochu> doko: yeah gnat got uploaded with a new default
19:36:42 <nthykier> and libxmlada?
19:36:54 <pochu> jmw: also libtemplates-parser, libgnatcoll
19:36:59 <jmw> yikes
19:37:08 <pochu> but that's just a part of it
19:37:26 <doko> https://lists.debian.org/debian-ada/2016/04/msg00003.html
19:37:31 <jmw> is this worth a gentle reminder about larger transitions to somewhere like d-d-a? (because everybody reads that, I hear)
19:39:04 <pochu> jmw: we could do it. whether that helps...
19:39:09 <jmw> quite
19:39:25 <jmw> or maybe just to the ada list
19:39:27 <pochu> though I'm pretty happy how people are handling transitions, for the most part
19:39:42 <jmw> yes, I think it's been working well on the whole
19:40:17 <pochu> (and I don't mind small transitions being uncoordinated)
19:40:58 <adsb> from memory ada transitions tend to be icky but self-contained
19:41:08 <jmw> maybe we should just wait and see then
19:41:30 <doko> mehh GCC 6.1 release day, and GCC trunk already ftbfs on mips and mips64el ...
19:41:37 <adsb> icbw though, been a while since I've poked
19:41:46 <jmw> #info Other transitions are healthy, and permitting self-contained transitions to be started autonomously has been working well
19:41:49 <pochu> yeah last time the biggest annoyance was to have several trackers in ben for months IIRC
19:42:16 <jmw> any others to note?
19:42:38 <pochu> I suppose we'll have a ghc transition soon
19:42:50 <pochu> and that will allow us to remove llvm-toolchain-3.5
19:43:12 <pochu> there will be a mini perl transition (minor version bump)
19:43:13 <doko> gcc-6 introduces new symbols in runtime libs, and will block packages until it migrates
19:43:19 <pochu> that's probably all I have to highlight :)
19:43:38 <pochu> doko: ok
19:44:02 <jmw> #info Forthcoming; gcc-6 introduces new symbols in runtime libs, and will block packages until it migrates
19:44:35 <jmw> right, moving on: any other business? wave for a slot
19:44:36 * jmw waves
19:44:59 <jmw> ok probably just me then
19:45:04 <jmw> #topic Wheezy EoL
19:45:12 <jmw> adsb: ^ could you use any help co-ordinating that?
19:46:06 <jmw> #info Some binaries are still missing from security uploads
19:46:09 <adsb> potentially. we need to work out what we're doing with the packages that are left in opu-new
19:46:26 <adsb> carnil's done sterling work recently catching us up
19:47:02 <adsb> other than typo-3, we're basically in sync. openjdk-6/mipsel has version sad because experimental
19:47:41 <jmw> oh the missing builds are also missing on security-master?
19:47:48 <adsb> jmw: which ones?
19:48:02 <jmw> I'm looking at oldstable.html
19:48:16 <adsb> https://release.debian.org/oldstable/missing-security.html is the difference between security and ftp-master. icewasel is a FP because it was released since dinstall
19:48:31 <adsb> so if it's not on that list, then yes it's also missing on security-master
19:48:34 <jmw> aha
19:48:41 <jmw> that's a much better list
19:48:54 <jmw> would negotiating a target date be helpful at this point?
19:48:57 <adsb> it is now, yes
19:49:04 <jmw> #undo
19:49:04 <MeetBot> Removing item from minutes: <MeetBot.items.Link object at 0x14f6a10>
19:49:05 <adsb> looking at them would be helpful
19:49:19 <jmw> #info Nearly all missing builds have been caught up from security uploads
19:49:24 <jmw> #info Target date needed
19:49:36 <jmw> #action jmw start negotiating Wheezy EoL target date
19:49:56 <adsb> I suspect we also still end up with packages where opu > stable, however. and possibly opu > pu, because of differing build failures for openjdk-7 at least
19:49:59 <adsb> it's all horrid
19:50:16 <jmw> we could fudge version bumps in stable if it really came to it
19:50:33 <jmw> dpkg and highlight are pending, are they just to be processed as normal?
19:51:25 <jmw> oh dpkg had an opu bug I think I saw
19:51:46 <nthykier> I believe dpkg already got uploaded?
19:51:46 <adsb> they both do
19:51:53 <jmw> okiedoke
19:52:04 <adsb> nthykier: uploaded, yes. that's why jmw's asking about it :P
19:52:09 <nthykier> ah
19:52:18 <jmw> it just stood out on the page
19:52:30 <jmw> long live wheezy
19:52:33 <jmw> right, aob?
19:53:26 <jmw> going....
19:53:29 <jmw> ... gone
19:53:32 <jmw> #topic Next meeting
19:53:44 <jmw> according to my calendar the next meeting is 25th May
19:53:51 <nthykier> ack
19:53:53 <jmw> is 1900UTC a better time?
19:54:00 <nthykier> ok with me
19:54:07 <nthykier> (don't care either way)
19:54:20 <jmw> object now or forever hold...
19:54:29 <pochu> that will be the start of SunCamp
19:54:30 <adsb> 1800UTC is a stretch for me in BST
19:54:41 <jmw> oh hm, suncamp
19:54:48 <nthykier> they have summer in UK? :P
19:54:49 <adsb> hmm, no it's not. nvm
19:54:56 <adsb> oh, nthykier made a funny
19:54:57 <jmw> we could delay a few days and get a suncamp report
19:55:21 <jmw> nthykier: you hush. it's been snowing for three days.
19:55:27 <nthykier> same here actually
19:55:31 <nthykier> its crazy
19:55:32 <jmw> "april"
19:55:33 <pochu> lol
19:55:36 <pochu> so warm in here :P
19:56:05 <nthykier> Skipping the IRC meeting in favor of SunCamp seems fine
19:56:31 <jmw> how about the week after, 1st June? though that might not work for adsb
19:57:04 <adsb> might it not? did I forget something?
19:57:15 <jmw> my calendar claims you have a significant date
19:57:29 <nthykier> hehe
19:58:01 * nthykier .oO( <hash>info: jmw knows adsb calender better than adsb! )
19:58:01 <adsb> yes. but that won't impact my availability
19:58:06 <jmw> ok
19:58:10 <jmw> I move 1st June then
19:58:28 <adsb> no, adsb knows, it just wasn't relevant. but jmw apparently wasn't sure :)
19:58:33 <nthykier> moved to 1st of June
19:58:43 <jmw> nthykier: more like jmw knows half the facts only, and therefore makes caution
19:58:45 <pochu> cool
19:59:00 <jmw> #info Next meeting: 1st June 2016 1900UTC (time change from normal)
19:59:07 <jmw> #endmeeting