19:00:44 <jmw> #startmeeting
19:00:44 <MeetBot> Meeting started Wed Sep 28 19:00:44 2016 UTC.  The chair is jmw. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:44 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:48 <jmw> #chair nthykier
19:00:48 <MeetBot> Current chairs: jmw nthykier
19:01:06 <jmw> right, it's wednesday, it's 19:00, and it's release time again :)
19:01:10 <adsb> blurg
19:01:14 <jcristau> blerg
19:01:15 <jmw> o/
19:02:50 <adsb> apparently it's a popular time for meetings :)
19:03:05 <jcristau> adsb: braincell.  i want it back.
19:03:12 <jmw> is it?
19:03:33 <nthykier> There is a jenkins meeting in #d-qa
19:03:38 <jmw> ah
19:04:13 * h01ger waves
19:04:15 <jmw> wonder if pochu is around
19:04:55 <adsb> jcristau: sure, I don't appear to be using it much this evening
19:05:10 <jcristau> :)
19:05:43 <jmw> oh well, maybe he'll catch us up
19:05:49 <nthykier> I do hope so :)
19:05:50 <jmw> let's start
19:05:57 <jmw> #topic Admin
19:06:22 <jmw> #link http://meetbot.debian.net/debian-release/2016/debian-release.2016-08-24-19.05.html is the last minutes
19:06:41 <jmw> I don't think we had any advance apologies this time
19:06:51 <jmw> #topic MySQL/MariaDB variants
19:06:51 <nthykier> you may want to include http://meetbot.debian.net/debian-release/2016/debian-release.2016-07-27-19.00.html as well
19:07:03 <nthykier> #undo
19:07:03 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x10008d0>
19:07:05 <nthykier> nvm :)
19:07:59 <jmw> #link http://meetbot.debian.net/debian-release/2016/debian-release.2016-07-27-19.00.html before those
19:08:03 <jmw> #topic MySQL/MariaDB variants
19:08:17 <h01ger> #munin has a meeting in 30min :) (and thanks for teaching me MeetBot knows undo now!)
19:08:19 <jmw> I have no idea where we are with this now, sorry
19:08:51 <nthykier> There are some default-mysql-* packages now and the next version of lintian will nag about some uses of "old" MySQL packages
19:09:02 <jmw> I have been out of the loop for too long being vacationy or something
19:09:28 <nthykier> (see lintian commit 9044421b3c9261943556e297a924dd4bb69cdcae)
19:09:33 <jmw> do they have the intended effect? :)
19:09:55 <nthykier> I did not check - I just hope so
19:10:04 <jmw> fair enough
19:10:39 <nthykier> it does include libmysqlclient-dev, mysql-server(-core) and mysql-client(-core) packages
19:11:01 <nthykier> (which gets replaced by a "default-mysql-$something")
19:11:44 <nthykier> if nothing else, it is a decent start
19:12:48 <jmw> the thing we mustn't lose sight of is deciding which ones will ship in stretch. but I don't think it's worth looking at that tonight
19:13:04 <jmw> that's the point of this defaults excercise, after al
19:13:25 <nthykier> ok
19:13:55 <nthykier> should we move on?
19:14:09 <jmw> yes
19:14:17 <jmw> #topic Porter roll-call
19:14:19 <jmw> ah this is yours
19:14:26 <nthykier> We completed the roll call
19:14:48 <nthykier> Except ppc and the waived architectures, all architectured had porters that replied in time
19:15:22 <nthykier> I got two topics further down about PPC and about the toolchain support issue
19:16:10 <jcristau> so this isn't where i ask if there's a reason not to disqualify ppc?
19:16:11 <nthykier> We also learned that we should have phrased the reply template differently (to push for more links from porters pointing to their contributions)
19:16:27 <nthykier> jcristau: nope - we will get there soon though :)
19:16:32 <jcristau> ack :)
19:17:00 * doko listens silently
19:17:13 <nthykier> But https://release.debian.org/stretch/arch_qualify.html is up to date with all the information I got (incl. toolchain and lack of porters)
19:17:50 <nthykier> anyway, lets move on if there are no remarks to the roll call
19:17:55 <nthykier> (itself)
19:18:31 <doko> nthykier: so mips* is still considered a candidate as a release arch?
19:19:06 <nthykier> doko: we will get to that a bit later - I got a topic about arch qual + upsteam support
19:19:32 <jmw> great
19:19:35 <aurel32> next time it would be nice to include glibc in the toolchain
19:19:35 <jmw> #topic Artwork
19:19:41 <jmw> also yours :)
19:20:05 <nthykier> Yupe (ftr, I intended these to be a quick status since last time and not a dicussion point)
19:20:08 <doko> is there a agenda for the meeting?
19:20:32 <nthykier> We got a bunch of artwork - I failed on doing a selection / vote for finding the default
19:21:02 <nthykier> We also got a proposal from mbiebl about including all of the artwork (in a separate package). I like that idea, so I intend to encourage it
19:21:13 <nthykier> EOT for me (unless there are questions)
19:21:19 <nthykier> doko: yes, in the gobby
19:21:27 <nthykier> (see /topic )
19:21:44 <jmw> #topic Secure boot status
19:22:04 <jmw> should probably make some notes about these
19:22:08 <jmw> #undo
19:22:08 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x143b610>
19:22:09 <jmw> #undo
19:22:09 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x143d2d0>
19:22:22 <nthykier> (ok, waiting for you before starting)
19:22:24 <jmw> #undo
19:22:24 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x143bf50>
19:22:43 <jmw> #info There are some default-mysql-* packages now and the next version of lintian will nag about some uses of "old" MySQL packages
19:23:00 <jmw> #info We still need to evaluate variants for Stretch when the alternative system is feasible
19:23:05 <jmw> #topic Porter roll-call
19:23:17 <jmw> #info Porter information has been updated in https://release.debian.org/stretch/arch_qualify.html
19:23:22 <jmw> #topic Artwork
19:23:35 <jmw> #info Artwork has all been collated
19:24:00 <jmw> #action nthykier Encourage shipping all artwork in a package
19:24:10 <jmw> #action nthykier Organise selection/voting of some sort
19:24:17 <nthykier> ack
19:24:21 <jmw> #topic Secure boot status
19:24:23 <jmw> ok I'm done
19:24:25 <nthykier> thanks
19:25:01 <nthykier> To my knowledge: shim got uploaded and rejected (due to d/copyright).  Allegedly this should have a patch and is waiting for vorlon to reupload
19:25:32 <nthykier> We also got a successful linux signing test by jcristau, which allegedly works albeit taking ~25 minutes to complete
19:26:00 <nthykier> jcristau: did I miss any other noteworthy changes in the past month?
19:26:03 <jmw> #info shim package is in progress and awaiting an upload
19:27:00 <jmw> is the signing thing the effort towards being able to sign builds on debian infrastructure?
19:27:03 <nthykier> as I understand it, the signing code has not been merged yet (but we did just get a patch to make it run with a different user)
19:27:15 <jcristau> we've got tentative dak patches, no ftpmaster input yet
19:28:16 <jcristau> and i'm not sure whether to set this up on franck or wait until we move to fasolo, that's also in ftpmaster hands
19:28:21 <jcristau> mostly
19:28:41 <jcristau> .
19:28:41 <jmw> #info linux signing infrastructure is in progress; there are tentative patches for dak but need ftp-master input
19:29:37 <nthykier> done from me as well
19:29:39 <jmw> jcristau: are you best placed to keep that rolling with ftp-masters?
19:30:04 <jcristau> i guess
19:31:10 <jmw> #action jcristau to continue progressing
19:31:50 <jmw> if you have time, makes sense
19:32:54 <nthykier> Next topic?
19:33:17 <jmw> #topic PIE by default for Stretch
19:33:25 <jmw> all teh topics for nthykier :)
19:33:34 <nthykier> "Propose ALL the topics!"
19:33:35 <nthykier> :P
19:33:55 <jcristau> ftwca topics
19:33:58 <nthykier> Should we go with PIE by default for Stretch?
19:34:11 <jcristau> probably
19:34:20 <nthykier> The majority of all porters across all ports (with porters) believed their port was ready
19:34:48 <nthykier> I understand that there are some blockers (e.g. rebuilding some static libraries with PIE in order) for this to be done
19:35:20 <jmw> presumably the downside is possible bugs in binaries?
19:36:07 <nthykier> Plus there can be slow downs on register-starved architectures (except i386, which got fixed in gcc-5)
19:36:52 <aurel32> what are the register starved architectures beside x86?
19:36:56 <jmw> which arches are those?
19:36:59 <nthykier> There will also be packages that need to disable PIE because they do "magic" (e.g. some asm)
19:37:36 <nthykier> jmw: aurel32: Standard disclaimer - did not map it to the Debian release architecture, since I don't know any arch beyond x86
19:37:43 <jmw> ok
19:37:57 <aurel32> ok
19:38:24 <nthykier> anyway, if we want the change in GCC, I suspect doko would like an answer "really soon now"
19:38:28 <jmw> #info could reveal bugs in built binaries (but those should be fixed or PIE disabled)
19:39:01 <doko> saw it at least on arm32
19:39:38 <jmw> #info can cause slowdowns in register-starved architectures, including i386 (fixed in gcc5) and arm32
19:39:41 <doko> I'm a bit concerned about the attitude of porters: "we don't know issues, let's do it"
19:40:10 <doko> at least the various arm ports should have resources for a test rebuild
19:40:30 <jmw> #info majority of porters believe their architecture is ready
19:40:45 <jmw> do problems cause build failures or just buggy binaries?
19:40:51 <jcristau> doko: are we concerned about build failures or miscompilation?
19:40:58 <jcristau> bah.
19:41:32 <nthykier> Most of the issues I am aware of will be FTBFS (which is not to say that there will be no runtime issues)
19:42:19 <jcristau> for build failures, worst case some arch breaks, and either the porters fix it or the pie change gets reverted?
19:42:24 <doko> jcristau: you usually can fix ftbfs with no-change rebuilds
19:43:08 <doko> so there is other fun about pie/pic interactions, however these shouldn't be arch specific
19:43:29 <jcristau> ok
19:43:31 <doko> so yes, my concerns are miscompilations. I think nobody tried to build a distro on arm* mips* with pie before
19:44:24 <jmw> if porters think their arches are ready, now is the time to throw the switch and try it I guess
19:44:26 <doko> and I don't see a point when there are plans to drop an arch for buster to add new problems for stretch, it's not worth it, and porters for these archs might have to fight other fires
19:44:42 <jmw> we can always roll it back globally or per-arch or disable it per-package, so we have some options if it's too much chaos
19:45:07 <jmw> but it *is* quite late in the cycle
19:45:10 <doko> disabling per package is "fun"
19:45:25 <doko> because -fno-pie turns off -fpic as well :-/
19:46:16 <nthykier> There is also the option of using the dpkg-buildflags approach, where dpkg adds a "compiler-spec" file to selectively enable it
19:46:40 <jcristau> nthykier: selectively based on what?
19:46:52 <nthykier> Ah no, it would have the same issue with disabling it
19:47:00 <helmut> if we consider rolling back, is there a reliable way to tell which packages were built with pie? scraping build logs sounds unreliable to me.
19:47:38 <aurel32> file tells it
19:47:51 <nthykier> jcristau: based on which compiler flags are passed
19:47:59 <nthykier> (AFAICT)
19:48:04 <jcristau> doko: otoh a number of binaries/packages are built with PIE on all archs for a few years and nobody noticed it was broken, afaik?
19:48:18 <doko> nthykier: selectively enabling will lead to intersting issues, when you first have to rebuild a library
19:48:27 <nthykier> jcristau: https://git.hadrons.org/cgit/debian/dpkg/dpkg.git/commit/?h=pu/dpkg-buildflags-pie-gcc-specs&id=ad4854b4b4711dd49e39371280f0609f8b81c2a6
19:48:50 <nthykier> doko: the static library issue?
19:49:09 <doko> jcristau: sure this is a subset. do you know how many of them worked initially?
19:49:14 <doko> nthykier: yes
19:49:49 <nthykier> doko: but we could use it for disabling PIE "per package"?
19:49:52 <jcristau> doko: i don't.  presumably some of them have build-time tests, too.
19:50:10 <jcristau> doko: also, if stuff breaks and it's too late to revert, it's an argument to disqualify that arch, which might make you happy ;)
19:50:57 <doko> nthykier: in principle yes, except for uncommon build systems, where you can't directly influcence the order of rhe -fno-pie and -fpic arguments (as in openjdk)
19:51:23 <nthykier> doko: ok
19:51:24 <jcristau> (:51, we might want to move on)
19:52:03 <doko> jcristau: well, this is a release-selfish approach then, because you leave it broken as a port
19:52:12 <jcristau> yes
19:52:33 <doko> but when did debian care about ports ...
19:52:54 <jcristau> i think it's fair for the release team to be concerned about release architectures
19:53:04 <jcristau> ommv
19:53:32 <doko> that's maybe a topic for another meeting =)
19:54:07 <nthykier> Should I send out a mail to d-release about enabling PIE by default and see what the other members say?  If there are no major concerns within a week, we would go for PIE by default?
19:54:16 <jcristau> sgtm
19:54:53 <nthykier> #action nthykier Send mail to d-release about enabling PIE by default! If there are no major concerns brought up within a week, Stretch will go with PIE by default
19:55:00 <nthykier> ok, lets move on then
19:55:06 <jmw> wfm
19:55:24 <jmw> #topic Architectures: upstream toolchain support
19:55:25 <doko> pleae make sure to get one or two persons per arch who work on fixing these
19:55:36 <doko> pic issues when they arise
19:55:45 <nthykier> doko: ok
19:56:12 <doko> just speaking out of experience enabling pie in another distro ...
19:56:37 <jmw> nthykier: is this and the next topic not really architecture qualification?
19:57:08 <nthykier> jmw: kind of.  You want to move it to a separate meeting ?  (Would WFM given we are running out of time)
19:57:23 <jmw> let's arrange the arch-qual meeting instead
19:57:24 <jmw> #undo
19:57:24 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x13a2410>
19:57:30 <jmw> #topic Architecture qualification
19:57:47 <doko> jmw: well, it's listed as release criteria, isn't it?
19:58:35 <jmw> it is, that doesn't mean it needs its own slot outside the normal qualification process
19:58:44 <jmw> unless you have a particular concern you want to bring up earlier than that?
19:59:46 <jmw> for arch-qual, we have this meeting in october, november or december if that works (though december is getting a little late for my comfort, personally. also holidays)
20:00:13 <jmw> or we could arrange something at the cambridge miniconf if we have enough people
20:00:23 <nthykier> We might want to do an out of band one
20:00:36 <jmw> or we could arrange something else
20:00:41 <jmw> what nthykier said :)
20:01:40 <jmw> maybe a doodle poll is a good move here. but what kind of window? October? November?
20:02:20 <nthykier> jmw: I say we do it off-line - I suspect there will be sufficient turn up for doing it at Cambridge
20:03:34 <nthykier> Or latter half of October / first 2 weeks of November
20:04:08 <jmw> #action jmw organise architecture qualification in late October or early November
20:04:22 <jmw> that do?
20:04:27 <nthykier> yupe
20:04:35 <jmw> #topic mips64el
20:04:43 <jmw> no idea what the status of this is
20:05:28 <nthykier> mips64el looks reasonably stable from an installability PoV, so it might make sense to move it out of "F***ED_ARCHES" and "BREAK_ARCHES"
20:05:43 <nthykier> (assuming the perl transition does not completely bork it)
20:06:17 <jmw> suits me, but I have very little investment so... :)
20:06:25 <nthykier> I think I will just do that and then we can remvert it, if there is an issue
20:06:31 <nthykier> revert*
20:06:45 <jmw> #action nthykier promote mips64el to BREAK_ARCHES, revert if there are issues
20:06:46 <jmw> right
20:06:46 <jcristau> lack of mariadb on mips64el makes the libmysqlclient switch kinda icky
20:06:55 <jmw> oh hm
20:06:56 <jcristau> if mips64el starts counting
20:07:08 <nthykier> #undo
20:07:08 <MeetBot> Removing item from minutes: <MeetBot.items.Action object at 0x1378610>
20:07:17 <jmw> you wuss :p
20:07:28 <nthykier> #action nthykier promote mips64el to BREAK_ARCHES once libmysqlclient is available on mips64el, revert if there are issues
20:07:28 <aurel32> indeed
20:07:36 <jmw> ok
20:07:47 <aurel32> the problem has been reported upstream there: https://jira.mariadb.org/browse/MDEV-10417
20:07:59 <jmw> nthykier: you had a space on that command, I don't think meetbot will see it
20:08:05 <nthykier> #action nthykier promote mips64el to BREAK_ARCHES once libmysqlclient is available on mips64el, revert if there are issues
20:08:06 <aurel32> and Vicentiu Ciorbaru got an account on the porter box to look at that
20:08:19 <nthykier> cool
20:08:22 <nthykier> EOT for me
20:08:29 <jcristau> -ERROR HY000: Error dropping database (can't rmdir './testing_1', errno: 39 "Directory not empty")
20:08:29 <aurel32> but if it becomes more critical we can try to have more people looking at it
20:08:32 <jcristau> +ERROR HY000: Error dropping database (can't rmdir './testing_1', errno: 93 "Directory not empty")
20:08:37 <jmw> #info the problem with mariadb is upstream: https://jira.mariadb.org/browse/MDEV-10417
20:08:54 <jcristau> is that some kind of ^t just to spite people? :)
20:10:00 <jmw> moving on?
20:10:05 <jcristau> yesplz
20:10:10 <nthykier> (ofm)
20:10:13 <jmw> #topic Release schedule
20:10:22 <jmw> #info Linux - 4.9 will be LTS, presumably November
20:10:38 <jmw> I'll put my cards right down and say we don't change our plans
20:10:57 <jcristau> +1
20:10:57 <nthykier> Ack
20:10:57 <jmw> but I'm open to persuasion
20:11:11 <jmw> even though that gives us slightly less time with stretch as stable and kernel upstream support overlapping
20:11:31 <jcristau> *crickets*
20:11:40 <jmw> winner.
20:11:41 <doko> I expect gcc-6.3 in december, same with python 2.7.13 and 3.5.3
20:12:07 <jmw> #agreed Stick to the published schedule to avoid confusion
20:12:11 <doko> so you want to shorten the schedule by two months?
20:12:17 <doko> ahh, ok
20:12:34 <jmw> so much for avoiding confusion :)
20:12:41 <jmw> #topic Mini-Debconf Cambridge
20:13:05 <jcristau> i'd like to go.  will try to confirm next week.
20:13:16 <jmw> we have the option of meeting space at cambs again if we want it, I think: will it be worth doing that or shall we just ad-hoc?
20:13:42 <jcristau> jmw: coordinate in e-mail since there's only 3 of us now?
20:13:47 <jmw> ok
20:13:52 <nthykier> +1
20:14:04 <jmw> #action jmw find out about meeting space requirements
20:14:13 * doko has to leave, will read backlog ...
20:14:18 <jmw> I'm going to skip the spain sprint, with pochu not here
20:14:18 <adsb> I'm vaguely still around, having to poke stupid things for being stupid for no apparent reason though
20:14:27 <jmw> #topic AOB
20:14:29 <jmw> any?
20:14:39 <adsb> nope
20:14:44 <jcristau> no
20:15:14 <jmw> #topic Next meeting
20:15:16 <nthykier> Britney patches have been submitted for review
20:15:20 <jmw> #undo
20:15:20 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x1070510>
20:16:03 <nthykier> #info Britney patches have been submitted for review - deadline Oct 03 for comments
20:16:09 * nthykier .
20:16:09 <jmw> ok
20:16:11 <jmw> #topic Next meeting
20:16:24 <nthykier> 26th of Oct according to the release calender
20:16:38 <jmw> #info Next meeting: 2016-10-26 19:00UTC
20:16:45 <nthykier> \o/
20:16:54 <jcristau> jmw: thanks for running this.  nthykier: thanks for all the topics :)
20:16:55 <jmw> so nthykier, that's 20:00 real time :p
20:17:16 <jmw> #endmeeting