#debian-release Meeting

Meeting started by nthykier at 19:03:12 UTC (full logs).

Meeting summary

  1. Transitions (nthykier, 19:04:40)
    1. MySQL -> MariaDB is now complete (nthykier, 19:05:29)
    2. OpenSSL transition is nearly complete (nthykier, 19:06:42)
    3. ACTION: nthykier to ensure wget gets rebuilt against openssl 1.1 in testing (nthykier, 19:07:14)

  2. Secure Boot (nthykier, 19:10:46)
    1. https://docs.google.com/document/d/1gHFkhMmn6VVvVQim5YcjJ8uc3xf1JHQnA9f8KSE6qqY/edit (Mithrandir, 19:12:43)
    2. https://github.com/rhinstaller/shim is one (jmw, 19:24:40)
    3. shim signing need us to convert our packaging repo from bzr to git and resubmit (per https://docs.google.com/document/d/1gHFkhMmn6VVvVQim5YcjJ8uc3xf1JHQnA9f8KSE6qqY/edit) (nthykier, 19:24:49)
    4. From lp:~ubuntu-core-dev/shim/trunk to https://github.com/rhinstaller/shim (nthykier, 19:25:00)
    5. https://code.launchpad.net/~ubuntu-core-dev/shim/trunk (jmw, 19:25:09)
    6. We are missing signing support for the bootloader, kernel modules (etc.) on ftp-master.d.o (even manual signing). Waiting for feedback from FTP-masters (nthykier, 19:26:09)

  3. PIE rebuilt or not (nthykier, 19:26:41)
    1. At least 3404 source packages would enable PIE after a no-change rebuild (nthykier, 19:38:02)
    2. ACTION: ivodd to select a subset to build with a good risk/reward balance (nthykier, 19:39:08)
    3. https://people.debian.org/~rbalint/pie-mass-rebuild/sources-rebuild-works.txt is the master list (jmw, 19:40:20)

  4. RC bug fixing (nthykier, 19:41:18)
    1. AGREED: We will ignore #704303 on the basis of it being fixed in the next release (nthykier, 19:48:39)
    2. The RC bug list for key packaes could use a review and get proposals for "will-remove", "is-blocker" or "can-defer" tags (nthykier, 19:50:24)

  5. Unblocks (nthykier, 19:50:41)
  6. AOB (nthykier, 20:10:55)
  7. Next meeting (nthykier, 20:15:50)
    1. Next meeting is 22nd of March at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics) (nthykier, 20:17:16)


Meeting ended at 20:18:00 UTC (full logs).

Action items

  1. nthykier to ensure wget gets rebuilt against openssl 1.1 in testing
  2. ivodd to select a subset to build with a good risk/reward balance


Action items, by person

  1. ivodd
    1. ivodd to select a subset to build with a good risk/reward balance
  2. nthykier
    1. nthykier to ensure wget gets rebuilt against openssl 1.1 in testing


People present (lines said)

  1. nthykier (118)
  2. jmw (83)
  3. ivodd (18)
  4. Mithrandir (6)
  5. MeetBot (5)
  6. jrtc27 (3)
  7. adsb (3)
  8. anarcat (1)
  9. jcristau (1)
  10. ansgar (1)


Generated by MeetBot 0.1.4.