19:02:05 <nthykier> #startmeeting
19:02:05 <MeetBot> Meeting started Wed Apr 26 19:02:05 2017 UTC.  The chair is nthykier. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:05 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:10 <nthykier> #chair jmw
19:02:10 <MeetBot> Current chairs: jmw nthykier
19:02:17 <jmw> ohai
19:02:21 <nthykier> Time for it again
19:02:48 <nthykier> :)
19:03:01 <nthykier> #topic admin
19:03:14 <nthykier> #info Last meetings minutes are at http://meetbot.debian.net/debian-release/2017/debian-release.2017-03-22-19.01.html
19:04:02 <jmw> sorry I missed that one
19:04:06 <jmw> and everything else for weeks now
19:04:31 <nthykier> It happens :)
19:04:33 <nthykier> pochu had one action item from last meeting (do a poll for a meeting) but I haven't see it.  I suspect he might have forgotten it.
19:05:36 <nthykier> That is what I had for admin.  Moving on :)
19:05:48 <nthykier> #topic Secure boot status
19:06:05 <nthykier> #info We got shim signed by Microsoft \o/
19:06:19 <jmw> woop
19:06:28 <nthykier> That was the good news
19:07:14 <nthykier> #info No sign of progress on signing support for dak.  The kernel maintainers will be undoing the -signed packages and go back to only shipping unsigned ones until dak support is there
19:07:34 <jmw> oh bleh
19:07:38 <jmw> really?
19:07:51 <nthykier> yes
19:07:58 <nthykier> Admittedly, I asked them to do it
19:08:14 <jmw> reasonable, in the circumstances
19:08:35 <nthykier> Ben said he refused having to sign kernels in stable, so I recommended it so linux was in a "releaseable state"
19:08:40 <jmw> do we abandon secure boot for stretch then, and try to chase down a release?
19:09:30 <nthykier> Given the lack of activity of #821051, I am not inclined to wait for it
19:09:41 <ivodd> we shouldn't wait for secure boot if the release is ready otherwise
19:10:09 <nthykier> It was last touched in January - last time an FTP master commented on it was in December and I have been unable to get a response / status from them over IRC either
19:10:31 <jmw> is time the only known blocker?
19:11:01 <nthykier> I have no idea what the blocker is - they are not answering my request for updates at all
19:11:39 <jmw> ok
19:11:45 <jmw> just exploring
19:11:54 <nthykier> :)
19:12:23 <nthykier> That said, even after dak signing is done, there are 6-8 bugs needing to get done after that
19:13:03 <ivodd> so it doesn't look like that's going to happen for stretch
19:13:07 <jmw> better to abandon than have rushed bugs, I suppose
19:13:25 <nthykier> :)
19:13:56 <jmw> should be #agreed then?
19:14:09 <nthykier> FTR - I am happy to consider putting it back on the table if there is a sudden progress before we find a release date
19:14:18 <nthykier> #agreed Secure boot will not be a blocker stretch
19:14:34 <nthykier> #undo
19:14:34 <MeetBot> Removing item from minutes: <MeetBot.items.Agreed object at 0x20571d0>
19:14:40 <nthykier> #agreed Secure boot will not be a blocker for stretch
19:15:09 <nthykier> Next item is from ivodd
19:15:13 <nthykier> #topic severity of arch:all FTBFS on i386 when it builds fine on amd64 (and related removals)
19:15:15 <jmw> we should bits that as well, it's the kind of thing that will end up in headlines, and let's make sure they are what we want to say
19:15:29 * jmw can do that
19:15:33 <nthykier> jmw: point - lets do a draft for that after the meeting
19:15:48 <nthykier> #undo
19:15:48 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x207f0d0>
19:15:59 <nthykier> #action jmw and nthykier to do a bits mail about the secure boot status
19:16:02 <nthykier> #topic severity of arch:all FTBFS on i386 when it builds fine on amd64 (and related removals)
19:16:05 <nthykier> ivodd:  ^
19:16:26 <ivodd> there was an archive rebuild on i386 and the FTBFS bugs where filed
19:16:37 <ivodd> some of them are about arch:all packages which build fine on amd64
19:16:53 <ivodd> there were some questions whether we consider this RC
19:17:07 <ivodd> a number of those packages are on the auto-removal list
19:17:17 <ivodd> if we don't consider this RC, we should say so and not remove these packages
19:17:35 <nthykier> I think the answer to that is largely related to "why" it fails
19:17:50 <jmw> how many bugs and packages are we talking?
19:17:53 <ivodd> well, I'm talking about packages that build fine on amd64
19:17:55 * KiBi tiptoes into the meeting
19:18:28 <ivodd> jmw: between 20 and 30
19:18:43 <nthykier> most (but not all) of them are in non-key packages as I recall
19:19:11 <jmw> where do the autobuilders build _all nowadays?
19:19:16 <nthykier> and64
19:19:19 <nthykier> amd64*
19:19:51 <nthykier> The bugs are fixed due to lucas (also) doing a mass rebuild test on i386
19:19:56 <jmw> I am inclined either to make them important or stretch-ignore and review again for buster then, personally
19:20:30 <nthykier> I am ok with that as well
19:20:31 <ivodd> so would I, provided they build fine on amd64
19:20:34 <jmw> I don't see them as being worth massive effort for stretch, though I'd take fixes if they appear
19:20:40 <ivodd> sure
19:20:52 <jmw> yes - must build on amd64 for stable maintenance, but beyond that I don't mind so much
19:21:24 <nthykier> #agreed arch:all FTBFS on i386 (where it builds fine on amd64) is candidate for a stretch-ignore
19:21:36 <nthykier> Does ^ cover it?
19:21:50 <ivodd> looks good
19:22:28 <ivodd> and thanks to lucas for the rebuild tests!
19:22:35 <nthykier> Indeed :)
19:22:49 <nthykier> Ok, moving on then
19:23:04 <nthykier> #topic Outstanding unblock requests
19:23:25 <nthykier> anyone have any pending unblock requests they would like a second pair of eyeballs on?
19:24:05 <ivodd> not really
19:24:23 <jmw> how many are we getting a day now?
19:24:30 <jmw> (having not been looking for a few weeks)
19:24:33 <nthykier> it is not too bad atm
19:24:52 <jmw> excellent :)
19:24:52 <nthykier> we are on 6 waiting for us and 5 tagged moreinfo
19:25:21 <nthykier> I am aware of some inbound uploads but nothing overwhelming
19:25:42 <nthykier> ok, think I will move on then
19:25:55 <nthykier> #topic Release status
19:26:19 <jmw> careful what is said in public here
19:26:26 <nthykier> :)
19:26:40 <jmw> we can always go to mail or a s3kr1t channel
19:27:27 <nthykier> We are running low on RC bugs in key packages.  We got about 1-2 is-blocker left that are currently unfixed
19:27:46 <nthykier> plus 1-2 fixed that will hopefully migrate soon
19:27:54 <jmw> do you have links to the blockers?
19:28:14 <jmw> (I can find them if not)
19:28:15 <nthykier> Sure
19:28:22 <nthykier> #849098 - fixed in sid, already unblocked
19:29:02 <nthykier> #849099 - open in sid, might not be a blocker as the other llvm packages have symbol versions (this is for 3.7 despite the title)
19:29:39 <nthykier> #861175 - open in sid.  Alternative being xcffib plus one more being fixed, but so far that hasn't happened
19:30:00 <jmw> just those three? I'm going to meeting link them
19:30:27 <nthykier> Those are the only one tagged is-blocker atm
19:30:41 <jmw> http://bugs.debian.org/849098 in llvm-toolchain-3.8 is a blocker for stretch
19:30:54 <jmw> http://bugs.debian.org/849099 in llvm-toolchain-3.9 is a blocker for stretch
19:31:05 <nthykier> #undo
19:31:05 <MeetBot> Removing item from minutes: <MeetBot.items.Link object at 0x2092e90>
19:31:12 <nthykier> http://bugs.debian.org/849099 in llvm-toolchain-3.7 is a blocker for stretch
19:31:15 <nthykier> (the title is wrong)
19:31:40 <jmw> http://bugs.debian.org/861175 in cairocffi is a blocker for stretch
19:31:42 <jmw> bah
19:31:46 <jmw> ok done
19:33:11 <nthykier> Furthermore, our release checklist is nearly done up to the point of finding a release date.
19:33:33 <adsb> we don't have a release or ftp key yet :P
19:33:36 <nthykier> We got 2-3 items left and most of them are in progress - notably none of them being obviously blocked
19:33:43 <nthykier> adsb: aha! good point!
19:33:58 <nthykier> adsb: do you have bugs for those?
19:34:19 <KiBi> Bug#860830: debian-archive-keyring: ftp-master key for stretch
19:34:27 <KiBi> Bug#860831: debian-archive-keyring: release key for stretch?
19:34:32 <adsb> was just finding them :)
19:34:34 <adsb> thanks KiBi
19:35:00 <adsb> should have filed them ages ago, but -ENOTIME
19:35:04 <KiBi> (the only release thingy I've seen over the past few weeks, except for releasing d-i)
19:35:36 <nthykier> adsb: I am adding them to our checklist so we (hopefully) remember to file them earlier next time :)
19:35:46 <jmw> should that bug be is-blocker?
19:36:13 <KiBi> those bugs, no?
19:36:20 <jmw> indeed
19:36:38 <nthykier> if we cannot release without them, they are is-blocker
19:37:01 <nthykier> any  reason why they are not RC btw?
19:37:18 <adsb> well removing the d-a-k package would seem counterproductive :P
19:37:30 <nthykier> (is-blocker filed)
19:37:38 <adsb> but mostly because it didn't occur to me tbh
19:37:47 <nthykier> ok, upgrading and marking them as no-remove
19:37:49 <jmw> ("debian-archive-keyring was REMOVED from testing!")
19:38:23 <adsb> (also d-a-k is too similar to dak)
19:39:01 <nthykier> :)
19:39:16 <KiBi> adsb: true that
19:39:33 <jmw> #info Archive keyrings still need to be included in a point release of jessie before we can release stretch
19:39:37 <nthykier> Re: the keyring bugs - is that between the FTP-masters and the d-a-k maintainers or ... ?
19:39:46 <nthykier> (or us and d-a-k?)
19:39:47 <adsb> the d-a-k maintainers is us :)
19:40:01 * KiBi giggles at nthykier :)
19:40:06 <nthykier> ah, will you look at that
19:40:44 <adsb> in practice right now it's me, 'cause mine and phil's keys are the only ones in its internal keyring, but that's fixable
19:40:52 <adsb> I even documented it last time
19:40:56 <nthykier> :D
19:40:58 <jmw> steady
19:41:16 <adsb> sometimes past me doesn't actively hate future me
19:41:20 <nthykier> :D
19:41:39 <nthykier> adsb: I assume you will have this sorted out in time for the upcoming point release?
19:42:04 <jmw> that's RSN
19:42:06 <adsb> I would be surprised right now
19:42:07 <adsb> it is
19:42:26 <adsb> and we have no control over one part of it
19:42:33 <nthykier> oh?
19:42:41 <jmw> we need a key from ftp
19:42:44 <adsb> yes, that
19:43:01 <nthykier> hmph
19:44:08 <nthykier> worst case, can we schedule the 8.9 release sooner than usual if we don't get it done in time for 8.8?
19:44:14 <jmw> or delay 8.8
19:44:39 <jmw> it's hard enough getting the right people around for one point release, let alone doing another a couple of weeks after
19:44:43 <adsb> 8.8 is already really overdue
19:44:48 <jmw> hm true
19:45:15 <adsb> it's 3 months since 8.7
19:45:29 <adsb> nearly 4 by the time we actually do the point
19:45:30 <KiBi> and 8.8 is already on track afaict.
19:45:40 <nthykier> right, we already announced 8.8
19:45:42 <KiBi> delaying at the last minute = not so nice
19:45:44 <adsb> I've got a few things to get through still, but basically yes
19:46:18 <nthykier> adsb: if there is something I can do to give you more time to sort out the d-a-k key for 8.8, don't hesitate to let me know
19:46:32 <jmw> what nthykier said
19:46:33 <adsb> I guess if it came to it we could -updates d-a-k or something. but let's see what happens
19:46:45 <nthykier> ah true, we do have that option as well
19:46:51 <nthykier> less nice, but it would work
19:46:52 <adsb> only if you can add more hours to the day or make my brain spend more of them sleeping
19:47:03 <nthykier> ITYM "less" :P
19:47:11 <jmw> fewer
19:47:13 <jmw> but anyway
19:47:13 <nthykier> (for the "sleeping" part)
19:47:14 <adsb> no, more, so I'm more awake during the others
19:47:21 <nthykier> oh
19:47:25 <nthykier> ok
19:47:32 <adsb> but yes, anyway
19:47:44 <nthykier> #action adsb will look at #860830 / #860831
19:48:05 <jmw> I can help with making the d-a-k wheels go round, but not on key generation
19:48:20 <jmw> well I can generate keys too, but it's Dodgy(tm)
19:48:24 <nthykier> :)
19:48:32 <KiBi> adsb: if there's anything I can do, shoot
19:48:39 <adsb> ta all
19:48:50 <KiBi> (d-a-k or anything else)
19:49:08 <nthykier> Also if you are aware of other important/must-have issues, please let me know.
19:49:20 <KiBi> I'm not aware of huge blockers for d-i right now, so spending a few moments on release things would be nice…
19:49:49 <KiBi> Granted, we probably have a few important/maybe-rc bugs here and there, but can't fix all the bugs©®™…
19:49:58 <jmw> my dinner is imminent, what's next?
19:49:58 <nthykier> So I can get them prioritized and get a feeling for when we should look at finding a release date
19:50:39 <nthykier> Ack, that is what I had for this topic
19:50:44 <nthykier> #topic AOB
19:50:48 <nthykier> any takers?
19:51:25 <nthykier> None?
19:51:26 <jmw> the date, but not in public. nthykier want to kick of a d-r-private mail?
19:52:16 <nthykier> EPARSE on that
19:52:30 <jmw> yeh I'll try again
19:52:52 <jmw> nthykier: is it time to start discussing a release date in team mail?
19:53:06 <jmw> the earlier we have a plan the better
19:53:17 * jmw is keen for things not to drag
19:53:35 <nthykier> Ah, yes, that was the reason why I wanted some input from you all about the release status. :)
19:53:39 <nthykier> #undo
19:53:39 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x1fb4990>
19:53:51 <nthykier> #action nthykier to email d-r-private about a release date
19:54:02 <nthykier> #topic AON
19:54:08 <nthykier> OTÆ
19:54:10 <nthykier> GAH
19:54:10 <jmw> no other news, no :p
19:54:13 <nthykier> #undo
19:54:13 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x205ed50>
19:54:14 * KiBi :)
19:54:21 <nthykier> #topic AOB
19:54:29 <nthykier> none of these, right... ?
19:54:35 <nthykier> Then in closing
19:54:39 <nthykier> #topic Next meeting
19:54:49 <nthykier> #info Next meeting is 24th of May at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
19:54:53 <nthykier> and with that...
19:54:56 <nthykier> #endmeeting