19:00:15 <nthykier> #startmeeting
19:00:15 <MeetBot> Meeting started Wed Jun 28 19:00:15 2017 UTC.  The chair is nthykier. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:15 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:18 <nthykier> o/
19:01:09 <KiBi> adsb: if checks can run for so long, could this be made async maybe?
19:01:26 <nthykier> #chair jmw
19:01:26 <MeetBot> Current chairs: jmw nthykier
19:01:28 <KiBi> put big '???' instead in the meanwhile, but let q-v get to other things?
19:01:38 <KiBi> #greetings everyone
19:01:41 <adsb> KiBi: not particularly easily in the current architecture
19:01:53 <adsb> it's something I've pondered every so often
19:01:59 <jmw> hm, I hate it when nthykier makes it sound like I know stuff
19:02:04 <nthykier> oh, I have been naught and forgot to update the agenda
19:02:05 <jmw> o/
19:02:07 <KiBi> adsb: ack for lack of easy, what about desirability?
19:02:21 <nthykier> jmw: you are here to ensure the meeting goes on if I lose connection :P
19:02:24 <jmw> nthykier: well I've removed the obviously redundant things from last time, at least :)
19:02:28 <adsb> maybe
19:02:39 <nthykier> #admin
19:02:40 <adsb> it's not /that/ common an occurence, at least it hasn't been in the psat
19:02:52 <nthykier> #info We released \o/
19:03:00 <jmw> \o/
19:03:11 <KiBi> \o/
19:03:12 * jmw has his life back! wait, the other thing
19:03:22 <nthykier> jmw, pochu and I all had action items related to that, which are now (obviously) complete
19:03:24 <adsb> nah, $dayjob just stole it back
19:03:35 <jmw> tru dat.
19:03:52 <jmw> (I should probably put my serious hat on now)
19:04:04 <nthykier> #topic transitions
19:04:23 <jmw> well, they started
19:04:28 <nthykier> They did
19:04:35 <jmw> and it appears I have forgotten everything about them since last touching them >6mo ago
19:04:43 <nthykier> A common problem :)
19:04:47 <jmw> poor pochu
19:05:21 <nthykier> I think we have a perl 5.26 transition coming up soon, otherwise I am not aware of anything
19:05:38 <nthykier> jmw: pochu: Have you seen anything or want to mention anything here?
19:05:39 <jmw> I don't think there's much to write home about yet. everything set up so far has gone alarmingly smoothly
19:05:59 <jmw> it's possibly time for a nthykier how-to-be-nice-to-us-over-transitions d-d-a mail
19:06:21 <jmw> you know, new cycle, new nagging
19:06:33 <nthykier> s/nthykier/jmw/ and you got a deal! ;)
19:06:39 <jmw> pfft
19:06:53 <jmw> #info Transitions have started in earnest, so far so good
19:07:15 <nthykier> Is our tooling still up to speed with the workflow?
19:07:31 <ScottK> python3 is about ready to start (fyi - didn't write the request yet).
19:08:26 <jmw> seems fine as far as I'm aware
19:08:30 <nthykier> ScottK: thanks :)
19:08:44 <nthykier> jmw: Thanks :)
19:08:50 <nthykier> I guess this was it for transitions then
19:08:52 <jmw> although I would like to make ben use tracker and not qa for links
19:08:58 <jmw> but niggle
19:09:08 <nthykier> jmw: nag mehdi
19:09:15 <nthykier> he is our ben-fixer
19:10:10 <jmw> it's not a big deal
19:10:13 <nthykier> ok
19:10:24 <nthykier> Lets move then :)
19:10:41 <nthykier> #topic stretch feedback
19:10:55 <nthykier> jmw: you just added this one, so you get to present it! :)
19:11:03 <jmw> it's your thing :p
19:11:16 <jmw> #info Feedback from the stretch cycle is collected in gobby
19:11:21 <nthykier> :D
19:11:28 <nthykier> oh that :)
19:11:34 <jmw> should we try to get feedback from the project as well as introspecting?
19:12:22 <nthykier> True, that might be good too
19:12:50 <nthykier> Mostly I was looking for actionable items or things to use for planning the buster freeze
19:13:26 <jmw> yeh
19:13:38 <nthykier> adsb: do we still have that "feedback@r.d.o" alias?
19:14:47 <adsb> we do. it's full of spam in character sets I don't understand
19:15:09 <nthykier> guess I should subscribe and then do a call for feedback
19:15:29 <nthykier> #action nthykier to do a project wide request for feedback
19:15:32 <jmw> I'd suggest working it into a bits mail
19:15:53 <jmw> it would be nice to get positive feedback too, of course
19:15:53 <nthykier> true, I'd have to subscribe before said bits mail though
19:16:41 <nthykier> jmw: what's next?
19:17:37 <jmw> #topic Publish britney remarks to tracker?
19:17:55 <nthykier> (ping pochu, you got an item coming up assuming you are around)
19:17:56 <jmw> previous minutes don't claim we talked about this, so it must be new
19:18:05 <nthykier> ok
19:18:31 <jmw> it's the question of whether britney remarks, which were originally for internal notes, should be published by britney so maintainers can use them as feedback too
19:18:49 <jmw> possibly taking one cycle out of the unblock feedback loop
19:19:47 <nthykier> I am fine with exposing the fact that there is a remark (and possibly what it is), but I don't think it should replace our primary communication with the maintainer (which would be unblock requests)
19:19:59 <jmw> no, totally
19:20:57 <nthykier> Any one else have a comment or should we just expose them?
19:21:05 <nthykier> (FTR, they are public already now)
19:21:27 <jmw> #info remarks are in fact already public, just not particularly easy to find
19:21:39 <KiBi> I only discovered this accidentally a few weeks ago :)
19:22:56 <nthykier> #action nthykier file a bug against britney about making her include remark hints in the excuses page
19:23:25 <nthykier> sounds like there were no objections, and if there are, we can still take them up on the bug report :)
19:24:09 <jmw> shall we skip line 12?
19:24:23 <nthykier> jmw: ack, until pochu appears
19:24:31 <jmw> #topic Buster planning
19:24:53 <jmw> so, we should decide on some high-level target dates so that we can talk about them incessantly on d-d-a until they stick
19:25:23 <nthykier> My opening gambit, stretch dates +2years
19:25:37 <nthykier> maybe tweak the transition deadline
19:25:51 <nthykier> but yes, we should
19:26:12 <jmw> sounds a good start. two years between freezes seems to work quite well, although the releases are gradually working along the year a bit
19:26:43 <jmw> nthykier: were you thinking transition freeze earlier or later?
19:26:48 <KiBi> yeah, the progressive slide isn't too good looking
19:26:57 <nthykier> later, but I remember a suggestion for a toolchain freeze
19:27:33 <nthykier> jmw: KiBi: actually, if we subtract the deliberate delay of 2 months in stretch, then we had a shorter freeze then jessie (counting "hard freeze")
19:27:34 <adsb> fwiw I'm fairly sure advice from previous RMs was "they don't really help"
19:28:00 <KiBi> nthykier: june is later than may
19:28:03 <nthykier> jessie was released in May, Stretch in June - June -2 months would be April
19:28:08 <KiBi> may is later than istr february
19:28:44 <KiBi> so if we could manage to avoid sliding a bit more, that'd be best.
19:29:52 <jmw> I'm all for trying to take a month off the freeze, if we can do it
19:30:01 <nthykier> We did
19:30:06 <jmw> another :)
19:30:15 <nthykier> that is going to be hard though
19:30:15 <adsb> again! again!
19:30:17 <adsb> (sorry)
19:30:29 <jmw> about mid may was when it felt like we lost momentum
19:30:50 <jmw> (though that did coincide with lots of $life, so my perspective may be skewed)
19:31:20 <nthykier> fundamentally, we have way too many issues left when the freeze starts - Feb. was one month of "incoming RC bugs = fixed RC bugs"
19:31:49 <nthykier> anyway, I think we are digressing
19:32:17 <nthykier> this basically wants an action item for starting the planning, if I am not mistaken
19:32:34 <jmw> do we want to try and line up with an LTS kernel again?
19:32:55 <nthykier> ack, that is what Ben requested
19:33:06 <jmw> #info We will try to line up with an LTS kernel again
19:33:09 <nthykier> (as I understood him when he asked us to move the stretch dates)
19:33:29 <jmw> hm that should probably be #agree, if there aren't objections
19:34:01 <nthykier> wfm
19:34:09 <jmw> #undo
19:34:09 <MeetBot> Removing item from minutes: <MeetBot.items.Info object at 0x10b6050>
19:34:13 <jmw> #agree We will try to line up with an LTS kernel again
19:34:44 <jmw> in which case, kicking off the process in autumn/winter 2018 is probably as specific as we need to be right now, and we should plan in more detail offline
19:35:06 <nthykier> true
19:35:15 <nthykier> can you put an action on me for getting the ball rolling on that
19:35:16 <nthykier> ?
19:35:33 <jmw> #action nthykier to start getting a timetable together
19:36:23 <nthykier> thanks
19:36:30 <jmw> of course I am assuming you and pochu are both happy to RM buster
19:37:20 <jmw> nthykier: how about leaving the arch qual items to next month? they're not urgent
19:37:50 <nthykier> actually, I would like to open the i386 item if we have time
19:38:09 <jmw> fine by me
19:38:19 <nthykier> #topic Retracting the i386 porter waiver
19:38:48 <nthykier> So, we have been approached about this several times during the stretch cycle and we punted it
19:39:35 <nthykier> basically we have been asked to retract the i386 porter waiver, since some people feel that i386 is not maintained as well any longer as it used to without explicit action
19:39:45 <nthykier> erh, explicit porters*
19:40:17 <nthykier> I believe pochu item about "Packages requiring instructions not present in an architecture's baseline" is an artefact of this
19:40:24 <nthykier> (at least partly)
19:42:22 <nthykier> I have not quite figured out how we would go about it, but it probably wants to be sooner rather than later
19:43:06 <nthykier> any comments/proposals?
19:43:07 <jmw> if we remove the waiver, are we realistically going to decide it's not high enough quality and drop it?
19:43:13 <jmw> feels unlikely to me
19:43:17 <nthykier> there is that
19:43:56 <jmw> or are you expecting it to get more attention if it isn't automatically staying?
19:44:34 <nthykier> I dont know what to expect, but we did drop powerpc because we were fearing where it was headed rather than were it was
19:44:43 <nthykier> where*
19:45:33 <nthykier> i386 decline is probably in a completely different ballpark, but ...
19:45:38 <jmw> I don't really have strong feelings
19:46:22 <nthykier> ok, thanks for the remarks :)
19:46:44 <KiBi> we still see i386 uploads
19:46:50 <KiBi> not sure there were so many powerpc ones
19:47:38 <nthykier> I would argue it is bad thing and every one should be source-only uploads! :P
19:48:25 <KiBi> “jessie”, so no.
19:48:25 <nthykier> but yes, perhaps we should have taken this with the rest of the arch-qualification
19:48:45 <nthykier> pfft, those bloody SRMs - always 2-3 years behind the game! ;)
19:48:47 <jmw> let's do that, and hopefully have pochu next time as well
19:49:26 <nthykier> AOB?
19:50:05 <nthykier> #topic AOB
19:50:09 <KiBi> 8.9/9.1 are treated outside the meeting I assume?
19:50:21 <nthykier> #undo
19:50:21 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x2057d90>
19:50:58 <nthykier> KiBi: Topic?
19:51:18 <nthykier> 8.9/9.1 planning?
19:51:25 <KiBi> for example
19:51:31 <nthykier> #topic 8.9/9.1 planning
19:51:41 <KiBi> Dates are floating already, not sure if there's anything specific planned for 9.1 though
19:52:00 <KiBi> 8.9 is likely going to be business as usual, but maybe 9.1 needs special care for some reason?
19:52:27 <KiBi> Plenty of live-related fixes on cdimage for one thing; not sure whether there's anything else on the -release thing, that's why I was wondering
19:52:41 <nthykier> adsb: ?
19:52:56 <adsb> not that I'm particularly aware of
19:53:15 <jmw> from our point of view I don't think there's anything of note
19:53:32 <jmw> just the usual didn't-test-my-package-enough mopping up
19:54:07 <KiBi> ok, sorry for the noise then
19:54:32 <nthykier> np :)
19:54:38 <nthykier> #topic AOB
19:55:22 <nthykier> any AOB?
19:55:36 <jmw> doesn't sound like it
19:56:34 <nthykier> jmw: I can see we don't agree on the next meeting date:)
19:57:03 <jmw> nthykier: well you do not agree with your own calendar then :p
19:57:15 <nthykier> oh wait we do - I just misread and was looking at the tech-ctte meeeting :P
19:57:20 <nthykier> #topic Next meeting
19:57:28 <nthykier> Next meeting is 26th of July at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
19:57:35 <nthykier> Thanks for attending :)
19:57:38 <jmw> wait
19:57:39 <nthykier> #endmeeting