19:06:51 <nthykier> #startmeeting
19:06:51 <MeetBot> Meeting started Wed Jul 26 19:06:51 2017 UTC.  The chair is nthykier. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:06:51 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:07:14 <nthykier> okay, meeting time now that I am done filing bugs upstream :P
19:08:18 <nthykier> #topic admin
19:08:33 <nthykier> #info Last meeting minutes is at: http://meetbot.debian.net/debian-release/2017/debian-release.2017-06-28-19.00.html
19:09:07 <nthykier> #info No progress on request for archive wide feedback on the release [assigned to nthykier]
19:09:43 <nthykier> #info nthykier should have filed a bug against britney for including remark hints in excuses - did not happen yet
19:10:21 <nthykier> #info nthykier should have made a draft time table for the buster release - did not happen yet
19:11:23 <nthykier> #topic Transitions
19:11:40 <nthykier> pochu: I believe you got better progress than I did :)
19:13:46 <pochu> heh
19:13:57 <KiBi> heh'llo
19:14:05 <pochu> perl happened and it was fast
19:14:27 <pochu> python3.6 is supported, no eta for the default switch yet
19:14:36 <nthykier> pochu: and the old 5.24 libraries are out of testing already?
19:14:59 <pochu> other big transitions are the ongoing haskell one, switching llvm to 4.0, removing openssl 1.0...
19:15:06 <pochu> nthykier: yep, it's all done
19:15:16 <nthykier> Great :)
19:15:31 <pochu> I don't know why, I thought they'd stay for linux. but maybe linux migrated in the end, didn't check
19:15:38 <nthykier> #info Perl 5.26 transition is complete
19:15:40 <pochu> I just know that it's completed :D
19:16:09 <nthykier> #info Python 3.6 is now supported, but not the default (no ETA for this switch yet)
19:16:16 <nthykier> wfm :D
19:16:53 <nthykier> llvm 4.0 ongoing as well?
19:17:26 <pochu> not yet, there's one problem there, with a possible workaround
19:17:34 <nthykier> ok
19:18:00 <nthykier> #info Other noteworthy transitions: haskell (ongoing), llvm 4.0 as default (hopefully starting soon), openssl 1.0 removal (ongoing)
19:18:24 <nthykier> EOT?
19:18:55 <pochu> aye
19:18:59 <nthykier> #topic Matters arising - Sprint?
19:19:36 <nthykier> Any takers for this one? (on the agenda, not sure who proposed the item)
19:20:31 <nthykier> If not, I will move on in 30
19:20:35 <nthykier> 30s*
19:21:12 <nthykier> time out
19:21:18 <nthykier> #undo
19:21:18 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x2094d10>
19:21:34 <nthykier> #topic Architectures - instructions not present in an architecture's baseline
19:21:44 <nthykier> pochu: you had this as an item in stretch that we defered to buster
19:21:51 <nthykier> Related bug #857147
19:24:01 <nthykier> pochu: ?
19:25:59 <nthykier> Moving on then
19:26:01 <nthykier> #undo
19:26:01 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x2094710>
19:26:48 <nthykier> #topic Architectures
19:27:18 <nthykier> sorry
19:27:22 <nthykier> #undo
19:27:22 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x2043690>
19:27:26 <nthykier> #topic AOB
19:27:29 <nthykier> Any AOB?
19:27:45 <adsb> not from me
19:27:47 <ivodd> Britney exploded last night
19:28:05 <ivodd> I worked around it by block ghc (and all of haskell), but that doens't look like a permanent fix
19:28:42 <nthykier> ivodd: recursion limit?
19:28:46 <ivodd> yes
19:28:50 <nthykier> ugh
19:29:16 <nthykier> #info Britney hits a recursion limit for ghc
19:30:02 <nthykier> ivodd: have you filed / could you please file a bug for this?
19:30:28 <ivodd> nthykier: I don't have much time in the coming days, so I might forget about it
19:30:36 <ivodd> but if I don't, I'll file the bug afterwards
19:30:42 <nthykier> ok
19:31:01 <nthykier> #action ivodd files a bug against britney for the stack overflow issue
19:31:10 <nthykier> #undo
19:31:10 <MeetBot> Removing item from minutes: <MeetBot.items.Action object at 0x20f1e90>
19:31:20 <pochu> nthykier: sorry, bad connection. let's defer that, yes
19:31:21 <nthykier> #action ivodd files a bug against britney for the recursion limit issue
19:31:39 <nthykier> pochu: ah, wb :)  Feared it might be something like that
19:32:06 <nthykier> If there is nothing else ... ?
19:33:10 <nthykier> #topic Next meeting
19:33:13 <nthykier> #info Next meeting is 23rd August at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
19:33:25 <helmut> wrt architectures: fedora is pondering removing i686. can we at least drop the porter waiver for i386 soon?
19:33:36 <nthykier> #endmeeting