19:01:02 <nthykier> #startmeeting
19:01:02 <MeetBot> Meeting started Wed May 23 19:01:02 2018 UTC.  The chair is nthykier. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:02 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:01:05 <nthykier> o/
19:01:20 <nthykier> #topic admin
19:01:39 <jmw> o/
19:01:43 <nthykier> #info Previous meeting minutes at: http://meetbot.debian.net/debian-release/2018/debian-release.2018-04-25-19.00.html
19:01:53 <nthykier> Actions from previous:
19:02:26 <nthykier> #info nthykier was supported to send out an ITM for the britney autopkgtest code - this is done and the code is merged (https://lists.debian.org/debian-release/2018/04/msg00236.html)
19:03:02 <nthykier> #info SRMs were to call out for some dates for the next point release - the call has been done the date has not been picked/announced yet
19:03:11 <adsb> ack
19:03:19 <adsb> sorry I'm kinda around
19:03:23 <adsb> waiting for delayed food
19:04:04 <jmw> the date is hard. I'm likely going to prioritise jessie, since we want the mop-up release to be asap after the security team hand over to LTS
19:04:10 <nthykier> #info Mithrandir, pochu and nthykier were to review the arch qual criteria - that happened (some minutes in note form at https://etherpad.wikimedia.org/p/debian-release-arch-qualification)
19:04:31 <nthykier> that should be all for "admin"
19:05:38 <nthykier> jmw: should I put you down for an action for getting the dates sorted out?
19:06:27 <jmw> if you like
19:06:40 <jmw> it doesn't need to be me, but things without names on are someone else's problem, so
19:07:05 <nthykier> #action jmw to find point release dates
19:07:13 <nthykier> indeed - thanks for volunteering :)
19:07:46 <nthykier> pochu: are you around for transitions?
19:08:18 <nthykier> #topic Missing recommends is or is not RC bugs
19:08:39 <nthykier> jmw: I think you put this one on the agenda for today?
19:08:55 <jmw> nothing to do with me
19:09:12 <nthykier> hmm it is written by me but I don't remember adding it
19:09:14 <nthykier> oh well
19:09:25 <nthykier> Anyway
19:09:26 <adsb> it's something that's come up several times over the years
19:09:28 <jmw> it's not written by an englishman, so I disclaim all responsibility :)
19:09:59 <nthykier> We have been asked to review RC bug policy for recommends (thread starting at https://lists.debian.org/debian-policy/2018/04/msg00064.html)
19:10:51 <adsb> (food)
19:11:16 <nthykier> adsb: given it has come up before, I assume our stance previously was "it is not an RC bug"?
19:11:47 <adsb> our stance previously was "errr we should probably think about it" I believe
19:11:59 <nthykier> hah
19:12:08 <adsb> it's been on the rc policy as-is for as long as I remember, but we've basically been cargoculting that across releases
19:12:20 <nthykier> and RRA is asking: "Before making a decision here, I'd like to know why the release team does *not* consider it an RC bug and what the reasoning is. It might be very good reasoning!  Or it could just be an oversight."
19:12:26 <nthykier> (quote from: https://lists.debian.org/debian-policy/2018/04/msg00067.html)
19:12:31 <adsb> I have no idea if there was a reason for it originally beyond "these recommends things are new"
19:12:44 <adsb> maybe aba or vorlon remember
19:13:07 <nthykier> smells like we ought to update the RC bug policy to reflect the current state :)
19:13:36 <adsb> there may well be other places where it doesn't aligh with policy, or that are outdated
19:13:59 <adsb> it doesn't necessarily have to align exactly, but it would be handy for us to at least be aware of where it doesn't, I think
19:14:30 <nthykier> RRA's (other) mail suggests that the policy decision was about "pkg in main recommending package *not* in main".  (Source https://lists.debian.org/debian-policy/2018/04/msg00065.html)
19:14:58 <nthykier> I am leaning towards blessing that interpretation into the RC bug policy
19:16:01 <nthykier> though it might be prudent to get some actual data/numbers on how much will be affected by that change
19:17:52 <nthykier> any comments on that or should I follow up on that thread saying we are interested in aligning with rra's interpretation assuming it does not imply a mass RC bug filing?
19:17:56 <mapreri> "blessing that interpretation into the RC bug policy" -> that also sounds like it should go straight into Britney's thoughts on the world
19:18:14 <nthykier> mapreri: well, britney should do it for Depends before that
19:18:44 <mapreri> I mean, enforcing stuff with non-satisfable recoemmends doesn't land in testing
19:19:08 <adsb> that's a subtly difference change
19:19:45 <nthykier> mapreri: As I read rra's mail, "Recommends: non-free" would be RC, but "Recommends: non-existant" would not
19:19:53 <nthykier> (for a package in main)
19:19:57 <adsb> nthykier is referencing #219978 aiui
19:19:57 <jmw> that seems an odd thing to do
19:20:15 <kibi> oh woops a meeting
19:20:16 <nthykier> jmw: "that" being a reference to ... ?
19:20:22 <adsb> which is only 15 years old...
19:20:26 <mapreri> nthykier: Personally, I don't see the difference between "Recommends: non-free" and "Recommends: non-existent"
19:20:30 <_rene_> oh, wow, that bug :)
19:20:32 <jmw> r:non-free being RC, but not r:non-existent
19:20:38 <mapreri> non-free is not debian
19:20:47 <mapreri> => non-free doesn't exist
19:20:58 <nthykier> mapreri: it does for britne
19:20:59 <mapreri> perfect implication here :P
19:21:10 <jmw> well non-existent doesn't exist either, unless you happen to have a source that can satisfy it, and then you're not self-contained any longer
19:21:15 <adsb> _rene_: indeed. britney still has a big blob of packages that exist on a particular architecture
19:21:19 <jmw> but you probably weren't anyway, so it's likely academic
19:21:26 <jmw> it just seems odd for one to be RC but not the other
19:21:27 <nthykier> jmw: ok, so are you in the "broken Recommends are RC" or "broken Recommends are non-RC"
19:21:32 <nthykier> ?
19:21:43 <nthykier> (third alternatives are welcome too btw)
19:22:06 <mapreri> oh wow that bug indeed, I forgot britney doesn't enforce main/contrib/non-free :3
19:22:23 <jmw> nthykier: I don't mind which, but we should be consistent. and we shouldn't rush into deciding if it's RC or not before we understand if there was a good reason or just oversight/nerves at the time
19:22:36 * _rene_ is not a RT member, but if opinions from outside want to be heard, I also lean to Recommends: not-exists not RC, Recommends: !main RC
19:23:31 <nthykier> jmw: ok
19:24:19 <jmw> #info We have been asked to review RC bug policy for recommends (thread starting at https://lists.debian.org/debian-policy/2018/04/msg00064.html)
19:25:34 <jmw> #info Recommends: <non-existing> and Recommends: <non-free> could be handled differently or not
19:28:15 <jmw> #info Debian Policy 2.2.1: ".. packages in main must not require or recommend a package outside of main for compilation or execution"
19:28:28 <jmw> any other important points?
19:28:32 <nthykier> ... agreed that we wait for aba + vorlon to reply on whether they remember why recommends are not handled as RC bugs?
19:28:47 <jmw> has anyone invited them to?
19:28:50 <nthykier> (/me agrees with the curren info ones)
19:29:26 <nthykier> I thought "< adsb> maybe aba or vorlon remember" was a British way of asking :P
19:29:55 <jmw> it's a british way of suggesting you might like to mail them :p
19:30:02 <aba> well, give me a few seconds
19:30:08 <jmw> ah even better
19:30:16 <adsb> well, I was semi-hoping they might notice tbh ;)
19:30:32 <adsb> but yes, also a suggestion that we ask
19:30:43 <aba> basically, because if you don't configure non-free, the package still installs fine
19:31:03 <aba> i.e. main is a closure with "depends", but not with all dependencies
19:31:20 <aba> (and also, in historical times, recommends was not automatically acted on IIRC)
19:33:06 <aba> and RC policy was always a bit different to debian policy - not every violation of a must clause is an RC bug
19:33:36 <ansgar> The reject faq from ftp-master has 'If you want your package in main it must not (Build-)Depend: or Recommend: a package which isn't in main too. That's what we have contrib for.'
19:33:44 <aba> what I'd tend to look at before that discussion is: about how many packages do we speak? does this generate loads of rc bugs, or just 1?
19:34:27 <aba> and the reject faq might have fixed things.
19:36:26 <nthykier> ansgar: "in main" - does that imply existance?
19:36:49 <nthykier> or is it only reject for "known non-free/contrib"
19:37:48 <ansgar> As far as I remember it was always 'has to exist'
19:39:05 <_rene_> then this wasn't enforced.
19:39:18 <nthykier> ok
19:39:33 <nthykier> I think this topic needs "further dicussion via mail"
19:39:52 * _rene_ knows of a package recommending stuff just there on !BE
19:40:21 <ansgar> _rene_: It's not enforced automatically, yes.
19:40:37 <nthykier> #action nthykier will follow up on the request and start a discussion
19:40:38 <_rene_> or actually, hmm, nevermind, I think it's a substvar which isn't set in BE archs
19:40:56 <nthykier> Moving on
19:41:04 <nthykier> #topic Architecture qualification for buster
19:41:31 <nthykier> As mentioned in admin, we had some ideas for revising the qualification criteria
19:41:50 <nthykier> These are in https://etherpad.wikimedia.org/p/debian-release-arch-qualification (in note form)
19:42:15 <nthykier> The idea was to compute/extract most of them automatically
19:43:12 <nthykier> To my knowledge, no one is actively working this (volunteers welcome) nor on doing architecture qualification for buster itself
19:43:50 <nthykier> Although, ISTR that Mithrandir did imply he was willing to start the process if we were happy with delegating the responsibility to him
19:45:50 <nthykier> Indeed, "<Mithrandir> if you want to deputise me to do those tihngs on behalf of the release team, I could do that, but I don't have time to join the team."  (http://meetbot.debian.net/debian-release/2018/debian-release.2018-04-25-19.00.log.html)
19:46:02 <jmw> I don't have a problem with that, so long as the parameters are adjustable later
19:46:05 * Mithrandir pipes up
19:46:31 <Mithrandir> sure, we'll iterate once we have a framework up
19:46:49 <jmw> that would be really helpful
19:48:11 <Mithrandir> I'll see if I can start putting something together, I've just not really had time yet.
19:48:32 <nthykier> Mithrandir: That would be excellent if you could do that :)
19:51:32 <nthykier> Mithrandir: Should I have a look at the "Qualitative indicators" (the old fashioned way) while you look at the automatic ones?
19:52:05 <Mithrandir> nthykier: sounds good.
19:52:08 <nthykier> good
19:52:32 <Mithrandir> I'm going to funerals for the next two days, so I won't make any progress before the weekend, but hopefully I can get some work done then.
19:52:50 <nthykier> Progress is measured in months here :P
19:52:54 <Mithrandir> :-)
19:53:00 <nthykier> #action Mithrandir will look at implementing a PoC/PoT on the automatic status indicators
19:53:38 <nthykier> #action nthykier will start the qualitative indicators (a.k.a. asking for concerns from parties)
19:53:45 <nthykier> #topic AOB
19:54:14 <nthykier> As we are almost out of time, I am skipping to AOB
19:54:42 <jmw> too early to ask who'll be at debconf?
19:54:51 <nthykier> (I know there is a topic about "Next meeting" - I will handle that in "Next meeting")
19:55:10 <nthykier> jmw: Unsure; not booked, not planned not anything
19:55:29 <jmw> ok
19:55:33 <jmw> just nosy
19:56:04 <nthykier> #topic Next meeting
19:56:28 <nthykier> So (the default time for the) next meeting falls in a poor time for DebConf
19:56:59 <jmw> um
19:57:03 <jmw> the next meeting is 27th June
19:57:12 <nthykier> jmw: oh it is the July one causing issues?
19:57:16 <jmw> yes
19:57:20 <nthykier> silly me
19:57:21 <jmw> it's possible I misled you in my mail though
19:57:57 <jmw> ah no I did not, you are just too keen
19:58:20 <nthykier> that only makes it easier
19:58:38 <jmw> #info Next meeting: 27th June 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
19:58:38 <nthykier> #info Next meeting is 27th June at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
19:58:41 <jmw> bah
19:58:41 <nthykier> #undo
19:58:41 <MeetBot> Removing item from minutes: <MeetBot.items.Info object at 0x20a6d50>
19:58:45 <nthykier> hah
19:58:53 <nthykier> Thanks for attending :)
19:58:56 <nthykier> #endmeeting