19:04:53 <nthykier> #startmeeting
19:04:53 <MeetBot> Meeting started Wed Apr 24 19:04:53 2019 UTC.  The chair is nthykier. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:53 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:05:06 <nthykier> Lets get started :)
19:05:21 <nthykier> #topic Admin
19:06:17 <adsb> o/
19:06:22 <nthykier> #info Minutes from last meeting are at http://meetbot.debian.net/debian-release/2019/debian-release.2019-03-27-19.01.html
19:06:57 <nthykier> #info nthykier had one item about sending a mail to team@ to discuss whether the meeting time is still ok; not done
19:08:10 <nthykier> #info jmw had a (non-listed) item about sending a d-d-a mail when we got below 300 RC bugs.  This has happened (and we are now at ~133 RC bugs \o/)
19:08:15 <nthykier> #undo
19:08:15 <MeetBot> Removing item from minutes: <MeetBot.items.Info object at 0x140ca50>
19:08:24 <nthykier> #info jmw had a (unlisted) action item about sending a d-d-a mail when we got below 300 RC bugs.  This has happened (and we are now at ~133 RC bugs \o/)
19:08:40 <nthykier> I think that was it for admin :)
19:09:34 <nthykier> Next up would be Transitions, but I don't think we have any of these at the moment
19:10:35 * elbrus is not the right person to know authoritive, but he doesn't think either
19:10:44 <nthykier> #topic Unblock queue
19:10:52 <nthykier> I think this topic is still relevant
19:11:51 <elbrus> (should we maybe ping people, in case they are not aware of the meeting, but are on-line?)
19:12:09 <nthykier> elbrus: by all means, please do
19:12:23 * elbrus fears to be not complete
19:12:40 <adsb> kibi: pochu_: jcristau: jmw
19:12:46 <nthykier> We got 27 unblock requests pending us (related thanks to ivodd for pruning a lot of them the other day) plus about 10 waiting for requesters
19:12:47 <elbrus> ivodd:
19:12:48 <adsb> that should do :)
19:12:59 <adsb> we got there between us
19:13:40 <nthykier> :D
19:14:16 <nthykier> The oldest open unblock request we have is from March 16 AFAICT and is unanswered by us #924742 (just to get a feeling of the backlog)
19:14:55 <nthykier> looks like we are due for a clean up round on unblocks
19:15:45 * elbrus has the feeling there are several non-trivial ones in the older set
19:15:47 <nthykier> #info We got 27 unblock requsts waiting for us and 10 waiting for requester.  Oldest one (waiting for RT) is about ~5 weeks old atm.
19:16:07 <nthykier> indeed, we are probably looking at rejecting or returning most of them with feedback
19:16:52 <elbrus> I have a general question
19:17:07 <nthykier> yes, please go ahaed :)
19:17:10 <elbrus> we do get pre upload requests once in a while
19:17:14 <nthykier> ... ahead*
19:17:55 <elbrus> nearly always what we tend to "want" is a package in unstable to diff with
19:18:34 <elbrus> so, should we encourage people to upload earlier, or is that shouting in our own foot?
19:19:05 <nthykier> You mean to be able to use d ? Or to get the unblock done in a single round trip?
19:19:29 <nthykier> (For the former, uploads to experimental is an option)
19:19:32 <elbrus> I mean, I was looking at blis this morning and thought that it may have been easier to just judge what the uploader wanted to migrate
19:20:02 * elbrus likes experimental, yes, but in this case that was even blocked already
19:20:13 <nthykier> ah, #926976 - we definitely want a debdiff in some form
19:20:45 <elbrus> I was thinking about roundtrips mostly
19:21:18 <elbrus> but I recognize it that we also want to encourage people to not upload to unstable too much
19:21:26 <nthykier> right - it is a double-edged sword; in many cases it is indeed faster as *most* uploads are beneign.
19:21:31 <elbrus> but if the fix is targetting testing...
19:21:59 <nthykier> Problem being we do not always agree on how a fix targeting testing should look
19:22:19 <elbrus> maybe we should say; uploads that can easily be reverted (e.g. not a new upstream version) are OK to try without a pre-approval
19:23:25 <nthykier> Would work for me.  The tricky part is getting people to revert it again if it becomes an issue (mostly because sid can contaminate testing in some cases)
19:23:30 <elbrus> s/should/could/
19:23:45 <elbrus> ack
19:24:02 <elbrus> I'll put this on my list for the freeze policy for buster
19:24:18 <nthykier> Thanks :)
19:24:24 <elbrus> s/buster/bullseye/
19:24:35 <elbrus> not changing the policy so late
19:24:42 <nthykier> :D
19:25:35 <nthykier> Ok, unwinding back to the unblock queue - perhaps we should look at a work session to clean up the queue
19:25:45 <nthykier> (on IRC)
19:26:54 <elbrus> I typically only have about two hours in the evening (UTC+2)
19:27:00 <elbrus> but otherwise, fine with me
19:28:03 <nthykier> ok - I was thinking a weekend day actually :) All the same, I think I will action it for me to propose a timeslot :)
19:28:21 <nthykier> #action nthykier to propose some timeslots for cleaning up the unblock queue
19:29:15 <nthykier> if there is nothing else about unblock requests, I think I will move on to "Freeze progress"
19:29:25 <nthykier> #topic Freeze progress
19:30:11 <elbrus> nthykier: I appreciated your e-mail
19:30:22 <elbrus> describing our PoV
19:30:37 <elbrus> and looking forward to a date
19:30:44 <nthykier> Thanks - I was hoping it would give an overview of what I see us waiting for
19:31:50 <elbrus> from what is on my radar, it did
19:32:12 <elbrus> (not claiming a very good radar though)
19:32:49 <nthykier> At the moment, I think the most concerning one is #927825 as it might be a pandora's box of delay (best case is obviously a nice simple quick fix, but ...)
19:33:01 <elbrus> indeed
19:33:39 <nthykier> #info One of the primary release blockers is #927825 (as it keeps DSA from upgrading ARM buildd machines)
19:33:58 <aurel32> technically we can upgrade them, just we need to run them with the stretch kernel
19:34:25 <nthykier> I am not turning ARM into the new sparc
19:34:27 <aurel32> maybe i should upgrade an armel machine while keeping the old kernel so that we can at least test the armel userland
19:35:16 <aurel32> agreed this should get fixed, but it doesn't worry me that much it's not a kernel stability issue
19:35:27 <aurel32> it just looks like a driver issue
19:35:28 <nthykier> aurel32: hmm, indeed that would be useful from the PoV of ensuring that buster works on arm (userland vice)
19:36:28 <nthykier> if you (DSA) is ok with that in the interrim, then I think it would be a fine step towards weeding out possible unknowns for buster
19:37:12 <nthykier> aurel32: were we only missing the arm machines now?
19:37:17 <aurel32> well i don't think we should release buster with that issue, but at least we can progress forward
19:37:24 <aurel32> nthykier: yes
19:37:40 <aurel32> i mean it means we have one month to find the driver issue, looks doable for me
19:39:18 <aurel32> Sledge: have you been able to look at the issue? If not, I'll start a rough "bisect" with the kernel from backports
19:39:31 <aurel32> s/backports/snapshot/
19:39:38 <nthykier> Thanks :)
19:40:54 <nthykier> #info #927825 is likely caused by a driver issue and fixing it within a month "looks doable" at the moment
19:41:39 <adsb> [eating, not that anyone would probably have noticed]
19:42:02 <nthykier> elbrus: I forgot to include release-notes in my status update - do you have anything on that front?  Are we missing anything there?
19:42:04 <pochu> adsb: yeah you don't make that much noise :P
19:42:22 <elbrus> release-notes are coming along
19:42:36 <elbrus> as a first timer on that front, it looks ok
19:42:55 <elbrus> backlog isn't too bad, and mostly with promises
19:43:31 <nthykier> :)
19:43:34 <elbrus> and if they don't turn up, I think I'll manage to create some text
19:44:05 * elbrus is very glad that there is a response from the security team about the notes
19:44:37 <elbrus> all-in-all, I think the release notes are fine
19:44:40 <nthykier> Our main selling points (from chapter 2) appears to be Apparmor, better German manpages, nftables, better disk crypto (LUKS2) and then (hopefully)  Secure boot support... :)
19:45:29 * pochu is preparing dinner as well, I'll be here intermitently
19:45:44 <nthykier> pochu: no worries, I think we are about to end (~15 minutes left)
19:45:50 <nthykier> (at most...)
19:46:19 <nthykier> I do not think I have any more to freeze progress
19:46:24 <kibi> can't really commit to doing more doc work at the moment
19:46:43 <kibi> (as opposed to fixing code issues)
19:47:18 <elbrus> kibi: please go fix code ;)
19:47:26 <nthykier> speaking of doc work - do we have any idea where the installation guide is (release-readiness-wise)?
19:47:47 <kibi> I don't
19:48:14 <elbrus> and you didn't ask Holger?
19:48:21 <nthykier> #info Possible blind spot being the installation guide
19:48:21 <elbrus> or didn't get a response?
19:48:33 <elbrus> want me to ask/chase him?
19:49:16 <nthykier> yes please :)
19:49:31 * elbrus was asking kibi... :)
19:49:49 <elbrus> as the wiki says he would do it...
19:51:01 <adsb> pochu: :P
19:53:44 <kibi> elbrus: please do
19:54:03 <nthykier> #action elbrus will follow up on the progress of the installation guide
19:54:05 <nthykier> Thanks :)
19:54:10 <elbrus> ack
19:54:13 <kibi> apparently I managed to uncover enough other issues to keep me busy, sorry about that
19:54:23 <nthykier> I think we are out of time, so I will move to AOB
19:54:33 <nthykier> #topic AOB
19:54:37 <nthykier> Any AOB?
19:54:51 <elbrus> two notes I like to make
19:55:22 <elbrus> 1: I am glad I could use autopkgtest on spu to spot a regression before the point release
19:55:37 <nthykier> awesome :)
19:55:48 <elbrus> so I'll think about how to make that more automated
19:56:08 <nthykier> SGTM :)
19:56:19 <elbrus> 2: I'm playing with arm64 on packet.net
19:56:44 <elbrus> depending on how that goes, that should be our next arch for autopkgtestng
19:56:50 <elbrus> autopkgtesting*
19:57:01 <nthykier> Sounds good as well :)
19:57:24 <elbrus> that's it from my side
19:57:26 * nthykier would be very excited to have more architectures in autopkgtests
19:57:30 <nthykier> Thanks for sharing :)
19:57:48 <elbrus> needs a couple of improvements to britney1 and 2
19:57:49 <nthykier> #topic Next meeting
19:57:53 <nthykier> #undo
19:57:53 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x1014150>
19:58:15 <nthykier> (sorry, thought you were done)
19:58:38 <elbrus> I can elaborate, but I can also quiet :)
19:58:41 <elbrus> quite
19:58:47 <elbrus> quit
19:58:52 <nthykier> Ack, I will look forward to the patches :D
19:59:08 <elbrus> I'll need to discuss the design
19:59:15 <nthykier> I will move on as we are out of time :)
19:59:23 <elbrus> ack
19:59:32 <nthykier> (happy to discuss it later though)
19:59:37 <nthykier> #topic Next meeting
19:59:37 <elbrus> :)
19:59:52 <nthykier> Next meeting is (assuming no changes) ...
20:00:12 <nthykier> #info Next meeting is 22nd May at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
20:00:15 <nthykier> #endmeeting