19:00:32 <elbrus> #startmeeting
19:00:32 <MeetBot> Meeting started Wed Apr 22 19:00:32 2020 UTC.  The chair is elbrus. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:32 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:45 <elbrus> #topic Admin
19:00:55 <elbrus> #info Previous minutes: http://meetbot.debian.net/debian-release/2020/debian-release.2020-02-26-19.02.html
19:01:06 <elbrus> #info elbrus had two actions for more release members; both done
19:01:16 <elbrus> #info ginggs had action for a patch to britney
19:01:25 * elbrus didn't see it materialize
19:01:29 <elbrus> ;)
19:01:47 <elbrus> #info elbrus had an action for architecture release
19:01:52 <elbrus> not done yet
19:02:00 <elbrus> #topic Welcome to Sebastinas and noahm
19:02:12 <noahm> hi!
19:02:12 <elbrus> Sebastinas, noahm, welcome to the team
19:02:37 <noahm> thank you
19:02:46 <elbrus> are you getting up to speed already?
19:03:03 * elbrus noticed transition bugs being acked by Sebastinas already
19:03:56 <elbrus> this is an open invitation to you for help request to get started
19:04:19 <Sebastinas> Yes, I got some small transitions done (libdvdread for example), some others are getting ready to migrate (poco)
19:04:33 <Sebastinas> pochu helped me to set up britney tests runs
19:04:47 <elbrus> awesome
19:05:15 <noahm> I haven't been particularly active yet. Hope to change that real soon now...
19:05:33 <elbrus> you have been watching the pu bugs already?
19:05:41 <noahm> yep
19:05:51 <elbrus> good
19:06:01 <elbrus> anything else for now?
19:06:38 <elbrus> #topic Transitions
19:07:07 <elbrus> any news on that front worth discussing?
19:07:37 * elbrus noticed ruby2.5-rm is nearly down, is anybody finishing that up?
19:07:52 <elbrus> done*
19:08:23 <ginggs> i'm not sure what needs to be done with src:linux in the python3.7-rm tracker
19:09:18 <Sebastinas> Filed some bugs for builds failures related to ruby2.5-rm and python3.7-rm
19:09:24 <elbrus> we had multiple new linux versions, is it hardcoded somewhere?
19:09:33 <elbrus> great
19:11:04 <elbrus> ginggs: I guess no clues here
19:11:19 <elbrus> anybody has any clue why ldc isn't finishing?
19:11:38 * elbrus tried several combinations of hints, but didn't seem to strike the right corde
19:11:58 <elbrus> my last hint is in my history if anybody wants to look
19:12:53 <elbrus> if no further comments, shall we move on?
19:13:25 <elbrus> #topic rc_policy status
19:13:29 <elbrus> https://release.debian.org/bullseye/rc_policy.txt
19:13:45 <elbrus> I reviewed that page a while ago
19:14:01 <elbrus> I wondered if we can remove the disclaimer at the top
19:14:19 <elbrus> or if we want more review
19:14:58 * elbrus hopes the policy editors will start maintaining a summary which we can reference with only our deltas
19:15:22 <Sebastinas> What's the status of autopkgtests regressions on arm64?
19:15:28 <Sebastinas> Are the also considered rc?
19:15:34 <elbrus> that's the next topic ;)
19:15:36 <Sebastinas> The policy only mentions amd64
19:16:18 <elbrus> we can discuss that now
19:16:34 <elbrus> I think we're about ready to do that
19:16:43 <elbrus> there's minor issues
19:17:13 <elbrus> like britney scheduling and blocking in some case where that's not appropriate
19:17:32 <elbrus> but in my opinion thats not RC in the package obviously
19:18:28 <elbrus> Sebastinas: we added amd64 explicitely when we enable arm64 to avoid those tests being considered RC in case of issues
19:18:39 <elbrus> but I think we can add it now
19:19:12 <elbrus> objections?
19:20:09 <ginggs> no
19:20:50 <elbrus> #agreed arm64 autopkgtest failures are now also considered RC
19:21:08 <elbrus> shall I remove the disclaimer at the head of rc_policy?
19:21:40 <noahm> I'll review rc_policy, but you should remove the disclaimer anyway.
19:21:49 <noahm> Doubt I will have a lot of feedback on it.
19:22:06 <elbrus> noahm: great
19:22:18 <elbrus> you know where the source lives?
19:22:35 <elbrus> https://salsa.debian.org/release-team/release.debian.org/
19:22:57 <noahm> I know now. ;)
19:23:20 <elbrus> #action elbrus removes the copy disclaimer of the rc_policy
19:23:45 <elbrus> #action noahm review rc_policy
19:23:48 <elbrus> ;)
19:24:08 <elbrus> #topic state of out-of-sync issues
19:24:46 <elbrus> in our bits from February we declared out-of-sync packages as being RC buggy in testing
19:24:56 <elbrus> I've been filing quite some bugs
19:25:09 <elbrus> lots of fixes in the mean time
19:25:27 <elbrus> currently 32 out-of-sync packages with bugs
19:25:32 <elbrus> https://udd.debian.org/dev/bugs.cgi?release=bullseye&merged=ign&fnewerval=7&flastmodval=7&fusertag=only&fusertagtag=out-of-sync&fusertaguser=release.debian.org%40packages.debian.org&rc=1&ckeypackage=1&clastupload=1&cautormtime=1&sortby=lastupload_s&sorto=asc&format=html#results
19:25:40 <elbrus> (load time is long)
19:25:56 <elbrus> problem of course is going to be key packages
19:26:04 <elbrus> as those aren't going to be removed
19:26:51 <elbrus> any ideas at this moment how to handle those, or should we just keep them as regular RC bugs?
19:29:07 <elbrus> just for you're info, I NMU arch:all packages that are *only* blocked on the buildd issue
19:29:24 <elbrus> and binNMU arch:<any> blocks
19:29:31 <elbrus> before filing bugs
19:29:43 <mapreri> well, src:check could just be revert the previous version
19:30:36 <elbrus> mapreri: good idea
19:30:49 * elbrus will check the others for a similar solution
19:30:58 <mapreri> src:libhibernate-validator-java I'd ping ebourg on IRC and otherwise nag in #-java, that ought to not be too exceptional
19:31:14 <Sebastinas> I can deal with libsoxr
19:31:19 <mapreri> src:libsoxr is .. cbmuser could you please look at that…
19:31:19 <Sebastinas> That also needs to be reverted
19:31:39 <mapreri> lobsoxr could be reverted, but it would be great if cbmuser or somebody could debug that
19:32:19 <Sebastinas> Don't care much for ports "fixes" if it breaks release arches, to be honest.
19:32:41 <elbrus> ack
19:32:43 <mapreri> elbrus: was src:pillow hold back by autopkgtest regression?
19:33:05 <mapreri> it's not clear to me looking quickly now
19:33:21 <elbrus> I'm not sure; I don't think so
19:33:29 <elbrus> uninstallability I think
19:33:56 <elbrus> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=955776
19:33:59 <mapreri> it's "not considered", so installability is not yet counted
19:34:04 <elbrus> there's info in the "blocks" section
19:34:25 <mapreri> ok, that's more convuluted
19:34:44 <mapreri> but overall, that one looks like the only "real" key package having real troubles, the other should be doable in due time
19:35:50 <elbrus> any help welcome :)
19:36:09 <elbrus> (thanks mapreri for jumping in)
19:36:25 <elbrus> # AOB
19:36:33 <elbrus> #topic AOB
19:37:01 <mapreri> mh ok, I see src:pillow is taken care by those blocks, perhaps that's enough given the autorm timer
19:37:17 <mapreri> oh, I forgot emacs.  that's.. I don't care :P
19:37:27 <elbrus> just a note: I removed quite a bit of rust recently to fix the out-of-sync mess in that ecosystem
19:37:42 <mapreri> (seriously, that's a FTBFS, I can't help with that)
19:37:58 <elbrus> that seems to have been well received in the rust team (as much could migrate after the removal)
19:38:08 <noahm> emacs looks like it has a fix upstream. just needs an upload...
19:38:17 <elbrus> I had some discussions with members of the rust team
19:38:20 <mapreri> noahm: then, everything's good
19:38:24 <elbrus> I hope things will improve
19:39:18 <elbrus> anybody anything else?
19:39:52 * elbrus shuts up for some minutes to give people time to finish :)
19:42:34 <elbrus> shall we close?
19:42:50 <elbrus> #topic Next meeting
19:43:01 <elbrus> #info Next meeting is 27th May at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
19:43:15 <elbrus> thanks everybody
19:43:20 <elbrus> #endmeeting