20:12:45 <elbrus> #startmeeting
20:12:45 <MeetBot> Meeting started Wed Jan 25 20:12:45 2023 UTC.  The chair is elbrus. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:12:45 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:12:52 <elbrus> #topic Admin
20:13:01 <elbrus> #info Previous minutes: http://meetbot.debian.net/debian-release/2022/debian-release.2022-10-26-18.59.html
20:13:12 <elbrus> #info elbrus had an action to check if he can patch udd to special case b-d-i in case of only -doc as arch:all
20:13:31 <elbrus> carried over from previous time; I think I'll just drop the idea for now
20:13:54 <elbrus> #info <somebody> had an action to mention testing upgrade in the next bits
20:13:57 <elbrus> done
20:14:05 <elbrus> #info Sebastinas had an action to reply to the branch protection thread
20:14:17 * elbrus recollects that one was done
20:14:36 <Sebastinas> Yes
20:14:52 <elbrus> great; always nice when actions are done :)
20:14:53 <Sebastinas> (we should revisit that early in trixie)
20:14:56 <elbrus> indeed
20:15:08 <elbrus> #topic Transitions & the freeze
20:15:18 <elbrus> php is done
20:15:25 <elbrus> horde fixes are flowing in
20:15:44 <Sebastinas> tiff will be done with python3.11-default
20:16:05 <Sebastinas> openimageio as well
20:16:39 <Sebastinas> I've added a block for the uncoordinated libkscreen transition that causes FTBFS in reverse dependencies
20:16:55 <elbrus> ack
20:17:55 <elbrus> I guess llvm 13 removal is basically blocked by bug #1017663, do we want to push that more?
20:17:56 <Sebastinas> And once libreoffice is fixed, python3.11-default should also have no other blockers.
20:18:10 <Sebastinas> I'd prefer to not touch ghc at this point.
20:18:17 * elbrus agrees
20:18:24 <Sebastinas> Last time fixing issues in haskell land took ~2 months
20:18:44 <elbrus> ginggs: is the python3-defaults situation described above also how you see it?
20:20:16 <elbrus> so only one still coming our way it webkit2gtk?
20:20:48 <Sebastinas> I expect that to happen, yes.
20:20:57 <Sebastinas> I haven't check the shibboleth-sp bug yet.
20:21:07 <elbrus> ack
20:21:33 <ginggs> o/
20:22:03 <ginggs> i only got highlighted now
20:22:08 <elbrus> oops, sorry
20:22:20 <elbrus> you proposed a delayed meeting ;)
20:22:39 <ginggs> np :)
20:24:20 <elbrus> so, ginggs, you recognize the python3-defaults situation described by Sebastinas?
20:24:23 <ginggs> yeah, i think the above describes python3-defaults
20:24:27 <elbrus> great
20:24:46 <elbrus> then let's go to the next topic I think?
20:24:47 <ginggs> nvidia-cuda-toolkit was an implicit dependency
20:25:02 <ginggs> but it seem it is aready fixed, might only need aging
20:25:20 <elbrus> might as well wait for libreoffice first?
20:25:43 <elbrus> unless that's taking too long...
20:26:26 <elbrus> #topic current status of bookworm
20:26:49 <elbrus> my view (or actually ivodd's) is here: https://udd.debian.org/dev/cgi-bin/rcblog7.cgi
20:27:13 <elbrus> looks better and better, but I haven't checked up on the key packages bugs lately
20:27:41 <elbrus> there's quite a bunch on grub, which seems to need help as most of those bugs are old already
20:28:04 <elbrus> otherwise I think most older bugs have seen some sort of progress
20:28:50 * elbrus focusses most on "rest: .. key.. 131"
20:29:30 <elbrus> did anybody else inspect the bugs list?
20:29:40 <Sebastinas> Not yet.
20:30:02 <Sebastinas> But with the transitions now finishing, I'll try to keep an eye on the list.
20:30:28 <elbrus> \o/
20:31:25 <elbrus> #topic current status of d-i
20:31:33 * elbrus summons kibi ;)
20:31:49 <elbrus> if he wants to share an insight
20:32:06 <elbrus> I've seen a lot of work going on in #d-cd
20:34:41 <elbrus> well, maybe better if we let him work on it :)
20:35:00 <elbrus> next topic is a nasty one....
20:35:15 <elbrus> #topic architectures
20:35:27 <elbrus> I think we suck at this
20:35:59 <elbrus> and I really like to start the trixie cycle with most architecture "tier 2ish"
20:36:11 <elbrus> but I don't know
20:36:57 <Sebastinas> We do. But at least one will be easy. Without a second  buildd, we need to drop ppc64el
20:37:26 <elbrus> but that second buildd is "a matter of installing" right? waiting for DSA...
20:38:09 <Sebastinas> I'll add a todo to check with them in a week or two.
20:38:53 <elbrus> #action: Sebastinas to check with DSA on the status of ppc64el
20:38:54 * kibi quietly appears
20:39:05 <elbrus> o/
20:40:20 <elbrus> do we agree on having all architectures (pending ppc64el) for bookworm then, for lack of better decision making earlier?
20:41:07 <ginggs> aye
20:41:14 <kibi> no objections here, but you folks probably know much better
20:41:53 <Sebastinas> Also no objection.
20:43:10 <elbrus> #agreed: carry bullseye architectures for bookworm, assuming we accept the ppc64el second buildd installation situation
20:43:34 <elbrus> kibi, do you want to share anything on d-i here? (no need, just, if you want to)
20:43:40 <kibi> happy to
20:44:19 <elbrus> #topic current status of d-i
20:44:22 <kibi> lots of time spend selecting packages to move to non-free-firmware (n-f-f later on), and adjusting d-i components to account for that change
20:44:53 <elbrus> so you have an overview for yourself now?
20:45:01 <elbrus> that's great news
20:45:17 <kibi> that means apt-setup, hw-detect, and debian-cd mostly; currently trying to restrict combinatorics regarding firmare-related use cases
20:45:55 <kibi> I think I'm >< close to being ready for a new Alpha/RC; even if we have more stuff to iron out before r0.
20:46:23 <kibi> heads-up: I'm not sure I'll end up implement a tri-choice for firmware: something like yes/ask/no
20:46:51 <kibi> the “ask” part would probably introduce new screens (needing translations with close to no time), so I'll probably implement just yes/no (probably defaulting to yes)
20:46:55 * elbrus can live with yes/no I think
20:47:25 <kibi> so that the official images (built with main/n-f-f) can behave as main/n-f-f or main only for users who would prefer that
20:47:44 <elbrus> also great news
20:48:02 <kibi> #1029543 has some gory details about keeping or not support for loading firmware from external storage (I think we'll keep it conditionally)
20:48:41 <kibi> rather brainstorming with myself so far, but I plan to publish the next release with some feature cut out, so that people can document what they use/need, so that we know where to draw the line
20:48:55 <elbrus> ack
20:49:15 <kibi> I'd like to spend more time on other topics in d-i, but that should fit during the soft-free to hard-freeze period, and not be crazy release-wise
20:49:48 <kibi> finally, we still need packages like firmware-nonfree to move to nff before we can build images that are reasonably useful, but I've got patches around for that
20:50:17 <kibi> plus things like keeping track of packages getting moved, migrating to testing (source+binary vs. NEW, source-only vs. britney, etc.)
20:50:56 <kibi> no timing yet, but I suspect we might have a release within a week, and we'll see how mad or happy users are, and how much absolutely needs changing before r0
20:51:02 <elbrus> you can give me package names you need and I can help looking
20:51:24 <kibi> TL;DR: don't think d-i (at least firmware-wise) will get in the way of the current timeline.
20:51:47 <elbrus> hurray
20:52:25 <kibi> thanks, but that part should be easy, I just need to get all my ducks in a row (bunch of infra stuff involved, like dep11 stuff, debian-cd configs, etc.), and tracking packages moving to nff is the easiest part I think
20:53:01 <kibi> that's all for me unless there are questions
20:53:25 <Sebastinas> Not from my side. Thanks for all the work on d-i.
20:53:27 <elbrus> clear enough from my side
20:53:37 <elbrus> and indeed, thanks for the work
20:53:57 <elbrus> #topic AOB
20:53:59 <kibi> (and debian-cd because Sledge wanted me to have more fun)
20:54:50 <ginggs> i have a quick one
20:55:43 <ginggs> elbrus: i've been meaning to ask for the out-of-sync period to be reduced from 60 to 30 days
20:55:56 <ginggs> elbrus: how would that affect your workload?
20:56:22 <ginggs> i'm suspecting not much
20:56:24 * elbrus expects not a lot but hasn't checked
20:56:58 <elbrus> and by now I think it *could* be semi-automatic, instead of the now scripted help
20:57:13 <ginggs> yeah, if something's been ignore for 30 days it will likely be ignored for 60
20:57:22 <elbrus> but, I'd rather do that *after* the release, and not now
20:57:31 <ginggs> elbrus: your call
20:57:55 <ginggs> we could agree to implent it at trixie opening
20:58:05 <elbrus> because once *we* block packages, than I'll stop filing altogether for this reason
20:59:51 <elbrus> Sebastinas: jcristau: what do you think of the reduction of 60 to 30 days for out-of-syncness?
21:00:08 <elbrus> (asking jcristau because he was a huge fan when I started filing the bugs)
21:00:57 <Sebastinas> Fine for me (I also like those bugs)
21:01:32 <elbrus> than I propose we do that after the trixie release unless another release team member objects
21:02:04 <elbrus> #agreed: out-of-sync age reduction from 60 to 30 days
21:02:10 <ginggs> \o/
21:02:40 <elbrus> AOB?
21:03:12 <ginggs> not from me
21:03:14 <elbrus> maybe me: please think about things that need mentioning in the release notes
21:03:45 <elbrus> it's awefully quiet in that area
21:03:45 <kibi> oh right
21:04:13 <kibi> adding an archive area doesn't quite happen enough, and as noted by gwolf on debian-project@, lots of things don't know about it yet
21:04:14 <Sebastinas> We'll need to mention merge-/usr there.
21:04:57 <kibi> it's probable that we'll have to keep adding support for it in various places; might not affect users (or not badly), but at least documentation wise, I expect bunch of chances in the installation guide, release notes, wiki.d.o, etc.
21:05:05 <kibi> not sure how much of that effort I'll be able to drive
21:06:08 <elbrus> #action: elbrus to start point in the release notes on items mentioned in the meeting
21:06:55 <elbrus> we're done?
21:07:09 <Sebastinas> Nothing else from my side
21:07:16 <Sebastinas> (sorry, still unpacking from the bruessels trip)
21:07:21 <elbrus> #topic Next meeting
21:07:32 <elbrus> #info Next meeting is 22 February at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
21:07:39 <elbrus> #endmeeting