19:01:35 <elbrus> #startmeeting
19:01:35 <MeetBot> Meeting started Wed Feb 22 19:01:35 2023 UTC.  The chair is elbrus. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:35 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:01:52 <elbrus> #topic Admin
19:02:01 <elbrus> #info Previous minutes: http://meetbot.debian.net/debian-release/2023/debian-release.2023-01-25-20.12.html
19:02:10 <elbrus> #info Sebastinas had an action to check with DSA on the status of ppc64el
19:04:58 <elbrus> I guess Sebastinas is gone... ginggs are you around now....
19:05:03 <ginggs> o/
19:05:28 <elbrus> ok, let's see if this is still useful
19:05:45 <elbrus> action for Sebastinas stays open I guess
19:05:49 <elbrus> #info elbrus had an action to start points in the release notes on items mentioned in the meeting
19:06:06 <elbrus> propably some happened, but I need to check for completeness
19:06:17 <elbrus> *probably
19:06:28 <elbrus> #topic Transitions
19:06:44 <elbrus> shouldn't be any real ones now, are there?
19:07:18 <elbrus> python3.10 got removed from bookworm, so even that one can be considered closed?
19:07:34 <ginggs> yes
19:07:54 <elbrus> for the auto-equinox-framework-rm I filed a bug recently
19:08:02 <ginggs> there is also Bug#1031587:  Handling of the request-tracker4 -> request-tracker5 transition in bookworm
19:08:18 <elbrus> #1031686
19:08:44 <elbrus> I didn't look carefully into that rt bug yet
19:08:52 <elbrus> what's the status?
19:10:14 <elbrus> mostly maintainers filed #1030749 to not release with RT4
19:10:30 <ginggs> request-tracker5 is already in testing, since july 2022
19:11:20 <ginggs> there are a couple of reverse dependencies of request-tracker4 that need switching to 5
19:12:51 <elbrus> would anything be pulled from testing (as in, can't finish) if we go for the transition now?
19:13:26 <elbrus> "the fact that this still required so much work" doesn't sound awesome
19:13:41 <elbrus> a week sounds good though
19:14:00 <elbrus> it would seriously help security I understand?
19:15:11 <elbrus> if Sebastinas also agrees, I'd say we should go ahead
19:16:17 <elbrus> pochu: you commented out of band, do you also agree?
19:17:58 <ginggs> "would anything be pulled from testing (as in, can't finish) if we go for the transition now?" i don't know
19:19:18 <elbrus> let's follow up in the bug and not force it here
19:20:48 <elbrus> do we want to discuss e2fsprogs now?
19:21:26 <Sebastinas> Sorry, had to change. I'm back now.
19:21:39 <elbrus> ack
19:21:53 <elbrus> we discussed the transitions
19:22:00 <kibi> not sure I have an opinion on this (now that the immediate d-i vs. testing issues are gone), except it feels very late in the release cycle to introduce this change
19:22:29 <elbrus> I have exactly that feeling
19:22:32 <Sebastinas> Not to happy that rt4 -> rt5 popped up, but as rt5 is already in testing we could just let them complete it.
19:23:17 <Sebastinas> ACK rt e2fsprogs.
19:23:39 <elbrus> #topic e2fsprogs bug #1031325
19:23:46 <Sebastinas> There was some progress on the RC bugs.
19:24:04 <elbrus> messy meeting :P
19:24:06 <Sebastinas> But we still don't know if we have a complete picture of the fallout
19:24:09 <Sebastinas> (sorry)
19:24:20 <elbrus> my fault
19:24:43 <elbrus> which RC bugs you refer to? the e2fsprogs ones?
19:24:53 <Sebastinas> yes, vmdb2 and co
19:25:00 <Sebastinas> grml-debootstrap and some others have been fixed.
19:26:17 <ginggs> on the one hand, if we do let e2fsprogs into testing, we may expose (and fix) more fallout
19:26:40 <ginggs> we don't get that by holding it in unstable
19:27:03 <elbrus> if we don't let it in, we don't have to fix the fallout
19:27:13 <elbrus> we can do that in trixie
19:27:27 <ginggs> yeah, they can just revert enabling that feature
19:27:48 <elbrus> which I would totally support, I don't want to hold back progress
19:28:23 <kibi> Ted insists others are lazy ass, but then that feature gets suddenly turned on when the freeze has started.
19:29:05 <kibi> If I were to make a call on this, I'd probably consider this bad timing, please try again once the freeze is lifted…
19:29:15 <elbrus> I'm not totally impressed by the quality of the communication in that issue :)
19:29:37 <elbrus> I'm with kibi
19:29:38 <kibi> (again, I don't have a strong feeling on this, either way seem to suck differently but equally to me)
19:29:51 <elbrus> on that too
19:31:36 <elbrus> Sebastinas, ginggs: what you say?
19:33:35 <Sebastinas> I tend to prefer to defer the change to trixie.
19:34:22 <Sebastinas> I would have felt more confident with it going ahead if Ted actually helped with identifying and fixing issues, but the discusson on the bug is a mess.
19:35:24 <ginggs> yeah, let's ask ted to revert
19:35:32 <elbrus> #agreed we'll ask the e2progs maintainer to revert the metadata_csum_seed feature
19:36:48 <elbrus> #topic unblock request
19:37:35 <elbrus> anything we want to discuss now?
19:38:07 <elbrus> none sticks out particularly
19:38:58 <Sebastinas> Has the mariadb situation settled?
19:39:17 <kibi> there was some mention of it earlier today
19:39:19 <elbrus> I expect it to migrate, yes
19:39:25 <Sebastinas> Okay, good.
19:40:09 <Sebastinas> Thanks for handling that.
19:42:12 <elbrus> #topic current status of bookworm
19:42:33 <elbrus> still seems to be going great
19:44:36 <elbrus> did anybody notice blocker bugs?
19:44:51 <elbrus> I marked two of them but no others are marked
19:45:00 <kibi> I didn't look but then I didn't encounter any on my little journey
19:45:06 <Sebastinas> I think we should get firefox-esr resolved somehow.
19:45:28 <Sebastinas> We should release with a browser as long as the security team is happy to support it as is.
19:45:42 <elbrus> we have chromium
19:45:59 <elbrus> but I think firefox-esr is better known and more popular
19:46:50 <kibi> it would definitely suck to release with it :(
19:47:05 <kibi> ahah long day typos… *without*
19:47:11 <elbrus> :)
19:48:49 <Sebastinas> Speaking of chromium, it's causing regressions.
19:48:52 <Sebastinas> I'll file a bug later.
19:49:01 <Sebastinas> autopkgtest regressions
19:49:23 <elbrus> I was in dubio earlier when looking at firefox-esr bugs, the package definitely could do with more maintenance/maintainers
19:49:44 <elbrus> that's why I left them as is
19:49:50 <kibi> I still remember when Mike tried orphaning it…
19:50:34 <elbrus> but we could mark the remaining one as bookworm-can-defer
19:50:37 <waldi> does firefox have more problems then "does not longer work on 32bit"?
19:50:46 <Sebastinas> waldi: No.
19:51:51 <Sebastinas> Some bug triage would help
19:51:59 <waldi> yeah, i see
19:54:00 <elbrus> anything else on the topic?
19:54:56 <Sebastinas> There is some stuff to clean up (old gcc versions, old vtk versions). But I hope autoremovals will take care of most of those.
19:55:20 <kibi> d-i will keep the old vtk version, sorry
19:55:25 <kibi> not enough time in a day to fix all the things
19:55:31 <elbrus> do you have an overview? or do you just go over the RC bugs?
19:55:36 <Sebastinas> vtk7?
19:56:04 <kibi> oh sorry, confusing that with vt*e*…
19:56:40 <Sebastinas> elbrus: Mostly going of the list of RC bugs.
19:56:48 <elbrus> ack, that's what I do too
19:57:19 <elbrus> I think some "should not be part of bookworm" we'll need to defer
19:57:30 <elbrus> e.g. #956423
19:57:50 <elbrus> hmm, I thought there were more
19:58:41 <elbrus> related... #1002901
19:59:22 <elbrus> but I think it's becoming to late to really solve those issues (because nobody seems to be really working on them
20:00:19 <elbrus> Sebastinas: IIRC bug #918984 was yours
20:00:31 <elbrus> how strong do you feel about that?
20:02:29 <Sebastinas> We'll need to defer that one.
20:02:44 <Sebastinas> (I totally forgot about it)
20:02:54 <elbrus> ack
20:03:40 <elbrus> anything else on the status of bookworm?
20:03:57 <Sebastinas> Not from my side
20:04:10 <kibi> quick update on the d-i side maybe?
20:04:30 <elbrus> #topic current status of d-i
20:04:43 <kibi> we have a release \o/ we have absolutely zero feedback about it /o\
20:05:02 <elbrus> that means it has no issues, right?
20:05:24 <kibi> the first part is great news though: all the infra bits seem to be in place: firmware packages (we care about) moved to n-f-f, the archive knows about it, buildds too, dep11 stuff too, debian-cd updated, and all /seems/ well
20:05:36 <kibi> no telemetry so your guess is as good as mine :)
20:05:53 <elbrus> I'm happy to hear this
20:06:04 <kibi> lack of support on packages.d.o caused a lot of wondering user-side, but at least now that's fixed too…
20:06:48 <kibi> TL;DR: no absolute confirmation users are testing it/liking it (or not), but at least it looked good to Sledge, amacater_ and me (bunch of tests/iterations last weekend).
20:07:15 <elbrus> the backlog was so long I decided to not read it ;)
20:07:28 <kibi> happy to take questions, but that's basically the big picture
20:07:29 <elbrus> #d-cd
20:07:38 <elbrus> thanks for the update
20:07:54 <kibi> wise choice… scrolling back up to check some thing, I was boring myself to death
20:08:04 <elbrus> LOL
20:08:06 <kibi> no worries
20:08:48 <elbrus> I guess that's it for now, right?
20:09:09 <kibi> sure
20:09:38 <elbrus> thanks again for all you work on it, much appreciated
20:09:55 <elbrus> *your
20:10:07 <elbrus> #topic AOB
20:10:52 <ginggs> nothing from me
20:11:07 <elbrus> Sebastinas just did his action to ask DSA
20:11:59 <kibi> nothing from me either
20:12:44 <elbrus> don't forget to file your ideas for the Release Notes
20:13:14 <elbrus> #topic Next meeting
20:13:15 <kibi> been there, done that, out of ideas \o/
20:13:25 <elbrus> #info Next meeting is 22 March at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
20:13:32 <elbrus> #endmeeting