18:59:49 <elbrus> #startmeeting
18:59:49 <MeetBot> Meeting started Wed Apr 26 18:59:49 2023 UTC.  The chair is elbrus. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:59:49 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:03 <elbrus> #topic Admin
19:00:12 <elbrus> #info Previous minutes: http://meetbot.debian.net/debian-release/2023/debian-release.2023-03-22-19.02.html
19:00:44 <elbrus> #info elbrus had an action to check on ruby-maxitest Depends
19:01:06 <elbrus> discussion still ongoing in #d-ruby, maybe we need to fix ben/dose
19:01:44 <elbrus> as it seems nothing is broken or really bad
19:01:57 <elbrus> #topic Transitions
19:02:41 <elbrus> without Sebastinas who typically is on to this one all I can say I think nothing is going on now (as it should)
19:03:47 <elbrus> does anybody know differently?
19:03:56 <kibi> not me :)
19:03:57 <ginggs> same here
19:04:06 <elbrus> good
19:04:10 <elbrus> #topic bit from the release team
19:04:20 <elbrus> I drafted something: https://paste.debian.net/hidden/c62aad62/
19:04:26 <elbrus> basically
19:04:30 <elbrus> * release date
19:04:40 <elbrus> * full freeze date
19:04:58 <elbrus> * ultimate date for unblock requests
19:05:23 <elbrus> I was wondering if I should make it longer and mention release-notes
19:05:49 <elbrus> and more things like in https://lists.debian.org/debian-devel-announce/2021/05/msg00000.html
19:05:51 <kibi> everything looks good; the explicit absolute last moment mention is a nice touch
19:06:42 <kibi> I think both upgrade testing and release notes section would make sense
19:06:58 <elbrus> OK
19:07:02 <kibi> that doesn't make the mail much longer, and could be a nice reminder for some people?
19:07:16 <elbrus> that was my thinking too
19:08:05 <elbrus> anything I missed I should mention?
19:08:53 <kibi> I'm not sure how useful RC bug count would be
19:08:57 <ansgar> elbrus: I don't understand [3].
19:09:09 <kibi> (I'm still glancing at the previous mail)
19:09:56 <elbrus> ansgar: I tried to explain what I meant with "ready to migrate"
19:09:59 <kibi> ah, right, I didn't check all the footnotes
19:10:27 <elbrus> because I *don't* mean it needs to have aged completely
19:12:02 <elbrus> but yes, that footnote needs improvement
19:12:11 <ansgar> elbrus: "The testing migration excuses must not mention *blocked*. It is acceptable if the required age has not been reached at this time."
19:12:53 <elbrus> I wonder why I thought that not mentioning "blocked" would work, I like the second sentence though
19:13:13 * kibi checked all years are indeed 202_3_.
19:13:19 <ansgar> Or "*blocked* (due to dependency issues, CI or piuparts failures or other reasons)"
19:13:20 <elbrus> thanks kibi
19:13:28 * h01ger blinks
19:13:54 <elbrus> indeed, that's probably what I mean
19:14:26 <elbrus> #action elbrus incorporate suggests for bits and send them out
19:15:13 <elbrus> suggestions even (I got fooled by our control syntax)
19:15:43 <elbrus> #topic unblock request
19:16:02 <kibi> (I like how bit and request are singular)
19:16:34 <elbrus> we have a bit of backlog, but things are going OK I think as long as the rate doesn't suddenly increase
19:17:41 <elbrus> kibi: are there more things you need for d-i?
19:17:46 <kibi> that'd be https://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=unblock;users=release.debian.org@packages.debian.org right?
19:17:53 <kibi> (BTS is still loading…)
19:17:57 <elbrus> I take it you'll let us know
19:18:09 <elbrus> I like udd better: https://udd.debian.org/dev/cgi-bin/unblock.cgi?moreinfo=ign&merged=ign&fnewerval=7&sortby=id&sorto=asc&chints=1&ctags=1&crttags=1
19:18:14 <kibi> ta
19:18:30 <elbrus> because that also shows the current excuses
19:18:56 <elbrus> it's made by ivodd, so I can't update testing == bullseye
19:18:57 <kibi> right now, I'm lacking both tpu uploads I approved; you already took care of grub2* (giving me latitude to get it when I need it), which was very nice.
19:19:16 <elbrus> the uploads are in, right?
19:19:35 <elbrus> as you ack'ed them, I assume you'll unblock them
19:20:02 <kibi> oh, I was so worried about whether to deal with the review I didn't spot the uploads happened already
19:20:49 <kibi> anyway, regarding requests, those + grub2 were the ones I had in mind; other d-i udebs should be a no-brainer as soon as I turn 'd' into some auto-l10n-hinter for d-i packages.
19:21:06 <kibi> I'll let you know if something less obvious come my way :)
19:21:12 <elbrus> ack
19:21:33 <elbrus> ginggs: you're fine too with reviews? anything particular?
19:21:47 <kibi> and yes, the amount of requests doesn't look crazy to me right now
19:22:06 <ginggs> elbrus: yes fine here
19:22:21 <kibi> ah, and current plan is linux/testing for RC 2, linux/unstable later
19:22:37 <kibi> (unless stuff happens, RC 2 is postponed, in which case I'll revisit)
19:22:52 <elbrus> ack
19:23:19 <elbrus> next topic?
19:23:28 <kibi> lgtm
19:23:50 <elbrus> #topic current status of bookworm
19:24:12 <elbrus> There are 143 bugs affecting bookworm, 83 in key packages
19:24:23 <elbrus> (https://udd.debian.org/dev/cgi-bin/rcblog7.cgi)
19:25:11 <elbrus> there are  still about 27 (rest) + 7 (with patch) key package bugs on the radar
19:25:39 <elbrus> nothing crazy jumping at me
19:26:02 <kibi> I killed the RC on haveged taggart try to add to that list ;p
19:26:04 <elbrus> gpac will be removed from testing
19:26:26 <elbrus> kibi: always nice to do
19:27:22 <elbrus> one thing worth discussing maybe: it seems we bumped the i386 baseline
19:28:14 <elbrus> I think we should acknowledge it, document it in the release notes and move on
19:28:24 <elbrus> bug #973414
19:28:25 <kibi> I wouldn't have said better
19:28:39 <kibi> oh, this isn't geode this time
19:28:59 <kibi> (of course yes it is :D)
19:29:14 <elbrus> yes, geode
19:29:53 <f_g> I did try to get some feedback from Sebastinas whether that is important enough to warrant a last minute fix, but I guess it got lost in the noise somewhere (and it was rather late in the cycle in my opinion anyway)
19:30:02 <elbrus> of course the challenge will be to figure out what the baseline now is :(
19:30:30 <elbrus> f_g: fixing rustc and rebuild a lot feels way too late indeed
19:31:04 <elbrus> it's a shame of course, but we considered dropping i386 altogether
19:31:23 <f_g> indeed. if there is some action required on our (rust-team/rustc maintainers) end just add it to the bug, I just accidentally stumbled in here right now and have to go ;)
19:31:44 <elbrus> if we acknowledge, that bug is no longer RC
19:32:21 <elbrus> ginggs: what you say?
19:32:35 <elbrus> (maybe need time to check, that's fine too)
19:33:28 <ginggs> i did read it before, i agree we acknowledge, release note it, move on
19:33:47 <elbrus> ack
19:34:13 <elbrus> #agreed we acknowledge the i386 baseline bump, document it and move on
19:34:30 <elbrus> anything else for this topic?
19:35:53 <elbrus> #topic current status of d-i
19:36:11 <elbrus> kibi: you mentioned RC2: when is the plan?
19:36:14 <kibi> RC2 coming up, lots of good stuff planned
19:36:38 <kibi> this week if I get all the pieces together, otherwise after the point release
19:37:09 <elbrus> ooo, that's soon :) love it
19:37:21 <kibi> we have a few things on the EFI front (grub2, grub-installer, os-prober), that means more baremetal testing, and that takes some more time than just VM-ing all the way
19:37:43 <pochu[m]> o/ sorry I'm late
19:37:51 <elbrus> \o
19:38:03 <kibi> I hope to get fewer such things over time, and to have RC3/RC4 much more quiet (l10n updates and very few things).
19:38:07 <kibi> hello pochu[m]
19:38:34 <kibi> (of course we'll have at least linux for RC3… since I'm not rushing it into testing right now)
19:39:15 <kibi> and that's about it for me; things going on, no blockers that I know of (big bugs are already in bullseye, possibly buster too), and nothing worrying me at this point
19:39:25 <kibi> (famous last words, I'll regret them…)
19:39:32 <elbrus> thank you
19:39:50 <elbrus> any questions before we move on?
19:40:11 <kibi> from me? no :) I can answer any questions you folks might have any time
19:40:39 <elbrus> I mostly meant for you, but both directions are good directions
19:40:41 <kibi> ah, and the plan is for me to learn how to spin images with RC2, but I wouldn't be sufficient for 12.0; but you might know that already :)
19:41:43 <elbrus> #topic RT sprint
19:41:56 <elbrus> maybe the wrong moment in the release flow
19:42:13 <elbrus> but I guess it's always the wrong moment to start about it
19:42:23 <elbrus> last time I recall was in Paris
19:42:37 <elbrus> I'm not good at organising these kind of things
19:43:12 <kibi> I'm not good either, and having a hard time finding time to go to such things anyway :(
19:43:13 <elbrus> I'd love to see some/most of you in real live to learn the tricks of the trade and discuss plans for trixie
19:43:17 <elbrus> I have a few
19:43:37 <elbrus> so: do we want one?
19:43:44 <ginggs> elbrus: when in the release cycle was the last one in Paris?
19:44:32 <pochu[m]> I don't remember that one
19:44:33 <kibi> March 2019, release during the summer
19:44:48 <elbrus> https://wiki.debian.org/BSP/2019/03/fr/Paris
19:46:35 <pochu[m]> a sprint would be nice, it's about time
19:46:39 <elbrus> apart from ginggs we're all in Europe, right?
19:46:54 <kibi> I think so
19:48:31 <elbrus> shall I start a thread on the list for ideas?
19:48:41 <pochu[m]> yes please
19:48:42 <elbrus> how to tackle the topic?
19:49:13 <elbrus> #action elbrus starts discussion on list about a sprint
19:49:18 <elbrus> ok
19:49:28 <elbrus> #topic AOB
19:50:02 <elbrus> shout
19:50:07 <kibi> YEAHHHHHHHHHHHHHHHHHH
19:51:18 <ginggs> nothing from me
19:51:28 <elbrus> if no further business, I'll finish the meeting
19:51:53 <elbrus> #topic Next meeting
19:52:04 <elbrus> #info Next meeting is 24 May at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
19:52:13 * elbrus will be in Hamburg then
19:52:29 <elbrus> #endmeeting