18:58:46 <elbrus> #startmeeting
18:58:46 <MeetBot> Meeting started Wed May 24 18:58:46 2023 UTC.  The chair is elbrus. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:58:46 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:59:07 <elbrus> #topic Admin
18:59:07 <elbrus> #topic Admin
18:59:14 <elbrus> #info Previous minutes: http://meetbot.debian.net/debian-release/2023/debian-release.2023-04-26-18.59.html
18:59:32 <elbrus> #info elbrus had an action to compose and send bits
18:59:40 <elbrus> that happened :)
18:59:49 <elbrus> #info elbrus had an action to start a thread about a sprint
18:59:54 <elbrus> that I forgot ...
19:00:16 <elbrus> highvoltage offered help organizing today :)
19:00:35 <elbrus> not sure how much... but I hope to not forget to send the mail soon
19:00:53 <elbrus> #topic Transitions
19:01:20 <elbrus> nothing should be going on ...
19:01:33 <ginggs> there was a request for nvidia-cuda-toolkit
19:01:38 <kibi> wasn't there some java thing?
19:02:02 <Sebastinas> I hope that nvidia-cuda-toolkit is for trixie.
19:02:02 <elbrus> I assumed that was for after the release
19:02:17 <ginggs> i don't think so :)
19:02:18 <textshell> (the tomcat9 transition is still breaking things)
19:02:33 <elbrus> crap, yes
19:02:53 <kibi> textshell: right, that one, thanks
19:03:33 <elbrus> textshell: do you happen to have some overview of that?
19:04:15 <ginggs> #1036676 anbe is looking at some FTBFS, but it's non-free, and I trust anbe is on top of things, so I'd be inclined to let through
19:04:18 <textshell> Not from memory. But there is still fallout and RC bugs popping up recently.
19:04:50 <textshell> e.g. #1036250
19:04:54 <textshell> and logback
19:05:24 <textshell> dependencies of puppet(server) which might be something not just to kick...
19:05:24 <Sebastinas> ginggs: It's too late.
19:05:59 <elbrus> Sebastinas: I agree, I really thought it to be for trixie (no cell in my brain thought otherwise)
19:06:32 <elbrus> textshell: can you help us and summarize everything you can collect together?
19:06:37 <Sebastinas> Also nothing in that mail says anything regarding bookworm.
19:07:10 <textshell> elbrus: i can scan through my open tabs later today and try to extract some bug ids.
19:07:27 <elbrus> that would already be extremely helpful
19:07:28 <kibi> and CUDA 12 is experimental only so all good?
19:08:13 <elbrus> textshell: are you part of the mail thread in bug #1034824?
19:08:34 <elbrus> please add it there if you can but ensure the release team is in CC too
19:08:50 <textshell> No, i'm just watching from the sideline. But i can try to write some notes to that bug.
19:08:58 <elbrus> please
19:09:03 <ginggs> well, i read the transition bug as a request to upload to unstable
19:09:14 <elbrus> I didn't
19:09:22 <ginggs> (as all good transitions should go)
19:09:43 <elbrus> yes, but we're in the freeze, so I don't expect him to expect us to ACK it now
19:09:51 <elbrus> all good transitions are planned
19:10:01 <elbrus> so this is planned not before the release
19:10:50 <kibi> and all blocking ftbfs bugs have been filed at important anyway
19:11:57 <kibi> pinged the bug.
19:12:10 <ginggs> kibi: ack, thanks
19:12:43 <elbrus> so, anything else on this topic?
19:13:05 <kibi> do we consider the adduser/apt thing like a transition?
19:13:13 <kibi> as it possibly impacts a bunch of other packages
19:13:33 <kibi> (not sure whether this should be discussed during the meeting at all, it just happened to appear on my radar earlier today)
19:14:02 <elbrus> I made it a seperate topic, but let's discuss now
19:14:13 <elbrus> #topic adduser
19:14:14 <kibi> ok, FTR this is #1036705
19:15:14 <kibi> (cuda 12 confirmed post-bookworm)
19:15:59 <Sebastinas> In hind sight I would have preferred if apt just gained back the dependency on adduser.
19:16:09 <elbrus> me too
19:16:17 <Sebastinas> This is now just whack-a-mole
19:16:19 <elbrus> (we'll learn from that)
19:16:34 <elbrus> so we can still do that
19:17:52 <elbrus> I'm fetching helmut
19:18:25 * kibi imagines elbrus's using a grappling hook
19:18:28 * helmut is here and catching up
19:21:31 <elbrus> josch did analysis on the archive for maintainer scripts calling adduser and deluser
19:21:59 <elbrus> (or so helmut claims)
19:22:15 <helmut> I think josch exhaustively searched for uses of adduser components in maintainer scripts and sent patches for all
19:23:12 <helmut> but fixing that stuff is deemed insufficient, because we want upgrades from bullseye to bookworm, then removing adduser, then purging left over packages to not break
19:23:27 <helmut> and the way to not break that is preventing adduser from being removable
19:23:30 <jochensp> #1035654
19:23:43 <helmut> which is what protected does, so we're good except for having broken piuparts
19:24:32 * olasd perks up
19:25:35 <helmut> but yeah, I'm not going to argue against adding back the dependency. it seems reasonably safe except for having been dropped for like half a year, so it could become a different whack-a-mole
19:26:45 <Sebastinas> At least it wouldn't regress compared to bullseye.
19:29:57 <olasd> from my PoV, piuparts is incidentally broken by not knowing what `Protected: yes` is, and only during its cleanup phase (after it's successfully tested the packages). Teaching piuparts about `Protected: yes` generally needs some design work which is not going to happen in time for now. piuparts can be made to behave like adduser is Essential, which would paper over the
19:29:59 <olasd> uninstallation issue in the cleanup phase
19:30:39 <elbrus> althought piuparts is part of our migration flow, it's not my biggest worry
19:30:49 <olasd> yeah, I understand
19:31:00 <elbrus> what's the expression, being between a rock and a hard place
19:31:02 <olasd> restoring the apt -> adduser dependency would have the same effect for piuparts
19:31:07 <elbrus> needing to do something
19:31:11 <h01ger> do we know that piuparts is the only tool that broke?
19:31:25 <elbrus> *that* is my worry
19:31:49 <kibi> shared
19:32:56 <helmut> I already thought that protected would cut it. I won't make promises about required, sorry.
19:34:48 <Sebastinas> olasd: Were there changes in piuparts in the last half year that makes it unable to handle an apt Depends on adduser?
19:35:13 <helmut> I strongly suppose no.
19:35:26 <Sebastinas> Okay, then let's put it back.
19:35:32 <olasd> Sebastinas: nope
19:35:33 <helmut> fair enough
19:35:53 <olasd> the only functional change is teaching it about non-free-firmware
19:35:54 <Sebastinas> We can experiment with required and protected after the release.
19:36:06 <elbrus> agree
19:36:29 <elbrus> #agreed the RT wants apt to put the Depends back
19:36:57 <Sebastinas> I'll reply to #1035654
19:37:04 <elbrus> thanks
19:37:07 <helmut> does that entail dropping protected
19:37:09 <helmut> ?
19:37:39 <elbrus> it doesn't do what we wanted it to do so I think that can be dropped no?
19:37:57 <helmut> it can. the question was whether it should.
19:38:15 <elbrus> I think it should, we can start over in trixie
19:39:34 <elbrus> Sebastinas: can you also comment on bug #1036705
19:40:29 <kibi> booh @ zwiebelbot
19:40:35 <Sebastinas> elbrus: Yes
19:40:38 <elbrus> yes, booh
19:40:41 <elbrus> thanks
19:41:09 <elbrus> apparently the zwiebelbot behavior is by design
19:41:15 <elbrus> (I'm told live here)
19:41:36 <elbrus> #topic current status of bookworm
19:41:51 <kibi> ok :)
19:42:10 <elbrus> nr of RC bugs have been increasing due to a flurry of QA
19:45:06 <elbrus> but otherwise it looks great I think
19:46:10 <elbrus> anybody that has serious concerns about things that might not get fixed in time and will japerdize the release quality?
19:46:56 <kibi> with the usual “kibi has limited focus” proviso: not me
19:47:53 <elbrus> ok, than lets just skip on
19:48:00 <elbrus> #topic current status of d-i
19:48:13 <elbrus> kibi: floor is yours
19:49:02 <kibi> evidently I bored everyone to death with the RC 3/RC 4 planning mail
19:49:09 <kibi> (or everybody was fine with it)
19:49:20 <ginggs> no news is good news
19:49:26 <kibi> next is RC 4, with proposed plans and question here: https://lists.debian.org/debian-release/2023/05/msg00824.html
19:50:42 <kibi> now the question is: what seems best from a release team point of view? RC 4 say tomorrow, or in a week or so
19:51:13 <elbrus> I don't think I have a strong opinion on that
19:51:49 <elbrus> and, kibi, I'm still alive
19:52:04 <elbrus> (you can draw the conclusions)
19:52:08 <kibi> :)
19:52:29 <kibi> seeing how we have moving parts like apt/adduser above, I'm even less sure what option is best at this point.
19:53:30 <kibi> in any case, current state is good, I'm rather happy with the state we reached, even if as usual everything converges late in the cycle
19:53:32 <elbrus> ack
19:53:59 <kibi> if nobody else has any preference (at least at this point), maybe move on, unless you have questions or topics to raise on that front?
19:54:24 <elbrus> just a big thanks for handling d-i
19:54:49 <kibi> and a big thanks for trusting me with it and the associated hints
19:54:57 <elbrus> sure :)
19:55:17 <elbrus> #topic AOB
19:56:09 <elbrus> after this meeting, I'll start the Full Freeze, but I'll add two hints for packages that are at 20/20 tonight
19:56:40 <elbrus> s/for packages/for two packages/
19:57:44 <kibi> I think I'll want to get RC 4 this week, and propose to upload a final debian-installer somewhen before the release.
19:57:46 <elbrus> I'm a bit behind with the Release Notes bugs in the bts (MR were easier to keep going, so I'll prefer those next time)
19:58:03 <elbrus> kibi: ACK
19:58:14 <kibi> so that we don't wait too long for a new release; and we'll “eventually merge” whatever is left at that point.
19:58:52 <kibi> I could even build images like I would for RC 5, so that they can be beta-tested before 12.0.0, just not sign/announce/publicize them
20:00:13 * elbrus noticed he skipped a topic: unblock requests
20:00:17 <kibi> I'll follow up to the planning mail later (might be tomorrow).
20:00:26 <elbrus> great
20:00:47 <kibi> (sorry, was still processing what to do, 50-50 feeling but not happy with deferring the choice to a coin toss)
20:01:17 <elbrus> that's OK
20:02:01 <elbrus> I've been regularly temporarily been in doubt what to decide this freeze
20:02:11 <elbrus> s/been//
20:02:43 <kibi> as long as we can still make decisions and live with them :)
20:03:12 <elbrus> typically the feeling goes away after the decision has been made
20:03:41 * elbrus finds making decisions is often harder than living with them
20:04:24 <elbrus> Sebastinas, ginggs: any other business?
20:04:36 <ginggs> nothing from me
20:05:39 <Sebastinas> Nothing
20:06:12 <kibi> thanks everyone
20:06:30 <elbrus> OK
20:06:35 <Sebastinas> hmm, maybe. I'll run another round of binNMUs to reduce he ESO: yes next week.
20:06:51 <Sebastinas> But the set is reasonably small already.
20:06:58 <elbrus> right, I should have another look at the wiki
20:07:08 <elbrus> https://wiki.debian.org/Teams/ReleaseTeam/ReleaseCheckList/BookwormCheckList
20:07:37 <elbrus> #topic Next meeting
20:07:47 <elbrus> release day :)
20:07:55 <elbrus> #info Next meeting is 28 June at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
20:08:04 <elbrus> #endmeeting