16:35:44 <terceiro> #startmeeting
16:35:44 <MeetBot> Meeting started Fri Mar 13 16:35:44 2020 UTC.  The chair is terceiro. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:35:44 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:36:02 <terceiro> #topic roll call
16:36:17 * utkarsh2102[m] waves o/
16:36:39 * kanashiro waves o/
16:37:16 * gwolf ≈
16:38:39 <terceiro> should we create an agenda with items that need discussion?
16:39:01 <utkarsh2102[m]> That sounds like a good idea
16:39:12 <srud[m]> \me
16:39:26 * PiratePraveen[m] says hi
16:39:54 <terceiro> please mention the items you want to discuss, right now
16:40:13 <PiratePraveen[m]> ruby 2.7 current status, rails 6 transition
16:40:28 <kanashiro> removal request for some packages which FTBFS against ruby2.7
16:40:35 <hacksk[m]> Hai
16:41:08 <utkarsh2102[m]> Ruby2.7 transitions: best way forward
16:41:22 <PiratePraveen[m]> ruby-aws-sdk, needs to reply to boutil
16:41:24 <utkarsh2102[m]> Time, date for the next month's meeting
16:41:48 <PiratePraveen[m]> an etherpad?
16:42:06 <utkarsh2102[m]> Pirate ‍ Praveen: I think the bot can take care of that. Though I'm not sure.
16:42:27 <terceiro> I'm organizing the agenda here, and will paste in the channel
16:42:40 <terceiro> so far I have:
16:42:56 <terceiro> - ruby2.7 transition - next steps
16:42:56 <terceiro> - ruby2.7 transition - RM some packages that FTBFS
16:42:56 <terceiro> - rails 6 transition
16:42:56 <terceiro> - time and date for next meeting
16:43:12 <terceiro> I missed the aws thing, will add
16:43:42 <terceiro> so ^ this list + ruby-aws-sdk. anything else?
16:44:00 <utkarsh2102[m]> Quick note: boutil pinged me 2 hours back saying he'll not be able to join :/
16:44:40 <terceiro> last chance for agenda items. moving on in 1 ...
16:44:55 <utkarsh2102[m]> I'd like to have a discussion about the next Ruby release as Hideki started a thread about it. But that's probably best kept for the next few meetings.
16:45:24 <terceiro> 2 ...
16:46:07 <terceiro> 3
16:46:11 <terceiro> let's start then
16:46:20 <terceiro> #topic ruby2.7 transition - next steps
16:46:47 <terceiro> kanashiro: what's the status from your pov?
16:47:01 <kanashiro> upload the ruby 2.7 only ruby-defaults from experimental to unstable?
16:47:09 <kanashiro> I think that is the next step
16:47:19 <terceiro> you need to open a transition with the RT first
16:47:38 <kanashiro> ok, so that is the next step :)
16:48:14 <terceiro> #link https://wiki.debian.org/Teams/Ruby/InterpreterTransitions
16:48:21 <kanashiro> I've faced some issues in Ubuntu after switching to ruby 2.7 only, hopefully we can just cherry-pick some patches
16:48:50 <terceiro> that wiki page documents the process, it's a little outdated as the last time we dropped the old ruby and made the new one the default in a single step
16:49:01 <terceiro> but the gist of it is still valid
16:49:23 <terceiro> FWIW I have been using ruby2.7 as default here for a while, and fixing whatever aI find
16:49:50 <terceiro> except when I find some issue that I can't fix reasonably quickly, then I revert back to 2.5
16:50:08 <terceiro> e.g. https://github.com/deivid-rodriguez/byebug/issues/654
16:50:12 <utkarsh2102> Me too. Mostly fixing some painful mipsel architecture failures.
16:50:25 <kanashiro> terceiro, and what do you think about the number of FTBFS we have against ruby 2.7 for now? is it ok to move forward?
16:50:26 <terceiro> everyone: are there concerns wrt the transition?
16:50:41 <terceiro> i.e. anything that should be resolved before we go ahead with it?
16:51:03 <terceiro> kanashiro: where's the list again (sorry)?
16:51:21 <kanashiro> terceiro, I've been using this link: https://udd.debian.org/cgi-bin/bts-usertags.cgi?user=pkg-ruby-extras-maintainers@lists.alioth.debian.org&tag=ruby2.7-transition
16:51:34 <terceiro> #link https://udd.debian.org/cgi-bin/bts-uhttps://udd.debian.org/cgi-bin/bts-usertags.cgi?user=pkg-ruby-extras-maintainers@lists.alioth.debian.org&tag=ruby2.7-transitionsertags.cgi?user=pkg-ruby-extras-maintainers@lists.alioth.debian.org&tag=ruby2.7-transition
16:52:17 <terceiro> kanashiro: I think that list is ok. i.e. it should not stop us from going ahead. either they get fixed, or removed from testing
16:52:31 <kanashiro> ack
16:53:01 <terceiro> of course, everyone who cares about ruby should try to help with those, but we don't need to wait for all of those to be fixed
16:53:41 <terceiro> also a decent part of that list is already fixed
16:54:06 <kanashiro> yes, I'll do some triage soon
16:55:24 <terceiro> #action kanashiro open ruby2.7-default transition ASAP, and after RT gives go ahead, upload to unstable
16:55:38 <terceiro> anything else on this topic?
16:55:52 <kanashiro> nope
16:57:09 <bhe[m]> hey. little late for the party !
16:57:29 <terceiro> let's move on then
16:57:35 <terceiro> #topic rails 6 transition
16:57:47 <kanashiro> terceiro, and what about removals?
16:58:12 <terceiro> kanashiro: is there something we need to decide here? or is the email you sent earlier all about it?
16:58:21 * kanashiro thought it'd be the next topic
16:58:23 <PiratePraveen[m]> gitlab already has a version with rails 6
16:58:29 <terceiro> #undo
16:58:29 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x15b6610>
16:58:36 <srud[m]> I haven't worked on rails since sprint..planning to work on that in couple of days
16:58:58 <terceiro> #topic rails 6 transition
16:59:07 <terceiro> kanashiro: sorry we'll go back to it in a bit
16:59:12 <kanashiro> ok
16:59:49 <terceiro> srud[m]: PiratePraveen[m] are there any blockers, other than the apps supporting rails 6?
17:00:12 <kanashiro> regarding rails 6, redmine does not support it yet (could you confirm this Duck?)
17:00:19 <PiratePraveen[m]> we need to decide when to upload to unstable
17:01:06 <PiratePraveen[m]> I think redmine and obs uploaders needs to decide
17:01:09 <PiratePraveen[m]> if it is ok to upload to unstable right now or should we wait
17:01:54 <kanashiro> I had a discussion about it with Duck some time ago and we think it'd be great at least to wait for the next redmine release
17:02:07 <terceiro> redmine seems to be a bit far from it: https://www.redmine.org/issues/29914
17:02:53 <PiratePraveen[m]> kanashiro ok sounds good
17:03:35 <kanashiro> on the OBS side I didn't have time to check it out yet
17:03:40 <terceiro> I think we should decide on a deadline soon
17:03:52 <terceiro> given the recent freeze deadlines that were announced by the RT
17:04:20 <terceiro> to avoid a new rails 5 situation and not leave it to the last minute
17:04:44 <terceiro> but maybe we can go back to this in the next meeting
17:05:20 <kanashiro> right, I think we can add this to the next meeting agenda
17:05:33 <PiratePraveen[m]> kanashiro last time we embedded rails in gitlab ,would that work for obs and redmine?
17:06:02 <terceiro> #info gitlab already has rails 6 support
17:06:09 <kanashiro> PiratePraveen[m], it should work but I'd like to avoid that
17:06:11 <terceiro> #info redmine does not have rails 6 support yet
17:06:31 <terceiro> #action kanashiro check status of obs wrt rails 6
17:06:58 <terceiro> #agreed rails 6 will not be uploaded to unstable just yet. we'll re-raise this topic in the next meeting
17:07:23 <terceiro> do my #'s above correctly summarize the current status?
17:07:33 <kanashiro> yes
17:08:17 <PiratePraveen[m]> yup
17:08:58 <terceiro> I think we can move on then?
17:09:19 <terceiro> #topic ruby2.7 transition - RM requests
17:09:22 <terceiro> kanashiro: go
17:09:30 <kanashiro> let me add some links here
17:09:37 <kanashiro> #link https://lists.debian.org/debian-ruby/2020/03/msg00034.html
17:09:47 <kanashiro> #link https://lists.debian.org/debian-ruby/2020/03/msg00006.html
17:09:55 <kanashiro> #link https://lists.debian.org/debian-ruby/2020/03/msg00011.html
17:10:15 <kanashiro> we have a bunch of candidates for removal
17:11:10 <kanashiro> since we don't have replies for those emails (do not consider the one I sent earlier today) I think we can move forward
17:11:23 <kanashiro> and file RM bugs
17:11:29 <terceiro> in general, I'm in favor of removing stuff that's broken, but only if it's broken
17:12:25 <kanashiro> any objections regarding the mentioned packages?
17:12:40 <terceiro> for example, I just checked ruby-multipart-parser
17:13:01 <terceiro> it hasn't seen new development in a while, but it builds just fine
17:13:58 <terceiro> autopkgtest fails on ci, but that's something that needs a fix on the debian side anyway
17:14:14 <kanashiro> ok, so should we remove ruby-upr, ruby-multipart-parser, and ruby-haml-contrib from the candidates for removal list?
17:15:51 <terceiro> IMO we should only remove stuff that
17:15:55 <terceiro> IMO we should only remove stuff that's causing issues
17:16:02 <PiratePraveen[m]> I think we can keep them till we get an rc bug
17:16:05 <terceiro> so yes
17:17:00 <kanashiro> ack, I'll reply to Daniel's email saying that we will not remove packages without an RC bug
17:18:51 <terceiro> #agreed we'll remove packages that are actually broken, not ones that are just old
17:20:32 <terceiro> moving on, we have only 9 min left
17:20:38 <terceiro> #topic ruby-aws-sdk
17:20:51 <terceiro> can someone please summarize the impasse for the record?
17:23:08 <utkarsh2102> That's what we decided during the sprints
17:23:09 <terceiro> ping
17:23:13 <utkarsh2102> terceiro: I remember you were supposed to reply to the RFS mail
17:23:25 <terceiro> utkarsh2102: yes, I was and I failed at that
17:23:26 <PiratePraveen[m]> I think we decided to not use single source as each gem has different release cycle
17:23:57 <PiratePraveen[m]> at least different versions
17:24:04 <PiratePraveen[m]> but boutils last mail seemed to indicate he wants to go ahead with a single source package
17:26:12 <terceiro> can someone followup to cedric's email then? he explicitly asked for the sprint participants to clarify the discussion that we had
17:26:38 <terceiro> even if it's to say: "no, you got it wrong", we actually agreed $THIS
17:27:10 <terceiro> is possible someone who is affected (e.g. by caring about reverse dependencies)
17:27:59 <terceiro> any volunteer?
17:28:33 <terceiro> *crickets*
17:29:27 <PiratePraveen[m]> I replied
17:29:59 <terceiro> didn't have to be *now* :)
17:30:00 <terceiro> but thanks
17:30:11 <PiratePraveen[m]> and ftr I had already tried to explain things, but he does not listen
17:30:45 <PiratePraveen[m]> its not very fun to repeat the same arguments over and over
17:31:57 <terceiro> yes I know
17:32:54 <terceiro> but is there something that we in this meeting can do to solve the issue?
17:33:05 <terceiro> note: we are 3min past our 1h time limit
17:33:11 <terceiro> let's try to converge
17:33:42 <PiratePraveen[m]> we could correct boutil
17:33:51 <terceiro> we should
17:33:59 <terceiro> I can reply to his email if that will help
17:34:25 <terceiro> #action terceiro to clarify the consensus in the 2020 ruby sprint about ruby-aws-sdk
17:34:54 <PiratePraveen[m]> terceiro thanks
17:34:56 <terceiro> is there anything else?
17:35:14 <kanashiro> that's it
17:35:27 <terceiro> #topic next meeting
17:35:40 <srud[m]> next meeting?
17:35:52 <terceiro> is this a day of the week and time that usually works for the present?
17:35:58 <terceiro> i.e. Fridays 16:30 UTC
17:36:11 <kanashiro> that works fine for me
17:36:37 <PiratePraveen[m]> fine for me
17:36:47 <srud[m]> Fine for me too
17:37:12 <terceiro> so would "every 2nd Friday, 16:30 UTC" work in general?
17:37:26 <kanashiro> yep
17:37:41 <utkarsh2102> I'd rather propose the first Friday
17:37:49 <utkarsh2102> But pretty alright with this, too
17:38:03 <terceiro> why the first? because it's easier to remember?
17:38:14 <terceiro> I'm indifferent FWIW
17:38:26 <gwolf> (as it could be clearly seen, I am just a lurker... :-) But will gladly attend meetings if I'm around... maybe even drop a line now or then)
17:38:45 <utkarsh2102> No reason, really. It's just nice. First Friday :P
17:39:00 <utkarsh2102> Note that we all were actually free during the first Friday as well
17:39:21 <utkarsh2102> 100% consensus for both the Friday's
17:39:39 <utkarsh2102> And also, the first Saturday is generally off for most.
17:40:09 <kanashiro> it doesn't matter whether it is the first or second Friday of the month for me
17:40:34 <kanashiro> I'd prefer to avoid Saturday
17:40:50 <PiratePraveen[m]> utkarsh2102 how? Second saturday is usually off
17:41:14 <terceiro> well shouldn't every Saturday be off? :-)
17:41:15 <utkarsh2102> Really? Then something's horribly wrong with my college :P
17:41:45 <utkarsh2102> If only everyone would be so nice :)
17:43:36 <terceiro> utkarsh2102: are you still volunteer to do the required social agitation? sending reminders etc
17:44:30 <utkarsh2102> terceiro: yes. That's not much work once we have $datetime fixed
17:44:38 <terceiro> ok
17:44:50 <terceiro> #agreed meetings on every first Friday of the month, at 16:30 UTC
17:45:06 <terceiro> #info utkarsh2102 is volunteering to make us not forget it
17:46:50 <utkarsh2102> \o/
17:47:11 <terceiro> #endmeeting