#debian-ruby Meeting

Meeting started by terceiro at 16:29:24 UTC (full logs).

Meeting summary

    1. https://jitsi.debian.social/AdvancedChecksLearnMoreover (terceiro, 16:30:04)

  1. #958523 (terceiro, 16:39:52)
    1. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=958523 (terceiro, 16:40:05)
    2. #958523- rubocop: conffiles not removed: /etc/rubocop/enabled.yml /etc/rubocop/disabled.yml (terceiro, 16:40:27)
    3. bug is simple to fix using debian/${package}.maintscript; see deb_installdeb(1) (terceiro, 16:44:52)
    4. use rm_conffile (terceiro, 16:45:12)
    5. https://salsa.debian.org/ruby-team/gitlab/-/blob/master/debian/maintscript#L1 (j4v4m4n, 16:47:22)

  2. https://github.com/rubocop-hq/packaging-style-guide/issues/4. (terceiro, 16:48:24)
  3. https://github.com/rubocop-hq/packaging-style-guide/issues/4 (terceiro, 16:48:35)
    1. the problem seems to be with packages that use dummy rails apps in their tests (terceiro, 17:02:39)
    2. needs further investigation (terceiro, 17:03:00)

  4. Maintainance of the Ruby toolchain (terceiro, 17:06:54)
    1. we need new people to help maintaining the ruby toolchain (terceiro, 17:10:06)
    2. ACTION: terceiro to post a RFH to the mailing lit (terceiro, 17:10:18)
    3. https://tracker.debian.org/teams/ruby-toolchain/ (terceiro, 17:10:32)

  5. ruby-netdns (terceiro, 17:13:01)
    1. ruby-netdns FTBFS for terceiro, but not for praveen or in the buildds (terceiro, 17:13:53)
    2. ACTION: j4v4m4n to downgrade the current FTBFS bug (terceiro, 17:14:14)

  6. new ideas for rubocop-packaging (terceiro, 17:14:51)
    1. utkarsh2102 asks everyone to suggest new checks for rubocop-packaging to detect issues in upstream code that we usually have to patch in debian (terceiro, 17:15:24)
    2. https://github.com/robotdana/git_ls (utkarsh2102, 17:16:40)
    3. https://github.com/robotdana/fast_ignore (utkarsh2102, 17:26:48)


Meeting ended at 17:30:20 UTC (full logs).

Action items

  1. terceiro to post a RFH to the mailing lit
  2. j4v4m4n to downgrade the current FTBFS bug


Action items, by person

  1. j4v4m4n
    1. j4v4m4n to downgrade the current FTBFS bug
  2. terceiro
    1. terceiro to post a RFH to the mailing lit


People present (lines said)

  1. terceiro (23)
  2. MeetBot (3)
  3. j4v4m4n (3)
  4. utkarsh2102 (2)


Generated by MeetBot 0.1.4.