#debian-rust Meeting

Meeting started by silwol at 18:59:27 UTC (full logs).

Meeting summary

  1. overview (silwol, 18:59:45)
  2. regular meetings (silwol, 19:03:02)
    1. IDEA: : each fourth wednesday of the month IRC meeting (stappers, 19:07:49)
    2. AGREED: regular meetings every fourth wednesday of a month, we'll revisit the decision by the end of the year. if changes are required, we'll announce them in the chat and on the mailing list. (silwol, 19:13:05)

  3. additional debian-rust mailing list (silwol, 19:13:25)
    1. IDEA: listadmin workload as agenda item for our meetings (stappers, 19:22:42)
    2. ACTION: stappers request debian-rust@lists.debian.org mailing list (silwol, 19:23:04)
    3. ACTION: silwol check wiki and readme once we have the list (silwol, 19:23:42)

  4. future of packaging with debcargo (silwol, 19:25:06)
    1. ACTION: attempt to estimate naive savings of dropping unused features/lib crate bin packages ( f_g ) (f_g, 19:58:29)
    2. issue on salsa: https://salsa.debian.org/rust-team/debcargo-conf/-/issues/17 (f_g, 20:00:27)
    3. ACTION: silwol f_g whip up a proof of concept MR implementing bin package / feature reduction feature in debcargo (f_g, 20:02:52)
    4. IDEA: the dev repo get included when the are deb-src in /etc/apt/sources.list (stappers, 20:15:26)
    5. ACTION: silwol contact Debian Go, JS and Haskell teams and Kali Linux maintainers for 'dev-repo' proposal (f_g, 20:16:30)
    6. ACTION: silwol include plugwash/raspbian in dev-repo proposal as well (f_g, 20:17:08)
    7. https://wiki.debian.org/IRC/debian-meeting (stappers, 20:24:12)
    8. ACTION: kpcyrd contact Kali rust people and see how/whether we can collaborate (maybe invite to meeting) (f_g, 20:25:57)

  5. what is everybody working on / planning and what blockers are beside the whole review thing (silwol, 20:29:33)
  6. debcargo feature-collapsing feature POC (silwol, 20:59:19)
    1. mailing request bugreport https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=966088 (stappers, 21:23:26)
    2. https://paste.debian.net/1157463/ (f_g, 21:33:25)
    3. pastebin 7463: aho-corasick bindgen cargo-lichking cargo-vendor cbindgen debcargo difference exa fd-find grcov hexyl nitrocli process-viewer pulldown-cmark ripgrep rustdoc-stripper xml-rs (stappers, 21:35:56)
    4. pastebin 7464: libtr-tid2 moonshot-trust-router-dbg moonshot-trust-router-dev libjs-trust-json-document bat bindgen cargo-lichking cargo-lock cargo-outdated cbindgen debcargo difference dotenv exa fd-find grcov hexyl lalrpop lscolors nitrocli process-viewer protobuf-codegen pulldown-cmark ripgrep rustdoc-stripper rusty-tags sqop sqv sniffglue spotify-tui ucd-generate xml-rs (stappers, 21:37:22)

  7. what is everybody working on / planning and what blockers are beside the whole review thing (silwol, 21:41:06)


Meeting ended at 21:58:58 UTC (full logs).

Action items

  1. stappers request debian-rust@lists.debian.org mailing list
  2. silwol check wiki and readme once we have the list
  3. attempt to estimate naive savings of dropping unused features/lib crate bin packages ( f_g )
  4. silwol f_g whip up a proof of concept MR implementing bin package / feature reduction feature in debcargo
  5. silwol contact Debian Go, JS and Haskell teams and Kali Linux maintainers for 'dev-repo' proposal
  6. silwol include plugwash/raspbian in dev-repo proposal as well
  7. kpcyrd contact Kali rust people and see how/whether we can collaborate (maybe invite to meeting)


Action items, by person

  1. f_g
    1. attempt to estimate naive savings of dropping unused features/lib crate bin packages ( f_g )
    2. silwol f_g whip up a proof of concept MR implementing bin package / feature reduction feature in debcargo
  2. kpcyrd
    1. kpcyrd contact Kali rust people and see how/whether we can collaborate (maybe invite to meeting)
  3. silwol
    1. silwol check wiki and readme once we have the list
    2. silwol f_g whip up a proof of concept MR implementing bin package / feature reduction feature in debcargo
    3. silwol contact Debian Go, JS and Haskell teams and Kali Linux maintainers for 'dev-repo' proposal
    4. silwol include plugwash/raspbian in dev-repo proposal as well
  4. stappers
    1. stappers request debian-rust@lists.debian.org mailing list


People present (lines said)

  1. f_g (155)
  2. silwol (120)
  3. stappers (52)
  4. infinity0 (43)
  5. kpcyrd (37)
  6. hntourne (15)
  7. andrewsh (7)
  8. wookey_ (2)
  9. MeetBot (2)


Generated by MeetBot 0.1.4.