#debian-rust Meeting

Meeting started by ncts at 17:59:10 UTC (full logs).

Meeting summary

  1. roll call (ncts, 17:59:32)
  2. CI & salsa integration, dashboard (ncts, 18:05:37)
    1. https://debian-rust-ci.hackeriet.no/public-dashboards/7f1cbd7469964b9ebe9028b3d9e56deb?orgId=1 (f_g, 18:07:16)
    2. IDEA: linting, d/copyright for a start (ncts, 18:11:19)
    3. ACTION: capitol to build something out to check for d/copyright and debcargo.toml as a start (ncts, 18:24:33)
    4. https://salsa.debian.org/rust-team/debcargo/-/blob/master/.gitlab-ci.yml btw - that one is pretty nice and straightforward :) (f_g, 18:25:01)

  3. status update on src:cargo merge with src:rustc (ncts, 18:32:36)
    1. https://salsa.debian.org/rust-team/rust/-/merge_requests/27 (f_g, 18:34:50)
    2. progess a bit slower than expected, but should be done soon (f_g, 18:35:42)
    3. f_g: need to properly arrange files and Suggests/Recommends among packages for rustc (ncts, 18:41:11)
    4. https://bugs.debian.org/1021868 (ncts, 18:41:40)

  4. BoF at FOSDEM (ncts, 18:44:22)
    1. https://pretalx.fosdem.org/fosdem-2024/talk/review/XY8RVXKD98AUN3XSTTHGW9DMEHKSVGA7 (f_g, 18:47:57)
    2. BoF for distro/upstream exchange at fosdem (f_g, 18:48:12)

  5. transitions and general documentation improvement (ncts, 18:50:45)
    1. https://salsa.debian.org/rust-team/debcargo-conf/-/issues/57#note_459134 (jamessan, 18:55:34)
    2. ACTION: werdahias plans for new gtk-rs release (ncts, 19:02:02)
    3. ACTION: f_g will go for hyper & co. in later weeks (ncts, 19:02:23)
    4. plugwash suggests transitioning hyper would be a "big bang" (ncts, 19:04:20)
    5. https://debian.pages.debian.net/ben/ (jamessan, 19:04:45)
    6. https://debian.pages.debian.net/ben/ (f_g, 19:04:45)
    7. https://release.debian.org/transitions/ (f_g, 19:05:00)
    8. jamessan works on alacritty update, which involves a lot of intertwined packages, including wayland 0.29 -> 0.31 (ncts, 19:06:35)
    9. ACTION: f_g play around with ben and see if it's a good fit for bigger future transitions (f_g, 19:10:01)
    10. ACTION: werdahias writes a wiki page about building cdylibs (ncts, 19:20:13)
    11. f_g suggests wasm things might also need the care (ncts, 19:22:23)

  6. lots of semver packages taged in experimental (ncts, 19:26:33)
  7. next meeting (ncts, 19:33:49)


Meeting ended at 19:37:37 UTC (full logs).

Action items

  1. capitol to build something out to check for d/copyright and debcargo.toml as a start
  2. werdahias plans for new gtk-rs release
  3. f_g will go for hyper & co. in later weeks
  4. f_g play around with ben and see if it's a good fit for bigger future transitions
  5. werdahias writes a wiki page about building cdylibs


Action items, by person

  1. capitol
    1. capitol to build something out to check for d/copyright and debcargo.toml as a start
  2. f_g
    1. f_g will go for hyper & co. in later weeks
    2. f_g play around with ben and see if it's a good fit for bigger future transitions
  3. werdahias
    1. werdahias plans for new gtk-rs release
    2. werdahias writes a wiki page about building cdylibs


People present (lines said)

  1. f_g (72)
  2. ncts (72)
  3. capitol (21)
  4. werdahias (18)
  5. jamessan (16)
  6. plugwash_ (3)
  7. MeetBot (2)
  8. count_omega (1)
  9. weepingclown (1)


Generated by MeetBot 0.1.4.