#debian-rust Meeting

Meeting started by werdahias at 16:00:08 UTC (full logs).

Meeting summary

  1. rollcall (werdahias, 16:01:22)
  2. status updates (werdahias, 16:03:53)
    1. thanks to the amazing work of f_g rustc is current with the stable release upstream (werdahias, 16:04:24)
    2. https://lists.debian.org/debian-rust/2024/06/msg00018.html - update from f_g (weepingclown[m]1, 16:04:42)
    3. event-listener 5.x transition underway in experimental (werdahias, 16:05:39)
    4. zbus transition to 4.x starting in experimental (werdahias, 16:06:01)
    5. f_g would appericate help wrt debcargo triaging (werdahias, 16:06:26)
    6. eventlistener almost done, werdahias would appreciate some help with sluice (werdahias, 16:08:20)
    7. ACTION: maytham and f_g look into http (werdahias, 16:09:23)
    8. ACTION: ncts looks at zip (werdahias, 16:10:47)
    9. nix transition to 0.27 happened, thanks to plugwash (werdahias, 16:11:54)
    10. ncts and me removed rust-instant and patched rdeps (werdahias, 16:12:36)

  3. packaging efforts / blockers (werdahias, 16:15:01)
    1. ACTION: werdahias (werdahias, 16:19:17)
    2. ACTION: werdahias tries to work on the RFS pile in August (werdahias, 16:19:40)
    3. ACTION: everyone improve the docs (werdahias, 16:23:30)
    4. ACTION: federico3 ncts[m] weepingclown[m]1 look into improving the tooling (werdahias, 16:33:26)

  4. miscellaneous (werdahias, 16:35:19)
    1. I wrote a draft for a cdylibs wiki page (werdahias, 16:39:17)
    2. ACTION: discuss backports at next meet (werdahias, 16:41:58)
    3. ACTION: werdahias (werdahias, 16:42:09)
    4. ACTION: werdahias organize next meet (werdahias, 16:42:30)
    5. https://go-team.pages.debian.net/ is a good example (weepingclown[m]1, 16:51:59)
    6. ncts[m] looked into having a team logo (werdahias, 16:54:33)
    7. ACTION: ncts[m] will work on logo, maybe vote on it in the next meet ? (werdahias, 16:58:55)
    8. policy /dh-compat bump (werdahias, 16:59:17)
    9. ACTION: werdahias will upload all custom crates with control files in august for dh-compat bump (werdahias, 17:04:40)


Meeting ended at 17:07:42 UTC (full logs).

Action items

  1. maytham and f_g look into http
  2. ncts looks at zip
  3. werdahias
  4. werdahias tries to work on the RFS pile in August
  5. everyone improve the docs
  6. federico3 ncts[m] weepingclown[m]1 look into improving the tooling
  7. discuss backports at next meet
  8. werdahias
  9. werdahias organize next meet
  10. ncts[m] will work on logo, maybe vote on it in the next meet ?
  11. werdahias will upload all custom crates with control files in august for dh-compat bump


Action items, by person

  1. federico3
    1. federico3 ncts[m] weepingclown[m]1 look into improving the tooling
  2. maytham
    1. maytham and f_g look into http
  3. ncts[m]
    1. federico3 ncts[m] weepingclown[m]1 look into improving the tooling
    2. ncts[m] will work on logo, maybe vote on it in the next meet ?
  4. weepingclown[m]1
    1. federico3 ncts[m] weepingclown[m]1 look into improving the tooling
  5. werdahias
    1. werdahias
    2. werdahias tries to work on the RFS pile in August
    3. werdahias
    4. werdahias organize next meet
    5. werdahias will upload all custom crates with control files in august for dh-compat bump
  6. UNASSIGNED
    1. ncts looks at zip
    2. everyone improve the docs
    3. discuss backports at next meet


People present (lines said)

  1. werdahias (92)
  2. weepingclown[m]1 (61)
  3. ncts[m] (39)
  4. siretart (18)
  5. federico3 (17)
  6. jamessan (7)
  7. maytham (6)
  8. MeetBot (2)
  9. efraim (1)
  10. mjt (1)


Generated by MeetBot 0.1.4.