#debian-rust Meeting

Meeting started by werdahias at 18:00:29 UTC (full logs).

Meeting summary

  1. rollcall (werdahias, 18:00:38)
  2. toolchain updates (werdahias, 18:03:55)
    1. trixie will have rustc 1.85 with the 2024 edition (werdahias, 18:12:43)

  3. transitions (werdahias, 18:15:35)
    1. env-logger 0..11 is done (werdahias, 18:17:40)
    2. noisycoil[m]1 will try to do bindgen and procfs (werdahias, 18:17:58)
    3. werdahias prepared zbus 5 in exp with noisycoil[m]1s help (werdahias, 18:20:13)
    4. noisycoil[m]1 works on rustix 1.0 (werdahias, 18:22:21)
    5. werdahias will do a mini-cxx update (not semver breaking) (werdahias, 18:22:47)
    6. ncts[m] will work on the http stack (werdahias, 18:23:12)

  4. misc (werdahias, 18:25:25)
    1. ACTION: werdahias will look into an UDD query for dh 12 crates (werdahias, 18:41:21)
    2. ACTION: werdahias adds wrapper to the book (werdahias, 19:00:30)
    3. ACTION: noisycoil[m]1will look into getting debcargo a manpage (werdahias, 19:04:21)


Meeting ended at 19:05:57 UTC (full logs).

Action items

  1. werdahias will look into an UDD query for dh 12 crates
  2. werdahias adds wrapper to the book
  3. noisycoil[m]1will look into getting debcargo a manpage


Action items, by person

  1. noisycoil[m]1
    1. noisycoil[m]1will look into getting debcargo a manpage
  2. werdahias
    1. werdahias will look into an UDD query for dh 12 crates
    2. werdahias adds wrapper to the book


People present (lines said)

  1. werdahias (93)
  2. noisycoil[m]1 (42)
  3. federico3 (12)
  4. jbicha (11)
  5. h01ger (10)
  6. plugwash (10)
  7. PlexSheep (8)
  8. ncts[m] (7)
  9. MeetBot (2)
  10. capitol (2)
  11. weepingclown[m][m] (1)
  12. BTS (1)


Generated by MeetBot 0.1.4.