15:59:23 <marga> #startmeeting
15:59:23 <MeetBot> Meeting started Sat Sep 7 15:59:23 2013 UTC. The chair is marga. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:23 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:59:31 <marga> #topic Introductions
15:59:47 <marga> So, let's see who's here :)
15:59:56 <CountryGrrl_AK> Checks In*
16:00:07 <marga> I'm Margarita, originally from Argentina currently living in Germany.
16:00:26 <detrout> I'm diane, I'm near los angeles
16:00:35 <Droidy> Leena here, from Finland
16:00:47 <CountryGrrl_AK> I am Kristen in Alaska
16:00:50 <Kinga> I'm Kinga, living in Hungary.
16:01:01 <detrout> wow, its early for you CountryGrrl_AK
16:01:14 <marga> Indeed!
16:01:15 <svaksha> Vid, from India.
16:01:18 <CountryGrrl_AK> Not much! I have animals to feed and a day to get started
16:01:28 <tvincent> I'm Thomas from France
16:01:29 <solveig> Solveig, from France
16:01:34 <eliad> Eliad, from Iran
16:01:36 <CountryGrrl_AK> It is 8:00am
16:01:40 <detrout> ok
16:02:04 <CountryGrrl_AK> We are from all over! Nice
16:02:11 <detrout> i think there was someone else who was further into the morning in alaska on the list
16:02:21 <paulproteus> Morning! I'm Asheesh, originally from India I suppose, but mostly from the US. Mostly here to listen; am a dude, but have some experience in mentorship and other things. I've run a number of gender-diversity-oriented programs for Python user groups and run "Open Source Comes to Campus, for Women in Computing" as part of my work at OpenHatch. Reading the agenda now.
16:02:42 <marga> Thanks everyone for attending :). I hope we can have some interesting ideas with such a varied group.
16:02:43 <paulproteus> Oh, and I'm working on a "Debian welcoming team" which has some overlap in goals with Debian Women I believe.
16:02:57 <marga> Oh, right the Agenda is at: https://wiki.debian.org/DebianWomen/IRC07September2013
16:03:06 <CountryGrrl_AK> Very nice paulproteus!
16:03:16 <marga> #topic What to do with the mentoring program
16:03:46 <detrout> how many women DDs are here?
16:04:02 <detrout> or is there other parts to mentoring?
16:04:15 <marga> So, Lesley sent an email to the list some days ago, commenting that the mentoring program is not working very well. Very few mentees, and very little track of what goes on after the initial contact.
16:04:36 <marga> detrout: even if not many are active in this meeting, I'm confident that we can recruit mentors if we need them.
16:04:53 <marga> However, I'm afraid that recruiting mentors is not very useful if we don't have mentees.
16:05:14 <detrout> I feel like it'd be helpful to have a clearer list of "work that needs doing"
16:05:22 <marga> So, my main concern is 1) how to get more mentees 2) how to make the mentoring program useful for them.
16:05:26 <paulproteus> FWIW for the mentoring project, if I were running it, I would focus on a few things. One is to help mentees get exposed to more parts of Debian than just chatting with their mentor, perhaps with what detrout remarks as work clearly worth doing.
16:05:37 <marga> detrout: indeed. That's one of paulproteus' projects I think :)
16:05:54 <paulproteus> Me and lucas and others; https://wiki.debian.org/how-can-i-help
16:06:13 <paulproteus> I think it has hit experimental; work continues on it slowly but surely.
16:06:47 <detrout> that's a neat program idea
16:06:56 <paulproteus> But the other thing I would recommend is adding/switching to a mindset where you actively request for mentees from the world. The most successful way I've seen this done is Fedora's "Design bounties," which I've cloned in a non-Fedora context as "Starling bounties."
16:07:00 <paulproteus> Let me pull up some info; 1 sec.
16:07:24 <paulproteus> Context: this is how they ask for a mentee, one at a time <http://mairin.wordpress.com/2010/07/09/fedora-design-bounty-fedora-slide-deck-template/> and this is how they thank them <http://mairin.wordpress.com/2010/07/23/second-fedora-design-bounty-ninja-identified/>
16:07:34 <detrout> While watching the debconf talks the presentation on the kernel had a long list of work needed.
16:07:35 <paulproteus> https://openhatch.org/wiki/Starling summarizes the key points of the outreach strategy.
16:08:18 <paulproteus> The long and short of it, "Pick a regular task that needs being done in Debian, and write up with high clarity how to solve it, and indicate that someone will mentor whoever wants to achieve the task, and add some time urgency, and make the prize for success be a signifier of community inclusion."
16:08:48 <paulproteus> This works for me in a different context with my "Request for Birthday Present" <http://www.asheesh.org/note/debian/rfbp.html>
16:10:13 <marga> paulproteus: I fear you have scared away everyone else :)
16:10:18 <paulproteus> Yeah, oops.
16:10:27 * detrout finishes reading
16:10:50 <CountryGrrl_AK> As a full time student studying computer science, I just fear I would not be able to devote time to any project consistently. That keeps me away as a Mentee
16:11:15 <detrout> so, one suggestion is to go through the list of wnpp and rate the difficulty of fixing them?
16:11:19 <marga> CountryGrrl_AK: would that be better if there were clearly scoped tasks?
16:11:23 <CountryGrrl_AK> But I am very interested in doing something!
16:11:32 <CountryGrrl_AK> Yes marga
16:11:41 <paulproteus> I also gave a talk at Debconf in case people want to watch, which was http://asheesh.org/pub/debconf-mentorship/ | http://www.youtube.com/watch?v=4z7hLxY9QIk . But that's not required reading. I'll close with: if something like a Starling Bounty is exciting for D-W, then "all" we need is someone willing to write up a blog post for a Debian Women Starling Bounty; I'd be happy to review the post and the plan. That's just one idea, and
16:11:41 <paulproteus> I'll hush for now!
16:11:57 * svaksha likes paulproteus's idea of specific, focused tasks with an end goal.
16:11:58 <CountryGrrl_AK> I have looked at projects and kind of get lost as to what I might do or how. It's new
16:12:13 <marga> detrout: I'm afraid that most of wnpp is not simple. Some may be, but usually the simple ones get done fast and the ones that linger are the difficult ones.
16:12:25 <detrout> i found an easy one!
16:12:33 <detrout> i almost finished fixing it
16:12:42 <CountryGrrl_AK> Oh you would Diane! LOL
16:12:47 <detrout> yes I would
16:13:02 <Kinga> CountryGrrl_AK: A bit same with me. Also would like to help with less time. Both in mentoring and being a mentee.
16:13:06 <marga> # agreed We need scoped and well described tasks that people can take on.
16:13:07 <CountryGrrl_AK> What is "wnpp"?
16:13:18 <detrout> work needed ... stufff packages
16:13:21 <marga> Oh, I think I shouldn't have used a space. I'll repeat (this is for the bot)
16:13:24 <marga> #agreed We need scoped and well described tasks that people can take on.
16:13:35 <detrout> maybe prospective?
16:13:36 <solveig> https://wiki.debian.org/DebianWomen/Projects/NewbieTasks
16:13:42 <marga> (work needed and prospective packages)
16:13:57 <CountryGrrl_AK> Ah! Thank you marga
16:13:58 <marga> solveig: yes, but it's empty!
16:14:25 <marga> #link https://wiki.debian.org/DebianWomen/Projects/NewbieTasks
16:14:42 <detrout> I know the #debian-med team tries to get people to package R modules. They do tend to be small and focused
16:14:45 <marga> (that's also for the bot, if you have interesting links that should go in the minutes, please use #link)
16:15:00 <solveig> marga: i addes the Bug triage link, but i think there is more ideas to list there
16:15:37 <marga> solveig: sure. I think the main problem is that someone has to sit down to think and write those, and apparently we are not very good at that :-/
16:15:59 <detrout> not quite mentoring but I thought a thing a socialish newish person can do is spend time helping others on #debian
16:16:07 <marga> So, we first need a NewbieTasks bounty, so that we can have Tasks Bounties later on :)
16:16:12 <paulproteus> The nice thing about Starling Bounties is you only have to write about one such task at a time, so you can focus on making it great.
16:16:41 <solveig> i thought everyone could add what they started with :)
16:17:14 <marga> #idea Get people to add what they started with to NewbieTasks
16:17:36 <marga> paulproteus: how often?
16:17:37 <paulproteus> solveig: If you can write an example there, that would help me better understand what you're aiming for.
16:17:41 <solveig> marga: thanks for dealing with the bot, i'm not used to it yet :)
16:17:54 <marga> no prob :)
16:17:59 <detrout> for my own purposes I'd like freeipa in debian, there's a long list of java packages that need packaging
16:18:01 <detrout> #ling https://www.redhat.com/archives/freeipa-devel/2013-September/msg00049.html
16:18:07 <detrout> er #link https://www.redhat.com/archives/freeipa-devel/2013-September/msg00049.html
16:18:14 <paulproteus> marga: Well, the goal from Fedora was to do them weekly. They definitely did not hit that frequency. They seem to aim for 1-3 times per year.
16:18:21 <solveig> paulproteus: i'm a newbie, the first task i took on was to triage bugs, so i added that to "NewbieTasks"
16:18:25 <marga> per year?
16:19:06 <solveig> paulproteus: what was your first task in Debian ? that could probably go there too :)
16:19:15 <marga> detrout: so, I think that what paulproteus says is that you could add "Package freeipa" as a Starling (Bounty)
16:19:38 <paulproteus> Yeah, per year, marga. This is similar to the 4 mentees per year bandwidth you've seen on inbound mails to the mentors list, so it seems within reason. If D-W finds that Starling Bounties are working well, I'm sure no one would object to seeing more of them!
16:20:03 <solveig> what reward would be given ? does debian-women have a pile of nice T-shirts or stickers sitting somewhere ?
16:20:08 <detrout> i think package parts of its dependencies is a starling bounty, packaging the whole thing looks like its taking someone employed by cannonical
16:20:33 <solveig> detrout: haha
16:20:34 <marga> detrout: ok, I have no idea how complicated it is :)
16:20:50 <marga> So, maybe it should be broken into smaller tasks.
16:20:59 <detrout> freeipa is roughly an attempt to build an opensource equivalent to active directory
16:21:14 <detrout> yes. i think packaging some of the dependencies is reasonable for a new person
16:21:19 <marga> I agree with Solveig's question. If we want them to be "Bounties" we should have some prizes.
16:21:33 <paulproteus> Fedora Design Team does something a little stronger, which is to make someone part of the team (commit access, etc.) upon successful completion. I think the best reward here would be, "We'll sponsor your package and get it into Debian, and also we'll welcome you as part of the Debian Women community."
16:22:04 <marga> paulproteus: but we already welcome everyone :)
16:22:07 <paulproteus> The kinds of people who apply for a competition will vary, based on the prizes offered. Therefore, in the classic formulation, you make the prize the ability to do more work / stay more involved.
16:22:17 <paulproteus> marga: That's fine; it still means something when people see it vividly on a nice-looking blog post.
16:22:20 <detrout> have you seen openbadges.org?
16:22:39 <marga> nope, checking it out now
16:23:06 <detrout> Complete the mentoring process and win a certificate! ;)
16:23:13 <detrout> (And thanks)
16:23:35 <paulproteus> Well, if the prize is your stuff lands in Debian, I would say honestly that is super cool.
16:23:44 * detrout agrees with paulproteus
16:23:54 <detrout> also we have people showing up and saying "Can I help debian"
16:23:56 <marga> I'll investigate openbadges later, seems interesting.
16:24:01 <marga> #link openbadges.org
16:24:08 <detrout> the hard part really is giving focused tasks
16:24:16 <marga> detrout: yes, yes, it's true.
16:24:25 <marga> That's the hard part.
16:24:36 * Kinga agree with detrout
16:24:54 <paulproteus> I'd say, if someone wants to commit to finding such a task, then I bet you (possibly with my help) can do it within two weeks, and then we can write up the post within two weeks of that.
16:25:01 <marga> So, you have the freeipa idea, can you write a wiki page that details it, and we do some promotion around it?
16:25:14 <detrout> I can try.
16:25:19 <marga> Awesome :)
16:25:30 <solveig> would "triage 20 bugs from given team/given package" be a focused task ?
16:25:37 <svaksha> marga: can I suggest what I'd love to see packaged in Debian? SciDB in Debian. Sadly I dont have the time or skills (and resources) for it.
16:25:41 <marga> #agreed Diane will try to create a wikipage detailing a freeipa packaging project
16:25:56 <detrout> svaksha: do you have a link to it?
16:26:01 <svaksha> scidb.org
16:26:12 <svaksha> http://scidb.org
16:26:37 <Kinga> #link http://scidb.org
16:26:39 <marga> solveig: yes, I think that it should probably also list a mentor and info like that, that you may be albe to provide.
16:27:01 <detrout> They've got ubuntu packages, so converting it isn't likely to be technically difficult
16:27:40 <paulproteus> Ooh, lovely.
16:27:40 <detrout> They may have license problems instead
16:28:27 <paulproteus> Usually, an element of the design bounties is that they are the one last task waiting before something really cool can happen. For example, in the one I linked, creating a T-shirt design is the missing piece in order to truly thank the Fedora summer coding students.
16:28:45 <paulproteus> Similarly, they are a task that the person writing the post really cares about, and is willing to mentor on.
16:28:52 <svaksha> there is also a python wrapper for it:https://github.com/jakevdp/SciDB-py . I tried to port it to python3, so feel free to bug the core-dev here: https://github.com/jakevdp/SciDB-py/tree/py3k
16:29:09 <svaksha> detrout: ^
16:29:09 <paulproteus> They're also typically doable in 24 hours, so that people can plausibly show up out of nowhere and get them fixed.
16:29:30 <paulproteus> I'm happy to continue discussion post-meeting if that's a better venue, but since we're talking here I wanted to illuminate those points.
16:29:44 <marga> Well, I think that we need to move on, but some very interesting ideas have come up. We would need to get more people involved in coming up with the projects, but it sounds like something we could do.
16:29:49 <paulproteus> Awesome!
16:30:08 <detrout> paulproteus: is there a debian-welcome team somewhere?
16:30:15 <marga> #agreed Let's try to involve more people in coming up with small scoped projects and promoting them in weekly/monthly basis
16:30:41 <marga> #topic Mini-debconf 2014
16:31:05 <marga> So, as you may know, we are planning on having a mini-debconf early next year, where all the speakers are female
16:32:09 <marga> My point for putting this in the topic was to hear ideas from any of you, and to encourage every woman in the meeting to think of a talk that she can present next year :)
16:32:50 <marga> (don't be shy :)
16:32:56 <paulproteus> (for detrout: debian welcome team has an empty mailing list http://lists.alioth.debian.org/mailman/listinfo/welcome-team and a collection of meeting minutes at http://etherpad.mozilla.org/welcoming and some code that we can to track as a group who we have welcomed so far, https://github.com/openhatch/oh-greenhouse , which a gsoc student at OpenHatch is continuing to work on; now back to the marga's topic. I need to loop back with
16:32:56 <paulproteus> Per, my main co-team-lead and plan our next steps.)
16:33:19 <detrout> ty
16:33:28 <detrout> i tend to avoid travel.
16:34:27 <solveig> #link https://wiki.debian.org/DebianWomen/Projects/MiniDebconf-Women/2014
16:35:10 <paulproteus> I'll just say I'm super excited about the conference. Perhaps pleia2 would be interested in talking about her work with OpenStack and maybe her opinions on what Debian can learn from it.
16:35:35 <SynrG> oops, I missed intros.
16:35:40 <marga> I organized a similar event in Argentina, about Free Software in general. And it was very interesting, because it was helpful in getting a lot of women who had never given talks, to give the first step, which is usually the hardest one.
16:35:58 <solveig> i saw there are plenty of venues listed ; is somebody gonna ask them ?
16:36:23 <marga> solveig: Mónica, from Barcelona, is leading the venue seeking team, and it seems to be going well.
16:36:26 <marga> SynrG: hello :)
16:37:02 <SynrG> hi :)
16:37:50 <Droidy> catching up with minutes, gotta go (birthday party)
16:37:58 <marga> Droidy: cheers
16:38:14 <marga> Anyway, I see that there's not much to say here, so, let's move on to the next topic
16:38:23 <marga> #topic Outreach program for women
16:38:45 <marga> This is a program that was originally started by GNOME, but has expanded to several Free Sofware projects
16:39:18 <Kinga> I only can speak about myself.
16:39:21 <marga> The idea is to complement the Summer of Code project, but focusing on getting women to collaborate with the projects, and not only with code.
16:39:29 <Kinga> Partly was discussed before.
16:40:10 <Kinga> Haven't seen a task list that I can read over. Get some information about their difficulties. Then pick one and get mentored.
16:40:27 <solveig> #link https://wiki.debian.org/OutreachProgramForWomen
16:40:50 <marga> For it to work for Debian-Women, we need two things: 1) to come up with projects in this scope (projects that would take about 3 months) 2) to get sponsors to pay the "interns"
16:41:16 <marga> Kinga: exactly, one of the main problems is that we don't have a task lists.
16:42:02 <Kinga> solveig: Isn't that GSoC?
16:42:47 <Kinga> solveig: I mean smaller tasks, not only in difficulties but in time as well.
16:43:22 <marga> Kinga: right, those would be for the mentoring part that we mentioned earlier.
16:43:54 <detrout> i have a vague idea that it'd be neat to have some consistent color palletes available for debian
16:44:08 <detrout> The idea came from reading this blog post http://blog.dustinkirkland.com/2013/08/ubuntu-fun-with-ps1.html
16:44:23 <Kinga> marga: I may help mentoring PHP related tasks. But I would be a mentee in Python tasks.
16:44:32 <marga> I personally think that we currently don't have enough energy to come up with tasks big enough for OPW. We might just try to get going with the smaller tasks, and if that goes well, then move into something bigger like OPW.
16:44:37 <paulproteus> Maybe someone can take an action item on talking to various non-coding parts of Debian about what work they need done?
16:44:44 <detrout> i don't know if there's a debian design / aesthetic team
16:44:47 <paulproteus> For example, wiki team, or listmasters.
16:45:02 <paulproteus> Trying to think what other such teams we can extract tasks from.
16:45:29 * detrout thinks some lists could use anti-spam list moderators
16:46:02 <Kinga> marga: Maybe just drop on a question what female users are missing in Debian? Let the users choose projects for us.
16:46:14 <paulproteus> One thing Lucas Nussbaum and I were thinking of is taking his packaging-tutorial and making it more interactive, like by creating corresponding screencasts.
16:46:20 <marga> Kinga: where can we ask such a question?
16:46:23 <paulproteus> I mention this in my talk, so luckily it's on my mind.
16:46:46 <maxy> Mmh, I think the alioth ones. Probably related to the fusionforge setup
16:46:50 <maxy> detrout: ^
16:47:09 <Kinga> marga: A wiki page, do it in a Debian News entry or something similar.
16:47:18 <detrout> actually a good task might be a blog post / screencast or something answering "how do I use debian"
16:47:22 <detrout> hi maxy
16:47:43 <Kinga> marga: Be it in an open and public page that we ask opinions of other girls.
16:47:50 <maxy> Hi everyone
16:48:09 <marga> detrout: how do I "use"? That's very wide, what would you cover in it?
16:48:35 <paulproteus> Oh, does publicity team need people, perhaps? Maybe they'd be a good collection of people to ping re: non-code Debian tasks.
16:48:42 <marga> #idea Get female users to contribute ideas of what they are missing in Debian
16:49:14 <marga> #idea Get non-code related tasks from non-code related teams, like publicity, webmasters, wiki team, listmasters, etc
16:49:21 <detrout> i was just curious of the people who are already using debian, what they were doing with it...
16:49:34 <detrout> and that can go into example "use cases" showing that debian is useful
16:49:49 <tvincent> paulproteus: publicity team always needs people :)
16:49:54 <marga> deavid: AH! I understand, so you mean people storytelling a bit of how they personally use Debian?
16:49:55 <paulproteus> perfect, tvincent (-:
16:50:04 <SynrG> s/non-code related/non-coding related/ ? (certainly there are tasks related to the code that aren't specifically coding tasks :)
16:50:25 <paulproteus> It might also be interesting to have a OPW intern work on video tutorials for how to use Debian on specific tasks, maybe including a voting process for choosing what newcomer-oriented "How to use Debian" video tutorials get made.
16:50:42 <paulproteus> Or to have someone focus on somehow a "secure computing" or "secure browsing" collection of such tutorials.
16:50:45 <detrout> from that paths into debian talk I was really impressed with the welcome to fedora page.
16:50:56 <marga> Indeed.
16:51:10 <solveig> +1
16:51:14 <marga> #idea Create a welcoming page as friendly as Fedora's
16:51:41 * bdale wanders in
16:51:42 <marga> #idea Create a series of videos on how to use Debian for specific tasks.
16:51:52 <bdale> Bdale, from Colorado, also a dude but always interested in helping here if I can
16:52:07 <detrout> hello bdale
16:52:35 <paulproteus> It also might be mega fun to have an OPW intern come up with ways we expect people to be able to use Debian, and do user testing.
16:52:58 <paulproteus> For those not familiar with user testing, this is where you sit someone new to your software down in front of it and ask them to do a specific task, and record what they attempt.
16:53:13 <detrout> that'd be useful to know
16:53:14 <paulproteus> This way it is possible to see what a newcomer sees, and then use that to guide what to improve in making the software more usable.
16:53:19 <marga> paulproteus: and this would be mega fun? :)
16:53:22 <paulproteus> I think so!
16:53:25 <paulproteus> If I had time I would be doing it!
16:53:32 <paulproteus> I would love that for both the website and Debian in general.
16:53:35 <solveig> i love doing that
16:53:43 <paulproteus> : D solveig for opw intern
16:53:46 <marga> #idea Do some "user testing" for specific Debian tasks
16:53:47 <solveig> no
16:53:58 <solveig> i'm no volunteer
16:54:31 <solveig> but it's fun when friends show their software and i don't use it the way they expect:)
16:55:02 <paulproteus> (-:
16:55:13 <solveig> but to mentor that, you would need to be in the same room
16:55:43 <detrout> I think there's some tools that can do audio & screensharing
16:55:50 <marga> It's great that so many ideas came up for this!
16:56:15 <marga> I think that we still need to deal with the sponsoring part, but at least there's quite a bunch of interesting ideas, which is awesome.
16:56:16 <detrout> Also I think freedombox also has a list of things that need doing...
16:56:29 <marga> So, moving on to the next topic
16:56:34 <paulproteus> marga: I think Debian itself should be the OPW sponsor, fwiw (-:
16:56:35 <marga> #topic Youtube channel
16:56:56 <marga> So, this is related to several things mentioned before.
16:57:13 <marga> I was told that it would be nice to have tutorials or stuff like that in a debian-women youtube channel.
16:57:45 <marga> I think the idea is very interesting, but it's also quite a lot of work, and would only be possible if several people are in charge of producing the content.
16:57:50 <bdale> detrout: indeed .. Petter's recent involvement has been helping a lot from the email stream I've been reading, but FreedomBox is definitely far from "done" and could use more hands
16:58:44 <marga> bdale: would there be a scoped project to give to people? If so, how big would that be?
16:59:13 <marga> I'd like to hear opinions, ideas, etc on the youtube channel.
16:59:54 <detrout> (for the youtube channel, it might make the most sense to have it as part of the debian-welcome, with contributions from debian-women
17:00:04 <bdale> I've had to step back from that work while we recover from the fire, so I'm not really the right one to ask right now. there's a #freedombox channel on this network that's low traffic, and there's the mailing list hosted in Debian list space, both are good places to go lurk and learn
17:00:33 <maxy> marga: I don't think debian and youtube channel mix well together, maybe a html5 page..
17:01:02 <marga> maxy: well, it doesn't necessarily need to be youtube, although the setup is usually easier. It could be any way of sharing videos.
17:01:08 <paulproteus> I think a Youtube channel (or online video collection in general) would be best if scoped toward specific content, and with a focus on getting viewership. Doing that kind of campaign could be a lot of work, and so I would focus on the question of which content we think people would want to see. Perhaps it even makes sense to simply import existing great youtube videos about Debian things, if we can do less work but get similar
17:01:08 <paulproteus> benefits by curating rather than creating. FWIW, in y'all's shoes, I would focus on some achieveable goals, set within some time period, that feel nice and small and don't necessarily commit the group to more work after that time period.
17:01:27 <marga> The important part is to have an online place with short videos, with new material coming in with time.
17:01:50 <paulproteus> So I would try to think about what the specific achievable goals would be. In this case, maybe "5 newcomer-oriented short videos explaining aspects of using Debian, all published in a six month period" or something like that?
17:02:16 <detrout> I'd argue that the videos should hosted somewhere "federated" but then mirrored to youtube as its really an attempt to get new people into debian
17:02:33 <detrout> so discoverability is an important element
17:02:44 <marga> sure, the hosting of the videos is the least of my worries. The content is what matters.
17:03:04 <detrout> paul has a good point
17:03:18 <paulproteus> I would also try to set some quantitative goal about the viewership on the videos, so you can evaluate after the fact if it was worth it to create/share/curate the videos in the first place.
17:03:33 <marga> paulproteus: indeed, just curating the videos from past debconfs / minidebconfs / LCAs and whatever conferences produced some Debian material is quite a task already.
17:04:20 <marga> I wouldn't focus on use, however. But more on how to contribute. i.e. packaging, translating, bug triaging, etc.
17:04:39 <CountryGrrl_AK> Like a video how to?
17:04:47 <marga> CountryGrrl_AK: right.
17:04:54 <CountryGrrl_AK> Nice
17:05:43 <CountryGrrl_AK> I, as a newbie to this, would find such a venue very helpful as I tend to stray a lot if forced to read screen text
17:05:43 <detrout> In an ideal world we could have both user focused & debian contributer focused content.
17:05:44 <marga> #idea We may already have a lot of content videoed, it may be time better spent to just "curate" that
17:05:45 <paulproteus> (I find these kinds of quantifiable goals both motivating and illuminating. The idea to set outreach goals like that comes to me from Jessica McKellar, who does some Debian and Ubuntu stuff now and then as well, mostly within the packaging project of the Python Twisted community.)
17:06:12 <marga> paulproteus: sure, yes.
17:06:13 <detrout> its probably easier to start with contributered focused though
17:06:34 <marga> #idea Have quatifiable goal as to viewership intended to decide if it's worth continuing or not.
17:06:51 <paulproteus> Maybe someone wants to find a handful of existing contributor-oriented videos and pick their favorite, and get publicity for it via Debian Project News and other venues, and then we can see if that increases viewership of that video compared to before the publicity campaign for it?
17:07:19 <marga> Something like "Video of the week"
17:07:43 <detrout> isn't DPN monthly?
17:07:50 <paulproteus> I'd shy away from phrasings that create commitments to do more work.
17:08:01 <marga> yes, you are right :)
17:08:11 <marga> But it has to be something catchy
17:08:13 <paulproteus> (-: I have years of experienc ein disappointing myself.
17:08:22 <detrout> :)
17:08:49 <paulproteus> I'm not sure it has to be catchy necessarily. We could try a non-catchy thing and see if we can still do some boosting of its viewership count. Then we'd know if catchy is strictly required.
17:08:56 <marga> CountryGrrl_AK: since you are saying that you'd find it useful. What content would you like to see that you don't currently see?
17:09:01 <paulproteus> marga++
17:09:20 <CountryGrrl_AK> marga: I really haven't seen anything
17:09:39 <marga> CountryGrrl_AK: sure, what video content would you like
17:09:51 <CountryGrrl_AK> But I should like to see something that explains any of the processes. You know, whats involved and how does it work
17:10:10 <CountryGrrl_AK> An over view kind of thing?
17:10:15 <marga> Sure
17:10:30 <marga> I think that should be covered by some debconf videos
17:10:39 <marga> We just need to dig them out and publicize them
17:10:54 <CountryGrrl_AK> Because I don't know and I find lots of technical writings. But since I don't have the foundation the technical is rather involved
17:11:02 <detrout> something like a "debian orientation" series of welcome videos
17:11:29 <marga> #idea Promote curated videos through DPN or similar media and measure how much viewership increases, to quantify the possibility of creating new content.
17:12:01 <marga> detrout: that's the catchy name I was looking for :)
17:12:12 <detrout> :)
17:12:12 <marga> Anyway, let's move on
17:12:22 <marga> #topic Local event/workshops
17:12:43 <marga> This is another thing that has been suggested to me, but I fear we don't have the people power to make a reality
17:13:04 <detrout> yes
17:13:16 <marga> However, I realize the for a lot of people (me included), meeting in person make a tremendous difference
17:13:39 <paulproteus> As I mentioned, I help run a series of events focused on getting women to know more about and contribute to free software projects <http://campus.openhatch.org/>. So I have a bunch of contacts with Women in Computer Science groups in the US now, fwiw.
17:14:04 * lesleyb waves
17:14:11 <lesleyb> sorry I'm late
17:14:13 <marga> hey lesleyb
17:14:16 <detrout> hello lesleyb
17:14:19 <lesleyb> hi detrout
17:14:22 <paulproteus> hi!
17:14:29 <lesleyb> hi paulproteus and marga
17:14:39 <dunetna> hi, i'm late too, but i'm also here :-)
17:14:56 <lesleyb> I think meeting people in person makes a huge difference
17:15:04 <marga> My main question is how we could make local workshops a reality, given that we are spread very thin.
17:15:04 <lesleyb> hi dunetna
17:15:30 <detrout> find places where there are already a good collection of interested parties?
17:15:38 <lesleyb> given that we are spread thin I think it has to be about networking in the community
17:15:47 <paulproteus> marga: Let me ask you more about what the goals of the local workshops would be. Do you want new women in Debian to be able to meet women also active in Debian?
17:16:00 <paulproteus> Trying to get a sense to see how I can be most helpful to your goals, that is.
17:16:03 <lesleyb> where there are events going on, can we tag along with a space for debian women ?
17:16:26 <lesleyb> there's the geek girl dinners
17:16:33 <lesleyb> I've never been to one of those
17:16:34 <Kinga> paulproteus: What's your experience? Are women confidently go and ask questions or just attend workshops in person?
17:16:45 <marga> lesleyb: I've never heard of that even
17:17:16 <Kinga> marga: We may cooperate with other distributions. Fedora mentioned already.
17:17:21 <lesleyb> it is/was a program where people effectively networked - all female - booked up a dinner party somewhere
17:17:23 <paulproteus> Kinga: In the Boston Python Workshop for women and their friends, which I helped start, lots of women confidently go and ask questions about programming. The instructors are >50% women, and the lead instructor is a woman (Jessica McKellar again).
17:17:46 <marga> paulproteus: I want to help more women get into Debian, and I think that if they meet nice Debian people that can help them, it would make a huge difference. I'm not sure if the workshop-giving person needs to be female as well. It might help, or might be just the same, don't know.
17:17:47 <paulproteus> In the Open Source Comes to Campus events, again, women generally attend and ask questions with similar degrees of involvement as men.
17:17:52 <paulproteus> marga: *nod*
17:18:19 <Kinga> marga: Make it a Linux workshop and let women choose if they like Fedora or Debian or anything else better. May sound bad, but it can help in general.
17:18:41 <marga> Kinga: that makes it even harder to organize. You'd need experts of all the distros.
17:18:51 <lesleyb> and its beats nothing at all
17:19:00 * lesleyb knows of the London Hackspace
17:19:14 <lesleyb> that's a place where people could do something
17:19:51 <paulproteus> marga: Interesting; so for that local events thing, I'm trying to organize (with Christian Körner) an index of low-key social events with Debian people around.
17:19:57 <lesleyb> and there is a community thing aimed at schools which is geek related
17:20:08 <paulproteus> Maybe I can just be reminded to report on that in a month or so?
17:20:13 * lesleyb thinks it's probably about networking in such places
17:20:20 <marga> So, the main goal of Debian Women is to get more women to participate in Debian, not just to get users. But maybe we need to get users first, and only then get them to participate?
17:21:02 <paulproteus> In my opinion, there are lots of women who use Debian, and the easiest sell is to convince someone who already uses Debian to become a contributor.
17:21:03 <detrout> a bit of both i think
17:21:04 <marga> paulproteus: I'll try :)
17:21:05 <lesleyb> I think we need to encourage users
17:21:17 <lesleyb> as well as encourage developers
17:21:23 <Kinga> marga: I mean mostly just Fedora for working together at workshops.
17:22:01 <detrout> debian needs a "better this is how you help" process, but debian also needs some visibility when facing the corporate sponsered distros
17:22:15 <paulproteus> Along those lines, maybe it makes sense to create a "News and tips on Debian, for Debian Women" newsletter, and then somehow do a web-based publicity campaign to capture email addresses of women who already do use Debian, and then periodically advertise the bounties-type stuff in there. I wonder if that "Tips" newsletter could just be a literal copy of DPN.
17:22:18 <lesleyb> +1 on that detrout
17:22:29 <marga> Kinga: sure, I have nothing against working together, I just find it harder to organize, because it means finding a place where you have abundance of both types of "instructors"
17:23:13 <lesleyb> as far as the newsletter idea goes .... I think it would be great if we could also organise to have some documentation that transfers well into a printed format
17:23:32 * Kinga agrees paulproteus
17:23:33 <paulproteus> Oh, for my part, I meant an email-based newsletter, so that we had an easy way to contact those people.
17:23:42 <lesleyb> so we can print up flyers or threefold articles and infos that are up to date.
17:23:48 <marga> paulproteus: that sounds a bit stalking... :-/
17:24:11 <lesleyb> paulproteus: that's great ... that we can send them emails but we have to contact them first to get their email
17:24:26 <marga> Right, that was the stalking part :)
17:24:31 <paulproteus> Even if we only send emails to the debian-women-users list, or whatever, rather than to individuals, we could periodically add something targeted at women, like, "Hey, you're a woman who uses Debian. Have you heard about this month's Starling Bounty, a contest to help women be more involved in Debian?"
17:24:34 <lesleyb> and I think having a few dead tree items - that are up to date - would be useful
17:24:58 <paulproteus> I think that if you sent a "Sign up to this newsletter for women in Debian" sign-up form around to women-in-tech groups, of which there are many and I can connect you with some, then you'd get a sizeable number of sign-ups.
17:25:11 * lesleyb is thinking of when we are actually out there, networking face-to-face
17:25:14 <paulproteus> s/women in Debian/whome who use Debian/
17:25:50 <paulproteus> s/whome/women/ # typos. I should eat breakfast.
17:25:51 <marga> #idea Create a newsletter for women who use Debian, using content from DPN, but also to advertise DW events.
17:26:13 <lesleyb> sounds good to me marga
17:26:28 <marga> #idea Create for-print material that can be given out at hackerspaces and other workshops.
17:26:37 <lesleyb> yep
17:26:48 * lesleyb votes for that one ;)
17:26:53 <marga> :)
17:27:06 <marga> #topic IRC Training Sessions
17:27:14 <Kinga> marga: Hmm. If too much news get pulled in from DPN, then it may not be that interesting. Hope there will be many DW events.
17:27:15 <marga> This is something we did back in 2010 and 2011
17:27:26 * lesleyb thought they were good
17:27:36 <marga> Should we do them again?
17:27:38 <lesleyb> yes
17:27:41 <marga> :)
17:27:48 <lesleyb> :)
17:28:10 <lesleyb> they take time but I think maybe a regular packaging one would be good
17:28:16 <lesleyb> one every quarter or so
17:28:23 <marga> So, the "hard tasks" are: 1) having a list of topics to cover 2) contacting instructors and organizing the sessions
17:28:32 <lesleyb> or every 6 months
17:29:21 <lesleyb> I think we could run certain topics regularly
17:29:24 <lesleyb> bug triaging
17:29:26 <marga> #idea Even if it's repeated, we may want to have a basic packaging training every 6 months, this usually gets quite a number of attendees.
17:29:27 <lesleyb> packaging
17:29:40 <lesleyb> exactly
17:29:45 <marga> #idea Same for bug triaging
17:30:03 <lesleyb> and then we eventually wouldn't need to rely on one 'trainer'
17:30:14 <lesleyb> any of us with the requisite skill could do it
17:30:25 <marga> I'm sure we don't even now need to rely on just one.
17:30:27 <detrout> good idea
17:30:32 <marga> But it's still hard to organize
17:30:49 <lesleyb> yep
17:31:09 <lesleyb> so we need a team or someone who likes doing this stuff to volunteer to organise it
17:31:18 <marga> Indeed. :)
17:31:33 <lesleyb> we need a list of topics - of which two have been mentioned -
17:31:38 <marga> I guess this is another task for the Starlings :)
17:31:49 <lesleyb> who are the starlings?
17:31:56 <lesleyb> s/s/S/
17:32:13 <marga> Something that paulproteus suggested. Like bounties, but with a different word, I don't know what it means exactly :)
17:32:22 <marga> I guess the difference is that you don't get money :)
17:32:23 <lesleyb> Starlings are birds
17:32:26 <Kinga> marga: I may volunter on bug hangling and basic packaging topics.
17:32:29 <lesleyb> they flock in huge quantities
17:33:04 * lesleyb tries to avoid thoughts on the amount of guano involved
17:33:11 <marga> ouch
17:33:13 <lesleyb> .. but they make wonderful patterns in the sky
17:33:39 <lesleyb> okay Kinga you're on the list of whatever we are
17:33:50 <maxy> There are some new and hot topics, like jenkings, or autopkgtest.
17:34:07 <marga> #idea We need someone / a team to coordinate the trainings, get the trainers, etc.
17:34:24 <solveig> git and/or svn sessions could be useful, they attracted lots of people during DebConf
17:34:32 <lesleyb> hot nd new are always good - they can be run as one offs initially and then if they stick they'll be added to the rota
17:34:41 <marga> #idea Git basics or similar
17:34:45 * lesleyb likes git
17:35:00 <paulproteus> I must run off; pardon me. I hope the rest of the meeting goes great, and I will read the logs. Thanks for having me, and I hope my contributions were useful, and if people have any feedback on style or my talking too much or anything, don't hesitate to email me or PM. Thanks!
17:35:17 <detrout> thank you paulproteus
17:35:18 <lesleyb> thanks for your contribution paulproteus
17:35:27 <lesleyb> good to have you here
17:35:42 <marga> #idea Other possible topics: jenkins, autopkgtest
17:35:45 <solveig> paulproteus: you talk too much but to say useful things so you're excused from me :)
17:35:59 <marga> #topic Any other ideas?
17:36:09 <marga> Anything else that we didn't cover?
17:36:13 <marga> Go crazy! :)
17:36:24 <solveig> other sessions ideas, you mean ?
17:36:27 <lesleyb> the thing is --- if we do something like make up a db of topics and trainers ... we could have emails, irc nicks of trainers etc
17:36:32 <marga> Any ideas of what DW can do.
17:36:35 <solveig> or ideas related to DW in genral ?
17:36:40 <lesleyb> then we could use that to write up the wiki pages
17:36:41 <detrout> i've thought that i should encourage myself to start writing a blog, and have some of it show up on the planet debian
17:36:50 <lesleyb> or section on the training sessions
17:36:58 <lesleyb> yes you should detrout
17:37:05 <lesleyb> my blog is in disarray
17:37:17 <solveig> it could be nice to have a "DW diner / breakfast / session" during the next Debconf
17:37:30 <lesleyb> I haven't re-installed movable type since I reset my server so it's there looking fairly 1908's
17:37:31 <marga> solveig: what would it be?
17:37:49 <dunetna> solveig: +1
17:37:57 <marga> I was hoping to have a DW day, where all talks are given by women :)
17:38:02 * lesleyb approaches her blog as a set of notes to herself about stuff
17:38:13 <lesleyb> that sounds ambitious marga :)
17:38:15 <solveig> marga: like this irc meeting, but in real-life during DC, advertised beforehand so newbies know they'll be welcomed by humans
17:38:18 <marga> Sure :)
17:39:03 <solveig> it my help with getting more women to DC / Debian in general
17:39:12 <solveig> *might
17:39:18 <lesleyb> well I suggest we could have DW meetings/breakfast/brunch thing and we could have a DW day
17:39:23 <lesleyb> but not on the same day
17:39:30 <dunetna> could we have dinner/breakfast/session in our cities in the same day?
17:39:34 <marga> #idea have some DW session during next DebConf where people are specifically welcome to participate
17:39:41 <solveig> dunetna: great idea
17:39:45 <lesleyb> maybe the meeting/brunch thing before the DW day
17:39:56 <lesleyb> that sounds cool dunetna
17:39:59 <marga> dunetna: how do you mean?
17:40:19 <detrout> Oh yeah. another situation to meet people... getting a gnupg key signed (or signing them) https://wiki.debian.org/Keysigning/Offers
17:40:30 <solveig> i'd say at the beginning
17:40:32 <solveig> it would serve as a welcoming time
17:40:41 <marga> solveig: yes, I was thinking the same
17:40:44 <lesleyb> +1 solveig
17:40:51 <dunetna> for instance, have the DW dinner on a specific day trying to joi local people interesetd int he topic
17:41:02 <marga> #idea (particularly useful if at the beginning of DebConf)
17:41:35 <marga> like a global meet up of Debian Women?
17:41:39 <dunetna> but i'm not sure it would work, if we could gather enough people...
17:41:46 <dunetna> marga: yes
17:41:51 <solveig> that would be a nice event to advertise
17:41:59 <marga> Yes, that's my fear as well, but we can still try it and see how it goes
17:42:00 <lesleyb> we could then take pics and post them in a gallery
17:42:01 <dunetna> (marga: you said go crazy ;-) )
17:42:08 <lesleyb> on the wiki perhaps
17:42:09 <solveig> :))
17:42:12 <lesleyb> and also on our own blogs
17:42:22 <marga> #idea Organize a global day for DW dinner, in every city
17:42:45 <marga> I think it's a crazy but very interesting idea
17:42:46 <marga> :)
17:42:50 <dunetna> :)
17:42:57 <moray> (hi, sorry I missed most of the meeting, just back in now from Glasgow)
17:43:05 <dunetna> hi moray!
17:43:13 <solveig> moray: you'll read the notes
17:43:16 <moray> marga: sounds like it would interact with the local Debian meetings idea
17:43:17 <lesleyb> here's the http://girlgeekdinners.com/ - someone might be able to crash their dinners
17:43:22 <lesleyb> hi moray
17:43:32 <moray> solveig: in fact, I assumed it was finished, so I was reading scrollback until now, then I found it was still going on!
17:43:39 <marga> #link http://girlgeekdinners.com/
17:43:40 <solveig> moray: you arrive in time for the "crazy ideas" session
17:43:59 <marga> Yeah, it's been 100 minutes already.
17:44:04 <moray> yeah
17:44:15 <moray> anyway, it looks like some good topics were covered earlier on :)
17:44:27 <dunetna> this one is not so crazy but... we need more D-W t-shirts!
17:44:32 <moray> lesleyb: right, many cities will have some exciting women and technology type group
17:44:48 <moray> dunetna: I was thinking that re the bounties thing above
17:44:49 <marga> #idea New debian-women t-shirts
17:44:56 <solveig> i want a DW T-shirt :)
17:44:59 <dunetna> i want one and i haven't seen one in any debconf since 2011
17:45:06 <solveig> (NOT pink please)
17:45:21 <moray> maybe something more than the most basic design, if we can get some new design ideas
17:45:24 <marga> I think it's time to wrap up. I'll be sending minutes to the mailing list (likely tomorrow). Please keep thinking crazy ideas! :)
17:45:39 <moray> (or at least, not only the plain geek black ones)
17:45:40 * lesleyb doesn't want a women's fit tee
17:45:51 <marga> #idea Get new design ideas for the t-shirts
17:45:51 <detrout> ok thank you marga
17:45:53 <lesleyb> thanks for your work on this marga
17:46:00 <moray> lesleyb: I think the last time round we took size orders from everyone in advance
17:46:01 <maxy> Mmh, debian women of the month gets a t-shirt.
17:46:10 <lesleyb> lol maxy
17:46:15 <detrout> Also I have to run now. bye
17:46:20 <lesleyb> bye detrout
17:46:30 <moray> lesleyb: if we want them for bounties etc. it could make sense to order extra ones, but I'm sure we can take specific size orders in advance as well
17:46:45 <marga> Yeah, the problem with that is the budget, but it's an idea that we would definitely like to have, if possible.
17:46:53 <lesleyb> yep
17:46:57 <CountryGrrl_AK> Thank you so much for running this meeting marga
17:47:00 <lesleyb> budget is god
17:47:11 <moray> marga: if we got organised to use our favourite printer, then the cost per t-shirt is rather low
17:47:14 <solveig> thanks marga
17:47:25 <marga> moray: you mean Mexico?
17:47:36 <moray> marga: yeah, though I'm not sure we would want enough to justify that
17:47:49 <marga> justify what, sorry?
17:48:11 <moray> I mean, if we only print a few, then doing it in Europe will be cheaper than having them delivered from Mexico, I would expect
17:48:18 <moray> or less hassle at least
17:48:25 <marga> well, if delivered to Europe :)
17:48:34 <marga> But sure, I see your point.
17:48:37 <moray> if someone can take care of a stock of t-shirts, then Mexican printing definitely makes sense
17:48:54 <marga> Anyway, I think it's a good idea in general.
17:49:10 <marga> Will end meeting now, so the bot logging stops, but everyone can keep talking :)
17:49:12 <marga> #endmeeting