17:06:40 <unknown_lamer> #startmeeting
17:06:40 <MeetBot> Meeting started Sun Jul 24 17:06:40 2011 UTC.  The chair is unknown_lamer. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:06:40 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:06:49 <unknown_lamer> #topic Roll Call
17:06:59 <darst> #info rkd
17:07:00 <unknown_lamer> Please write `#info $HCOOP-USER' if you are present
17:07:03 <unknown_lamer> #info clinton
17:07:04 <Smerdyakov> #info adamc
17:07:05 <bipt> #info bpt
17:07:06 <kuril> #info ryan
17:07:22 <Smerdyakov> Great!  Zero matches with nicks. ;)
17:07:52 <unknown_lamer> one nit: for #action things we need to use IRC nicks so meetbot knows who it is
17:08:01 <Smerdyakov> OK
17:08:18 <unknown_lamer> ok, since it appears the rest of the channel is idle we can end the roll call and head on over to item #1 unless anyone has any last minute additions to the agenda
17:08:45 <bipt> question: can we discuss transferring accounts to the NCB, or should that wait until the next meeting?
17:09:15 <unknown_lamer> bipt: as a board member you have full permission to add any agenda topic ... what the answer is no one knows
17:09:20 <unknown_lamer> but we should tack that onto the end
17:09:52 <bipt> ok, adding
17:10:05 <darst> you can see I divided it up into a board/admin sections... if you want to make a distinction
17:10:21 <unknown_lamer> yes, the board is not really interested in theory what the admins are doing
17:10:26 <Smerdyakov> I certainly appreciate holding separate meetings.  I would rather skip an admin meeting.
17:10:26 <unknown_lamer> except for that pesky overlap thing
17:10:34 <unknown_lamer> ok, so let's go to topic #1...
17:10:42 <unknown_lamer> #topic Progress Report
17:10:56 <unknown_lamer> bipt: as the secretary, what were those tasks we were all assigned last time again?
17:11:27 <bipt> HCoop's domains were to be transferred to gandi.net
17:11:39 <unknown_lamer> #info HCoop's domains were to be transferred to gandi.net
17:11:43 <Smerdyakov> One task not completed is getting http://hcoop.net/board/ up to date. ;)
17:12:12 <unknown_lamer> Smerdyakov: at least bipt has been busy getting emacs working on guile so ey has a valid excuse ;)
17:12:51 <Smerdyakov> I don't really care so much.  I'm trying to spin down my involvement with HCoop, so y'all are free to get disorganized in any way that doesn't slow down my divestment. :P
17:13:07 <unknown_lamer> Smerdyakov: I pestered em about it a few days ago
17:13:25 <unknown_lamer> the /board area is ... why did exactly 0 secretaries bother keeping it up to date after the initial setup...
17:13:32 <Smerdyakov> So the meeting log with action items isn't up on the web somewhere?
17:13:39 <Smerdyakov> (from last time)
17:13:39 <unknown_lamer> it is but I forgot where
17:13:44 <bipt> Smerdyakov, it's on the meetbot page: http://meetbot.debian.net/hcoop/2011/hcoop.2011-04-23-17.01.html
17:13:47 <darst> http://hcoop.net/~rkd/hcoop/logs/
17:14:01 <unknown_lamer> ok
17:14:02 <Smerdyakov> But apparently we confused it.
17:14:03 <bipt> the other items were that Smerdyakov and darst were going to coordinate to get darst access to the wells fargo account
17:14:10 <bipt> and i was going to get our physical records from frank
17:14:25 <unknown_lamer> ok, so physical docs first: those were sent, yes?
17:14:32 <darst> #info adamc and rkd are meeting this Wednesday to get wells fargo bank account transfered
17:14:51 <bipt> #info frank sent hcoop's physical documents to bpt
17:15:17 <unknown_lamer> ok, so it looks like we actually accomplished the few goals we assigned last time
17:15:20 <bipt> yes
17:15:41 <unknown_lamer> Any further comments on the topic?
17:15:42 <bipt> unknown_lamer, you did get the domains transferred, iirc?
17:15:57 <unknown_lamer> yes
17:16:03 <unknown_lamer> you already #infoed that too
17:16:14 <unknown_lamer> oh wait, I missed the "to" in "to be"
17:16:17 <bipt> i #info'ed the todo item (:
17:16:26 <bipt> #info unknown_lamer transferred HCoop's domains to gandi.net
17:16:49 <unknown_lamer> info on accessing them is available to admins
17:17:11 <Smerdyakov> unknown_lamer, does someone besides you have the info stored off of HCoop servers?
17:17:13 <unknown_lamer> also I am listed as the contact for everything so I need to clean that up, but HCoop owns them now!
17:17:22 <unknown_lamer> Smerdyakov: no one else has the info off of hcoop servers
17:17:34 <Smerdyakov> unknown_lamer, sounds like an action item to me, though maybe it's for "the admin meeting."
17:17:53 <bipt> #info (the secretary should remove the first domain-transfer #info from the minutes)
17:18:15 <unknown_lamer> #action unknown_lamer will give another board member the information to administer our domains
17:18:27 <Smerdyakov> I was thinking of it more in terms of admins than board members, but OK.
17:19:09 <unknown_lamer> Smerdyakov: we can discuss the details later... darst could just grab the info now
17:19:18 <unknown_lamer> that satisifes both board-member-p and adminp
17:19:21 <Smerdyakov> Ready for next item!
17:19:29 <unknown_lamer> alright
17:19:35 <darst> I can copy the information to a secure encrypted filesystem where I keep my other sensitive stuff
17:19:36 <unknown_lamer> #topic Financial Status
17:19:47 <unknown_lamer> darst: ok, can you just #info the stuff from the wiki for the meeting minutes?
17:20:28 <darst> #info: Total cash assets: USD 3519.66
17:20:41 <darst> #info Sum of active member balances: 5931.85
17:21:06 <darst> #info Latest income from last billing cycle: 784.00  (has been going down slightly)
17:21:27 <Smerdyakov> You know, the portal is out of date.
17:21:34 <Smerdyakov> I haven't been adding charges to the co-op.
17:21:41 <Smerdyakov> I should do that now, and then we use the new numbers.
17:21:53 <darst> #info monthly expenses: 774.85  (monthly+yearly/12)
17:22:07 <darst> so we need a few new members...
17:22:26 <unknown_lamer> darst: is there a way to quickly figure out how many members left vs joined?
17:22:53 <unknown_lamer> also after the meeting I want to deal with this ALF character. I think we need to reject the application since whoever it is never paid and ... is using a probable fake name
17:23:02 <kuril> I was going to bring that up
17:23:04 <unknown_lamer> oh wait, we gave ALF an account
17:23:23 <darst> may+june+july had five members retiring
17:23:39 <kuril> I was wondering about that.  Sketchy apps like that make me think someone is up to no good.
17:23:44 <Smerdyakov> There.  Done.
17:23:45 <darst> and I think one or two new ones
17:24:14 <darst> I thought the name on google checkout did match the user name...
17:24:32 <Smerdyakov> #info Real latest co-op balance: $-1652.83
17:26:02 <Smerdyakov> Darn it.  The portal numbers vs. real-world account balances don't add up again.  Off by $700.
17:26:11 <unknown_lamer> which way?
17:26:19 <Smerdyakov> Too little money on hand in real life
17:27:07 <unknown_lamer> urgh, we need to do an audit but I hear that is a huge PITA
17:27:20 * Smerdyakov thinks.... that is about the amount we'd expect from one missed Peer 1 payment somewhere.
17:27:53 <unknown_lamer> Smerdyakov: would you be willing to assist darst in doing an audit as your final act of anything treasurer related since we avoided performing one for so long?
17:27:58 <Smerdyakov> Anyway... ain't the sort of thing we can resolve right now.
17:28:15 <Smerdyakov> unknown_lamer, willing to provide certain kinds of assistance, but not necessarily all. :P
17:28:20 <darst> I have recently been playing with "ledger", a command line accounting tool
17:28:37 <unknown_lamer> the specifics we can discuss on list, I just wanted to check
17:28:40 <darst> I have tracked all of DebConf's finances with it
17:28:59 <Smerdyakov> OK.  Anything else to say on this item?
17:29:03 <unknown_lamer> #action Smerdyakov and darst will figure out on list how to resolve our account balance discrepancy
17:29:16 <unknown_lamer> that should be it
17:29:37 <unknown_lamer> do we need a separate topic for transfering the bank info, or can I assume Smerdyakov and darst can handle that on their own?
17:29:50 <Smerdyakov> We're handling it.
17:29:51 <unknown_lamer> unless bipt needs to fedex someone papers or something
17:29:52 <darst> I think we got it
17:29:59 <Smerdyakov> And it's not just transferring info.
17:30:04 <Smerdyakov> We have to meet in person to transfer access rights at the bank.
17:30:19 <unknown_lamer> ouch, I hope you were going to be in nyc anyway this weekend
17:30:19 <darst> Smerdyakov: does wells fargo need a copy of a board resolution saying I am the new treasurer ?
17:30:48 <unknown_lamer> ok, so ... if you two can handle that on your own ...
17:30:53 <Smerdyakov> I doubt it, but I can't say for sure.
17:30:59 <unknown_lamer> #topic Acquiring a machine to replace mire
17:31:15 <kuril> banks usually only care if the signatory is there
17:31:22 <kuril> but then that's for personal accounts
17:31:23 <unknown_lamer> I am of the opinion that now that we have a fast machine doing afs we need a fast machine to replace mire since it is the weakest link
17:31:31 <unknown_lamer> otoh, we don't really have money for it
17:31:52 <unknown_lamer> I *thought* we had at least $1000 more than we do...
17:31:53 <Smerdyakov> I still think it's ridiculous for us to have multiple machines.
17:32:04 <unknown_lamer> I think a two 'machine' set up is ideal
17:32:15 <Smerdyakov> I would be OK with one as a backup, but not doing regular duty.
17:32:16 <unknown_lamer> the KDC and such really do need to be segregated from user access
17:32:26 <Smerdyakov> We just don't have enough activity now to saturate fairly cheap single machines of today.
17:32:41 <unknown_lamer> yes, which brings me to ... rkd suggested kvm
17:32:42 <Smerdyakov> And, of course, I'd rather see Kerberos and AFS dropped.
17:32:59 <darst> suppose we acsked 15 members to add $100 to their balance in order to fund a new machine?
17:33:04 <unknown_lamer> which I was opposed to initially, but then I discovered that oh wow it has online live migration...
17:33:22 <unknown_lamer> Smerdyakov: If afs and kerberos are dropped I am retiring...
17:33:31 <kuril> problem with new machines in the past is that we often let them sit unused for months until someone gains time to configure it
17:33:32 <unknown_lamer> openafs sucked initially *because we were using an untested release*
17:33:41 <unknown_lamer> now that 1.4 is mature it is rock solid and I do not want to give up the convenience it provides
17:33:56 <unknown_lamer> kuril: yes, hence my requirement that I actually port fwtool before we did *anything*
17:34:06 <bipt> afs doesn't seem to be causing any real problems except for people assuming normal ssh keys and such will work
17:34:07 <unknown_lamer> now, rkd pointed out that we could use kvm on fritz and I am actually liking this idea now
17:34:50 <Smerdyakov> I'm sorry I brought it up.  I'm incorrigible.
17:35:05 <darst> I can do the kvm setup fairly quickly - only "tricky" part is setting up its ethernet as a bridged interface, which I think I can do while it's still running
17:35:22 <Smerdyakov> unknown_lamer, can you summarize your complete plan for final utilization of machines?
17:35:27 <unknown_lamer> ok
17:35:34 <kuril> hm fwtool has the same name as a GIS tool. neat :-0
17:36:37 <unknown_lamer> fritz = everything deleuze does as more. mire2 = what mire does now but more powerful. mire = deprecated, you have N months to GTFO off before we do it for you if your setup is simple, or we just yank the power under you if anything is complicated. deleuze = secondary for fritz, move things off asap. hopper = trash bin
17:37:14 <darst> anyway, for the board meeting:
17:37:20 <unknown_lamer> one thing we could do right now is get hopper offline (I think I can get that done today actually), remove its drives as spares for deleuze (they use the same drives down to the model#), and then sell the carcass
17:37:21 <darst> is it agreed we don't go buying another machine just yet ?
17:37:40 <unknown_lamer> darst: hang on
17:37:52 <unknown_lamer> I want to vote after we deal with hopper...
17:38:05 <Smerdyakov> OK, so we'd have 3 physical machines at Peer 1?
17:38:06 <unknown_lamer> xanadu and hopper were mistakes... and getting rid of baltar ugh
17:38:17 <kuril> I'd prefer we get our finances straight before making any purchases and asking for donations from any member
17:38:24 <unknown_lamer> Smerdyakov: after deprecated mire and deleuze two
17:38:33 <unknown_lamer> + kvm &c
17:38:40 <Smerdyakov> unknown_lamer, I thought you were saying that deleuze would stay around as "secondary"?
17:39:00 <unknown_lamer> Smerdyakov: for another year at most
17:39:15 <unknown_lamer> I think this is getting into admin discussion territory
17:39:17 <Smerdyakov> So your eventual plan involves no backup machine for Kerberos and AFS?
17:39:19 <bipt> then it'd be just fritz and mire2, plus offsite backup etc.?
17:39:38 <unknown_lamer> Smerdyakov: the plan is more complicated and I think we should vote on not spending money now and whatnot
17:40:05 <Smerdyakov> Well, I agree that it would be scary to spend money now.  I think this discussion _is_ important to figure out what we _wish_ we could spend, on some rational plan.
17:40:08 <unknown_lamer> the main board issue here are: do we buy a new machine (seems like no, which I agree with now), and do we remove and sell hopper?
17:40:18 <unknown_lamer> removing and selling being separate issues, we could just recycle it
17:41:16 <Smerdyakov> I'm happy to vote in favor of any of those....
17:41:21 <unknown_lamer> ok,
17:41:38 <unknown_lamer> #info vote: the board will not authorize the purchase of a new machine for now
17:41:41 <unknown_lamer> +1
17:41:44 <darst> I think kvm on fritz, migrated to a new machine once we can
17:41:45 <Smerdyakov> +1
17:41:45 <darst> +1
17:41:49 <kuril> +1
17:41:55 <bipt> +1
17:42:00 <unknown_lamer> #agreed the board will not authorize the purchase of a new machine for now
17:42:33 * Smerdyakov thinks the new desktop he just got at work is more powerful than any of HCoop's servers. ;)
17:42:38 <unknown_lamer> now, for hopper, is everyone OK with just admitting it was a waste of money and getting rid of it?
17:42:53 <Smerdyakov> I don't even remember the circumstances of buying it.
17:43:03 <unknown_lamer> I want to hear discussion on this before we vote. mostly from darst since he has to remove it and deal with it
17:43:04 <kuril> I don't either
17:43:13 <unknown_lamer> Smerdyakov: ntk purchased xanadu and hopper for 'cheap'
17:43:17 <Smerdyakov> Is this the machine ntk brought in without getting official approval?
17:43:18 <bipt> neither do i, and i don't remember what it's doing now (spamd?)
17:43:20 <darst> I can do the removing and shipping
17:43:21 <unknown_lamer> then it turns out the disks costs more than the machines...
17:43:28 <Smerdyakov> (Or even having any discussion that could be construed as unofficial approval)
17:43:32 <unknown_lamer> bipt: spamd, secondary dns, secondary kdc
17:43:41 <darst> as long as we can leave it racked until we are ready to dispose of it
17:43:50 <kuril> so it is at least taking some cpu cycles off other machines at the moment?
17:43:55 <kuril> but not enough to warrant its use?
17:44:22 <unknown_lamer> fritz has a usual load average of 2-3 (with 8 cores, this is too low)
17:44:27 <unknown_lamer> hopper has a usual load average of 1..
17:44:32 <kuril> okay
17:44:35 <unknown_lamer> so given its power use it is wasting a lot
17:44:36 <Smerdyakov> How many cores on hopper?
17:44:51 <unknown_lamer> two processors, one core each (despite what the wiki says)
17:44:54 <kuril> less hardware = less potential for failure = better
17:45:01 <unknown_lamer> they show up as a 2x2 because of hyper threading
17:45:18 <Smerdyakov> I'm ready to vote hopper off the island.
17:45:23 <kuril> me too
17:45:27 <unknown_lamer> but they are also Xeon P4s that are less powerful tahn deleuze's, the IBM support sucks, drives are incredibly expensive, &c &c &c
17:45:44 <unknown_lamer> #info vote: hopper will be decomissioned asap
17:45:45 <unknown_lamer> +1
17:45:48 <Smerdyakov> +1
17:45:49 <darst> +1
17:45:49 <bipt> +1
17:46:22 <unknown_lamer> #agreed hopper will be decomissioned asap
17:46:28 <unknown_lamer> kuril doesn
17:46:35 <kuril> +1
17:46:37 <unknown_lamer> t get to vote it off the island apparently
17:46:47 <kuril> sorry
17:47:02 <unknown_lamer> so, as for selling the carcass...
17:47:13 <Smerdyakov> That depends on what we could expect to get for it.
17:47:28 <unknown_lamer> we should keep the drives for deleuze (the rootfs RAID1 uses identical disks)
17:47:34 <Smerdyakov> Then we compare that against the labor costs of selling.
17:47:35 <kuril> I would be surprised to expect much for the time put into trying to sell it
17:47:48 <unknown_lamer> and then I think a local nyc only craigslist post and "you have to come and get it from us" will be the best plan
17:47:52 <kuril> finding a good free E-Waste program would probably be more worthwhile
17:47:53 <unknown_lamer> if no one wants it, off to the recycling center
17:48:30 <darst> yeah
17:48:33 <kuril> okay
17:48:40 <unknown_lamer> darst: how hard would it be to get hopper out of the rack do you think?
17:49:07 <unknown_lamer> well, I guess we can discuss the details detail;s later but
17:49:16 <darst> hm
17:49:19 <darst> let me check the pictures
17:49:30 <darst> I think for all of them, pulling out of the rack should not be too hard
17:49:41 <unknown_lamer> #info vote: we will attempt to sell hopper locally and recycle it if it proves difficult
17:49:42 <unknown_lamer> +1
17:49:46 <kuril> +1
17:49:49 <darst> there is a bit of a problem with misalignment of some machines and some not screwed in
17:49:52 <darst> +1
17:50:02 <Smerdyakov> +1
17:50:03 <bipt> +1
17:50:03 <darst> but physical logistics should *not* be a limiting factor
17:50:19 <unknown_lamer> #agreed we will attempt to sell hopper locally and recycle it if it proves difficult
17:50:40 <unknown_lamer> darst: alright, I'll look at the images &c too in a bit and we can figure out how exactly to get it out
17:50:49 <darst> talk -> sysadmin meeting
17:51:00 <unknown_lamer> but, since we've voted hopper off the island and deferred purchasing a server...
17:51:12 <unknown_lamer> unless anyone has anything else to say on the matter that is board related we can move onto our FINAL TOPIC
17:51:22 <darst> ok, hoopper should not be too hard
17:51:28 <Smerdyakov> unknown_lamer, I'm ready!
17:51:41 <unknown_lamer> #topic Transferring bank accounts to the NationalCooperativeBank
17:51:44 <unknown_lamer> bipt: you have the floor
17:52:36 <bipt> i propose that we move our bank accounts from Wells Fargo to the National Cooperative Bank
17:52:53 <bipt> provided that they can meet our (minimal?) banking needs
17:53:16 <unknown_lamer> an aside: http://www.google.com/search?q=xseries+335&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:unofficial&client=iceweasel-a#q=IBM+xseries+335&hl=en&safe=off&client=iceweasel-a&rls=org.mozilla:en-US:unofficial&prmd=ivns&source=lnms&tbm=shop&ei=HVwsTtDPDonX0QHCxrjkDg&sa=X&oi=mode_link&ct=mode&cd=5&ved=0CA8Q_AUoBA&bav=on.2,or.r_gc.r_pw.&fp=fb7158b64f4d7106&biw=974&bih=707
17:53:17 <Smerdyakov> Where do they have branches?
17:53:59 <Smerdyakov> I don't want to have too much say in this decision, since I don't want to be dealing with our finances at all by a few months from now; but it seems prudent to consider the ease of future treasurer transitions.
17:54:06 <kuril> bipt: what reasons are there besides moving from a non-cooperative bank?  what are the presumed benefits?
17:54:14 <Smerdyakov> Wells Fargo's essentially regional nature has been a huge pain in the ass this time around.
17:54:37 <darst> http://www.ncb.com/default.aspx?id=4114  NCB branch locations
17:54:37 <Smerdyakov> They're less regional with the purchase of Wachovia, but still a pain for Bostonians.
17:54:47 <bipt> Smerdyakov, they have national offices in NYC, DC, Oakland CA, and also alaska and virginia and ohio
17:55:00 <Smerdyakov> (And here I'm referring to an issue that came up when I moved locations.)
17:55:07 <bipt> and branches in ohio. i'm not sure whether you can do banking at the national offices or not
17:55:12 <bipt> and of course they have online banking
17:55:17 <unknown_lamer> do we qualify as a cooperative for their purposes?
17:55:17 <darst> bipt: if they have fewer locations, can we do more without visiting a location?
17:55:34 <Smerdyakov> Wells Fargo has online banking, but won't allow authorization of new account users without both old and new people showing up at a branch.
17:55:35 <bipt> kuril, the primary reason would be to move to a non-profit cooperative bank
17:55:37 <unknown_lamer> (FWIW I like the idea of moving to a cooperative bank)
17:56:22 <Smerdyakov> I'm generally in favor of for-profit service providers, but I recognize that view may not mesh with the most common views of HCoop members. ;)
17:56:25 <kuril> bipt: do they have benefits for cooperatives that WF does not provide?  Do they charge fewer fees etc?
17:56:50 <Smerdyakov> You know, this question probably deserves a hcoop-discuss thread.
17:57:19 <bipt> kuril, part of their charter is to help finance cooperatives, so they'd likely be easier to work with if we needed loans in the future
17:57:31 <kuril> it's a big move so some sort of pro/con list should be developed to see what justification there is besides them being a cooperative
17:57:45 <unknown_lamer> that's another thing ... when we do finally get more hardware I wonder if we could /finance/ it
17:57:53 <bipt> i am not proposing to take a vote to move our accounts immediately
17:58:42 <bipt> unknown_lamer, yes, i was thinking about that
17:59:17 <Smerdyakov> My suggested resolution is that bipt starts an hcoop-discuss thread.
17:59:22 <unknown_lamer> ok, if it's ok with everyone I think this needs to be dealt with on discuss
17:59:29 <unknown_lamer> it appears I have one person in agreement
17:59:32 <bipt> +1
17:59:33 <kuril> I agree
17:59:34 <Smerdyakov> +1
17:59:35 <kuril> +1
17:59:38 <darst> +1
17:59:57 <unknown_lamer> #action bipt will start an hcoop-discuss thread about moving to NCB
18:00:00 <kuril> its worth considering but we need more info on benefits and any negative outcomes
18:00:03 <unknown_lamer> ok, is that everything?
18:00:14 <unknown_lamer> kuril: yep, and money is ... a bit important
18:00:45 <Smerdyakov> Meeting over?
18:00:56 <Smerdyakov> Just squeaked past 2:00. :(
18:01:05 <kuril> I have nothing to add
18:01:07 <bipt> +1
18:01:08 <kuril> +1
18:01:09 <Smerdyakov> +1
18:01:19 <unknown_lamer> alright then!
18:01:22 <unknown_lamer> #endmeeting