19:04:51 <Tallguy-Nick> #startmeeting Training WG
19:04:51 <MeetBot> Meeting started Mon Oct 24 19:04:51 2016 UTC.  The chair is Tallguy-Nick. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:51 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:05:20 <Tallguy-Nick> Hi can I just check who is here for the Training WG meeting?
19:05:56 <logrady> I am!
19:06:19 <Tallguy-Nick> welcome! Beginning to think it was going to be a lonely meeting
19:06:44 <BlakeGirardot_> Hi
19:06:46 <Tallguy-Nick> Do you want to try out Mumble, or would you prefer us to stay on IRC?
19:06:47 <logrady> just you and meetbot??
19:06:58 <logrady> IRC is fine with me
19:07:02 <Tallguy-Nick> Welcome Blake
19:07:42 <Tallguy-Nick> OK, I've taken the headphones off - seeemed to get in the way of typing!
19:08:17 <Tallguy-Nick> Okay, we have an agenda at
19:08:22 <Tallguy-Nick> #link https://trello.com/b/ZYzEoama/hot-training-wg
19:09:19 <Tallguy-Nick> I can either work my way through the list, or I'd actually rather just ask if either of you would like to discuss anything in particular?
19:09:39 <logrady> either is fine with me
19:09:56 <BlakeGirardot_> looking
19:12:00 <BlakeGirardot_> I think we can move LearnOSM staging site to the completed category
19:12:13 <BlakeGirardot_> (sorry have not looked at the trello in a long time :)
19:12:33 <Tallguy-Nick> I'm happy with that - Im happy with the method I've been using - seems to work
19:13:13 <Tallguy-Nick> I've moved it
19:14:18 <Tallguy-Nick> Id like to discuss any potential ideas concerning the training of new mappers. I have something I have been considering using LearnOSM, but are there any other ideas?
19:15:02 <logrady> Please share your idea
19:16:19 <Tallguy-Nick> A new section within LearnOSM dealing with mapping with the TM - staged approach for new mappers with sections on imagery alignment and all the other parts that frequently crop up
19:17:11 <logrady> what exactly do you mean with imagery alignment?
19:18:26 <Tallguy-Nick> advice on what to move - buildings or the satellite imagery alignment,
19:21:21 <logrady> I've just done a bit of mapping in #2248 over the past few days and other Hurrican Matthew task over the past few weeks. What I've consistently run into buidings not squared and slighly off from what I'm seeing in the imagery using JOSM. I undertand this is an issue with mapathon mappers using iD.
19:23:05 <logrady> i agree something needs to be done. i'm basically using all my mapping time aligning and squaring buidlings that have already been entered.
19:23:48 <logrady> I know there was some discussion about this issue on the HOT mailing list. Have you looked at all the comments that were shared there? It might be worth it to review the archive as there were a lot of suggestions.
19:24:48 <BlakeGirardot_> I am not sure if the project instructions mentioned the offset or not
19:24:58 <BlakeGirardot_> If not, it would be good if they did mention it.
19:25:07 <Tallguy-Nick> I think there is a lot more that we could / should do for new mappers
19:25:24 <logrady> Blake - honestly I don't think many (new?) mappers read the project instructions
19:26:15 <Tallguy-Nick> But it could also involve more structure for validators. Perhaps we should recommend one or two projects that newbies start on - buildings only. And a few validators give feedback, prioritising those projects?
19:26:25 <BlakeGirardot_> Well. They need too. Everyone should, the should be useful
19:27:13 <logrady> one of the suggestions on the HOT mailing list was to make it so that you had to "check off" that you'd read the instructions - i think others are seeing the same issues that i am.
19:27:51 <BlakeGirardot_> Ya, if they are not reading instructions on the project, the idea they will read LearnOSM is out the window.
19:28:32 <BlakeGirardot_> But I think people do read them, people want to do this right. Maybe we can find out with piwik
19:28:34 <logrady> i think the way to solve the issue is to try to determine the cause(s), is it poor instruction at the mapathons? is iD not suited to these tasks? do we need to make changes to the work flow? is there  something that needs to be done with the TM?
19:29:08 <Tallguy-Nick> There are some that look for info - many visit the beginners section of LearnOSM. I think we could provide even better and structured guidance
19:29:31 <BlakeGirardot_> (piwik is the traffic stats on the tasking manager, not sure if we can tell if people are hitting instructions tab or not)
19:29:39 <logrady> how may people start mapping on their own and how many start via a mapathon?
19:29:44 <Tallguy-Nick> logrady: probably all of those!
19:30:06 <logrady> ok, if it is all of those then what sequence do we need to tackle them in?
19:30:26 <Tallguy-Nick> I'm not sure we want a sequence
19:31:02 <Tallguy-Nick> The TM needs enhancing. but while that happens we can also work on other 'help' and guides.
19:31:15 <logrady> if we figure out an order then some of the other problems might be fixed as a result (one issue may depend on another)
19:32:03 <Tallguy-Nick> I've trained at many mapathons - often you can't used a fixed order, because if depends on the terrain, but
19:32:22 <Tallguy-Nick> start beginners with perhaps buildings, then
19:32:34 <logrady> back to my question about how mappers start using the TM, if it is on their own what resources are they using (can we be sure they look at LearnOSM), if it is at a mapathon, what information is being presented, is it consistent and does it include LearnOSM?
19:33:04 <Tallguy-Nick> There is no 'one' route
19:34:04 <Tallguy-Nick> You can see using piwik, the referring website - haven't studied it for a while for the TM, but there are referrals from a number of places
19:34:16 <logrady> ok, if there is no one route then there is likely no one solution. but i think we still need to prioritize what we want to fix, if we start with LearnOSM documents and the problem(s) persist we will need to take another approach.
19:34:56 <Tallguy-Nick> How have you been getting on with your research? Do you have any ideas on something that could help?
19:35:00 <logrady> piwik is available for learnosm.org. has it been installed for tasks.hotosm.org?
19:35:09 <Tallguy-Nick> yes
19:35:49 <BlakeGirardot_> https://piwik.hotosm.org/ (pop down for selecting what site to see stats for)
19:35:51 <logrady> if by research you mean the HOT Training Centre I have stopped working on that. It is administered by the Activation Committee of which I'm not a mmeber. I suggest contacting Russell to provide and update to the TrWG.
19:35:52 <Tallguy-Nick> #link https://piwik.hotosm.org/index.php?module=CoreHome&action=index&idSite=7&period=day&date=today#?module=Dashboard&action=embeddedIndex&idSite=7&period=day&date=today&idDashboard=1
19:36:27 <Tallguy-Nick> Is there something else we could use / do?
19:37:53 <logrady> not sure what you mean Nick re "something else we could use / do?"
19:38:11 <BlakeGirardot_> I really think it is just limbo at the moment. We know we want to improve the content and possibly migrate it to learnosm
19:38:16 <Tallguy-Nick> I wasn't sure if you were researching something similar but more user friendly?
19:38:47 <BlakeGirardot_> and then refocus the courses on just doing a simple quiz and mark users as having read the materials.
19:39:32 <logrady> I have expertise on online learning environments. I suggested using one of these for the HOT Training Centre as well as on the HOT mailing list. There does not appear to be any interest in pursuing this. You explained to me why LearnOSM needs to stay the way it is. I don't think there is anything left for me to do
19:40:45 <Tallguy-Nick> Blake - could the training centre be made better for absolute beginners, or is it a non starter?
19:41:18 <logrady> Blake - I've suggested quizzes. This is built in to the current software the HOT Training Centre is using (Moodle). But I believe the activation committee is moving it to GitBook. But you'd have to check with them.
19:44:09 <BlakeGirardot_> yes, quizzes.
19:44:58 <BlakeGirardot_> The issue is Moodle is just.... hard UI to make use of, so finding another place for the content I think is a good idea. But moodle is not bad for quizzes and keeping track of who has completed them.
19:46:09 <BlakeGirardot_> It would take a fair amount of work to make the moodle UI much better. It supports templates, but that does not make the work any less nor does it make it any easier to collaboratively work on the content itself.
19:46:35 <Tallguy-Nick> logrady: I think it's worth investigating. I'd like it if the TrainingWG was more than LearnOSM, and would do my best to help if you investigated and tried something - perhaps not moodle, but is there something else?
19:46:36 <BlakeGirardot_> GitBooks seems rather neutral and supports multiple editors for the content
19:48:33 <Tallguy-Nick> ok - I think we need to spend a little more time investigating things.
19:48:47 <logrady> There are many other elearning solutions. I suggested Udemy on the HOT mailing list when the issue about training was discussed. I would need organizational buy-in to set up a course at Udemy. Again, I don't believe there is any interest.
19:49:03 <Tallguy-Nick> I guess that any changes to the TM will be a period of at least months
19:49:17 <Tallguy-Nick> What's involved in setting up Udemy?
19:49:20 <hot_slack_bot> <russell.deffner> sorry all, I'm reading back/lurking in Slack
19:49:34 <Tallguy-Nick> Welcome lurker Russ
19:50:04 <hot_slack_bot> <russell.deffner> There was really only one reason for me to migrate course content to Gitbook...
19:50:22 <logrady> I would need to set the curriculum. See here for some guidelines: https://support.udemy.com/customer/portal/articles/1594299-quality-review-checklist?b_id=3056
19:50:32 <logrady> there's a PDF available for download
19:51:04 <hot_slack_bot> <russell.deffner> Since the formal project ended (and as I wrote in the final report) - we need a way to continually evaluate and improve content - hard/impossible for mutli editing directly in moodle
19:51:46 <Tallguy-Nick> #link https://support.udemy.com/customer/portal/articles/1594299-quality-review-checklist?b_id=3056
19:51:56 <hot_slack_bot> <russell.deffner> originally I was going to just use google docs, Gitbook once we link with the hotosm Github repo we can do issue tracking, etc.
19:51:57 <Tallguy-Nick> just added the link to make the minutes easier
19:52:29 <logrady> i have no issue with no longer using Moodle. I do think it is possibly short sighted to more to another platform that is not designed to support elearning or you may just end up trading one set of problems for another.
19:52:47 <hot_slack_bot> <russell.deffner> And having content in something like Gitbook will hopefully make it easier to see what content can/should go into LearnOSM
19:53:06 <Tallguy-Nick> logrady: is there a cost implication for Udemy?
19:53:13 <logrady> no
19:53:25 <Tallguy-Nick> & where / how is it hosted?
19:53:25 <osmbot-test> Tallguy-Nick: Error: "where" is not a valid command.
19:53:39 <hot_slack_bot> <russell.deffner> is it open source ? ;)
19:53:51 <logrady> we would set the price for participants. of course we would make it free. many others do the same
19:55:10 <hot_slack_bot> <russell.deffner> I think it would be wrong move to go from an open source platform
19:55:24 <logrady> I believe udemy is (was) owned by ESRI. there are many other similar platforms like coursera, EdX, etc. Some require a faculty appointment, which I no longer have.
19:56:49 <logrady> if you want open source you have to host it yourself. does OSM/HOT have the capabillities of installing an open source elearning software?
19:57:26 <Tallguy-Nick> that depends on what's needed.
19:58:00 <logrady> here is one example, http://openmooc.org/
19:59:13 <logrady> if there's a LAMP stack available then I think drupal can be installed. if so there's this possiblity: https://www.drupal.org/project/elearning
20:00:50 <Tallguy-Nick> I got over a 1000 hits when I searched elearning on github, so I think there are possibilities
20:00:55 <Tallguy-Nick> #link https://github.com/search?utf8=%E2%9C%93&q=elearning
20:01:15 <hot_slack_bot> <russell.deffner> I guess I don't see the point in switching; reminder I was being paid to work on the current courses; who/how/why are we going to 'reinvent the wheel'?
20:03:01 <logrady> not sure what you mean by reinventing the wheel, my suggestion is to take curriculum and basically copy/paste into a proper elearning application
20:03:48 <BlakeGirardot_> We are definately limited on system admin time
20:04:23 <logrady> russell - as i understand there is a desire to move the HOT Training Centre from moodle, correct?
20:04:48 <logrady> and as i also understand, the current suggestion is to move it to gitbooks
20:04:49 <hot_slack_bot> <russell.deffner> not really
20:04:55 <Tallguy-Nick> I don't want us to ignore possibilities, but I do think we need a skeleton of an idea of how we would do something, the cost (if any), and what would be involved
20:05:08 <hot_slack_bot> <russell.deffner> we just needed a way to edit/enhance content
20:05:38 <logrady> russell - see blake's comments earlier in this chat about moving away from moodle. he has outlined quite a few issues.
20:05:43 <hot_slack_bot> <russell.deffner> that's where moodle get's tough is a multi-user editing/commenting solution
20:06:21 <Tallguy-Nick> ok.  If moodle didn't work, we need to investigate what potential other resources there are
20:07:00 <logrady> nick - as i understand it the activation committee is moving the HOT Training Centre to GitBook, Russell can you confirm?
20:07:03 <BlakeGirardot_> Ya, the key issue with moodle is it is hard to collaborate on content. And the UI for sure is top heavy. So I think we are looking at where the content might live, and how to use moodle just for the things moodle is best at.
20:07:06 <Tallguy-Nick> We need something that a 'team' could work on, not just an individual
20:07:17 <hot_slack_bot> <russell.deffner> We are duplicating content
20:08:52 <Tallguy-Nick> I'm still open to ideas  - preferably with a little research behind them, so we can see exactly what could be achieved with available resources, or what resources would be needed
20:09:50 <BlakeGirardot_> Ya, I agree nick
20:10:10 <BlakeGirardot_> So I think the path we are on is.... moving content from moodle to "independent" gitbooks
20:10:29 <BlakeGirardot_> so it can be worked on, while some group figures out the best place for that content to go
20:10:55 <BlakeGirardot_> that supports quizzes, badges, roster, certificates and maybe content there as well.
20:11:15 <BlakeGirardot_> gitbooks is pretty neutral format, it is just markdown
20:11:22 <BlakeGirardot_> so it can go anywhere
20:11:31 <logrady> ok, then maybe putting together a list of requirements might be one step?
20:11:36 <BlakeGirardot_> but there is a onetime process of taking content from moodle and getting it into gitbooks
20:12:04 <BlakeGirardot_> that sounds like a good first  step logrady
20:12:10 <Tallguy-Nick> logrady: yes - sketch out an idea so we have more idea of what would be invloved
20:12:13 <Tallguy-Nick> involved
20:12:55 <Tallguy-Nick> or learnosm Blake - I can add sections
20:13:05 <Tallguy-Nick> #link http://nick-tallguy.github.io/en/tm_mapping/
20:13:16 <Tallguy-Nick> shows something I was 'playing' at to test out
20:14:15 <logrady> this is a good idea but my main concern with mapswipe (and any new mappers' efforts) is that there is no feedback on your work
20:14:44 <Tallguy-Nick> I know - this was just an 'idea' and I needed a starting introduction.
20:15:16 <Tallguy-Nick> Just an embryo at the moment. Need a couple of weeks work before I'm ready to present anything properly
20:16:00 <Tallguy-Nick> I'll try to put something together for the next meeting
20:16:03 <logrady> i think the issue of providing mappers with feedback needs to be addressed at some other issue within the overall workflow of the TM
20:16:27 <logrady> nick - i think what you have done is a great start and a good idea
20:18:58 <Tallguy-Nick> logrady: could you carry on researching an elearning course / environment please
20:19:58 <logrady> nick - honestly i don't think that's probably a worthwhile task for me to engage in. i think the activation committee is in charge of this as they have the course running in the HOT Training Centre
20:21:51 <Tallguy-Nick> As I understand it, the platform there is the problem. Have I got that right? Would another platform be worthy of consideration. You've suggested a couple
20:22:45 <logrady> i think a decision needs to made around requirements first but again, that's up to the activation committee
20:23:30 <BlakeGirardot_> I think the activation wg would be happy to turn it over to the training wg
20:23:44 <BlakeGirardot_> the activation wg is more interested in the content than the platform
20:23:50 <Tallguy-Nick> I'm happy with that - would that help logrady
20:23:52 <BlakeGirardot_> which they can work on via gitbooks in parallel
20:24:58 <logrady> I was told by the activation wg that if I wanted to be involved in changes made to the HOT Training Centre that I needed to join the activation wg. I'm already on two working groups.
20:25:05 <BlakeGirardot_> an expert in elearning would help a lot
20:25:29 <BlakeGirardot_> ok, I'll ask the activation wg if they would be willing to pass the platform part off to the training wg
20:26:02 <Tallguy-Nick> Sounds like a misunderstanding. Activation WG are interested in the Activation curriculum - beginners guide would be our province
20:27:17 <logrady> nick - I assure you, there was no misunderstanding.
20:27:29 <Tallguy-Nick> ...   ok - let's move on
20:28:13 <Tallguy-Nick> BlakeGirardot_: could you find out if we can have access to the platform please?
20:29:11 <BlakeGirardot_> Ya, I'll figure out whats up
20:29:40 <Tallguy-Nick> thanks for that.
20:30:11 <Tallguy-Nick> I'm intending to expand on my start on LearnOSM, and should have something to show at the next WG meeting.
20:30:58 <Tallguy-Nick> BlakeGirardot_: was there any feedback on the TM admin guide?
20:31:02 <Tallguy-Nick> #link http://nick-tallguy.github.io/en/coordination/tasking-manager-project-admin/
20:31:27 <logrady> blake - i emailed you my feedback on your lesson on mapping roads in Africa that's in the HOT Training Centre, have you had any time to look at it?
20:32:18 <BlakeGirardot_> I did read it but I have not had a chance to work on it at all, thank you very much for sending it
20:32:33 <logrady> ok, thanks for the update
20:33:36 <logrady> i think the feedback i provided on the TM admin guide has been implemented, not sure if anyone else has provided edits
20:35:35 <Tallguy-Nick> I think I reviewed your feedback and made changes. Nothing outstanding as far as I know
20:39:26 <Tallguy-Nick> OK - I'm happy to add the module to the main LearnOSM site - it can be expanded as needed
20:40:39 <Tallguy-Nick> #action Tallguy-Nick to add TM admin module to LearnOSM
20:41:30 <Tallguy-Nick> OK - is there any more to be discussed this evening?
20:42:09 <logrady> I have nothing further at this time.
20:42:25 <Tallguy-Nick> OK
20:42:32 <BlakeGirardot_> Not from me, thank you very much logrady and npeihl
20:42:35 <BlakeGirardot_> heh
20:42:35 <Tallguy-Nick> #topic date of next meeting
20:42:37 <BlakeGirardot_> Tallguy-Nick:
20:43:07 <Tallguy-Nick> 7th November 2016, 1900hr UTC
20:43:33 <Tallguy-Nick> I'd like us to try Mumble at the next meeting - but have IRC as a backup.
20:44:10 <Tallguy-Nick> logrady - have you tried mumble?
20:44:36 <logrady> no, is there any value added?
20:44:48 <Tallguy-Nick> you speak instead of type
20:45:20 <logrady> that will mean creating the minutes will likley be difficult and time consuming!
20:45:40 <Tallguy-Nick> If it improves the meeting, I'm willing to try
20:45:47 <logrady> and you can't use skype because you're on a linux box?
20:46:12 <Tallguy-Nick> I can use skype, but my version is a little outdated - still works sort of
20:46:27 <Tallguy-Nick> Mumble is cross platform
20:46:54 <logrady> i use skype for the fundraising wg, the vibe of the mtg is different and there are scant minutes, just bullet points of action items
20:47:32 <Tallguy-Nick> A brief summary sounds good to me
20:47:58 <logrady> i don't know how many active members there are on the TrWG and whether they want to install another piece of software
20:48:18 <Tallguy-Nick> #link https://wiki.openstreetmap.org/wiki/Mumble
20:49:01 <logrady> just looking at here, https://sourceforge.net/projects/mumble/
20:49:40 <Tallguy-Nick> the wiki link I've added has the configuration for 'our' version
20:50:50 <Tallguy-Nick> OK - for next time.  Mumble at the ready if possible
20:51:01 <Tallguy-Nick> Are we ok with an end of meeting now?
20:51:35 <BlakeGirardot_> I am thank y'all for being here.
20:52:02 <Tallguy-Nick> Thanks to all participants & look forward to the next one!
20:52:05 <logrady> yes, thanks to everyone for their participation and efforts
20:52:10 <Tallguy-Nick> #endmeeting