15:06:15 <BlakeGirardot> #startmeeting Tech Working Group Meeting, Nov. 7th, 2016
15:06:15 <MeetBot> Meeting started Mon Nov  7 15:06:15 2016 UTC.  The chair is BlakeGirardot. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:15 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:06:41 <BlakeGirardot> I was just about to add an agenda item
15:07:10 <BlakeGirardot> Cristiano, can you give a brief update on the overall development picture at HOT at the moment? Whats happening basically?
15:07:30 <BlakeGirardot> #topic HOT Dev Activity Overview
15:08:29 <BlakeGirardot> It can be brief, does not have to be super detailed, but would help to know what the moving parts are as it relates to dev projects
15:10:12 <hot_slack_bot> <cristiano> Sorry, kids just got up so I have to go, but yeah
15:10:16 <hot_slack_bot> <cristiano> OK, 1 sec
15:10:47 <hot_slack_bot> <cristiano> - development work on imagery coordination tool as part of PacDID
15:11:15 <BlakeGirardot> #link http://hirc.dev.hotosm.org/
15:11:16 <hot_slack_bot> <cristiano> that just started as of last week and will send out an email with details
15:11:30 <hot_slack_bot> <cristiano> not that one, but yeah on the lines ;)
15:11:54 <hot_slack_bot> <cristiano> we are considering whether it's worth to just build on that or start from scratch
15:12:18 <hot_slack_bot> <cristiano> then also as part of PacDID, more OAM work on UI and API
15:12:21 <hot_slack_bot> <cristiano> more filters
15:12:36 <hot_slack_bot> <cristiano> and have a default TMS for all imagery uploaded
15:12:51 <hot_slack_bot> <cristiano> automatically, instead of having to launch the TMS creation manually
15:13:41 <hot_slack_bot> <cristiano> there's more on OAM, but I can send an email to the list with the complete workplan
15:13:56 <BlakeGirardot> #link https://hotosm.org/updates/2016-07-20_hot_launches_new_pacdid_drone_imagery_project
15:14:18 <hot_slack_bot> <cristiano> on OSM Analytics, since Brussels we have discussed some priorities, but haven't started much work yet
15:14:55 <hot_slack_bot> <cristiano> we will soon, as a couple of projects will start over the next month with potential dev budget for OSMA
15:15:22 <hot_slack_bot> <cristiano> mostly to add more tags/features
15:15:33 <hot_slack_bot> <cristiano> and have guided/thematic analysis
15:15:38 <BlakeGirardot> #link https://hotosm.org/updates/2016-04-28_explore_how_the_world_is_mapped_with_osm_analytics
15:16:15 <hot_slack_bot> <cristiano> there was also some work started by Rodolfo and Martin on improving processing by parallelizing crunch tasks
15:16:28 <hot_slack_bot> <cristiano> I have to check where we're at with that
15:17:08 <hot_slack_bot> <cristiano> OK, sorry guys I really have to run, I wish I had more time to give all the details, but I will follow up later iwth an email or here
15:17:18 <BlakeGirardot> Later cristiano
15:17:27 <BlakeGirardot> I will try and just mention the other stuff I know of
15:17:30 <hot_slack_bot> <cristiano> would be great if we can move the TWG meeting to eiather hlaf hour earlier or 17:30 utc
15:18:01 <BlakeGirardot> The HOT Export tool is getting some attention as well
15:18:22 <BlakeGirardot> Mhairi is leading the effort on that
15:18:47 <BlakeGirardot> I believe she is still in the request for comments phase, prioritization of issues, etc
15:18:52 <BlakeGirardot> so the very beginning
15:19:12 <BlakeGirardot> Agenda: #link https://hackpad.com/TWG-Meeting-11.2016-F1e6EXk65hE
15:19:36 <BlakeGirardot> issues and +1'ing issues here: https://github.com/hotosm/osm-export-tool2
15:19:55 <BlakeGirardot> and check out the attached github wiki where there is documentation on the additional dev work
15:20:28 <FTA> i need to read up a bit more on the export tool's infrastructure before i can dive into helping with those
15:20:50 <BlakeGirardot> HOT Tasking Manager 3.0 - this is officially moving forward as of today actually
15:21:33 <BlakeGirardot> We have a big list of changes and enhancements going in github + a lot of feedback from the missing maps crew
15:21:33 <FTA> wooh!
15:22:20 <BlakeGirardot> I am going to be sheparding that project
15:23:11 <BlakeGirardot> #link https://github.com/hotosm/osm-tasking-manager2
15:23:27 <FTA> though there are many issues open, i think they can be grouped up into a few different categories. but some of them require big-picture answers to whether we want to implement certain things or not
15:23:28 <BlakeGirardot> same deal, please put issues in there and/or give some +1's to existing issues
15:23:43 <BlakeGirardot> FTA: exactly right I think
15:24:05 <BlakeGirardot> I will also be using the github wiki for project documentation
15:24:21 <FTA> yes i think that could use some updating as well
15:25:00 <BlakeGirardot> That is the first stage I think, group up the existing issues and work with the community to decide priorities and answer some "is the TM the right place" questions
15:26:07 <BlakeGirardot> One related note, but not quite a HOT dev project is
15:26:49 <BlakeGirardot> working with #link http://healthsites.io/ to figure out and implement an OSM loop for their curated health sites data
15:27:26 <BlakeGirardot> I think that is it for around the HOT world of dev work
15:28:11 <BlakeGirardot> Any questions or comments on any of the above?
15:28:45 <FTA> i haven't kept up with the training working group lately, but was there any more talk about moving away from moodle? or am i mixing up conversations?
15:29:06 <BlakeGirardot> I can tell you my view on it
15:29:19 <BlakeGirardot> Russ is here, he can tell you his take/understanding as well
15:29:29 <russdeffner> Hi all, mostly lurking but can talk on that point
15:29:48 <BlakeGirardot> We like the ability to quiz and keep track of who has completed specific training
15:29:54 <russdeffner> We'd like the Activation training to be easier to update
15:30:28 <russdeffner> So not 'moving away', but 'duplicating' the content to gitbooks in hopes that facilitates content update/review
15:31:23 <FTA> alright that makes sense
15:31:25 <russdeffner> If we do 'move away' from moodle, we'll need to replace several features like a roster, badges/certificates and 'testing'
15:32:33 <FTA> yes i've had to deal with moodle for academic courses and am not a fan of dealing with content on it. but it does seem to be a good fit for the whole assessment cycle
15:32:58 <BlakeGirardot> That is a good way to say it FTA
15:33:38 <BlakeGirardot> gitbooks seems to be a very good place for editing content and keeping it mostly platform neutral
15:34:30 <FTA> so the future goal would probably be something where the gitbooks content is directly integrated (as opposed to the reading modules on moodle), then they advance to the next page and take the exams through moodle
15:34:40 <BlakeGirardot> Training wg has laura in it and she is an online learning platform expert (among other things)
15:35:41 <BlakeGirardot> but ya, i think that is what we are trying to figure out fta, personally, I think that is a good compromise that addresses things that are important to a diverse group of interested folks.
15:36:12 <FTA> great
15:36:18 <BlakeGirardot> #topic Courses website at hotosm
15:36:23 <BlakeGirardot> heh, little late with that
15:36:58 <BlakeGirardot> Do we have the link to gitbooks?
15:37:48 <russdeffner> https://www.gitbook.com/book/bgirardot/hotosm-activation-curriculum/details
15:38:02 <BlakeGirardot> I will work on getting that url updated to hotosm
15:38:52 <FTA> do you host that through github for gitbook? or is it only on their platform?
15:39:05 <BlakeGirardot> It is a hybrid
15:39:09 <FTA> ok
15:39:33 <BlakeGirardot> At the moment it is all on gitbook, but you can use github to hold the content and still interact with it through gitbook
15:40:44 <BlakeGirardot> One thing I will note is that courses needs to have the software updated
15:41:28 <BlakeGirardot> Which I guess could have been part of the dev overview, dodobas's time has become very limited so we are trying to find someone who can fill in on the more week to week, non critical sys admin work
15:42:13 <BlakeGirardot> At the moment dodobas's time has to be dedicated to "something is on fire" type or priority work :)
15:42:20 <FTA> hehe
15:42:49 <FTA> i don't know much about the stack, but that may be something i wouldn't be opposed to filling in for if we are needing someone
15:43:47 <BlakeGirardot> Ok, cool, we can talk about that off line. It has served us well not having many people have access to our core infrastructure, but we are looking at expanding our use
15:44:16 <BlakeGirardot> of AWS as well so there would be less exposure for more folks to help keep things going.
15:44:51 <BlakeGirardot> Right now most of our systems, all the hot services but OAM run on a physical machine using docker containers
15:45:11 <BlakeGirardot> but as we have seen recently, that is creating quite a load and slowing down the TM
15:45:29 <BlakeGirardot> so some of this should probably get migrated to an AWS instance.
15:46:00 <FTA> alright
15:46:44 <BlakeGirardot> Pretty much to date it has been all dodobas and we have never had to worry about anything systems related, it has all run like a top for years now.
15:47:24 <FTA> yeah since you don't have the hardware to deal with, that makes things easier :)
15:47:50 <BlakeGirardot> Shall we move to the next topic?
15:48:28 <BlakeGirardot> #topic HOTOSM Website
15:48:43 <BlakeGirardot> #link https://github.com/hotosm/hotosm-website
15:49:11 <BlakeGirardot> FTA: Did you have anything specific in mind on this topic?
15:50:17 <FTA> not specifically, just wanted to check if there were any updates
15:50:31 <BlakeGirardot> xamanu: Did you have anything to update related to the website tech side?
15:50:49 <xamanu> The website work is happening, but very basically: I maintain (alone) the updates and here and there some minor enhancements. Issues are handled over github: https://github.com/hotosm/hotosm-website/issues/118
15:51:07 <xamanu> Nothing really special on this. Maybe two issues are worth mentioning:
15:51:32 <xamanu> 1 - I'd love to have a team to work with. Especially for content and life of the website. But as long as I'm doing it alone, there isn't any problem either.
15:52:10 <BlakeGirardot> ( reached out to MSf for spotlight content, got some I need to process into something for the website )
15:52:24 <xamanu> 2 - the server is in bad condition, because it's not upgradeable to an ugly technical issue. I reported this over a year ago and we could never fix it. probably a new sys admin will tackle this. Until then the server is not updates since probably 18 months...
15:52:54 <FTA> most of the updates are through the drupal gui, right, and not the github?
15:53:14 <xamanu> FTA, code is handled through version control (git)
15:53:26 <xamanu> Content is handled through the Drupal GUI
15:53:47 <BlakeGirardot> xamanu: Is that a good idea?
15:54:01 <xamanu> BlakeGirar, what?
15:54:24 <BlakeGirardot> code update via github v. via drupal's building in updating mechanisim
15:54:35 <BlakeGirardot> built in mechanism*
15:55:03 <xamanu> drupal's building in updating mechanism is NOT the recommended way to do it. It got included for people who are not familiar with servers.
15:55:21 <BlakeGirardot> fair enough, that is why I asked :)
15:55:56 <xamanu> You usually don't want to have writing access to all files of the website. That's actually a security issue.
15:56:30 <BlakeGirardot> Sounds to me like we need to make this kind of a very high priority issue
15:57:32 <xamanu> Are you referring to the server? Yes, this is a problem. I tried to fix it a couple of times and I know about server work and Debian. But this is an ugly error, and we might need a reinstallation of the basic virtual machine.
15:58:21 <BlakeGirardot> #action Follow up on where we are with the supplemental sys admin hire and make this one of their first efforts
15:58:22 <xamanu> Please be aware: Drupal is getting updated, no problem. The operation system is not upgradeable since 18 months or so.
15:58:29 <BlakeGirardot> Oh, ok, I see
15:58:36 <BlakeGirardot> That makes me feel better
15:58:58 <BlakeGirardot> (not being sarcastic, I was a lot more worried about drupal being out of date)
15:59:05 <xamanu> Here is the related issue to this: https://github.com/hotosm/hotosm-website/issues/46
15:59:22 <xamanu> BlakeGirar, yes indeed. Not updating Drupal for 18 months would be a real problem.
15:59:52 <xamanu> With the server it's not good, but still I don't expect to get hacked tomorrow (although we never know)
16:00:00 <BlakeGirardot> xamanu: So you have root access to where our website runs?
16:00:04 <xamanu> yes
16:00:13 <BlakeGirardot> ah, ok, cool
16:00:58 <BlakeGirardot> Looking at the agenda ....
16:01:16 <BlakeGirardot> Anything else on the hotosm website before we hit the next topic?
16:01:25 <xamanu> not from my side :)
16:01:41 <BlakeGirardot> #topic Mumble
16:01:45 <BlakeGirardot> Ok, sounds good then
16:02:03 <BlakeGirardot> FTA: Did you have something specific on the mumble topic?
16:02:17 <BlakeGirardot> (I keep asking you because you created our agenda today, thank you very much :)
16:02:18 <FTA> i believe the items were increasing participants number and the stable echo bot
16:02:28 <FTA> stabler*
16:03:20 <BlakeGirardot> ah, yes, I agree
16:03:51 <russdeffner> +1
16:03:57 <BlakeGirardot> I think this gets solved with an AWS instance for miscellaneous bots, which I think we need.
16:04:20 <BlakeGirardot> Mainly for the mumble bot and some slack integrations
16:04:51 <BlakeGirardot> I think a debian based micor instance would take care of all of our needs for the forseeable future, these things are not a lot of resources
16:05:19 <FTA> yeah it shouldn't be difficult to consolidate a lot of these different bot processes (though i don't know how much they take up bandwidth-wise)
16:06:02 <BlakeGirardot> At the moment the echo bot runs on AndrewBucks personal equipment so gets knocked off line a lot with small hiccups in connectivity or uptime.
16:06:44 <BlakeGirardot> My understanding is that the mumble server itself, bandwidth wise is no where near impacting our allocated bandwidth
16:07:07 <FTA> ok
16:07:56 <BlakeGirardot> bandwidth on the bots is probably minimal as well for the forseeable future.
16:09:11 <BlakeGirardot> I would like to see more people hangout on mumble
16:09:14 <BlakeGirardot> :)
16:10:03 <BlakeGirardot> We have had an increase in usage by OSMAfrica which is great, feedback is it works well
16:10:07 <xamanu> Me too!
16:10:30 <BlakeGirardot> Sorry, have to jump in a few
16:10:51 <FTA> that's alright, i think we've covered a good chunk of the agenda
16:10:52 <BlakeGirardot> #topic Meeting date, time
16:11:19 <BlakeGirardot> I personally think we need to meet every two weeks at the moment due to all the dev work going on
16:11:34 <BlakeGirardot> It would be good to get the dev project managers and developers in here as well.
16:11:41 <BlakeGirardot> It can't be all sys admin fun
16:11:44 <FTA> +1
16:12:16 <BlakeGirardot> I am going to doodle for a time. I know it will be a challenge as Mhairi is in indonesia
16:12:49 <BlakeGirardot> and cristiano in california
16:13:21 <BlakeGirardot> so from gmt -9 to gmt + 6
16:13:46 <BlakeGirardot> Anyone here have any solid no go times?
16:14:31 <BlakeGirardot> for me it is basically gmt 07:00 - gmt 12:00 is very hard for me to attend, that is my main sleep time.
16:14:49 <FTA> at least for my mondays only no gos are really 13 - 16 UTC
16:15:18 <FTA> wait i did that math wrong, 18-21 utc :)
16:16:24 <BlakeGirardot> what is your start time russ?
16:16:42 <russdeffner> or my sleep time is...
16:17:56 <russdeffner> roughly 3:00-11:00 UTC
16:18:44 <BlakeGirardot> any days of the week we should avoid based on who is here?
16:19:34 <FTA> any day is fine by me
16:20:43 <BlakeGirardot> #action Send out an email and/or doodle for day time finalization
16:20:49 <BlakeGirardot> which I will do
16:21:25 <BlakeGirardot> Anything else before we close? Besides big thank you to FTA for making this meeting happen?
16:21:43 <FTA> hey i'm glad to get the wheel going again :)...none on my end
16:22:37 <russdeffner> yes thanks for getting the TWG going again
16:22:40 <BlakeGirardot> FTA I am going to start reviewing the TM issues and documenting some groups in the wiki before I start assigning tags to individual issues
16:23:15 <BlakeGirardot> So any feedback, input, etc on the groupings would be most appreciated
16:23:55 <BlakeGirardot> #endmeeting