17:01:28 <TheSnide> #startmeeting
17:01:28 <MeetBot> Meeting started Tue Oct  8 17:01:28 2013 UTC.  The chair is TheSnide. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:28 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:01:33 <TheSnide> hi
17:02:23 <TheSnide> #info agenda is 2.2, munin-c, etc.
17:02:33 <TheSnide> #topic 2.2
17:02:54 <TheSnide> nothing really new here.
17:03:50 <TheSnide> we have to decide if i should continue in the sql branch, or just merge in devel
17:04:31 <TheSnide> devel feels more lively, but it *will* be broken from time to time
17:04:54 <TheSnide> and the eventual upgrades wont be easy.
17:05:27 <TheSnide> but it enables 2.1.x to have early sql feats
17:05:48 <TheSnide> (the more i think about it, the more i do like it)
17:06:11 <TheSnide> ... anyway, i said that 2.1.x is _unstable_.
17:08:24 <TheSnide> if noone objects, i'll make it an agreement :)
17:08:55 <TheSnide> well...
17:08:56 <GrumpyFux> question, sql will be the way to go?
17:09:04 <TheSnide> yes.
17:09:05 <GrumpyFux> Or is it still rather proof-of-concept?
17:09:16 <TheSnide> nope, it will replace datafiles.
17:09:46 <TheSnide> code is *way* easier to write.
17:09:49 <GrumpyFux> So, even if it should break with a big boom, you'll rather fix than revert?
17:10:12 <TheSnide> it wont. (i hope). but yes, i'll fixit.
17:10:50 <GrumpyFux> and at the moment sql isn't obviously broken?
17:10:54 <TheSnide> did anyone tried m
17:10:55 <TheSnide> ?
17:11:13 <TheSnide> well, i changed the sql schema several times already.
17:11:41 <TheSnide> i cannot say it wont change anymore. but as it is a sqlite db for now, it feels like datafiles.
17:11:43 <GrumpyFux> But in a way, that's short-term cache-like data anyway?
17:12:08 <TheSnide> just initial acces is much faster.
17:12:28 <TheSnide> no need to load the *whole* data in ram prior to use.
17:12:51 <TheSnide> after access is slower, but not that slower.
17:12:53 <GrumpyFux> Anyway, I feel inclined to: Bring it to a bigger audience, 2.1 is declared unstable, so better see the booms early
17:13:01 <olasd> sounds like a huge win in any case
17:13:27 <TheSnide> GrumpyFux: that's my rationale
17:13:28 <GrumpyFux> (evil plan to abuse sql will follow)
17:13:37 <olasd> are all the datafiles being converted to sql? how backend-specific is the sql code?
17:13:56 <olasd> (i.e. can we switch out to $real_dbms if we want to?)
17:13:59 <TheSnide> olasd: for what i've seen currently, yes. i just have to rewrite most of the code.
17:14:13 <TheSnide> olasd: but it's not a bad thing per se.
17:14:43 <GrumpyFux> olasd: Unless I'm mistaken, you could delete datafiles any time now anyway (unless munin is just running)
17:14:46 <TheSnide> olasd: currently it recreates a whole new db each run.
17:15:18 <olasd> I see
17:15:25 <TheSnide> olasd: 2.2 wont have real sql backend i'm afraid.
17:15:42 <TheSnide> as i dont want to rewrite the whole m-u.
17:15:45 <TheSnide> not for 2.2
17:15:56 <TheSnide> i will do. but later.
17:16:07 <TheSnide> urgent matter is cgi for now.
17:16:18 <olasd> well, if it allows setups with a few hundred nodes without the "I'm loading a multi-hundred-megabyte datafile" overhead, it's a win
17:16:21 <TheSnide> specifically html.
17:17:02 <TheSnide> 500 nodes overview currently has a 300ms response time. in plain CGI mode.
17:17:20 <olasd> yeah, that's "a bit" better :p
17:17:23 <TheSnide> on a 2GHz Xenon
17:17:34 <TheSnide> Xeon.
17:17:35 <TheSnide> :D
17:17:48 <TheSnide> (from 2k9 era)
17:18:25 <olasd> IMO, considering the time it took, you have ironed most of the kinks out of the SQL stuff
17:18:39 <olasd> if the DB is recreated on every run, I don't see where the upgrade issue is?
17:19:30 <olasd> (or rather, might be)
17:19:34 <TheSnide> old data, for derive limits.
17:19:41 <TheSnide> but it's very marginal.
17:19:46 <olasd> oh, right
17:20:02 <olasd> (so you fetch some data before wiping the db?)
17:20:07 <TheSnide> and "thou shall not twiddle munin's internals"
17:20:44 <TheSnide> as, a sqlite db has more connectors than a perl storable :)
17:21:35 <TheSnide> "if you have issues in stuff you built from it, i'll just laugh evily"
17:21:53 <TheSnide> (not really, but you get the mood)
17:22:26 <TheSnide> olasd: but anyway. it's a huge win. period.
17:22:53 <olasd> right
17:23:11 <TheSnide> olasd: and no, most of the time spent was doing things that failed miserably.
17:23:18 <olasd> *pat pat*
17:24:29 <TheSnide> olasd: but now i think i found out a way to make it work nicely
17:25:06 <TheSnide> even much less code than previous iterations :)
17:26:23 <TheSnide> so, i'll just mergw it in devel regularly. agreed ?
17:26:49 * TheSnide casts a quick vote
17:26:52 <TheSnide> +1
17:27:40 <TheSnide> ....
17:28:44 <TheSnide> #agreed sql branch will be merged regularly in devel and rreleased as 2.1
17:28:57 <olasd> well I'm in favor, more exposure means more incentive for quick fixes :p
17:29:19 <TheSnide> #topic munin c
17:30:17 <TheSnide> pretec started to work on the .deb
17:31:24 <fenris02> TheSnide, have docs?  if so, i can start the rpm's ..
17:32:39 <TheSnide> there's several readme
17:33:00 <fenris02> i see 3 licenses, and a one-line readme.
17:34:11 <TheSnide> inside the src/*
17:34:16 <fenris02> wait.  make that two licenses, and a readme.  the readme says gpl2, but the git repo has gpl2 and 3
17:34:43 <TheSnide> pretec also noticed the license hell
17:35:00 <fenris02> either one is fine with me tbh, just needs to be consistent
17:36:40 <fenris02> and ftr, i already have rpms .. they are really just waiting on docs so a user can actually use it.
17:43:46 <TheSnide> munin-c is designed to be a dropin
17:44:19 <TheSnide> only for the node, it has to be called from inetd, and that should be package driven.
17:44:26 <TheSnide> (inetd conf)
17:45:37 <TheSnide> ... but i'll write some manpages, using POD
17:51:05 <TheSnide> #action TheSnide has to write some manpages
17:51:42 <TheSnide> #info fenris02 has rpms that waits for some polish and docs.
17:52:11 <TheSnide> fenris02: we agreed to split in 2 binary packages.
17:52:20 <TheSnide> node + plugins
18:01:19 <TheSnide> #topic else
18:01:32 <TheSnide> any topic ?
18:05:20 <GrumpyFux> bugs? #1382 went rrd upstream, Tobi has promised to pick my patch+enhancement
18:06:51 <TheSnide> nice
18:07:42 <GrumpyFux> And I'd be glad if an SNMP wizard could browse through the related tickets I've created
18:08:11 <TheSnide> you shall ask nicolai, he's quite fluent in snmp
18:08:33 <TheSnide> (janl)
18:09:48 * TheSnide doesnt look much @ bugs lately.
18:10:33 <GrumpyFux> We should do some kind of BSP ... there are way too many at the moment
18:12:32 <GrumpyFux> And I hate to look into "Hm, that's interesting" tickets, just to find I filed them
18:14:24 <helmut> ohh. meeting. hi :)
18:16:12 <TheSnide> helmut: meeting is mostly closing itself :)
18:16:12 <helmut> followup remark to munin-c: the code base has diverged in consistency since the recent moves. moving it around and bolting autotools onto it has not helped. we should clean that up.
18:16:58 <TheSnide> GrumpyFux: i won't have time for a BSP, so i cannot advocate one :-/
18:17:44 <GrumpyFux> Let's do a munin WWDC for that
18:18:14 <helmut> if you think that it helps, I can step in as maintainer for munin-c and review all branches/patches for errors, consistency and legalese.
18:24:19 <helmut> I need to train my C skill anyway. ;-)
18:24:47 <TheSnide> helmut: please do.
18:25:10 <TheSnide> #topic munin c
18:25:13 <helmut> TheSnide: that'd imply that the canonical location for munin-c.git is one that I can write to. any ideas?
18:25:34 <TheSnide> #info helmut proposed "I can step in as maintainer for munin-c and review all branches/patches for errors, consistency and legalese."
18:25:56 <TheSnide> helmut: you *do* have a github account :)
18:26:29 <TheSnide> ---> https://github.com/helmutg
18:27:22 <TheSnide> helmut: but, the canonical location for munin-c is like the other official git : git.munin-monitoring.org
18:27:25 <helmut> I failed to delete it, so I stopped using it, because I can no longer abide by the tos
18:28:02 <GrumpyFux> --verbose (after the meeting)
18:28:03 <TheSnide> helmut: git@git.munin-monitoring.org:munin-c.git
18:28:40 <TheSnide> #action TheSnide will give push access to helmut on g.mm0 for munin-c
18:28:56 <TheSnide> helmut: let's sort it out after the meeting
18:29:01 <helmut> TheSnide: ack. I'll drop you a mail after the meeting
18:30:30 <TheSnide> #topic else
18:32:30 <TheSnide> GrumpyFux: would it be interesting to have an irc hacking meeting ?
18:32:58 <GrumpyFux> Meaning precisely?
18:33:33 <TheSnide> GrumpyFux: doing munin hacking all together at a fixed time.
18:34:02 <TheSnide> GrumpyFux: with IRC as a shared communication medium
18:34:19 <GrumpyFux> I have no experience with that
18:35:11 <TheSnide> #action TheSnide will orga a small munin IrcHackFest to see if there's some interested ppl
18:37:59 <TheSnide> ok, anything else ?
18:40:35 <TheSnide> #endmeeting