17:08:48 <TheSnide> #startmeeting
17:08:48 <MeetBot> Meeting started Tue Oct 15 17:08:48 2013 UTC.  The chair is TheSnide. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:08:48 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:08:57 <m-r-b> <dcrouch@freenode> rpm -qa | grep munin | tr '\n' ' '  munin-node-2.0.17-1.el5 munin-2.0.17-1.el5 munin-common-2.0.17-1.el5
17:09:35 <TheSnide> hi all, today the meeting will be a little slower than usual, since i'm not fully here
17:09:59 <kjetilho> commuting? :)
17:13:27 <TheSnide> yeah, didnt finish :)
17:14:01 <TheSnide> #topic 2.2
17:14:17 <TheSnide> #info nothing new here.
17:14:39 <TheSnide> any questions ?
17:15:04 * TheSnide sounds intimidating (sorry)
17:20:57 * h01ger waves
17:38:19 <TheSnide> h01ger: hi
17:38:30 <TheSnide> ok@ got my gprs back :)
17:38:54 <TheSnide> so, next topic
17:39:06 <TheSnide> #topic munin-c
17:40:04 <TheSnide> i'm currently deploying munin-c on many win32 nodes.
17:40:50 <TheSnide> it compiles quite nicely with cygwin. but it is a 32b app. so it has issues to launch 64b apps.
17:41:46 <TheSnide> also, launching scripts on win32 is not possible, due to mandatory perm args
17:42:06 <TheSnide> but .exe do work very well.
17:42:45 <TheSnide> just that cygwin doesnt emulate the whole /proc subsystem renders some plugin useless.
17:45:28 <helmut> munin license stuff is cleared now, so it should be ready for debian, but feedback from pretec is missing thus far
17:45:42 <helmut> err munin-c of course.
17:45:52 <TheSnide> helmut: next code from me is gpl2+
17:45:56 <TheSnide> (munin-c
17:45:57 <TheSnide> )
17:46:44 <TheSnide> let's make it a req for new code in munin-c (gpl2+)
17:46:56 <helmut> it already is. ;-)
17:47:21 <TheSnide> #agreed munin-c license is gpl2+. any new code shall be compliant also.
17:48:03 <helmut> <nitpick>well actually gpl{2,3} since I only cleared that licene from all contributors thus far
17:48:19 <TheSnide> *grrr*
17:49:04 * TheSnide suggests copyright assigment to avoid issues later.
17:49:13 * TheSnide hides.
17:49:50 <TheSnide> #agreed license is only gpl2 or gpl3.
17:50:55 <helmut> I'd like to enforce the "main-line first"-policy on munin-c. opposition?
17:50:56 <TheSnide> about the "external plugin"...
17:51:33 <kjetilho> helmut: what does that mean?
17:51:45 <TheSnide> helmut: make munin-c mainline. pb solved.
17:51:48 <helmut> kjetilho: munin-c doesn't get any features that aren't available in munin mainline
17:52:35 <helmut> TheSnide: we can discuss that when node parses conf and plugin covers 80% of basic plugins
17:52:51 <TheSnide> helmut: but yes, it sounds sane
17:53:20 <TheSnide> yeah, i still have the conf to parse.
17:53:32 <helmut> my primary reason for mainline-first is that it keeps us focused. it may not be right all the time, but it is a good guidance
17:54:10 <helmut> experimenting with new features and evaluating their usefulness is much cheaper in terms of developer time when doing it in something other than C
17:54:51 <TheSnide> helmut: i do have a very specific goal, but i'll make it match the consensus
17:55:19 <TheSnide> aka, my need is in C ;)
17:56:45 <helmut> well making C mainline sounds like a viable longterm goal to fulfil this policy. ;-)
17:56:47 <TheSnide> #agreed munin-c should have only the main node feat
17:57:25 <helmut> maybe cover sql master first. ;-)
17:57:56 <TheSnide> "different budget line"
18:04:51 <helmut> #nexttopic?
18:09:34 <TheSnide> #topic nexttopic
18:09:50 <TheSnide> what's up ? :)
18:11:41 <TheSnide> #topic guide
18:12:50 <TheSnide> i'd like to make the guide our official doc, that we can refer to.
18:13:44 <TheSnide> The thing is that nice url dont change, and therefore i'd like to avoid using an external service for that. (rtd.org)
18:14:58 <TheSnide> so, i'll try to cook some scripting soup to autobuild the current, official, version of it and make it avail on w.mm0
18:15:51 <TheSnide> it might even offer to build some dev branch
18:15:54 <TheSnide> :)
18:23:51 <helmut> TheSnide: why not have fanc redirects for now? may be easier
18:24:10 <helmut> (only consider if it really means less work)
18:25:50 <m-r-b> <n-st@freenode> hi, is there some way to hide the threshold line in graphs like the one of the 'df' plugin?
18:41:31 <TheSnide> helmut: i dont think it is much work.. but will see
18:41:37 <TheSnide> ok, ending here
18:41:44 <TheSnide> #endmeeting