19:39:02 <TheSnide> #startmeeting
19:39:02 <MeetBot> Meeting started Tue Aug 19 19:39:02 2014 UTC.  The chair is TheSnide. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:39:02 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:39:14 <TheSnide> dipohl: was a little late, sorry
19:39:41 <TheSnide> Nothing much new, only galleries
19:39:51 <TheSnide> #topic Plugin gallery
19:40:25 <TheSnide> dipohl started to work on that part, and so far her work looks promising :)
19:40:37 <dipohl> I would like to use the opportunity to harmonize and care for consistency in the distri plugins
19:41:23 <TheSnide> changing working core plugins is generally a bad idea, but changing categories can be ok, depending on the case
19:41:57 <dipohl> so investigate and define our programming rules
19:42:29 <dipohl> do we have a code style guide within Munin Guide?
19:42:31 <TheSnide> Multiple words category names are allowed.
19:42:44 <dipohl> but mixed cases don't work
19:42:53 <dipohl> I just tested on my server
19:43:10 <TheSnide> category names are case insensitive. or should be.
19:43:14 <dipohl> it'll will all be lower case (which is good for our gallery ;)
19:43:23 <TheSnide> As the html code should uppercase the first letter.
19:43:48 <TheSnide> and all lowercase for anything path related
19:43:51 <dipohl> no in munin overview the categories are all written in lower case
19:44:01 <TheSnide> oh.
19:44:27 <TheSnide> well... i guess i missed that bug. But since noone complained let's declare it a feature :)
19:44:41 <dipohl> I really like it
19:44:51 <TheSnide> i don't mind.
19:45:06 <dipohl> ok, now it's a feature :)
19:45:20 <TheSnide> #agreed in munin overview the categories are all written in lower case
19:45:25 <TheSnide> yep
19:45:56 * TheSnide didn't have time to do anything munin-related these days.
19:46:16 <dipohl> #topic Coding Guide
19:46:22 <dipohl> do we have such a thing?
19:46:25 <TheSnide> #topic Coding Guide
19:46:56 <TheSnide> We don't. Well, not in _written_ format that can be pinpointed at
19:47:19 <dipohl> I think we should have one for the plugin authors
19:47:25 * TheSnide recalls that he was commited to write something down about that some years ago
19:47:27 <dipohl> there are already instructions in the wiki
19:48:02 <TheSnide> yep. we also have the procotol rules
19:48:13 <dipohl> http://munin-monitoring.org/wiki/plugin-bcp
19:48:55 <dipohl> e.g. the API for multigraph plugins
19:49:13 <dipohl> I found a lot of different formats for the config part
19:49:46 <dipohl> http://munin-monitoring.org/wiki/PluginGallery#Currentstateoftheproject
19:50:37 <TheSnide> actually, the official API is the "exec" of the plugin.
19:50:49 <TheSnide> We don't enforce any rules on the plugin source
19:51:25 <dipohl> how comes that these config sections are similiar?
19:51:27 <TheSnide> ... yet we can provide some guiidelines that ease the work of plugin authors & your script :)
19:51:37 <dipohl> ACK! :)
19:51:51 <TheSnide> don't ever underestimate the power of copy/paste
19:52:19 <dipohl> I did not write a multigraph plugin since now
19:52:46 <TheSnide> --> that's why examples are very important. and _have_ to be quite careful on our own code
19:52:49 <dipohl> had a short look into and didn's find the "config" call option
19:53:25 <TheSnide> for multigraph ?
19:53:28 <TheSnide> there is
19:55:06 <dipohl> concerning "changing working core plugins" I would like to set fix category in plugin https://github.com/munin-monitoring/munin/blob/devel/plugins/node.d.linux/proc.in
19:55:32 <dipohl> The author set per default "Process Info" which is bad as we have "processes" already
19:56:21 <dipohl> I don't want a inflation of categories in the distributed plugins
20:00:41 <dipohl> TheSnide?
20:01:08 <dipohl> I looked once again in the multigraph plugin and found what I called API before
20:01:23 <TheSnide> yep, inflation of categories in the core plugin is bad
20:01:40 <dipohl> my $plugin = Munin::Plugin::Framework->new;
20:01:46 <TheSnide> "Process Info" --> "processes" is a good move
20:02:11 <TheSnide> yeap, he factorized the code in a Munin::Plugin::Framework class
20:02:24 <dipohl> Can we delete the option to set category in plugin-conf.d also btw.?
20:02:39 <dipohl> in proc.in
20:02:42 <dipohl> ?
20:02:43 <TheSnide> why ?
20:02:56 <dipohl> because that is a seldom used feature
20:03:00 <dipohl> and as said before
20:03:15 <dipohl> I think it is better to do that in masters conf
20:03:45 <TheSnide> well, i don't like to mess with overriding master's config
20:03:53 <TheSnide> (as a munin user)
20:03:59 <TheSnide> so, YMMV
20:04:02 <dipohl> why?
20:04:22 <TheSnide> delegation of administration.
20:04:43 <TheSnide> munin's master has only munin admins. they only add new nodes.
20:04:54 <dipohl> but I don't like users that infuse categories in the central overview ;)
20:05:05 <TheSnide> Then what's monitored on the said nodes is completely delegated to node admins
20:05:06 <dipohl> as a munin master administrator ;-P
20:05:34 <TheSnide> I understand, but as I said. YMMV :)
20:05:41 <dipohl> YMMV?
20:06:19 <TheSnide> http://en.wiktionary.org/wiki/your_mileage_may_vary
20:07:10 <dipohl> for my script it is simple to find the fix reference graph_category in the plugins code
20:07:29 <dipohl> this author /hides/ graph_category in $category
20:07:38 <TheSnide> (meaning: each user/install has its own eccentricities
20:08:02 <dipohl> and as not many plugin authors offer the opportunity to set env.category
20:08:17 <dipohl> I vote for KISS
20:08:37 <TheSnide> but what's plain wrong is that the env var is env.category and not env.graph_category
20:12:05 <dipohl> so how to solve the issue?
20:14:39 <TheSnide> you do parse "graph_category (.*)" ?
20:15:25 <TheSnide> just add a comment that you'll parse instead, if the category contains a "$"
20:16:00 <dipohl> fyi: I just grepped for these sort of parameters
20:16:02 <dipohl> node.d.java/jmx_.in:    env.category jvm
20:16:03 <dipohl> node.d.linux/proc.in:# You can set the env-var "category" to override the default category.
20:16:03 <dipohl> node.d.linux/proc.in:my $category = exists $ENV{'category'} ? $ENV{'category'} : "Process info";
20:16:15 <dipohl> ^and found only these 3 plugins
20:16:54 <dipohl> ah, 2 plugins :)
20:17:18 <dipohl> grep -Ri ENV node.d.* | grep -i category
20:17:42 <dipohl> That's why I think it would be ok to delete the option
20:18:08 <dipohl> it is irrelevant, because some hundred plugins don't offer this option
20:21:45 <dipohl> and only 2 do so
20:24:39 <TheSnide> well. ok :)
20:24:55 <TheSnide> as proc.in is a new plugin that isn't in stable-2.0 :p
20:25:01 <dipohl> puh, that was hard work ;)
20:25:39 <TheSnide> :)
20:26:03 <TheSnide> for main code, a coding guide would also be welcome
20:26:49 <dipohl> me is the wrong person for that, as I am a PERL stranger :)
20:27:43 <dipohl> concerning the contrib instance of munin gallery
20:28:13 <dipohl> I would not try to fetch graph_category, but use the directories
20:29:00 <dipohl> for the future, we should invent some sort of tagging as you already said
20:29:22 <TheSnide> πyup
20:29:26 <TheSnide> yup
20:29:42 * TheSnide has to go
20:29:46 <dipohl> me too
20:29:58 <TheSnide> ok, ending
20:30:03 <TheSnide> #endmeeting