19:38:03 <TheSnide> #startmeeting
19:38:03 <MeetBot> Meeting started Tue Oct 28 19:38:03 2014 UTC.  The chair is TheSnide. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:38:03 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:38:06 <TheSnide> Hi all.
19:38:17 <TheSnide> #chair ssm dipohl1 h01ger
19:38:17 <MeetBot> Current chairs: TheSnide dipohl1 h01ger ssm
19:38:49 <TheSnide> a quick meeting (i have to go @ 2000 UTC
19:41:00 <TheSnide> some things happened since last week, mostly several 2.0.x releases, in order to reach testing before jessie's freeze.
19:41:15 <TheSnide> #topic 2.0
19:41:59 <TheSnide> #info 2.0.24 is out. 2.0.25 is just behind the corner. But as there won't be any time before the freeze, no need to rush it more than needed.
19:42:06 <h01ger> hi
19:43:00 <TheSnide> 2.0.x will get less attention, and will only recieve bugfixes. This enable to focus more on 2.1.x
19:43:10 <TheSnide> #topic 2.1
19:43:22 <TheSnide> ... which comes to this.
19:44:09 <TheSnide> 2.1 is in a quite good shape, as the demo is running smoothly with 2.1.9 since a while.
19:45:46 <TheSnide> The next iteration, 2.1.10 contains more than 157 commits, 168 files changed, 5202 insertions(+), 882 deletions(-)
19:46:23 <TheSnide> 54 files changed, 2028 insertions(+), 287 deletions(-) is just for the doc/ subdirectory.
19:47:36 * h01ger cheers TheSnide for doing the meetings every week and even alone, if he has to. thats really great transparancy and openess!
19:48:04 <h01ger> contentwise i have nothing to add atm..
19:48:13 <dipohl1> ACK and thanks from here too!
19:49:35 <TheSnide> #info http://guide.munin-monitoring.org/ is the new home of our documentation, thanks to dipohl1 & ssm.
19:50:08 <TheSnide> #action TheSnide will change the URL for the Guide on the wiki toolbar.
19:50:21 <dipohl1> :-)
19:51:08 <TheSnide> 2.1 has currently a very solid html cgi. But its cron counterpart hasn't be touched.
19:51:16 <TheSnide> So the roadmap would be:
19:51:46 <TheSnide> 1. use the cgi for the cron html also, in the same way it is done for cron graphing.
19:52:28 <TheSnide> 1a. maybe add some multi-processing to the mix, but it's low prio
19:52:56 <TheSnide> 2. convert the graph cgi to use SQL only, and remove the datafile completely.
19:54:11 <h01ger> thats sqlite?
19:54:22 <TheSnide> 3. convert the update part to use SQL only. See what can be done for limits.
19:55:04 <TheSnide> h01ger: yes. sqlite is the current goal. But SQLite specific code is to be avoided, in order to be SQL portable, and be able to nicely leverage DBI.
19:55:29 <h01ger> *nods*
19:56:08 <TheSnide> I'm thinking about considering the DB as a GPU. Some things might be offloaded via stored proc, but you should always have "software fallback".
19:56:45 <TheSnide> .. and the offload will come afterwards, in a db-specific fashion anyway.
19:58:29 <TheSnide> 4. leverage the munin-api to have a sample HTML5 implementation. One that doesn't need any CGI.
19:59:31 <TheSnide> That roadmap is certainly ambitious. The nice part of it being ordered that way is that we can decide to ship 2.2 anytime in between.
20:00:00 <TheSnide> --> we always have a fully working release at each step.
20:00:08 <TheSnide> .. So, that would be it for me.
20:00:19 <TheSnide> #topic misc
20:00:30 <kenyon> has the infinite recursion URLs issue been fixed with munin-cgi-html in 2.1? I think I saw it only happen with diskstats. googlebot would crawl urls forever.
20:00:51 <TheSnide> kenyon: is there a bug about it ?
20:01:11 <kenyon> I didn't create one, don't know. I just disabled cgi html
20:01:17 <TheSnide> hm.
20:01:26 <kenyon> no idea where to start investigating
20:01:30 <kenyon> it would allow addresses like http://kenyonralph.com/munin-cgi/munin-cgi-html/kenyonralph.com/darwin.kenyonralph.c
20:01:33 <kenyon> om/kenyonralph.com/diskstats_latency/devildog.kenyonralph.com/diskstats_throughput/buddyinfo/diskstats_l
20:01:37 <TheSnide> kenyon: start by reporting the bug :-D
20:02:15 <kenyon> ...atency/turing.kenyonralph.com/diskstats_iops/apache_accesses.html
20:02:35 * TheSnide has to go now (sorry). I'll leave the meeting open. h01ger or dipohl1 : feel free to end it when it dries up.
20:02:56 <TheSnide> ... I'll end it in 2 hours from now if not ended already.
20:03:31 * h01ger will go afk now too
20:03:36 <h01ger> have a good evening!
20:04:54 <dipohl1> bye h01ger and TheSnide
20:05:20 <dipohl1> I will go now also
20:05:31 <dipohl1> so end the meeting now?
20:10:37 <kenyon> OK, created a bug report issue on github
20:19:58 <dipohl1> #endmeeting