19:35:05 <TheSnide> #startmeeting
19:35:05 <MeetBot> Meeting started Wed Mar 4 19:35:05 2015 UTC. The chair is TheSnide. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:35:05 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:35:17 <TheSnide> hi all
19:35:37 <ssm> ello
19:37:15 <TheSnide> about 2.1 there is nothing mucn to say for me. anyone ?
19:37:43 <TheSnide> (codestyle will its ow, topic)
19:37:48 <TheSnide> own
19:38:04 * ssm has been doing bug and pull request triage to get back into perl coding shape again
19:38:28 <TheSnide> yeah, saw that. impressive & thx
19:38:43 <ssm> Lots of good contributions from the community. :D
19:39:50 <TheSnide> yep, too bad is i don't have much online time. i'm mostly offline these days…
19:40:45 <TheSnide> #topic coding style
19:41:10 <TheSnide> i made some edits some time ago
19:41:55 <TheSnide> but i'd advocate a pre-commit hook, which would do the work for us
19:41:56 <ssm> perl code edits, or coding style edits, or edits to the documented coding style?
19:42:17 <TheSnide> documenting
19:42:28 <TheSnide> (the style=
19:43:15 * ssm uses perltidy a lot, I'd like to have, or make, a perltidyrc to reflect the project coding style
19:43:42 <TheSnide> i'm then wondering about how to auto test the PR, to have them normalized
19:44:07 <kjetilho> whatever you decide, please do not change TABs (the character) to be anything but 8 characters wide
19:44:09 <TheSnide> ssm: i made an rc file, but it suits my style
19:44:11 <ssm> that's not a simple solution
19:44:47 <ssm> There is a .dir-locals file in the project setting TAB to 4 characters. I tend to ignore it. I like to indent with 4 spaces, and keep tabs away
19:45:05 <kjetilho> TheSnide: rc, as in .vimrc?
19:45:11 <ssm> or at 8 spaces wide
19:45:59 <TheSnide> perltidyrc
19:46:19 <ssm> goodie :)
19:46:26 <kjetilho> ah. is there a converter from perltidyrc to .emacs or .vimrc? :)
19:46:44 <TheSnide> rm any tab setting
19:47:00 <TheSnide> i despise them
19:47:19 <TheSnide> (didn't know it eisted)
19:47:27 <ssm> kjetilho: Not that I know of
19:47:31 <ssm> TheSnide: consider it done :D
19:47:51 <ssm> #action ssm will delete TAB settings
19:48:15 <TheSnide> even the "magic markers" should be hunted down
19:48:47 <ssm> in-file tab/space/indent markers, and -*- cperl -*-
19:48:50 <kjetilho> yeah, I don't see why we should "force" cperl-mode on Emacs users
19:49:02 <ssm> that's an ancient sin.
19:49:18 <TheSnide> wedon't have those infamous .in files, so let each "ide" sort its way out
19:49:30 <ssm> It was probably necessary for the .in files, to say "this is perl", and you should use "cperl-mode".
19:50:00 <TheSnide> yup, but it can be "killed at sight"
19:50:29 <ssm> #action ssm will delete in-file editor-specific mode/indent/tab markers
19:50:52 <TheSnide> for the "tab is 8, 4 or 32 spaces" i don't care either
19:51:23 <TheSnide> let each user set his own pref
19:51:38 <ssm> and indent the code with 4 spaces for each level?
19:52:18 <kjetilho> I think "no tabs at all in the code" is the best way to avoid weirdness going forward
19:52:27 <ssm> yes
19:52:33 <TheSnide> no space in code ;)
19:52:48 <kjetilho> Jimmy probably disagrees, though :)
19:52:49 <ssm> and 3-space tabs, as a compromise :P
19:52:53 <TheSnide> each ident is 1 tab
19:53:06 <TheSnide> no vertical align
19:53:17 <TheSnide> that's the original sin
19:54:22 <kjetilho> well, that's the problem .. handling continuations
19:55:11 <kjetilho> on the other hand, when there is a perltidy regime in place, it doesn't matter much. run your own rc while editing, change it back before commiting :-p
19:55:45 <ssm> and make perltidy, emacs and vim agree. You can probably do a perltidy-on-save in addition to on-commit.
19:59:05 <TheSnide> i managed to evangelise tab on all my other projects ;)
19:59:43 <TheSnide> rationale is : ident is 1 tab. always.
20:00:22 <kjetilho> TheSnide: and continuations?
20:00:28 <TheSnide> indent is mandatory, no vertical "let's love this here to make it beautiful"
20:01:00 <TheSnide> for continuations, youhave 2 options
20:01:26 <TheSnide> 1 arg per line
20:01:51 <TheSnide> 1 tab idented, obviously
20:02:20 <TheSnide> do not have too much args on a SLOC
20:02:51 <TheSnide> subgrouping being option #2
20:03:14 <kjetilho> http://pastie.org/10000280
20:03:32 <kjetilho> (oh no, I missed out on being pastie #10M!)
20:04:18 <TheSnide> hehe
20:04:57 <TheSnide> use temp var for ternary
20:05:24 <TheSnide> useonly 1 statement per LOC
20:05:49 <TheSnide> (that's personal fav)
20:06:37 <TheSnide> I agree itis slower in perl, but i do not care much
20:11:57 <kjetilho> TheSnide: better example: http://pastie.org/10000301
20:12:21 <kjetilho> the issue here is that many people will want the $argument3 to line up under check_something(
20:12:47 <kjetilho> and if TAB can be anything, that can't really be done
20:13:08 <kjetilho> at least I've never seen an editor which supports using a mix of TAB and Space to accomplish it
20:14:08 <TheSnide> https://gist.github.com/anonymous/827ef6e1755f91b3b113
20:15:01 <TheSnide> i used sp̂ace because of web browser
20:15:06 <kjetilho> 3!
20:15:50 <TheSnide> yup, _on purpose_
20:17:28 <TheSnide> for the temp arg use a temp var
20:18:32 <TheSnide> if you use shortcut eval, and line is too long, don't
20:21:28 <kjetilho> but what to do about the parameter list to the function?
20:24:03 <TheSnide> 1arg per line
20:24:21 <TheSnide> result in temp var
20:24:32 <TheSnide> reusing temp var in if()
20:24:49 <TheSnide> do *not* minify code
20:25:03 <TheSnide> you'll be glad in 6 months ;)
20:25:41 <TheSnide> as the temp var will have a meaningful name, that helps
20:26:09 <TheSnide> helps making wrong code look wrong
20:26:55 <kjetilho> ok. no nested parenthesis, ever
20:27:02 <TheSnide> ... catchd many bugs related to unit being mismatched
20:27:12 <kjetilho> if you need parenthesis, use a temporary variable.
20:27:14 <TheSnide> basically, yes
20:27:42 <TheSnide> as usual, it is a guideline. brain usage is still mandatory ;)
20:28:06 <kjetilho> no!!! can't allow others to think. it will be chaos! :)
20:28:47 <TheSnide> well, you got the point ;-))
20:28:50 <kjetilho> :)
20:29:05 <kjetilho> have you commited your rc?
20:29:29 <TheSnide> no, still have ro retrive it (on far laptop)
20:29:38 <kjetilho> the bad thing about such changes is the jumbo patch it causes
20:30:04 <kjetilho> which makes backporting really hard
20:30:55 <TheSnide> second rule is "only change code area/function you are changing"
20:31:15 <kjetilho> can you make perltidy only affect a single function?
20:31:21 <TheSnide> and, whitespace commit should be discrete
20:31:31 <TheSnide> not that i know of.
20:31:42 <TheSnide> but i use git add -p
20:31:45 <kjetilho> ok, so do the perltidy thing manualy
20:32:36 <kjetilho> aha, nice tip
20:33:04 <kjetilho> but I think perltidy in practice will cause the patch to be one big hunk
20:33:30 <TheSnide> using "s" for splitting, and e xor.edit
20:33:33 <TheSnide> for
20:35:48 <TheSnide> #action TheSnide will commit an updated perltidyrc
20:36:11 <TheSnide> ... i also thinks that this rules cannot be expressed in the rc
20:36:38 <kjetilho> it needs to be stated in CONTRIBUTING.md
20:37:05 <TheSnide> i usually tend to make the patch, and the follow it by a whitespace commit
20:37:34 <TheSnide> ... so one can merge the fix in a backport
20:38:05 <kjetilho> ok, my bad. I hadn't read HACKING.pod
20:38:34 <TheSnide> another option would be a gigantic whitzspace patch on every "live" branch
20:39:15 <TheSnide> that would ease backporting as the whitespace would arleady be applied.
20:39:44 <kjetilho> right.
20:39:45 <TheSnide> #info strategy to white apmly is to be decided next meeting
20:41:01 <TheSnide> ok, have to go. will close the meeting, or still thing to say ?
20:41:37 <kjetilho> yes, I wanted to point to the homepage:
20:42:08 <kjetilho> http://munin-monitoring.org/ -- the repository is nowhere to be found
20:42:19 <kjetilho> lots and lots of references to tar-balls on Sourceforge
20:42:34 <kjetilho> no mention on the Development page either
20:43:19 <kjetilho> so: I suggest that someone with wiki-access adds a link to the Github page to the Download section
20:43:44 <kjetilho> and at the top of the Development page
20:44:14 <kjetilho> and if I'm blind, I still think the link needs to be more obvious
20:46:29 <TheSnide> kjetilho: could make a list and submit it offmeetint ?
20:47:10 <TheSnide> #info our homepage has irrelevant data
20:48:11 <kjetilho> :-D
21:07:25 <TheSnide> #endmeeting