19:28:51 <sumpfralle> #startmeeting
19:28:51 <MeetBot> Meeting started Wed Mar 28 19:28:51 2018 UTC. The chair is sumpfralle. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:28:51 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:28:55 <TheSnide> hi
19:29:19 <sumpfralle> #chair h01ger TheSnide kenyon
19:29:19 <MeetBot> Current chairs: TheSnide h01ger kenyon sumpfralle
19:30:02 <sumpfralle> who goes first with a topic?
19:30:39 <sumpfralle> #topic review last meeting
19:30:50 <sumpfralle> I asked chteuchteu today via email if he would help with the new website.
19:30:59 <sumpfralle> TheSnide uploaded the new release to sf.
19:31:23 <sumpfralle> I prepared a pull request for the SNMPConfig thing - kenyon please review
19:31:49 <sumpfralle> I did not yet do the cherry-picking from 2.0 to master :(
19:31:54 <sumpfralle> anything else?
19:32:37 <TheSnide> sumpfralle: i usually "merge" from 2.0 to master
19:32:42 <TheSnide> (when possible)
19:33:21 <TheSnide> i'll issue 2.0.37 right no
19:33:23 <TheSnide> w
19:33:30 <sumpfralle> great!
19:33:46 <sumpfralle> merge/cherry-pick: here we have quite different code branches - is merge suitable here?
19:34:37 <TheSnide> if possible, merge is better.
19:34:49 <TheSnide> specially in the stable->master way.
19:35:25 * TheSnide still thinks that bugfix should happen on stable first, then be merged into master.
19:35:52 <h01ger> uhm, cherry pick from 2.0 to master, else… things can become interesting
19:36:11 <h01ger> but anyway, i need to go afk now, sorry & have fun!
19:36:29 <sumpfralle> throwing in his opinion and letting us discuss :)
19:36:47 <TheSnide> sumpfralle: do as you think is best
19:36:54 <sumpfralle> anyway: I will take a look, if merge is suitable or if I will get overwhelmed by the deviating code
19:36:57 <sumpfralle> good
19:37:11 * TheSnide is too low touch those days to have a strong voice :)
19:37:12 <h01ger> (and then i firmly believe things should move from master to 2.0 and not the other way round…)
19:37:54 <TheSnide> h01ger: jajaja, but.... #ohwell :)
19:37:59 <sumpfralle> :)
19:38:06 <h01ger> *g*
19:38:44 <sumpfralle> TheSnide: I did not really follow the 0.35/0.36 issue: was it only the munin_stats plugin?
19:38:56 <TheSnide> yup
19:39:01 <TheSnide> and the .37 also
19:39:02 <h01ger> well, cgi graphing broke
19:39:10 <h01ger> but i should really run now
19:39:12 <h01ger> o/
19:39:14 <TheSnide> h01ger: the whole cgi ?
19:39:15 <sumpfralle> in general or only for this plugin?
19:39:25 <sumpfralle> run!
19:39:35 <sumpfralle> anyway
19:39:39 <TheSnide> i thought it was only that plugin that emitted tons of warnings
19:39:43 <h01ger> see issue 939 and what bcg said here
19:39:44 <sumpfralle> three releases in a week - that is fantastic! :)
19:40:02 <TheSnide> sumpfralle: s/fantastic/fukup/ ? :p
19:40:10 <sumpfralle> at least it is alive ...
19:40:30 <TheSnide> indeed.... a little hysterical even...
19:40:37 <sumpfralle> but lovely!
19:40:41 <sumpfralle> new topic?
19:40:58 <TheSnide> #topic 2.999
19:41:14 <TheSnide> i pushed some fixing code in a PR
19:41:30 <sumpfralle> yes, and I just commented them five minutes ago
19:41:43 <sumpfralle> what do you think, is the current status of the branch?
19:41:54 <TheSnide> basically it does remove the big datastructure in the munin-update, and updates everything on the fly
19:43:06 <sumpfralle> I had the feeling (based on bug reports), that graph config values are not stored, there, yet?
19:43:27 <sumpfralle> (just wild guess - ignore, if you disagree)
19:43:45 <TheSnide> no, limits don't work yet
19:44:01 <TheSnide> as the code does parse the datafile, which isn't here anymore
19:44:14 <sumpfralle> ah - right - I just found that in my notes :)
19:44:22 <TheSnide> ... and i have to refactor it to take into account the sql.
19:44:51 <sumpfralle> I have a small list of items, that I want to ask you - I would do this somewhen outside of the meetings, or?
19:44:55 <TheSnide> ... but to be honest, i'd like to delegate the actual computation to munin-update also, and be able to do it on the fly
19:45:01 <TheSnide> sumpfralle: sure
19:45:04 <sumpfralle> cool
19:45:13 <TheSnide> let's move it outside... +1
19:45:25 <TheSnide> (but still here)
19:45:32 <sumpfralle> yes
19:45:50 <sumpfralle> so I would just repeat my plan of merge/cherry-pick changes from 2.0 to master
19:46:01 <sumpfralle> and then we discuss about a release next week?
19:46:31 <sumpfralle> I think, you documented the release for 2.0 very well - but I did not look for the new master approach (if there are differences)
19:46:38 <dipohl> hi all and sorry for being late..
19:46:49 <sumpfralle> #chair dipohl
19:46:49 <MeetBot> Current chairs: TheSnide dipohl h01ger kenyon sumpfralle
19:46:52 <sumpfralle> welcome!
19:47:23 <sumpfralle> (we are discussing 2.999 bits right now)
19:48:09 <sumpfralle> but TheSnide is missing for three minutes, so maybe let's postpone this? ...
19:48:20 <dipohl> Did you already had topic next release of stable 2.0?
19:48:37 <sumpfralle> yes, it was included in the first topic
19:48:41 <dipohl> ok
19:48:47 <sumpfralle> #action TheSnide will release 2.0.37 today
19:49:02 <dipohl> good! :)
19:49:12 <sumpfralle> #topic Gallery
19:49:18 <hugin> [13munin] 15steveschnepp pushed 1 new commit to 06stable-2.0: 02https://git.io/vxa6Z
19:49:18 <hugin> 13munin/06stable-2.0 14ced8e85 15Steve Schnepp: 2.0.37
19:49:26 <sumpfralle> he just did :)
19:49:45 <hugin> [13munin] 15steveschnepp tagged 062.0.37 at 14dacf89d: 02https://git.io/vxa6B
19:49:58 <sumpfralle> dipohl and me improved the gallery a bit and we would like to deploy it on gallery.m-m.o
19:50:03 <sumpfralle> who is in control of that server?
19:50:09 <sumpfralle> (I am not)
19:50:43 * dipohl has also no access
19:51:26 <sumpfralle> some I had ssm in mind?
19:51:56 <dipohl> yes he has, but he is not available as it seems
19:52:30 <sumpfralle> #action sumpralle asks ssm for access to gallery.m-m.o
19:52:40 <TheSnide> ssm did change job, and therefore he doesn't have acces to either
19:52:47 <dipohl> it is possible that be0rn has access
19:53:07 <sumpfralle> who could contact him?
19:53:19 <dipohl> we can send a message here in chat
19:53:22 <hugin> [13munin] 15kenyon commented on issue #945: Can you also include these related commits:... 02https://git.io/vxa67
19:53:38 <sumpfralle> or should me move it to the demo server?
19:54:01 <sumpfralle> (I do not know, what is attached to gallery.m-m.o - mails or similar?)
19:54:14 <dipohl> that would be a good workaround at least
19:54:27 <sumpfralle> TheSnide: who owns the demo server?
19:54:38 <dipohl> we can change the link in wiki accordingly
19:54:47 <sumpfralle> no - just change the DNS
19:54:52 <sumpfralle> (if we do this)
19:55:19 <TheSnide> sumpfralle: it's Bushmills
19:55:19 <dipohl> sure, if you have access to that
19:55:26 <TheSnide> but i have access
19:55:46 <sumpfralle> is it ok to move the gallery there or should we try to keep the other one?
19:56:20 <dipohl> I would prefer a server to which we have easy access
19:56:22 <sumpfralle> (I have no idea about the social network allowing us to use the server - thus I just ask blindly)
19:56:36 <dipohl> as there will be more changes following
19:56:50 <sumpfralle> e.g. the new website(!)
19:56:51 <dipohl> the links need to be adapted
19:57:08 <dipohl> when I move the wiki page about plugin gallery to the Guide
19:57:50 <sumpfralle> From my point of view, everything can go onto a single small server (just like the demo one, I guess). If we keep backups (I could arrange this), I could live with this easily. How about you?
19:58:02 <dipohl> +1
19:58:55 <dipohl> As the Munin-Gallery is also hosted on my server, we can also use that
19:59:17 <sumpfralle> yes, sounds also reasonable
19:59:21 <dipohl> I mean for the gallery
19:59:26 <sumpfralle> yes
19:59:33 <sumpfralle> Thus: who has access to the DNS zone?
19:59:59 * dipohl don't know
20:00:16 <sumpfralle> I guess, TheSnide is busy doing the finishing touches for the release announcements :)
20:00:17 <dipohl> possibly also be0rn
20:00:31 <sumpfralle> let us postpone this discussion to the next week?
20:00:35 <dipohl> ok
20:00:47 <sumpfralle> #info decide about the future gallery host
20:00:54 <TheSnide> sumpfralle: indeed
20:00:56 <sumpfralle> #info find out, who is in control of DNS
20:01:01 <sumpfralle> good! :)
20:01:08 <sumpfralle> so let us finish this meeting?
20:01:23 <dipohl> did you already talk about the new homepage?
20:01:38 <dipohl> you wanted to contact chteuchteu..
20:01:40 <sumpfralle> I said, that I asked chteuch just today
20:01:50 <sumpfralle> so he had no chance to answer, yet :(
20:01:58 <dipohl> i c
20:02:05 <dipohl> it's ok
20:02:15 <dipohl> as I still have a lot of pages to move to the Guide
20:02:18 <dipohl> ;)
20:02:20 <sumpfralle> yeah!
20:02:38 <sumpfralle> it will be all so beautiful!
20:02:51 <sumpfralle> #endmeeting