19:30:04 <sumpfralle> #startmeeting
19:30:04 <MeetBot> Meeting started Wed Apr  4 19:30:04 2018 UTC.  The chair is sumpfralle. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:30:04 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:30:13 <sumpfralle> welcome!
19:30:25 <sumpfralle> who is here?
19:30:31 * dipohl is here
19:30:38 <sumpfralle> #chair be0rn TheSnide dipohl h01ger
19:30:38 <MeetBot> Current chairs: TheSnide be0rn dipohl h01ger sumpfralle
19:31:02 <sumpfralle> (any one else wants to have chair permissions?)
19:31:10 <sumpfralle> #topic Review of the last meeting
19:31:34 <sumpfralle> http://meetbot.debian.net/munin/2018/munin.2018-03-28-19.28.html
19:31:40 <sumpfralle> Access to the gallery: I asked be0rn via IRC right now
19:31:50 <sumpfralle> TheSnide released 2.0.37 - juhu!
19:32:22 <sumpfralle> Website: I was in contact with chteuchteu - he will be happy to work on it
19:32:35 <sumpfralle> we will do the content - he will take care for technical things
19:32:50 <dipohl> fine :)
19:32:53 <sumpfralle> yes!
19:33:10 <sumpfralle> I wrote down the following potential topics: munin-node-c, guide -> manpages, #munin at irc.freenode, progress with 2.999
19:33:20 <sumpfralle> pick something?
19:34:07 <dipohl> #topic Munin Guide
19:34:19 <sumpfralle> progress?!
19:34:44 <TheSnide> hi
19:34:45 <dipohl> content from a lot of wiki pages has already been moved to the Guide
19:34:57 <dipohl> but still a lot to do left
19:35:40 <TheSnide> huge +1 with the current work
19:35:54 <sumpfralle> yes!
19:35:55 <sumpfralle> http://munin-monitoring.org/search?q=%22should+be+moved+to+the+Munin-Guide%22
19:36:01 <sumpfralle> there is the list of 22 pages
19:36:04 <sumpfralle> is this accurate?
19:36:21 <dipohl> the list may be not fully complete
19:36:55 <dipohl> as I picked the pages when I saw one valuable
19:37:44 <sumpfralle> ok. I was focussing on plugins recently. I would switch now to the guide migration - in order to get the new website soon :)
19:37:48 <dipohl> but as you see in the index, it's has shrinked very much
19:38:02 <dipohl> http://munin-monitoring.org/wiki/TitleIndex
19:38:09 <TheSnide> indeed, we should keep a static version of the wiki
19:38:33 <sumpfralle> yes, I could do that
19:38:34 <TheSnide> just in case we need it later.
19:38:47 <dipohl> TheSnide: I delete the pages on my way
19:38:51 <TheSnide> ok
19:39:04 <dipohl> as we should have an old backup
19:39:12 <sumpfralle> so we keep on deleting? (I am fine with both)
19:39:17 <TheSnide> for migrated pages, it should be deleted indeed
19:39:19 <dipohl> yes please
19:39:35 <sumpfralle> thus no static archive? (I do not mind)
19:40:14 <dipohl> when I started the work, I asked whether there is a backup
19:40:21 <dipohl> and I was told there was
19:40:32 <dipohl> so I hope there still is ;-)
19:41:07 <sumpfralle> ok - so let us postpone the potential static export after the switch to the new website?
19:41:31 <dipohl> sumpfralle: most of the content is already deleted
19:41:41 * sumpfralle likes that
19:42:20 <dipohl> I wrote to ML about the multi version agreement
19:42:28 <dipohl> and TheSnide confirmed it
19:42:35 <dipohl> that is another important issue
19:42:53 <sumpfralle> I would summarize: we would like to offer a static export; it has to be taken from a backup; this will be done later?
19:42:54 <dipohl> we have to recover deleted content about stable 2.0
19:43:05 <dipohl> summarize: yes
19:43:07 <sumpfralle> yes, I understood - and he agreed
19:43:28 <dipohl> which was already in master repo /doc
19:43:38 <sumpfralle> #info static export of trac data: we would like to offer a static export; it has to be taken from a backup; this will be done later
19:43:39 <dipohl> so we don't need the wiki backup for this
19:43:56 <dipohl> offer?
19:43:56 <sumpfralle> ah - ok - this was another topic - I was confused
19:44:02 <sumpfralle> publish
19:44:05 <dipohl> no!
19:44:15 <dipohl> we don't want 2 knowledge bases
19:44:27 <dipohl> the backup is only for archive
19:44:34 <sumpfralle> ok
19:44:51 <dipohl> and internal use (if needed, which I don't hope)
19:44:51 <sumpfralle> new text: we will keep a backup of the trac data for the archive
19:44:53 <sumpfralle> ?
19:45:08 <dipohl> yes, that would be good
19:45:24 <dipohl> if we want to lookup who is the author of content
19:45:37 <sumpfralle> #info trac data (reverting the previous note): we will keep a backup of the trac data for the archive
19:45:59 <dipohl> an _old_ backup
19:46:03 <sumpfralle> yes
19:46:07 <dipohl> < 2015
19:46:26 <sumpfralle> #info trac data (reverting the previous note): we will keep an old backup (<2015) of the trac data for the archive
19:46:33 <sumpfralle> :)
19:46:35 <dipohl> :-)
19:46:54 <sumpfralle> so let's hope for a website switch in a few weeks - yeah!
19:47:02 <dipohl> #topic multi-version Guide
19:47:25 <dipohl> we want the guide to show info for all Munin versions
19:47:36 <sumpfralle> yes
19:47:48 <dipohl> we want to mark them to get a clear understanding for the users
19:48:12 <sumpfralle> does this need preparation? (some style thing)
19:48:14 <dipohl> TheSnide proposed to use an icon of the Munin Logos
19:48:33 <dipohl> blue-white logo -> stable 2.0
19:48:44 <dipohl> green logo > version 3.0
19:49:02 <dipohl> I asked Quentin in my may if he can do this
19:49:07 <dipohl> no answer yet
19:49:45 <sumpfralle> that was a very recent request, or?
19:50:21 <dipohl> https://sourceforge.net/p/munin/mailman/message/36282315/
19:51:09 <dipohl> another task is to recover the deleted content about stable 2.0 in the Guide
19:51:24 <sumpfralle> I think, TheSnide will do this?
19:51:34 <dipohl> e.g. munin-html, munin-graph
19:51:42 <sumpfralle> (at least I understood his mail like this - without thinking further about it)
19:51:51 <TheSnide> yep
19:52:07 <dipohl> TheSnide: Please be careful..
19:52:18 <dipohl> I will not loose my recent additions :)
19:52:38 <sumpfralle> #action TheSnide will recover the few removed munin-2.0-pages of the munin-guide
19:52:38 <TheSnide> sumpfralle: we could also add our site to archive.org
19:52:45 <dipohl> TheSnide said he marks the content that is only valid for version 3.0
19:52:56 <sumpfralle> TheSnide: I thought, this happens automatically?
19:53:14 <TheSnide> well, one has to hint archive.oef
19:53:16 <TheSnide> org
19:53:17 <dipohl> sumpfralle: no, this has to be done manually
19:53:40 <sumpfralle> who will do that?
19:53:44 <dipohl> as we feed the Guide with info from both versions from the start..
19:53:50 <dipohl> fed
19:53:59 <sumpfralle> I will
19:54:11 <sumpfralle> #action sumpfralle registers the munin website at archive.org
19:54:16 <sumpfralle> dipohl: how can we mark the versions? Does this need some special markup?
19:54:25 <dipohl> yes
19:55:20 <dipohl> we need a markup that can be put to sections on a page
19:55:28 <dipohl> so small entities
19:55:52 <sumpfralle> will you prepare an example? Or is this the thing you asked Quentin?
19:56:07 <dipohl> and we can work with /notes/ additionally
19:56:23 <dipohl> I asked in my mail to the ML
19:56:36 <dipohl> I am not an expert on RST
19:56:53 <sumpfralle> ok
19:57:19 <sumpfralle> I will clarify that question on the mailinglist - just to be safe :)
19:57:30 <dipohl> thanks!
19:57:57 <sumpfralle> the time is almost up - do we want another topic?
19:58:22 <TheSnide> yup
19:58:29 <dipohl> topic Munin-Gallery?
19:58:51 <sumpfralle> #topic munin gallery
19:59:06 <sumpfralle> be0rn will report back, whether we can still use the host and gain access to it
19:59:12 <sumpfralle> (we sounded positive)
19:59:22 <sumpfralle> "we" -> "he"
19:59:30 <TheSnide> i got a reply from jo
19:59:40 <TheSnide> and got sudo root
19:59:52 <dipohl> \o/
19:59:55 <sumpfralle> yeah!
20:00:06 <sumpfralle> should we be polite and wait for be0rn answer?
20:00:24 <sumpfralle> Or is it already settled (with the technical side of the access)?
20:00:41 <TheSnide> we should tell him
20:00:44 * dipohl is not in a hurry
20:01:07 <sumpfralle> be0rn: are you listening?
20:01:29 <sumpfralle> let us switch to another topic meanwhile?
20:01:33 <dipohl> TheSnide: it would be good if sumpfralle gets access also
20:02:19 <sumpfralle> I would use it wisely :)
20:02:22 <TheSnide> the server is quite old. i have to see how we can upgrade it.
20:02:31 <sumpfralle> is it a physical machine?
20:02:31 <TheSnide> but outside meeting
20:02:35 <sumpfralle> (no VM?)
20:02:38 <TheSnide> vm
20:02:41 <TheSnide> old os
20:02:50 <sumpfralle> ok - I would be happy to take care for this
20:03:03 <TheSnide> +1
20:03:08 <dipohl> +1
20:03:47 <sumpfralle> info? we wait for access approval for sumpralle to the gallery/trac server from be0rn - correct?
20:04:39 <dipohl> ok for me
20:06:00 <dipohl> what was the issue with munin-c?
20:06:16 <sumpfralle> #info we wait for access approval for sumpralle to the gallery/trac server from be0rn
20:06:20 <sumpfralle> #topic munin-node-c
20:06:51 <sumpfralle> TheSnide: would like to replace the munin-node code (perl) with the c-based alternative
20:07:00 <sumpfralle> correct?
20:07:12 <dipohl> https://guide.munin-monitoring.org/en/latest/architecture/munin-c.html
20:07:33 <TheSnide> yep
20:08:09 <sumpfralle> I have no feelings about this.
20:08:17 <dipohl> ups, the SSL-Link brings warnings..
20:08:20 <dipohl> http://guide.munin-monitoring.org/en/latest/architecture/munin-c.html
20:09:15 <dipohl> you mean remove the perl written munin-node completely?
20:09:16 <sumpfralle> "root uid is not supported" - this is important, or?
20:10:22 <dipohl> TheSnide: does munin-c have the complete feature set of the perl munin-node?
20:10:40 <sumpfralle> according to the current state of the guide: not, yet.
20:10:58 <sumpfralle> I think, it is more question, if the direction would be ok - not if it should happen right now.
20:11:02 <TheSnide> nope. that is the main issue
20:11:34 <sumpfralle> The privilege part is probably the most interesting one :)
20:11:40 <be0rn> Oh, sorry, I'm not really here tonight. I will check about the access tomorrow.
20:12:22 <sumpfralle> be0rn: FYI TheSnide said, "jo" has technical root access
20:12:29 <sumpfralle> you decide, if this answers the question
20:12:40 <be0rn> If he has, then I have too ;-)
20:12:52 <sumpfralle> power twins!
20:13:00 <be0rn> \o/
20:14:42 <sumpfralle> regarding munin-node-c: I have no objections. Personally I have the feeling, that perl is maybe not the optimal implementation language (anymore), since we have a hard time, finding capable contributors. Thus opening the spectrum of used languages is not too, bad?
20:15:09 <sumpfralle> my commas go wrong everywhere :(
20:16:10 <dipohl> sumpfralle: don't mind, we have powerful mind parsers ;)
20:16:45 <sumpfralle> indeed!
20:17:35 <sumpfralle> let us postpone the discussion?
20:17:44 <sumpfralle> or is it done?
20:17:58 <dipohl> concerning the language switch: I am not against it (when we find solutions for the privilege problems)
20:18:14 <dipohl> but I want the full feature set of the existing node :)
20:18:19 <TheSnide> ok have to go
20:18:29 <sumpfralle> good - let us end this meeting
20:18:45 <sumpfralle> I am not here, next week - I hope, you will have fun!
20:18:49 <sumpfralle> #endmeeting