#reproducible-builds Meeting

Meeting started by lamby at 18:00:03 UTC (full logs).

Meeting summary

  1. Introductions (lamby, 18:00:22)
  2. What's the right procedure to submit non-bug improvements to diffoscope? (brett) (lamby, 18:08:43)
    1. ACTION: brett to add "reporting bugs" (or similar…) to --help output of diffoscope (lamby, 18:12:14)

  3. jenkins.debian.org psuedopackage (lamby, 18:12:22)
    1. ACTION: danielsh to mention on t.r-b.o how to file bugs using the new pseudopackage (in the footer…?) (lamby, 18:15:01)

  4. CI guidelines for setting reproducibility workarounds (e.g. S_D_E) (emaste) (lamby, 18:15:36)
  5. is there a proper download URL for strip-nondeterminism tar? (bmwiedemann) (lamby, 18:22:32)
    1. ACTION: lamby to publish generic tools somewhere (future-proof URL) and to update release docs (lamby, 18:29:53)
    2. https://anonscm.debian.org/git/reproducible/strip-nondeterminism.git (lamby, 18:30:13)

  6. upstreaming reproducibility fixes (e.g. avfs done by bmwiedemann) (lamby, 18:30:31)
    1. IDEA: < danielsh> (track patches without "Forwarded: yes" DEP-3 metadata, by age, and so forth) (lamby, 18:39:25)
    2. http://dep.debian.net/deps/dep3/ (vagrantc, 18:40:47)

  7. Any other business? (lamby, 18:41:24)
    1. IDEA: github organisation to collate r-b patches against github-hosted upstreams (StevenC99, 18:52:01)


Meeting ended at 18:52:50 UTC (full logs).

Action items

  1. brett to add "reporting bugs" (or similar…) to --help output of diffoscope
  2. danielsh to mention on t.r-b.o how to file bugs using the new pseudopackage (in the footer…?)
  3. lamby to publish generic tools somewhere (future-proof URL) and to update release docs


Action items, by person

  1. brett
    1. brett to add "reporting bugs" (or similar…) to --help output of diffoscope
  2. danielsh
    1. danielsh to mention on t.r-b.o how to file bugs using the new pseudopackage (in the footer…?)
  3. lamby
    1. lamby to publish generic tools somewhere (future-proof URL) and to update release docs


People present (lines said)

  1. lamby (75)
  2. bmwiedemann (35)
  3. danielsh (34)
  4. vagrantc (32)
  5. emaste_ (24)
  6. StevenC99 (10)
  7. brett (9)
  8. dkg (6)
  9. MeetBot (4)
  10. infinity0 (2)
  11. h01ger (1)
  12. siamezzze (1)


Generated by MeetBot 0.1.4.