#reproducible-builds: Reproducible Builds Meeting #7

Meeting started by danielsh at 17:59:46 UTC (full logs).

Meeting summary

  1. Introductions (danielsh, 17:59:54)
    1. agenda at https://pad.riseup.net/p/reproducible-irc-meeting-7 (mapreri, 18:00:55)

  2. Action items from last meeting (danielsh, 18:01:55)
    1. ACTION: brett to add "reporting bugs" (or similar…) to --help output of diffoscope (danielsh, 18:02:57)
    2. http://deb.debian.org/debian/pool/main/s/strip-nondeterminism/ (mapreri, 18:07:25)
    3. ACTION: lamby to publish generic tools somewhere (future-proof URL) and to update release docs (danielsh, 18:07:48)
    4. HELP: debian udd: implement DEP-3 "Forwarded" tracking #851225 (liaise with mapreri) (danielsh, 18:13:08)

  3. - SOURCE_PREFIX_MAP encoding: should we support colons in path names? (danielsh, 18:13:18)
    1. ACTION: infinity0 write code for SOURCE_PREFIX_MAP alternatives, send data to thread (danielsh, 18:16:55)
    2. https://gist.github.com/infinity0/1b9acca742aa09e032841fa2a9ef9fa8 (h01ger, 18:18:31)
    3. AGREED: Don't do a v0 SOURCE_PREFIX_MAP unless we can't agree on a v1 timelily. (danielsh, 18:18:36)
    4. AGREED: Solicit feedback on SOURCE_PREFIX_MAP before releasing a 1.0 spec. (danielsh, 18:20:38)

  4. Any other business (danielsh, 18:21:31)


Meeting ended at 18:22:19 UTC (full logs).

Action items

  1. brett to add "reporting bugs" (or similar…) to --help output of diffoscope
  2. lamby to publish generic tools somewhere (future-proof URL) and to update release docs
  3. infinity0 write code for SOURCE_PREFIX_MAP alternatives, send data to thread


Action items, by person

  1. brett
    1. brett to add "reporting bugs" (or similar…) to --help output of diffoscope
  2. infinity0
    1. infinity0 write code for SOURCE_PREFIX_MAP alternatives, send data to thread


People present (lines said)

  1. danielsh (66)
  2. h01ger (23)
  3. mapreri (21)
  4. infinity0 (17)
  5. vagrantc (11)
  6. brett (3)
  7. MeetBot (2)
  8. FauxFaux (1)
  9. emaste (1)


Generated by MeetBot 0.1.4.