#reproducible-builds Meeting

Meeting started by lamby at 15:59:37 UTC (full logs).

Meeting summary

  1. Introductions (lamby, 15:59:50)
    1. Apologies from Mattia (mapreri) -- it's Festa della Repubblica tomorrow (lamby, 16:02:14)
    2. there is #archlinux-reproducible on freenode (h01ger, 16:03:10)

  2. Feedback for the reproducible.json spec format (lamby, 16:04:41)
    1. proposed format: http://rb.zq1.de/spec/json-format.txt (h01ger, 16:05:46)
    2. https://tests.reproducible-builds.org/reproducible.json.bz2 is the format debian is using (h01ger, 16:06:31)
    3. : the next step is to write a parser for this json and feed the data into postgresql on jenkins.d.n - then the next step is to modify our debian python scripts, running as jenkins jobs, to enable them to build debian pages and suse pages (h01ger, 16:15:53)
    4. once we have this json parser, the format defintion should be part of that code, possible as comments - because that will be the de facto reference implementation (h01ger, 16:16:14)
    5. https://github.com/polydawn/hitch/blob/7c30b81209d7495eb09a6f079b3458beeebb6b74/api/records.go (Eric[m], 16:23:02)
    6. https://github.com/polydawn/hitch/blob/7c30b81209d7495eb09a6f079b3458beeebb6b74/api/records.go (lamby, 16:23:29)
    7. https://github.com/bdrung/image-release-spec (lamby, 16:23:36)

  3. tests.r-b.o/Debian once Stretch has been released (lamby, 16:24:25)
  4. upgrading build nodes once stretch is out (h01ger, 16:28:37)
  5. Reproducible Builds Summit #3 2017 (h01ger, 16:35:46)
    1. ACTION: h01ger to set up a doodle poll re Summit #3 dates (lamby, 16:39:39)
    2. Tentative dates are a) Oct 31 → Nov 2, b) Nov 7 → Nov 9. (lamby, 16:43:51)
    3. no work has been done on funding the event yet… talk to us if you want to sponsor it (h01ger, 16:44:31)

  6. Next meeting when? (lamby, 16:46:48)
    1. next meeting on the first thursday of the month, that will be july 6th 2017 at a to be decided time (h01ger, 16:48:20)
    2. ACTION: lamby will announce the next meeting (h01ger, 16:48:32)

  7. Any other business (lamby, 16:48:43)


Meeting ended at 16:59:09 UTC (full logs).

Action items

  1. h01ger to set up a doodle poll re Summit #3 dates
  2. lamby will announce the next meeting


Action items, by person

  1. h01ger
    1. h01ger to set up a doodle poll re Summit #3 dates
  2. lamby
    1. lamby will announce the next meeting


People present (lines said)

  1. h01ger (130)
  2. lamby (60)
  3. bmwiedemann (45)
  4. vagrantc (39)
  5. Eric[m] (14)
  6. sangy (12)
  7. emaste (11)
  8. danielsh` (8)
  9. MeetBot (3)
  10. Faux (3)
  11. fsckd (2)
  12. siamezzze (1)
  13. infinity0 (1)


Generated by MeetBot 0.1.4.