18:08:55 <vagrantc> #startmeeting
18:08:55 <MeetBot> Meeting started Mon Nov 9 18:08:55 2020 UTC. The chair is vagrantc. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:08:55 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:09:13 <vagrantc> #topic say hello
18:09:19 <vagrantc> hello!
18:09:34 <Foxboron> Hello!
18:09:36 <jelle> hello!
18:10:06 <bmwiedemann> hello
18:10:10 <vagrantc> ok, that was easy.
18:10:30 <vagrantc> #topic pick time for "how to debug" session on 2020-11-16 https://framadate.org/CFKEmKOb3avTbPFe
18:10:49 <vagrantc> looks like the poll suggests 17UTC
18:11:24 <jelle> indeed
18:12:04 <vagrantc> shall we proceed with that time?
18:12:28 <bmwiedemann> not ideal for me, but you have my writeup already to work with
18:13:02 <vagrantc> bmwiedemann: a shame, since you proposed the topic ...
18:13:52 <vagrantc> i am curious what various other distros do, and it'd be great to be able to ask questions, since i don't know the specifics of other distros all that well
18:14:31 <vagrantc> and ... scheduling is hard.
18:14:52 <vagrantc> bmwiedemann: you think there's a chance you can make it?
18:15:10 <bmwiedemann> that reminds me that Neal mentioned 2 other Fedora people working on reproducible builds. pgreco = Pablo Greco + ignatenkobrain = Igor Raits
18:15:41 <vagrantc> oh, would be good to rope them in
18:16:05 <bmwiedemann> yes, I will probably be there for some time. just not 100%
18:16:16 <vagrantc> ok, let's go with 18UTC then
18:16:42 <vagrantc> #agreed 2020-11-16 18:00UTC
18:16:49 * h01ger waves as he just comes in
18:17:04 <h01ger> happy vagrantc took over the chairing!
18:17:08 * vagrantc waves
18:17:28 <vagrantc> #topic pick topic(s) for future (2020-11-30?) topic-specific irc sessions
18:17:41 <vagrantc> so, shall we randomly select the next topic? 2020-11-30 ?
18:17:49 <vagrantc> poll for time again?
18:18:14 <jelle> sounds good
18:18:24 <vagrantc> or anyone want to weigh in on a topic they'd really like to see?
18:18:49 <vagrantc> the previously brainstormed topics are:
18:19:05 <vagrantc> <h01ger> discussion of rb-format
18:19:05 <vagrantc> <h01ger> debian: distributing .buildinfo files for real
18:19:05 <vagrantc> <h01ger> debian: a new .deb format including .buildinfo files (combine or separate from previous?)
18:19:08 <vagrantc> <jelle> goals from last summit https://reproducible-builds.org/files/ReproducibleSummit5EventDocumentation.html#__RefHeading___Toc14828_2303288670
18:19:11 <bmwiedemann> we could use the Gunner method of sticking dots to a topic and see where there are most
18:19:11 <vagrantc> <Foxboron> review current published research being done; collect some of it on the webpage.
18:19:14 <vagrantc> <vagrantc> diverse-double-compiling in the real world
18:19:17 <vagrantc> <bmwiedemann> use dettrace more in tools - especially the autoclassify.
18:19:20 <vagrantc> <vagrantc> strategize a vision for reproducible builds 1/3/5 years in the future
18:19:23 <vagrantc> <vagrantc> open office hours Q&A session
18:19:25 <vagrantc> <jelle> rebuilder progress / pain points
18:19:28 <vagrantc> <david-a-wheeler> fully reproducible distros ... next steps (needs to be broken down a bit more)
18:19:31 <vagrantc> it would probably cause spots on my screen
18:20:32 <bmwiedemann> If we only had modern real-time collaboration tools...
18:21:06 <bmwiedemann> e.g. etherpad
18:21:18 <vagrantc> https://pad.sfconservancy.org/p/reproducible-builds-meeting-agenda
18:21:31 <vagrantc> should have mentioned the pad earlier...
18:21:44 <jelle> we can skip the rebuilder progress / pain points I think
18:21:49 <vagrantc> problem was, i was interested in nearly all of them
18:21:54 <jelle> :D
18:22:16 <bmwiedemann> vagrantc: chose the top 3 of them then
18:23:31 <vagrantc> ok, i'll mark three of them, if everone else does, we'll see what happens
18:23:36 <Foxboron> Reviewing the research would require some planning and time though :)
18:23:52 <Foxboron> as a headsup :p
18:24:39 <vagrantc> Foxboron: maybe propose that for the following with more lead time?
18:25:16 <vagrantc> we have some difficult to distinguish colors :)
18:25:22 <jelle> kinda interesting in the double compilation, but not sure how much time I'd dedicated to it
18:25:26 <jelle> vagrantc: oh good pint
18:25:49 <jelle> err.. I marked Q/A and research papers
18:26:19 <vagrantc> alright, i cast my three
18:26:40 <vagrantc> seems like three entities have cast at least two
18:26:59 <jelle> double-compilation is fun, as well, we kinda left off somewhere at the last summit
18:27:18 <jelle> but I am not sure how much time I want to invest versus reproducible buidls progress
18:27:23 <vagrantc> been putting more into it, but floundering
18:27:42 <jg> vagrantc: might be good to call for an agenda some days before each meeting. That tends to allow for things to percolate well, and when something percolates to the top that may need some study in advance, time to do homework (e.g. diverse double compilation).
18:27:57 <vagrantc> jg: agreed
18:28:18 <jg> the power of the chair is to help set the agenda, so select a topic....
18:28:22 <vagrantc> in absence of further input, let's do office hours...
18:28:38 <vagrantc> jg: i kind of fell into the chair role this time on short notice :)
18:29:12 <jg> heh. Been there, done that on HTTP. someone has to be responsible to organize a meeting. I'm happy to elect someone else ;-).
18:29:49 <vagrantc> i guess i'll call it "office hours / open questions" so as not to confuse it with openoffice. :)
18:30:21 <bmwiedemann> vagrantc: would that be a one-off or will we discuss how to establish regular office hours?
18:30:32 <vagrantc> bmwiedemann: i'd be open to either
18:30:37 <jg> the other responsibiity of a chair is to ensure minutes go back to the mailing list....
18:30:40 <vagrantc> long-term, i think it'd be cool to have a standing session
18:30:45 <jelle> agreed
18:31:11 <vagrantc> it's a potential entry point for new contributors, people curious about the topic, etc.
18:31:45 <vagrantc> let's do one, see how it goes, and then maybe open it up for a standing thing?
18:31:58 <vagrantc> and do a bunch of outreach
18:32:12 <vagrantc> or at least, i'll try to ... :)
18:32:13 <bmwiedemann> I'd think, we can just try to have an increased IRC presence around Mondays 18:00 UTC +-2h
18:32:28 <vagrantc> bmwiedemann: that's not a bad idea, sure
18:32:46 <h01ger> sorry, i'm still not really here...
18:33:08 <vagrantc> though having a specific time to advertise and at least 1-3 people to actualyl answer :)
18:33:19 <Foxboron> Im always on IRC :p
18:33:26 <vagrantc> exactly
18:34:52 <vagrantc> so ... unless there are objections ... let's call the office hours for 2020-11-30 ... maybe just call the hours 16-19UTC ? i can be there that whole time and if anyone else is available, so much the better?
18:35:13 <bmwiedemann> +1
18:35:19 <jelle> worksforme!
18:35:24 <Foxboron> Yes :)
18:35:35 <jelle> vagrantc: maybe we should also mail/tweet about it
18:35:41 <vagrantc> jelle: exactly
18:35:52 * jelle can offer a free retweet
18:35:58 * vagrantc wonders how 2020-11-30 is for holidays
18:36:13 <vagrantc> might be an awkward time to start this, at least from a USA perspective
18:36:52 <vagrantc> tail end of thanksgiving weekend ... but hey, whatever :)
18:36:58 <bmwiedemann> black friday is 2020-11-27
18:37:35 <vagrantc> whatever, we can always do it another time :)
18:37:55 <jelle> isn't the holiday ideal for hacking?
18:38:02 <jelle> *holidays
18:38:02 <vagrantc> :)
18:38:27 <vagrantc> #agreed we'll pilot "office hours / open questions" 2020-11-30 16-18UTC
18:38:38 <vagrantc> hopefully MeetBot is listening to me :)
18:39:08 <vagrantc> #topic any other business
18:39:19 <vagrantc> anything else you've been holding back on? :)
18:39:56 <jelle> happy with kpcyrd's new rebuilderd, I hope Debian also get's an instance soon!
18:39:57 <vagrantc> otherwise ... we call this a short meeting
18:40:03 <bmwiedemann> shall we think about a schedule for the rb research topic already, to give enough time to prepare?
18:40:22 <vagrantc> bmwiedemann: sounds good to me
18:41:21 <bmwiedemann> also, the topic sound a bit ambiguous: is it about published research or ongoing research "being done" ?
18:41:49 <vagrantc> Foxboron: care to comment what your thoughts were?
18:42:13 <Foxboron> bmwiedemann: Yo, I thought we could see what people has published.
18:42:29 <Foxboron> So nothing "in the works" but has been presented/published and i relevant to this effort.
18:42:39 <jelle> "new insights"?
18:42:51 <Foxboron> Yeah, essentially. Try not work in a vaccu,
18:42:57 <Foxboron> vaccum*
18:43:21 <bmwiedemann> so collect the state-of-the-art
18:43:29 <vagrantc> so seeking out and cataloging what's already out there
18:43:37 <vagrantc> and deciding how to publish it
18:44:01 <Foxboron> Essentially. If there is anything new we should keep an eye on or new insight from academia we are somewhat deatached from
18:44:25 <vagrantc> sounds interesting
18:44:28 <Foxboron> If there are people interested presenting research to us it might be interesting, but maybe not the right forum
18:45:07 <Foxboron> I know sangy keeps an eye and so on. So it might be interesting having something curated and pointed at with a short intro. Im a bit unsure how we'd present it
18:45:17 <vagrantc> having such stuff up on our site might also make it more likely other new work will get in touch with us
18:45:20 <Foxboron> but we want to add academic work to the website so I think this is all relevant
18:45:40 <Foxboron> vagrantc: we have some already. On my todo to go over it and improve the few we have.
18:45:46 <vagrantc> great
18:45:55 <Foxboron> https://reproducible-builds.org/docs/publications/
18:46:27 <vagrantc> the next topic-specific slot would be december 14th, if we follow the same pattern
18:47:17 <jg> vagrantc: note that both chairing a meeting and taking notes is often not feasible. you should feel free to ask for a scribe for minutes.
18:47:52 <h01ger> #info meetbot can take notes during the meeting and will write an automated summary
18:47:53 <vagrantc> jg: we have a bot to do that for us
18:48:45 <jg> that's good for the notes, but that doesn't get one finished minutes....
18:49:13 <vagrantc> jg: it's the best we've got, and anyone can step in to improve it
18:49:53 <jg> ask an attendee to generate minutes from the bot notes....
18:50:34 <vagrantc> i don't think there's enough content in this meeting to warrant more detailed notes than what meetbot will generate
18:50:57 <vagrantc> but if someone wants to do the work, they're welcome to
18:51:40 <jg> certainly not today's meeting...
18:51:51 <bmwiedemann> Foxboron: would 2020-12-14 work for you or should we schedule another topic before?
18:52:14 <Foxboron> bmwiedemann: Do another topic :) I think I need some help from sangy :p
18:52:20 <Foxboron> and he is busy :D
18:53:20 <vagrantc> Foxboron: so maybe bring it up at another meeting or on the list when you've got a little more background sorted?
18:53:22 <bmwiedemann> I'd just go to scholar.google.com and look what I find.
18:53:45 <Foxboron> bmwiedemann: yes, a good starting point but doesnt cover everything usually
18:54:00 <Foxboron> vagrantc: that works for me :)
18:55:07 <vagrantc> #info Foxboron will continue to do followup on related published research
18:55:13 <Foxboron> <3
18:55:25 <bmwiedemann> that would leave 2020-12-14 for the long-term vision then. Certainly a topic that can need some preparation, too
18:55:46 <vagrantc> bmwiedemann: good point!
18:55:57 <vagrantc> maybe we tentatively schedule that for then ...
18:56:13 <vagrantc> end of year is also a theoretically good time to review and plan for the future :)
18:56:39 <bmwiedemann> new year's resolution for r-b?
18:56:48 <vagrantc> heh
18:57:17 <vagrantc> bmwiedemann: shall we propose that as a tentative proposal and confirm at the next meeting?
18:57:23 <bmwiedemann> yes
18:57:51 <vagrantc> #agreed tentatively propose 2020-12-14 for the long-term vision
18:58:07 <vagrantc> i daresay, we'll conclude on time
18:58:14 <jelle> :)
18:58:19 <vagrantc> #endmeeting