17:58:08 <h01ger> #startmeeting
17:58:08 <MeetBot> Meeting started Mon Dec  7 17:58:08 2020 UTC.  The chair is h01ger. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:58:08 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:58:26 <h01ger> #topic say hi and review/amend the agenda at https://pad.sfconservancy.org/p/reproducible-builds-meeting-agenda
17:58:37 * h01ger = Holger Levsen, hello again
17:58:37 * vagrantc = Vagrant Cascadian
18:00:20 <h01ger> seems this could be a very short meeting :)
18:00:40 * h01ger will wait 3 more min
18:01:23 <kpcyrd> before I suggest any items, can somebody describe the scope of the meeting in a short sentence for me? :)
18:02:38 <jelle> o/
18:02:57 <h01ger> kpcyrd: top level topics, where we might find out about details which we then discuss in detail at another place
18:03:07 <jathan> Hello.
18:03:24 * h01ger is a happy a few more peopole showed up
18:03:54 <h01ger> kpcyrd: you are editing the list for the other type of meetings (which is cool, i just want to make sure you know)
18:04:24 <h01ger> #topic review of action items from last meeting http://meetbot.debian.net/reproducible-builds/2020/reproducible-builds.2020-11-23-17.58.html
18:04:37 <h01ger> there were two action items:
18:04:51 <h01ger> bmwiedemann was going to post the results of the debugging meeting to the list
18:05:08 <h01ger> and vagrantc was going to announce the AMA / office hours meeting
18:05:31 <vagrantc> ah, was planning on announcing the *next* meeting ... bah.
18:06:02 <h01ger> i cannot find such a mail from bmwiedemann... but i'm confident this is a good enough reminder and we can move on :)
18:06:15 <vagrantc> works for me
18:06:35 <h01ger> #action bmwiedemann will either post the results of the debugging meeting or tell us he already did
18:06:55 <h01ger> #topic topic specific meetings: review of the last one: open office hours Q&aA session
18:07:24 <h01ger> #info that meeting was logged too: http://meetbot.debian.net/reproducible-builds/2020/reproducible-builds.2020-11-30-17.19.log.html
18:07:49 <jelle> I didn't fully participate but it looked really good
18:07:50 <vagrantc> it was nice, we actually had some good questions :)
18:07:53 * h01ger liked what he saw of that meeting, but wasnt present all the time. i think we should repeat these, eg monthly
18:08:11 <vagrantc> i vaguely recall tentatively planning for another early/mid january
18:08:37 <h01ger> #info another office hour session is planned for early/mid january
18:08:43 <h01ger> vagrantc: are you doing this or?
18:08:58 <vagrantc> h01ger: i was planning on it, yeah
18:09:09 <h01ger> cool
18:09:12 <vagrantc> maybe i talked about the january one at the last session
18:09:27 <h01ger> #action vagrant is driving the next office hour session in january
18:10:02 <h01ger> so, next topic then
18:10:19 <h01ger> #topic next topic specific meeting: when and which topic
18:10:20 <vagrantc> wait
18:10:35 <vagrantc> can we revert topic briefly, i found the time
18:11:36 <h01ger> #topic topic specific meetings: review of the last one: open office hours Q&aA session
18:11:54 <vagrantc> #action vagrant will post next meeting time to list 2021-01-07 18:00-20:00 UTC
18:11:58 <vagrantc> ok, thanks :)
18:12:07 <jelle> nice!
18:12:31 * h01ger puts it into his calendar
18:12:34 <h01ger> #topic next topic specific meeting: when and which topic
18:13:10 <h01ger> vagrantc: again your topic :)
18:13:43 <vagrantc> i've driven a few, wouldn't mind if someone else wanted to go for it
18:14:04 <vagrantc> that said, we tentatively planned a long-term vision session for the ... 14th of this month, i think?
18:14:43 <h01ger> i guess so, thats in 7 days
18:15:28 <vagrantc> a little brain-dump prep is here for that:
18:15:33 <vagrantc> #link https://pad.sfconservancy.org/p/reproducible-builds-vision
18:16:16 <vagrantc> as for future topics, we can feel free to brainstorm more and/or pick from the existing list in the agenda
18:16:37 * h01ger thinks its ok to only pick one in advance
18:16:56 <h01ger> so next monday, 18 UTC it is?
18:17:08 <vagrantc> for the long-term vision, sure
18:17:36 <vagrantc> unless we want to un-tentiveificate it :)
18:17:46 <h01ger> #info long term visions meetings on 20201214 at 18 UTC on #r-b
18:18:04 <vagrantc> and beyond that, maybe we pause for now and come back to it?
18:18:09 * h01ger likes meetings to be known 7 days in advance and this matches that
18:18:14 <h01ger> pause what?
18:18:18 <vagrantc> pause scheduling more
18:18:36 <h01ger> sure
18:19:12 <h01ger> #action h01ger will announce the vision meeting on the list
18:19:28 <h01ger> #topic poll for a new meeting time
18:20:14 * h01ger is happy to do another poll, i'm just unsure whether that should be about the meeting in 14 days already. on a 2nd thought, i think yes now
18:20:31 <h01ger> vagrantc: whats your take? (your name is in the pad :)
18:21:02 <vagrantc> bmwiedemann asked for it and couldn't make it, so we should at least acknowledge the request :)
18:21:16 * h01ger nods
18:21:36 <vagrantc> or should we maybe wait till january regardless?
18:21:51 * vagrantc kind of finds the last half of december to be hard for meetings
18:22:05 <h01ger> i can set up another dudle, announce it tomorrow, let it run til in 7 days, so we can announce it a week in advance. or we wait til january
18:22:08 <vagrantc> sort of off-topic
18:22:16 <vagrantc> works for me :)
18:22:30 <h01ger> in normal years i'd agree, but in 2020...
18:22:55 * vagrantc shrugs
18:23:21 <h01ger> i just wondered whether the biweekly frequency is good or too often
18:23:54 <vagrantc> it's tricky ... too infrequent and they are hard to remember ... too frequent and not much content ...
18:24:21 <vagrantc> short meetings are fine, but only if the time works for everyone ... which is hard to come by
18:24:38 <h01ger> right
18:24:53 <h01ger> #topic announcement of next meeting
18:25:31 <vagrantc> i propose to pause the general meeting till mid-january ... 11th or 18th
18:25:44 <h01ger> #info the next general meeting will be on 20201221 on #r-b. the exact time will be determinded by a dudle announced by h01ger at latest tomorrow
18:25:56 <vagrantc> or not :)
18:26:25 <h01ger> someone recently said 'too infrequent and they are hard to remember' ;)
18:26:47 <h01ger> #topic any other business
18:26:52 * vagrantc threw out a lot of points that were somewhat at odds with each other
18:28:28 <jelle> hmmm interesting
18:30:25 <jelle> I can share that we are doing some awesome work with rebuilderd / verified builds progress :)
18:31:09 * h01ger can confirm that, from watching from the sidelines
18:31:35 <jelle> I'm working on a blog post with a summary of this year's efforts
18:31:53 * jelle hopes it inspires other distros to do verified builds ^_^
18:32:06 <vagrantc> jelle: nice to hear!
18:33:38 <h01ger> josch has done some development for debrebuild which should land in devscripts soon
18:34:16 <vagrantc> which should improve the ability to do verification builds for debian?
18:34:23 <h01ger> and he is working on his metasnap service to make snapshot.d.o usable to recreate all the build envs (and not only some)
18:34:33 <h01ger> vagrantc: yes
18:34:38 <vagrantc> awesome
18:35:04 <jelle> I can share that having verification builds with nice diffoscope results help :)
18:35:35 <h01ger> :)
18:35:38 <vagrantc> yeah, i guess it really gets down to the variations you really want to test and only those
18:36:08 <jelle> I liked this idea of bmwiedemann btw of doing some sort of detection on builds, but I am too swamped :-)
18:37:01 <h01ger> last week we also (re)discovered that https://reproducible-builds.org/contribute/ needs an overhaul to make it less debian centric and move the debian speficic stuff to /contribute/debian/ or some such. if someone is looking for low hanging fruits, this has some
18:37:37 <jelle> also that would be an interesting topic for a meeting, package manager integration / verification build schemes
18:38:22 <kpcyrd> I think https://tests.reproducible-builds.org/ also shouldn't default to debian :)
18:38:27 <h01ger> jelle: yes. (we had some real life sessions about that topic too, but i guess we'll need more)
18:38:33 <h01ger> kpcyrd: patches welcome.
18:38:49 <h01ger> (i agree)
18:39:09 <h01ger> any other business? else i wouldnt mind closing 20m early today
18:39:12 <kpcyrd> I looked into that at some point but it's really difficult to maintain all the apache rewrite rules without breaking anything
18:39:31 <kpcyrd> (for me)
18:40:22 <bmwiedemann> do you need unit-tests for the rewrite rules?
18:40:25 <h01ger> https://tests.reproducible-builds.org/ should show https://reproducible-builds.org/citests/ and not what its showing right now, right? i think that should be fairly simple. will take a look!
18:40:38 <h01ger> hi bmwiedemann
18:40:47 <bmwiedemann> good evening everyone
18:40:54 <kpcyrd> yes. everything debian should be in /debian/
18:41:10 * h01ger nods
18:41:41 * h01ger is not happy more discussions were started in #debian-reproducible now, instead after the meeting.
18:41:48 <h01ger> hard to follow them all
18:42:11 <h01ger> but i guess we can close this meeting now, though i will give bmwiedemann a few minutes for closing comments :)
18:42:24 <h01ger> (bmwiedemann and everyone)
18:43:38 <bmwiedemann> I'll look for the debugging meeting minutes and send them to rb-general
18:44:15 <h01ger> :))
18:46:23 <h01ger> okidoki
18:46:34 <h01ger> thank you all for contributing!
18:46:39 <h01ger> #endmeeting