16:08:11 <asn> #startmeeting
16:08:11 <MeetBot> Meeting started Wed Aug 13 16:08:11 2014 UTC.  The chair is asn. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:08:11 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:08:13 <Yawning> it's regarding Sponsor S (on trac)
16:08:17 <asn> #action asn should forward the financial thread to kpdyer
16:08:18 <asn> ;)
16:08:41 <asn> ok.
16:08:48 <asn> and htat's pretty much what I've been up to.
16:08:52 <ianamason> selimthegrim: yes I saw, mostly they were vinods though. I was just mi=oving them across.
16:08:56 <selimthegrim> ah
16:09:02 <asn> Who wants to go next?
16:09:07 <kpdyer> i will
16:09:14 <asn> kpdyer: please
16:09:30 <kpdyer> in regards to FTE, I've setup a bunch of new bridges
16:09:39 <kpdyer> including ipv6 bridges
16:09:40 <Yawning> (https://trac.torproject.org/projects/tor/wiki/org/sponsors/SponsorS/PluggableTransports/Proposal)
16:10:09 <Yawning> fixing dual stack support on the bridge side is on my todo list, sorry about the current situation
16:10:22 <kpdyer> i've also setup bridges on ports 80/8080
16:10:28 <asn> kpdyer: saw. that's nice.
16:10:30 <kpdyer> i think i have nearly 10 fte bridges now
16:10:45 <kpdyer> also tried to do some dns-based bridges, but i didn't convince mikeperry
16:11:04 <asn> yeah saw that argument too.
16:11:08 <kpdyer> it's on my todo list to revisit that and properly think about the pros/cons of DNS bridges
16:11:21 <asn> yeah, i don't have a seasoned opinion on this either.
16:11:36 <kpdyer> i'll be presenting a paper on FTE at USENIX next week
16:11:42 <Yawning> oh sweet :)
16:11:42 <asn> great
16:11:56 <kpdyer> advances on the crypto/algo side
16:12:06 <asn> great
16:12:06 <kpdyer> but they might bubble their way into the FTE PT one day
16:12:17 <asn> *might* ?
16:12:30 <asn> why not? if they are good.
16:12:36 <Yawning> assuming I were to use libfte, how concerned should I be with interoperability?
16:12:59 <kpdyer> atm, the Tor PT and LibFTE implementations are not compatible
16:13:01 <infinity0> how's the config for fte? i'm going to try setting up a fte|websocket bridge some time
16:13:02 <Yawning> (eg: hypothetically, if I wanted a mobile version)
16:13:05 <Yawning> ah I see
16:13:20 <Yawning> are the differnces documented anywhere?
16:13:24 <kpdyer> no
16:13:56 <kpdyer> the main issue is that it will be a huge development effort to get the LibFTE work into a state that's ready for deployment
16:14:05 <Yawning> ah I see
16:14:21 <kpdyer> so, would need at least a month of solid effort, unfortunately
16:14:22 <asn> but isn't libfte used somewhere already?
16:14:28 <kpdyer> yeah, sort of
16:14:29 <kpdyer> https://github.com/uproxy/libfte
16:14:30 <asn> isn't it deployed, that is.
16:14:42 <Yawning> so the hypothetical someone should crib off the tor pt implementation
16:14:44 <asn> (btw, what are the users of FTE currently? Tor, uproxy (?), anything else?
16:14:46 <asn> )
16:14:48 <kpdyer> lantern
16:15:05 <asn> aha
16:15:16 <kpdyer> yeah, there's an important effort here to merge the various implementations
16:15:22 * dcf1 consults https://obfuscation.github.io/ and finds that the table is out of date.
16:15:22 <kpdyer> that would be good for everyone
16:15:30 <Yawning> *nods*
16:15:36 <kpdyer> yep
16:15:42 <Yawning> would merging all this mean a flag day for fteproxy bridges on the tor side?
16:15:53 <kpdyer> no
16:15:57 <asn> kpdyer: lantern doing FTE is new? was it true during the seattle meeting?
16:15:58 <dcf1> Eep, and the IRC meeting info is out of date too.
16:16:02 <Yawning> link protocol is compatibile?
16:16:03 <kpdyer> asn: yes
16:16:16 <kpdyer> link protocol will be compatible eventually
16:16:20 <Yawning> ah I see
16:16:23 <asn> "yes" means a different thing depending on which question you answered :(
16:16:46 <kpdyer> asn: yes, lantern was in FTE as of seattle.
16:16:49 <asn> kpdyer: ack
16:16:52 <dcf1> "some (FTEProxy, ...) have already been adapted to  other tools (Lantern, Psiphon"
16:16:52 <kpdyer> oops
16:16:56 <asn> dcf1: i can update the github
16:16:56 <kpdyer> other way around
16:17:06 <asn> dcf1: soon-ish.
16:17:16 <asn> anyone else who wants to do it; please feel free to.
16:17:24 * dcf1 crowdsources github patches.
16:17:32 <infinity0> blanu2 is in charge of obfuscation github i think
16:17:43 <kpdyer> so, that leads me to my next point
16:17:48 <infinity0> RushingWookie: ping
16:18:05 <kpdyer> i'm starting to wrap up on phd and have started writing my dissertation
16:18:05 <RushingWookie> Hi
16:18:29 <asn> kpdyer: aha
16:18:37 <kpdyer> so, i am starting to consider what post-phd life will look like for me
16:18:46 <asn> :)
16:18:49 <dcf1> infinity0 is the only public person at https://github.com/obfuscation/. I guess the others are private? I haven't known whom to tell people to talk to when I invite them to our github group.
16:18:58 <infinity0> RushingWookie: PT meeting atm :) date changed from last week
16:19:09 <RushingWookie> I see, didnt notice that
16:19:10 <infinity0> yeah everyone has to individually set themselves as public
16:19:41 <kpdyer> hopefully, i'll have a clear picture of what time (if any) i'll have to properly sort out these various FTE implementations
16:19:44 <selimthegrim> kpdyer: going to stick around Portland?
16:19:54 <kpdyer> selimthegrim: maybe
16:20:11 <infinity0> dcf1: although it looks like everyone is an admin
16:20:15 <infinity0> 11 members atm including a lot of people here
16:20:33 <asn> kpdyer: ok.
16:20:41 <kpdyer> as one option, i've submitted a grant to OTF (https://www.opentechfund.org/) to properly sort out obfuscation across these various projects
16:20:55 <kpdyer> and i have a number of other interesting paths that i may go down
16:21:08 <infinity0> oh, no. there's an admin "team" where everyone is a member, but we have no actual permissions to admin the obfuscation group :/
16:21:08 <kpdyer> so, that's why i was interested in the financial talks
16:21:39 <asn> kpdyer: the financial talks will not be that interesting, I'm afraid.
16:21:55 <kpdyer> asn: fair enough, just want to make sure we're not duplicating efforts
16:21:59 <kpdyer> will anyone else be at usenix?
16:22:02 <asn> absolutely
16:22:08 <asn> i'nm not going to be at usenix :(
16:22:19 <asn> roger will be, of course.
16:22:26 <kpdyer> ok
16:22:26 * dcf1 will.
16:22:28 <asn> i bet he will have good suggestions for your funding questions.
16:22:38 <kpdyer> asn: i'm sure he will
16:22:46 <kpdyer> dcf1: have you got an invite to the state department event?
16:22:58 <dcf1> I think I got something like that.
16:23:32 <dcf1> I think I will do a short work-in-progress talk about domain fronting at the beginning of FOCI.
16:23:46 <kpdyer> ok, cool
16:24:18 <asn> great
16:24:24 <kpdyer> that's roughly it from me
16:24:24 <asn> kpdyer: are you done? :O)
16:24:28 <asn> should we proceed?
16:24:32 <kpdyer> yep, i'm done
16:24:37 <asn> thanks
16:24:39 <asn> who next?
16:24:48 <selimthegrim> Myself, Ian, and Vinod?
16:24:54 <asn> selimthegrim: yes, go for it.
16:25:12 <selimthegrim> I stabilized the performance issues we were having last week
16:25:44 <selimthegrim> some of it is just inherent in the overhead of the new class structure, but some of it is due to our default large buffer size
16:26:05 <selimthegrim> It will be interesting to see the JavaScript patches I submit's effecfs
16:26:22 <selimthegrim> *effects which I'll be taking a closer look at later today
16:26:30 <selimthegrim> no dropped packets though at least
16:27:17 <selimthegrim> I was going over Ian and Vinod's commits as well and had a few minor points relevant to the tickets I want to finish by the 18th
16:27:31 <selimthegrim> But they can be probably hashed out over github
16:28:14 <selimthegrim> the big hurdles left are the SOCKS patch and the transparent proxy
16:28:34 <asn> ack
16:28:47 <selimthegrim> yegnev, ianamason: how is the gitian coming on Linux
16:29:35 <ianamason> so i just finised a streaming mjpeg module which will appear soon on github, and am now back to finalizing the gitain TBB bundles.
16:29:51 <selimthegrim> yes, I was going to ask about that content type
16:29:59 <asn> you've made a functional TBB? :)
16:30:02 <ianamason> today i am testing the windows and linux bundles.
16:30:21 <ianamason> yes the mac works fine, we demoed it at the last safer PI meeting.
16:30:37 <ianamason> yes all three should work.
16:30:53 <selimthegrim> hmm, im getting my new MBA this week, that should give it a workout
16:30:54 <selimthegrim> ok
16:31:24 <selimthegrim> i will get around to integrating that for the tor fork after the GSoC close date, since it's not one of the listed objectives
16:31:24 <asn> .oO(master of business administration + stegotorus?)
16:31:28 <selimthegrim> heh
16:31:31 <selimthegrim> MacBook Air
16:31:37 <asn> ah
16:31:42 <selimthegrim> courtesy of Tulane University physics dept
16:32:36 <selimthegrim> Did you guys run valgrind as a normal step or in response to functional bugs in JEL
16:32:46 <ianamason> selimthegrim: I added a gitian directory to the github stegotorus wuthh all the recipes.
16:32:47 <selimthegrim> when you discovered your bug
16:32:52 <selimthegrim> excellent.
16:33:22 <ianamason> yes I valgrind everything. I also used fortify and coverity just pennies for heaven
16:33:43 <asn> (is anyone else waiting for a status report btw? except from dcf1 ?)
16:33:54 <RushingWookie> me
16:34:46 <infinity0> RushingWookie: go ahead
16:35:02 <selimthegrim> ianamason: I might need your help using valgrind at some point, I had a bit of trouble integrating the ctgrind patch, but that can wait until after the 18th
16:35:13 <RushingWookie> Ok so as this is the last week of GSoC, I’ve been trying to finish up.
16:35:36 <RushingWookie> I’m still working on a pull request for deduplicating pts
16:35:49 <RushingWookie> and ive been writing some tests for fog
16:36:13 <ianamason> selimthegrim: valgrind on linux. mac too dodgey
16:36:21 <selimthegrim> yes, of course.
16:36:31 <asn> RushingWookie: it would also be great
16:36:37 <asn> if you could prepare some kind of document with future directions
16:36:37 <infinity0> by "deduplicating pts" is meant how we handle the case where one program provides more than one PT method, e.g. obfsproxys -> obfs3,scramblesuit
16:36:38 <selimthegrim> wait, the build is too dodgy or valgrind
16:36:43 <asn> ruand problems of the current architecture
16:36:46 <RushingWookie> ok
16:36:54 <RushingWookie> infinity0: yeah
16:36:58 <asn> infinity0: ack
16:37:16 <selimthegrim> ok ill stick to linux then for poking
16:37:21 <RushingWookie> asn: Yeah I’ll write a doc and send it out on the tor-dev list
16:37:37 <asn> RushingWookie: great
16:38:13 <ianamason> selimthegrim: valgrind on mac == dodgey.
16:38:22 <infinity0> quick report from me, i have to go in a few min - last week we put flashproxy in the debian ftp upload queue
16:38:23 <infinity0> https://ftp-master.debian.org/new.html
16:38:24 <RushingWookie> i also have to finish up passing the ServerTransportOptions to each pt. ive figured out how to do it but just need to get the format nailed down
16:38:45 <RushingWookie> #12614
16:39:06 <RushingWookie> thats about it for me
16:39:19 <selimthegrim> ah that is relevant to me as well
16:39:27 <infinity0> :) thanks!
16:39:28 <asn> great
16:39:36 <asn> dcf1: you want to hit us with music?
16:39:45 <asn> with *your* music?
16:39:51 <dcf1> With pleasure.
16:40:06 <dcf1> I was at Def Con last week.
16:40:15 <dcf1> One talk was quite PT-related.
16:40:26 <dcf1> I shall link to the slide where the PT discussion starts and you acn navigate with the arrow keys.
16:40:26 <asn> thegrugq's talk?
16:40:27 <asn> yeah.
16:40:29 <dcf1> https://www.portalmasq.com/assets/player/KeynoteDHTMLPlayer.html#24
16:40:40 <dcf1> Also https://www.portalmasq.com/portal-defcon.pdf.
16:41:05 <dcf1> It's a nice thing to look at if you like seeing your software's name in PowerPoint form.
16:41:20 <asn> )
16:41:21 <asn> :)
16:41:36 <dcf1> Apart from that, the 4.0-alpha-1 release features meek over Google and meek over Amazon.
16:41:49 <dcf1> How it looks is: https://trac.torproject.org/projects/tor/wiki/doc/meek#Quickstart.
16:42:11 <kpdyer_> how was that talk?
16:42:20 <kpdyer_> in the abstract they talk a lot about FTE
16:42:21 <dcf1> I think I will write a short blog post explaining how to use it.
16:42:24 <kpdyer_> in the slides, not at all
16:42:31 <dcf1> The talk was good, kpdyer.
16:42:32 <asn> dcf1: great idea (wrt blog post)!
16:42:34 <kpdyer_> or, they review all PTs
16:42:53 <dcf1> Yes, the talk was not really related to the abstract nor the title. I suspect it changed after they got it accepted.
16:43:13 <selimthegrim> dcf1: This seems related to the talk Ryan gave at HOPE?
16:43:13 <asn> the original talk was more PT-ish?
16:43:20 <dcf1> I talked to one of the speakers afterward, and I emailed all three of them to invite them to this meeting and the github etc.
16:43:22 <selimthegrim> on travel routers?
16:43:36 <dcf1> asn, https://defcon.org/html/defcon-22/dc-22-speakers.html#Lackey.
16:43:37 <asn> dcf1: ah great
16:43:57 <dcf1> I'm sure there will be a video online by and by.
16:43:57 <selimthegrim> in fact I believe it _is_ the same talk.
16:44:22 <dcf1> Don't know selim, I wasn't at HOPE.
16:44:29 <dcf1> That's all from me.
16:44:53 <selimthegrim> I have a DVD of this talk, if anyone should need a copy.
16:45:09 <asn> thank you dcf1
16:45:15 <asn> anyone else waiting in line
16:45:15 <asn> ?
16:45:48 <asn> aaand I think this sums it up
16:45:54 <asn> let me shut down that useless meetbot
16:45:54 <Yawning> \o/
16:45:55 <asn> #endmeeting