13:32:20 <nickm> #startmeeting
13:32:20 <MeetBot> Meeting started Wed Sep 24 13:32:20 2014 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:32:20 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:32:28 <nickm> I think it's time for a tor meeting!  Who's in?
13:32:30 <nickm> (I am)
13:32:31 * asn is in
13:32:38 <Sebastian> yo
13:32:38 <Yawning> <-
13:34:34 <athena> hello meeting!
13:34:36 <nickm> ok. so, I've been distracted by some libevent stuff, but I've got some patches merged and some schedule stuff written.  I sent a sponsorS schedule thing to arma .  Either it's perfect, or arma still needs to let me know what to improve.
13:35:18 <nickm> I'm hoping I can start implementing more 0.2.6.x features pretty soon, and that others can too.
13:35:19 <athena> the big horrible rebase is finished and in my cmux_refactor_for_026_squashed
13:35:24 <nickm> wooot!
13:35:28 <Yawning> \o/
13:35:32 <athena> also got some code reviews done
13:35:54 <nickm> athena: next is ... sharing it with robgjansen, and everybody tries to review it?
13:36:04 <athena> yeah, sounds about right
13:36:11 <nickm> dgoulet, Yawning: this is a big branch, and if I try to review it alone, I will kinda go mental and let athena down.
13:36:25 <nickm> asn: Sebastian: you too if you can
13:36:34 <Yawning> Is there a ticket number associated with this?
13:36:43 <Sebastian> I need to learn about channels.
13:36:45 <athena> #9262 IIRC
13:36:46 <Yawning> so I can just write that down and not forget?
13:36:50 <Yawning> ty
13:36:50 <Sebastian> I haven't groked them yet unfortuantely
13:36:55 <nickm> yes, #9262.
13:37:01 <athena> looks like we're short a bot
13:37:18 <Yawning> oh hey that's on my whiteboard already
13:37:39 <Yawning> s/not/and/ apparently >.>
13:37:52 * nickm mentions the branch on the ticket.
13:39:17 <Yawning> I did a bunch of reviews, wrote a tiny patch for #13213
13:39:36 <nickm> I've emailed djb, tanja, ian goldberg, nick hopper, and aniket kate about my ed25519 stuff.  If nobody gets back to me, I'm going to have to think.
13:39:41 <Yawning> looked over the guardiness script and then asn started chainsawing it apart to use sqlite, so need to re-review
13:40:00 <nickm> athena: I'm seeing some warnings when I build that branch with --enable-gcc-warnings
13:40:12 <nickm> not too many though
13:40:28 <nickm> gcc 4.8.3
13:40:29 <Sebastian> clang and gcc report different warnings with --enable-gcc-warnings. It's best to use both to be sure
13:40:44 <athena> okay, i'll try it and have a look
13:40:48 <nickm> thanks
13:41:10 <Sebastian> can we get rid of the c90 stuff? Are there systems we care about that don't have a more recent compiler?
13:41:31 <nickm> That's a good research question.  Open a ticket, maybe?
13:41:34 <Yawning> someone, somewhere will complain
13:41:36 <Yawning> >.>
13:42:00 <nickm> I don't care too much if we break the native irix compiler or something.
13:42:18 <nickm> I'd like to keep building with gcc, clang, icc, msvc, etc.
13:42:23 <Sebastian> Yawning: it's hard to research that without making the change and seeing if someone complains. I'll open a ticket and propose a way forward.
13:42:38 <Yawning> Sebastian: yar
13:43:40 <nickm> #action sebastian opens a ticket and tells people about how to drop our c90 requirement
13:43:52 <nickm> #action yawning will have a look at the latest branch for 9262
13:43:57 <nickm> #action nickm will have a look at the latest branch for 9262
13:44:08 <nickm> perhaps we should collaborate after our initial review.
13:44:27 <Yawning> indeed
13:45:28 <nickm> here's the sponsor s schedule draft for sponsor-s testing that I did for armadev : http://paste.debian.net/122796/
13:45:29 <Yawning> (I seem to recall hearing rumors of gerrit or similar)
13:45:42 <nickm> If it looks dumb or impossible, someone should let me know soon.
13:46:06 <nickm> Yawning: I think gerrit/something-similar is stalled waiting on somebody to say they're willing to install and babysit it.
13:46:26 <nickm> s/to say they're willing//;
13:46:31 <Yawning> ah
13:46:54 <Sebastian> #13233
13:48:55 <nickm> who else wants to check in with something?
13:49:15 <asn> ehm hello
13:49:18 <Sebastian> I'm helping asn with guardiness stuff
13:49:26 <Sebastian> a tiny bit
13:49:32 <asn> last week I sent a mail about the guardiness script to tor-dev
13:49:39 <asn> and received very good feedback from sebastrian and weasel
13:49:49 <asn> that prompted me to refactor the script to use sqlite instead of the summary files idea.
13:50:04 <asn> the new script is almost ready and I will push it to the Internet in the next hour.
13:50:12 <asn> furthermore, I did a few reviews.
13:50:32 <asn> and finished the tor2web patch I was making #12844. i'm curious to learn from Virgil whether it speeds up tor2web at all.
13:50:47 <asn> and that's that.
13:50:59 <asn> next week, I'm going to be working again on the little-t-tor side of #9312
13:51:00 <asn> next week, I'm going to be working again on the little-t-tor side of #9321
13:51:01 * nickm wonders if armadev's optimistic data patch will help too
13:51:08 <nickm> nice
13:51:20 <asn> the little-t-tor side is almost ready.
13:51:34 <asn> i need to give it some more chutney testing, and devise a missing unittest that has to do with bandwidth weights.
13:51:42 * asn crosses fingers
13:53:11 <asn> EOF
13:54:55 <nickm> who's next?
13:55:56 <nickm> did we get everyone?
13:57:34 <nickm> ok.  looks like we did a short meeting this week.
13:57:36 <nickm> thanks, all!
13:57:42 <nickm> #endmeeting