#tor-dev Meeting

Meeting started by nickm at 15:01:52 UTC (full logs).

Meeting summary

    1. https://gitweb.torproject.org/torspec.git/tree/proposals/264-subprotocol-versions.txt (nickm, 15:02:26)
    2. https://gitweb.torproject.org/torspec.git/tree/proposals/266-removing-current-obsolete-clients.txt (nickm, 15:02:33)
    3. ACTION: add RecommendedRelayProtocols (nickm, 15:14:23)
    4. ACTION: nickm : make required mean required (nickm, 15:18:38)
    5. ACTION: nickm note required behavior with Required and cached consensuses (nickm, 15:19:28)
    6. ACTION: hardwire the required lists? (nickm, 15:22:39)
    7. ACTION: nickm remove the ANYOF notation. (nickm, 15:24:19)
    8. ACTION: somebody check what happens when the target (bad) clients get an empty consensus (nickm, 15:55:40)
    9. ACTION: nickm or somebody flesh out the poison consensus idea and add it to the proposal (nickm, 15:56:11)
    10. ACTION: add a "pulling the switch timeline" section summarizing the above discussion (nickm, 16:13:26)
    11. ACTION: nickm should document arma's new/old location idea above. (nickm, 16:16:07)


Meeting ended at 16:19:18 UTC (full logs).

Action items

  1. add RecommendedRelayProtocols
  2. nickm : make required mean required
  3. nickm note required behavior with Required and cached consensuses
  4. hardwire the required lists?
  5. nickm remove the ANYOF notation.
  6. somebody check what happens when the target (bad) clients get an empty consensus
  7. nickm or somebody flesh out the poison consensus idea and add it to the proposal
  8. add a "pulling the switch timeline" section summarizing the above discussion
  9. nickm should document arma's new/old location idea above.


Action items, by person

  1. nickm
    1. nickm : make required mean required
    2. nickm note required behavior with Required and cached consensuses
    3. nickm remove the ANYOF notation.
    4. nickm or somebody flesh out the poison consensus idea and add it to the proposal
    5. nickm should document arma's new/old location idea above.
  2. UNASSIGNED
    1. add RecommendedRelayProtocols
    2. hardwire the required lists?
    3. somebody check what happens when the target (bad) clients get an empty consensus
    4. add a "pulling the switch timeline" section summarizing the above discussion


People present (lines said)

  1. armadev (92)
  2. nickm (89)
  3. Sebastian (36)
  4. isis (18)
  5. asn_ (3)
  6. MeetBot (2)
  7. Grobbler_ (2)
  8. Grobbler (1)
  9. dgoulet (1)
  10. naif (1)


Generated by MeetBot 0.1.4.