13:30:10 <nickm> #startmeeting weekly tor dev meeting
13:30:10 <MeetBot> Meeting started Wed Mar  9 13:30:10 2016 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:30:10 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:30:39 <Sebastian> hello meeting
13:30:52 <nickm> hihi.  Time for the weekly net team meeting. I see Sebastian and dgoulet and h01ger too!  Anybody else around?
13:31:14 <dgoulet> o/
13:31:16 <special> hello
13:31:23 <nickm> hi special !
13:31:41 * h01ger will mostly be lurking around, but waves some more!
13:31:52 <nickm> so, quick updates.  Mine will be quick indeed.
13:32:21 <isabela> oi
13:32:44 <nickm> dgoulet and isabela convinced me to take some time off.  I have been filtering my tor mail aside since Thursday evening or so.  I spent the weekend organizing old photos and taking my kid to the library and cooking and cleaning the basement and fun stuff like that.
13:32:55 <dgoulet> epic
13:33:12 <isabela> :)
13:33:20 <nickm> Mon and Tue I went on dates with my wife while the kid was in school!  We got to go to an art museum! And have adult conversation!  And use bad words!
13:33:41 <h01ger> *g*
13:33:48 <nickm> And now I'm back.  I should do this more. Thanks to dgoulet and isabela for talking me into this, and thanks to everybody for putting up with any inconvenience that happened.
13:33:58 <nickm> My biggest priorities for today are:
13:34:01 <nickm> - catching up.
13:34:08 <nickm> - seeintg what needs to get done to put out an 0.2.8 rc
13:34:12 <nickm> err make that
13:34:19 <nickm> #action nickm catches up on email
13:34:26 <nickm> #action nickm documents how to filter all your tor email for a while
13:34:39 <nickm> #action see what's left for putting out an 0.2.8 rc
13:34:50 <nickm> #action see how we're doing on 0.2.9 planning
13:35:27 <nickm> #action see how we're doing on end-of-month deliverables for Mar/Apr: make sure mine get done, and that other people get reminded about the deadlines.
13:35:44 <nickm> And if there's extra time, maybe I'll do extra stuff, but let's be realistic here.
13:36:12 <nickm> Also, during discussion time, I'd like to pick a couple more proposals and start scheduling review times for them.  But that's nater.
13:36:15 <nickm> *later
13:36:16 <nickm> who's next?
13:37:00 * isabela plans on updating wiki with discussions from valencia and start organizing tickets for 0.2.9 (make sure all deliverables has a ticket and are tagged correctly)
13:38:07 <isabela> I also plan on documenting the code review process and see if we can start implementing it
13:38:24 <isabela> nickm: I can help with the proposals discussion scheduling too
13:38:49 <nickm> thanks; I'd appreciate that!
13:38:59 <isabela> I will be sending emails to folks for us to tag tickets and maybe we can start the 0.2.9 triage next monday
13:39:08 <dgoulet> +1
13:39:13 <nickm> cool.
13:39:17 <isabela> nickm: I will need your help with sponsorU feb report
13:39:18 <isabela> done!
13:39:29 <nickm> isabela: when is sponsorU feb report due? what timeframe to work on it?
13:39:38 <nickm> #action nickm helps isabela with sponsorU feb report
13:39:59 <dgoulet> (to complement on isabela, "Reviewer" field has been added this morning to trac)
13:40:00 <nickm> discussion item for later: any plans for making 0.2.9 triage more realistic than 0.2.8?
13:40:16 <nickm> also, who has an update?
13:40:18 <isabela> nickm: i guess they know we were all in valencia or in transit.. it was due last week but we should be fine if we send it over by next monday the latest
13:40:27 * dgoulet can go next
13:40:28 <Sebastian> I want to try the #17668 fix on my dirauth, but people found more issues during review
13:40:32 <Sebastian> I wonder if I should wait with that?
13:40:37 <Sebastian> oh sorry dgoulet, go ahead.
13:40:42 <dgoulet> Sebastian: please continue
13:40:55 <Sebastian> that was all for me, I didn't have time for more core-tor stuff after vlc so far.
13:40:58 <nickm> #action nickm needs to fix issues in #17668
13:41:24 <dgoulet> easy and quick:
13:41:27 <dgoulet> Catched up on emails and after VLC tasks. I started code on #17238 (see _heavy_ dev branch ticket17238_029_01). I still have some email to send out but I would say I'm back to "developer mode".
13:42:00 <Sebastian> #action Sebastian tries #17668 fix and reports to dirauth ops
13:42:01 <dgoulet> I plan to squash 028 hs bugs this week... some in need review some in need revision.
13:42:13 <dgoulet> --
13:42:16 <nickm> dgoulet: btw, do you remember that some of the students in the MIT 6.S194 class I'm mentoring are interested in some prop#224 tasks?
13:42:55 <dgoulet> nickm: hrm... some GsoC also ... but it might be a bit difficult to give something. we can talk after if you want
13:44:02 <nickm> let's put it in discussion then.
13:44:43 <special> I've been reading through parts of 224 and finding inconsistencies or problems, queued up a few mails to write about them
13:45:09 <special> available to write/review/discuss some hsdir code whenever dgoulet wants me to
13:45:35 <special> and I set up a copy of gerrit to play with, but it isn't yet ready to expose to anyone. Also found out about another tool that might be less intrusive to process.
13:45:42 <special> that's all
13:46:52 <nickm> Julius was showing me how some bugtrackers (redmine?) can automatically create a subticket for items in a code review.  Not sure that's the route to go, but it looked pretty cook.
13:47:16 <special> (the other tool is https://phacility.com/phabricator/differential/)
13:47:34 <dgoulet> Sebastian: we tried it few months ago
13:47:38 <dgoulet> special: ^ arf
13:47:43 <special> what was the conclusion?
13:47:57 <dgoulet> not positive iirc
13:48:10 <special> specific reasons would be helpful
13:48:32 <dgoulet> unfortunately don't recall so maybe we could give it another try with more focus on "testing" and keeping a record of comments :)
13:48:35 <nickm> It was a pain in the butt to use if you didn't want to install their special command-line uploaded tool.  And the tool was scary.
13:48:58 <nickm> isis might remember more.
13:49:09 <special> ah
13:50:27 <nickm> I think we had tickets about it too; searching trac might also be informative
13:50:32 <nickm> Anybody else with a status thing?
13:52:13 <Anonym00se> Hello, any dev can help me some questions?
13:52:54 <nickm> Anonym00se: Hi!  We're having a meeting now; we should be done in 40 min or so.  Maybe try #tor ?
13:53:15 <nickm> ok, we're through status.  I had a couple of discussion topics, and others may have more.
13:53:32 <nickm> I have:
13:53:42 <nickm> 1. what proposals to schedule discussion for
13:54:11 <nickm> 2. how do we get 0.2.9 triage to produce more realistic results than we got for 027 or 028?
13:54:20 <nickm> and, what else?
13:55:13 <dgoulet> I'm good with that
13:55:17 <isabela> me too
13:55:54 <Anonym00se> At the moment I study C and intend to follow with asm , I wanted to know of someone active in the project, what it is considered essential to contribute technically , if possible cite materials or topics .
13:56:13 <nickm> Anonym00se: That's a good question! Will you still be around in 30 min?  We are having a meeting right now.
13:56:36 <Anonym00se> Right.
13:57:36 <nickm> so, let's look at the proposal list!
13:58:08 <nickm> https://gitweb.torproject.org/torspec.git/tree/proposals/000-index.txt
13:58:41 <Anonym00se> I'm a studying and honestly I never contributes on a project before, it brought me here .
13:59:07 <nickm> Linus's prop#267 looked interesting.
13:59:14 <dgoulet> #266 could be fun
13:59:18 <umoukun> Anonym00se, goto #tor
13:59:21 <dgoulet> prop#266 *
13:59:27 <nickm> dgoulet: I think we already had one of those.
13:59:32 <dgoulet> oh great!
13:59:42 <nickm> though I need to revise the heck out of it.
13:59:45 <special> is prop#236 meant to still be OPEN?
13:59:46 <nickm> based on that discussion.
14:00:14 <nickm> special: I don't know! Let's ask the guard folks. :)
14:00:21 <nickm> olabini: ^ ?
14:00:24 <nickm> Sebastian: ^ ?
14:00:28 <special> ah, looks like it talks about rotation period too
14:00:57 <dgoulet> it has guard fraction
14:01:16 <dgoulet> which asn wanted (not) to work on soon-ish if I recall correctly
14:01:40 <dgoulet> so not implemented yet thus "Open" could be ok
14:01:46 <dgoulet> (not deployed let say)
14:02:02 <special> prop#237 also looks like it maybe shouldn't be open
14:02:22 <dgoulet> ah yeah that is merged ^
14:02:52 <nickm> special: could you make a list of these? :)
14:03:11 <nickm> Have we got anything else that we should schedule a review/discussion meeting for?
14:03:59 <special> dgoulet: do you think it's useful to have meetings to work on finalizing 224, or should we wait?
14:04:32 <dgoulet> special: hrm... we should probably do that as we go, it's so big I fear to get lost in things we'll be implementing in 6 months from now
14:05:42 <nickm> Does it make sense to divide 224 into pieces?
14:05:47 <dgoulet> but 224 could get out of DRAFT
14:05:52 <nickm> Does it make sense to make a list of all the pain points remaining in 224?
14:05:53 <dgoulet> nickm: you mean in multiple proposals?
14:07:02 <dgoulet> we kind of did identify pain point back in DC during the "Arlington accords" for 224 and found "solutions" for them, but we should definitely make sure the proposal is up to date with those
14:07:06 <dgoulet> and see if any are missing
14:07:22 <nickm> Possibly.  Or possibly consider each section of prop224 as an independent thing and discuss them separately to the extent we can?
14:08:06 <dgoulet> sure, since we are in the HSDir support coding phase and (soon) Relay support phase, we could totally discuss that!
14:08:17 <dgoulet> as we code, we'll find more inconsistency/issue with the proposal also
14:09:03 <nickm> btw, the students are especially interested in the ring parts of the hsdir support.  So maybe focus on the parsing at first?  I'll have more to report soon.
14:09:30 <nickm> for fun: here's a diagram of the ring algorithm as specified. https://people.torproject.org/~nickm/volatile/diagram.png
14:09:47 <dgoulet> nickm: we made a roadmap for HSDir support and right now encoding/decoding is the first step
14:09:50 <dgoulet> let me upload the pic :)
14:10:11 <dgoulet> https://people.torproject.org/~dgoulet/volatile/vlc-hs-meeting-p1.jpg
14:10:19 <dgoulet> https://people.torproject.org/~dgoulet/volatile/vlc-hs-meeting-p2.jpg
14:10:29 <dgoulet> ah wow 403
14:10:52 <dgoulet> better
14:11:11 <dgoulet> anyway, yes discussion on 224 definitely
14:12:23 <nickm> okay.  Can anyone volunteer to write up an issue summary on that in advance of a meeting?
14:12:46 <dgoulet> I nominate special :D
14:13:21 <special> meaning, a list of topics to cover in the first meeting? a list of specific issues identified? both?
14:13:30 <special> but sure, I will
14:13:36 <isabela> how we are doing with scheduling? should i propose dates based on ppls preferences in the wiki?
14:14:21 <dgoulet> isabela: I would say so yes
14:14:26 <isabela> ok
14:14:31 <dgoulet> it did work for the other
14:14:34 <dgoulet> s
14:15:00 <dgoulet> special: you should add yours: https://trac.torproject.org/projects/tor/wiki/org/teams/NetworkTeam/MeetingSchedule
14:15:06 <nickm> isabela: yes, sounds good. dgoulet and special would be good for listing must-have people for prop#224 discussion.
14:15:23 <special> will do, although mine changes approximately weekly
14:15:44 <nickm> for discussing prop#267, ln5 is needed.  If we can get leif, that would rock, since he has opinions, but I don't  know if he feels like stopping by.
14:16:05 <nickm> are we sufficiently advanced on this topic?
14:16:16 <dgoulet> I heard lots of dicussion happened around it in VLC so ln5 has probably updates :)
14:16:39 <dgoulet> nickm: yeah 2 proposal review in the pipe, good start for now I would say :)
14:16:54 <isabela> ok, i will follow up with ln5 as well
14:17:09 <nickm> cool. Topic 2, and this is mostly for isabela.
14:17:15 <isabela> :)
14:18:07 <isabela> I would like us to really prioritize the deliverables we need to get done by end of Q3
14:18:14 <nickm> Is there any prep that I/we should do to make sure that as we triage 0.2.9, it goes well?  IOW, a) everybody who should participate participates, b) not too much gets dumped on me, c) we don't skip critical stuff just because it's nonfunded, but d) we don't triage-in 3X the tickets that we can imagine doing.
14:18:47 <nickm> Have we got the roadmapping from the VLC meeting on a spreadsheet yet?
14:19:02 <isabela> nickm: not yet, that is what I want to work this week
14:19:09 <isabela> nickm: is in the wiki tho
14:19:36 <nickm> If we have the stuff that is specifically sponsor-required Tagged, and if we have work estimates on those, and if we have them mapped to people, that's a good good way for us to start.
14:19:43 <dgoulet> identifying open tickets that are deliverables for Q3 and putting them in "High" priority sounds a good start
14:19:52 <dgoulet> nickm: :)
14:19:59 <nickm> :)
14:20:00 <isabela> yes, my idea was to start adding those to the 0.2.9 triage tag
14:20:19 <isabela> i was thinking of making user all work that needs to be done by Q3 is there
14:21:01 <isabela> I plan on emailing the team to review them and add the right info to it
14:21:12 <isabela> size, priority
14:21:46 <isabela> I also plan on adding the monthly tag to them according to the roadmaps
14:22:00 <dgoulet> isabela: (we could have a Size field with a  drop down menu instead of using Points, if that would be more appropriate let me know that I have the power to do so :)
14:22:23 <isabela> dgoulet: sounds good
14:22:41 <dgoulet> now that I*
14:23:07 <isabela> what do y'all think of focusing on sponsor work first, organize those tickets
14:23:14 <isabela> then start looking at non-sponsor stuff
14:23:17 <dgoulet> +1
14:23:19 <isabela> to see how much more we can add
14:24:33 <nickm> +1.  And not to be grumpy-nickm, but:
14:24:59 <nickm> I will really need other folks besides me to help being the last-ditch-sponsored-ticket-catchers.  I can do it, but I can't be the only one. :)
14:25:30 <dgoulet> nickm: not sure I understand "last-ditch-sponsored-ticket-catchers" ? you mean find ticket that should have a sponsor?
14:26:05 <nickm> I mean that by default, if there is a sponsored Tor ticket that nobody wants to do, I have to do it. :)
14:26:10 <nickm> Or at least, I feel like I do.
14:26:23 <dgoulet> ah!
14:26:51 <dgoulet> we can do a pass of "Assigning" tickets to people after that I guess, won't cover them all but it,s a start I guess :S
14:27:00 <isabela> hopefully as part of organizing things we will have owners to tickets and cced people as well
14:27:22 <isabela> I will try to distribute thigns according to what we discussed in valencia (the percentages division)
14:28:32 <dgoulet> ah yes that
14:29:59 <nickm> ok.  More for this meeting? :)
14:30:30 <dgoulet> all good here
14:30:41 <isabela> I think I am good. i will be emailing the team on the triage stuff as well as follow up on the proposals discussion meetings
14:30:56 <nickm> ok cool!
14:30:59 <nickm> #endmeeting